]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- 4.9.13 auto/th/kernel-4.9.13-1 auto/th/kernel-nopae-4.9.13-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 26 Feb 2017 20:49:31 +0000 (21:49 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 26 Feb 2017 20:49:31 +0000 (21:49 +0100)
kernel-small_fixes.patch
kernel.spec

index 26fde240e2503c4917df5243d084a457fb1bbf7a..319191ce2821f2eacb3c4fdd4b50d92f33d2f795 100644 (file)
@@ -61,50 +61,3 @@ index 098ce9b179ee..fcf8d0aa66ec 100644
 -- 
 2.11.0
 
-From 5edabca9d4cff7f1f2b68f0bac55ef99d9798ba4 Mon Sep 17 00:00:00 2001
-From: Andrey Konovalov <andreyknvl@google.com>
-Date: Thu, 16 Feb 2017 17:22:46 +0100
-Subject: dccp: fix freeing skb too early for IPV6_RECVPKTINFO
-
-In the current DCCP implementation an skb for a DCCP_PKT_REQUEST packet
-is forcibly freed via __kfree_skb in dccp_rcv_state_process if
-dccp_v6_conn_request successfully returns.
-
-However, if IPV6_RECVPKTINFO is set on a socket, the address of the skb
-is saved to ireq->pktopts and the ref count for skb is incremented in
-dccp_v6_conn_request, so skb is still in use. Nevertheless, it gets freed
-in dccp_rcv_state_process.
-
-Fix by calling consume_skb instead of doing goto discard and therefore
-calling __kfree_skb.
-
-Similar fixes for TCP:
-
-fb7e2399ec17f1004c0e0ccfd17439f8759ede01 [TCP]: skb is unexpectedly freed.
-0aea76d35c9651d55bbaf746e7914e5f9ae5a25d tcp: SYN packets are now
-simply consumed
-
-Signed-off-by: Andrey Konovalov <andreyknvl@google.com>
-Acked-by: Eric Dumazet <edumazet@google.com>
-Signed-off-by: David S. Miller <davem@davemloft.net>
----
- net/dccp/input.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/net/dccp/input.c b/net/dccp/input.c
-index ba34718..8fedc2d 100644
---- a/net/dccp/input.c
-+++ b/net/dccp/input.c
-@@ -606,7 +606,8 @@ int dccp_rcv_state_process(struct sock *sk, struct sk_buff *skb,
-                       if (inet_csk(sk)->icsk_af_ops->conn_request(sk,
-                                                                   skb) < 0)
-                               return 1;
--                      goto discard;
-+                      consume_skb(skb);
-+                      return 0;
-               }
-               if (dh->dccph_type == DCCP_PKT_RESET)
-                       goto discard;
--- 
-cgit v0.12
-
index c8ae3fbd26b21d0afaa287e9b4bfbac0dddb4504..38f969ed2449bcdeeb925256aca69e3f177e3a2c 100644 (file)
@@ -73,7 +73,7 @@
 
 %define                rel             1
 %define                basever         4.9
-%define                postver         .12
+%define                postver         .13
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -125,7 +125,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: 0a68ef3615c64bd5ee54a3320e46667d
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  ced440f98d136be403d38c53cb8fce9d
+# Patch0-md5:  0a230f5a610d0724e7435d945bfe91a6
 %endif
 Source1:       kernel.sysconfig
 
This page took 0.066504 seconds and 4 git commands to generate.