]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- fix for https://bugzilla.kernel.org/show_bug.cgi?id=204151
authorAndrzej Zawadzki <zawadaa@pld-linux.org>
Tue, 24 Sep 2019 11:31:07 +0000 (13:31 +0200)
committerAndrzej Zawadzki <zawadaa@pld-linux.org>
Tue, 24 Sep 2019 11:31:07 +0000 (13:31 +0200)
kernel-small_fixes.patch
kernel.spec

index 6467050d8842fc3dc1d2c74489247915d42c8f97..fcb13ed724d5c50b0a9405b9610a868cbf6b310a 100644 (file)
@@ -1,2 +1,21 @@
-;
-;
+diff --git a/drivers/net/wireless/intel/iwlwifi/mvm/fw.c b/drivers/net/wireless/intel/iwlwifi/mvm/fw.c
+index 014eca6596e2..32a5e4e5461f 100644
+--- a/drivers/net/wireless/intel/iwlwifi/mvm/fw.c
++++ b/drivers/net/wireless/intel/iwlwifi/mvm/fw.c
+@@ -889,11 +889,13 @@ static bool iwl_mvm_sar_geo_support(struct iwl_mvm *mvm)
+        * firmware versions.  Unfortunately, we don't have a TLV API
+        * flag to rely on, so rely on the major version which is in
+        * the first byte of ucode_ver.  This was implemented
+-       * initially on version 38 and then backported to 36, 29 and
+-       * 17.
++       * initially on version 38 and then backported to29 and 17.
++       * The intention was to have it in 36 as well, but not all
++       * 8000 family got this feature enabled.  The 8000 family is
++       * the only one using version 36, so skip this version
++       * entirely.
+        */
+       return IWL_UCODE_SERIAL(mvm->fw->ucode_ver) >= 38 ||
+-             IWL_UCODE_SERIAL(mvm->fw->ucode_ver) == 36 ||
+              IWL_UCODE_SERIAL(mvm->fw->ucode_ver) == 29 ||
+              IWL_UCODE_SERIAL(mvm->fw->ucode_ver) == 17;
+ }
index 19c9b9e56f38cc9a89cf3afef6f9a35b7d83c782..00a14a3f9f4635ee3331276d42c170d11825a509 100644 (file)
@@ -67,7 +67,7 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             1
+%define                rel             2
 %define                basever         5.3
 %define                postver         .1
 
@@ -690,7 +690,7 @@ rm -f localversion-rt
 %endif # vanilla
 
 # Small fixes:
-#%patch2000 -p1
+%patch2000 -p1
 %patch2001 -p1
 #%patch2003 -p1
 %patch2004 -p1
This page took 0.112467 seconds and 4 git commands to generate.