]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- added fix for Bad page map BUGs in Xen PVM auto/th/kernel-3.14.2-2
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 4 May 2014 09:48:29 +0000 (11:48 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 4 May 2014 09:48:29 +0000 (11:48 +0200)
- rel 2

kernel-small_fixes.patch
kernel.spec

index 2b0f82db5682493080513837ec3d1fe6b473d89b..740b2867742ff5227d42975e080a02161da0a9f0 100644 (file)
@@ -70,3 +70,110 @@ index 3b1ea34..eaa808e 100644
        /* Ask for all the pages supported by this device */
        result = scsi_vpd_inquiry(sdev, buf, 0, buf_len);
        if (result)
+
+David Vrabel identified a regression when using automatic NUMA balancing
+under Xen whereby page table entries were getting corrupted due to the
+use of native PTE operations. Quoting him
+
+       Xen PV guest page tables require that their entries use machine
+       addresses if the preset bit (_PAGE_PRESENT) is set, and (for
+       successful migration) non-present PTEs must use pseudo-physical
+       addresses.  This is because on migration MFNs in present PTEs are
+       translated to PFNs (canonicalised) so they may be translated back
+       to the new MFN in the destination domain (uncanonicalised).
+
+       pte_mknonnuma(), pmd_mknonnuma(), pte_mknuma() and pmd_mknuma()
+       set and clear the _PAGE_PRESENT bit using pte_set_flags(),
+       pte_clear_flags(), etc.
+
+       In a Xen PV guest, these functions must translate MFNs to PFNs
+       when clearing _PAGE_PRESENT and translate PFNs to MFNs when setting
+       _PAGE_PRESENT.
+
+His suggested fix converted p[te|md]_[set|clear]_flags to using
+paravirt-friendly ops but this is overkill. He suggested an alternative of
+using p[te|md]_modify in the NUMA page table operations but this is does
+more work than necessary and would require looking up a VMA for protections.
+
+This patch modifies the NUMA page table operations to use paravirt friendly
+operations to set/clear the flags of interest. Unfortunately this will take
+a performance hit when updating the PTEs on CONFIG_PARAVIRT but I do not
+see a way around it that does not break Xen.
+
+Cc: stable@vger.kernel.org
+Signed-off-by: Mel Gorman <mgorman@suse.de>
+Acked-by: David Vrabel <david.vrabel@citrix.com>
+Tested-by: David Vrabel <david.vrabel@citrix.com>
+---
+ include/asm-generic/pgtable.h | 31 +++++++++++++++++++++++--------
+ 1 file changed, 23 insertions(+), 8 deletions(-)
+
+diff --git a/include/asm-generic/pgtable.h b/include/asm-generic/pgtable.h
+index 34c7bdc..38a7437 100644
+--- a/include/asm-generic/pgtable.h
++++ b/include/asm-generic/pgtable.h
+@@ -680,24 +680,35 @@ static inline int pmd_numa(pmd_t pmd)
+ #ifndef pte_mknonnuma
+ static inline pte_t pte_mknonnuma(pte_t pte)
+ {
+-      pte = pte_clear_flags(pte, _PAGE_NUMA);
+-      return pte_set_flags(pte, _PAGE_PRESENT|_PAGE_ACCESSED);
++      pteval_t val = pte_val(pte);
++
++      val &= ~_PAGE_NUMA;
++      val |= (_PAGE_PRESENT|_PAGE_ACCESSED);
++      return __pte(val);
+ }
+ #endif
+ #ifndef pmd_mknonnuma
+ static inline pmd_t pmd_mknonnuma(pmd_t pmd)
+ {
+-      pmd = pmd_clear_flags(pmd, _PAGE_NUMA);
+-      return pmd_set_flags(pmd, _PAGE_PRESENT|_PAGE_ACCESSED);
++      pmdval_t val = pmd_val(pmd);
++
++      val &= ~_PAGE_NUMA;
++      val |= (_PAGE_PRESENT|_PAGE_ACCESSED);
++
++      return __pmd(val);
+ }
+ #endif
+ #ifndef pte_mknuma
+ static inline pte_t pte_mknuma(pte_t pte)
+ {
+-      pte = pte_set_flags(pte, _PAGE_NUMA);
+-      return pte_clear_flags(pte, _PAGE_PRESENT);
++      pteval_t val = pte_val(pte);
++
++      val &= ~_PAGE_PRESENT;
++      val |= _PAGE_NUMA;
++
++      return __pte(val);
+ }
+ #endif
+@@ -716,8 +727,12 @@ static inline void ptep_set_numa(struct mm_struct *mm, unsigned long addr,
+ #ifndef pmd_mknuma
+ static inline pmd_t pmd_mknuma(pmd_t pmd)
+ {
+-      pmd = pmd_set_flags(pmd, _PAGE_NUMA);
+-      return pmd_clear_flags(pmd, _PAGE_PRESENT);
++      pmdval_t val = pmd_val(pmd);
++
++      val &= ~_PAGE_PRESENT;
++      val |= _PAGE_NUMA;
++
++      return __pmd(val);
+ }
+ #endif
+-- 
+1.8.4.5
+
+--
+To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
+the body of a message to majordomo@vger.kernel.org
+More majordomo info at  http://vger.kernel.org/majordomo-info.html
+Please read the FAQ at  http://www.tux.org/lkml/
index 8280d0bd5a4e8501abbd0978099da539fd5dbc32..e995f5acbd7e33fc0ba18665aac5b4e97e00c650 100644 (file)
@@ -68,7 +68,7 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             1
+%define                rel             2
 %define                basever         3.14
 %define                postver         .2
 
This page took 0.074254 seconds and 4 git commands to generate.