]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- up to 5.1.15; improved xfs writeback support (from xfs ml) auto/th/kernel-5.1.15-1 auto/th/kernel-nopae-5.1.15-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 25 Jun 2019 15:36:23 +0000 (17:36 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 25 Jun 2019 15:36:23 +0000 (17:36 +0200)
kernel-small_fixes.patch
kernel.spec

index bf7da33aa7208ec0e661230f5fce8fe25a2bd53d..0eb6a2159c1d76a659378995be1b5779c48bcfa7 100644 (file)
@@ -1,43 +1,3 @@
-From: Shaohua Li <shli@fb.com>
-
-Basically this is a copy of commit 001e4a8775f6(ext4: implement cgroup
-writeback support). Tested with a fio test, verified writeback is
-throttled against cgroup io.max write bandwidth, also verified moving
-the fio test to another cgroup and the writeback is throttled against
-new cgroup setting.
-
-Cc: Tejun Heo <tj@kernel.org>
-Signed-off-by: Shaohua Li <shli@fb.com>
----
- fs/xfs/xfs_aops.c  | 2 ++
- fs/xfs/xfs_super.c | 1 +
- 2 files changed, 3 insertions(+)
-
---- linux-4.19/fs/xfs/xfs_aops.c.org   2018-11-21 10:31:12.348955352 +0100
-+++ linux-4.19/fs/xfs/xfs_aops.c       2018-11-21 10:34:35.241764742 +0100
-@@ -660,8 +660,10 @@ xfs_add_to_ioend(
-                       list_add(&wpc->ioend->io_list, iolist);
-               wpc->ioend = xfs_alloc_ioend(inode, wpc->fork,
-                               wpc->imap.br_state, offset, bdev, sector);
-+              wbc_init_bio(wbc, wpc->ioend->io_bio);
-       }
-+      wbc_account_io(wbc, page, len);
-       if (!__bio_try_merge_page(wpc->ioend->io_bio, page, len, poff, true)) {
-               if (iop)
-                       atomic_inc(&iop->write_count);
-diff --git a/fs/xfs/xfs_super.c b/fs/xfs/xfs_super.c
-index 584cf2d..aea3bc2 100644
---- a/fs/xfs/xfs_super.c
-+++ b/fs/xfs/xfs_super.c
-@@ -1634,6 +1634,7 @@ xfs_fs_fill_super(
-       sb->s_max_links = XFS_MAXLINK;
-       sb->s_time_gran = 1;
-       set_posix_acl_flag(sb);
-+      sb->s_iflags |= SB_I_CGROUPWB;
-       /* version 5 superblocks support inode version counters. */
-       if (XFS_SB_VERSION_NUM(&mp->m_sb) == XFS_SB_VERSION_5)
 --- linux-5.1/net/sunrpc/Kconfig~      2019-05-06 02:42:58.000000000 +0200
 +++ linux-5.1/net/sunrpc/Kconfig       2019-05-10 12:54:36.566903892 +0200
 @@ -34,7 +34,7 @@ config RPCSEC_GSS_KRB5
@@ -49,3 +9,163 @@ index 584cf2d..aea3bc2 100644
        bool "Secure RPC: Disable insecure Kerberos encryption types"
        depends on RPCSEC_GSS_KRB5
        default n
+Move setting up operation and write hint to xfs_alloc_ioend, and\r
+then just copy over all needed information from the previous bio\r
+in xfs_chain_bio and stop passing various parameters to it.\r
+\r
+Signed-off-by: Christoph Hellwig <hch@lst.de>\r
+---\r
+ fs/xfs/xfs_aops.c | 35 +++++++++++++++++------------------\r
+ 1 file changed, 17 insertions(+), 18 deletions(-)\r
+\r
+diff --git a/fs/xfs/xfs_aops.c b/fs/xfs/xfs_aops.c\r
+index a6f0f4761a37..9cceb90e77c5 100644\r
+--- a/fs/xfs/xfs_aops.c\r
++++ b/fs/xfs/xfs_aops.c\r
+@@ -665,7 +665,6 @@ xfs_submit_ioend(\r
\r
+       ioend->io_bio->bi_private = ioend;\r
+       ioend->io_bio->bi_end_io = xfs_end_bio;\r
+-      ioend->io_bio->bi_opf = REQ_OP_WRITE | wbc_to_write_flags(wbc);\r
\r
+       /*\r
+        * If we are failing the IO now, just mark the ioend with an\r
+@@ -679,7 +678,6 @@ xfs_submit_ioend(\r
+               return status;\r
+       }\r
\r
+-      ioend->io_bio->bi_write_hint = ioend->io_inode->i_write_hint;\r
+       submit_bio(ioend->io_bio);\r
+       return 0;\r
+ }\r
+@@ -691,7 +689,8 @@ xfs_alloc_ioend(\r
+       xfs_exntst_t            state,\r
+       xfs_off_t               offset,\r
+       struct block_device     *bdev,\r
+-      sector_t                sector)\r
++      sector_t                sector,\r
++      struct writeback_control *wbc)\r
+ {\r
+       struct xfs_ioend        *ioend;\r
+       struct bio              *bio;\r
+@@ -699,6 +698,8 @@ xfs_alloc_ioend(\r
+       bio = bio_alloc_bioset(GFP_NOFS, BIO_MAX_PAGES, &xfs_ioend_bioset);\r
+       bio_set_dev(bio, bdev);\r
+       bio->bi_iter.bi_sector = sector;\r
++      bio->bi_opf = REQ_OP_WRITE | wbc_to_write_flags(wbc);\r
++      bio->bi_write_hint = inode->i_write_hint;\r
\r
+       ioend = container_of(bio, struct xfs_ioend, io_inline_bio);\r
+       INIT_LIST_HEAD(&ioend->io_list);\r
+@@ -719,24 +720,22 @@ xfs_alloc_ioend(\r
+  * so that the bi_private linkage is set up in the right direction for the\r
+  * traversal in xfs_destroy_ioend().\r
+  */\r
+-static void\r
++static struct bio *\r
+ xfs_chain_bio(\r
+-      struct xfs_ioend        *ioend,\r
+-      struct writeback_control *wbc,\r
+-      struct block_device     *bdev,\r
+-      sector_t                sector)\r
++      struct bio              *prev)\r
+ {\r
+       struct bio *new;\r
\r
+       new = bio_alloc(GFP_NOFS, BIO_MAX_PAGES);\r
+-      bio_set_dev(new, bdev);\r
+-      new->bi_iter.bi_sector = sector;\r
+-      bio_chain(ioend->io_bio, new);\r
+-      bio_get(ioend->io_bio);         /* for xfs_destroy_ioend */\r
+-      ioend->io_bio->bi_opf = REQ_OP_WRITE | wbc_to_write_flags(wbc);\r
+-      ioend->io_bio->bi_write_hint = ioend->io_inode->i_write_hint;\r
+-      submit_bio(ioend->io_bio);\r
+-      ioend->io_bio = new;\r
++      bio_copy_dev(new, prev);\r
++      new->bi_iter.bi_sector = bio_end_sector(prev);\r
++      new->bi_opf = prev->bi_opf;\r
++      new->bi_write_hint = prev->bi_write_hint;\r
++\r
++      bio_chain(prev, new);\r
++      bio_get(prev);          /* for xfs_destroy_ioend */\r
++      submit_bio(prev);\r
++      return new;\r
+ }\r
\r
+ /*\r
+@@ -771,14 +770,14 @@ xfs_add_to_ioend(\r
+               if (wpc->ioend)\r
+                       list_add(&wpc->ioend->io_list, iolist);\r
+               wpc->ioend = xfs_alloc_ioend(inode, wpc->fork,\r
+-                              wpc->imap.br_state, offset, bdev, sector);\r
++                              wpc->imap.br_state, offset, bdev, sector, wbc);\r
+       }\r
\r
+       if (!__bio_try_merge_page(wpc->ioend->io_bio, page, len, poff, true)) {\r
+               if (iop)\r
+                       atomic_inc(&iop->write_count);\r
+               if (bio_full(wpc->ioend->io_bio))\r
+-                      xfs_chain_bio(wpc->ioend, wbc, bdev, sector);\r
++                      wpc->ioend->io_bio = xfs_chain_bio(wpc->ioend->io_bio);\r
+               bio_add_page(wpc->ioend->io_bio, page, len, poff);\r
+       }\r
\r
+-- \r
+2.20.1\r
+\r
+\r
+Link every newly allocated writeback bio to cgroup pointed to by the\r
+writeback control structure, and charge every byte written back to it.\r
+\r
+Tested-by: Stefan Priebe - Profihost AG <s.priebe@profihost.ag>\r
+Signed-off-by: Christoph Hellwig <hch@lst.de>\r
+---\r
+ fs/xfs/xfs_aops.c  | 4 +++-\r
+ fs/xfs/xfs_super.c | 2 ++\r
+ 2 files changed, 5 insertions(+), 1 deletion(-)\r
+\r
+diff --git a/fs/xfs/xfs_aops.c b/fs/xfs/xfs_aops.c\r
+index 9cceb90e77c5..73c291aeae17 100644\r
+--- a/fs/xfs/xfs_aops.c\r
++++ b/fs/xfs/xfs_aops.c\r
+@@ -700,6 +700,7 @@ xfs_alloc_ioend(\r
+       bio->bi_iter.bi_sector = sector;\r
+       bio->bi_opf = REQ_OP_WRITE | wbc_to_write_flags(wbc);\r
+       bio->bi_write_hint = inode->i_write_hint;\r
++      wbc_init_bio(wbc, bio);\r
\r
+       ioend = container_of(bio, struct xfs_ioend, io_inline_bio);\r
+       INIT_LIST_HEAD(&ioend->io_list);\r
+@@ -727,7 +728,7 @@ xfs_chain_bio(\r
+       struct bio *new;\r
\r
+       new = bio_alloc(GFP_NOFS, BIO_MAX_PAGES);\r
+-      bio_copy_dev(new, prev);\r
++      bio_copy_dev(new, prev);/* also copies over blkcg information */\r
+       new->bi_iter.bi_sector = bio_end_sector(prev);\r
+       new->bi_opf = prev->bi_opf;\r
+       new->bi_write_hint = prev->bi_write_hint;\r
+@@ -782,6 +783,7 @@ xfs_add_to_ioend(\r
+       }\r
\r
+       wpc->ioend->io_size += len;\r
++      wbc_account_io(wbc, page, len);\r
+ }\r
\r
+ STATIC void\r
+diff --git a/fs/xfs/xfs_super.c b/fs/xfs/xfs_super.c\r
+index 594c119824cc..ee0df8f611ff 100644\r
+--- a/fs/xfs/xfs_super.c\r
++++ b/fs/xfs/xfs_super.c\r
+@@ -1685,6 +1685,8 @@ xfs_fs_fill_super(\r
+       sb->s_maxbytes = xfs_max_file_offset(sb->s_blocksize_bits);\r
+       sb->s_max_links = XFS_MAXLINK;\r
+       sb->s_time_gran = 1;\r
++      sb->s_iflags |= SB_I_CGROUPWB;\r
++\r
+       set_posix_acl_flag(sb);\r
\r
+       /* version 5 superblocks support inode version counters. */\r
+-- \r
+2.20.1\r
+\r
index d79a2d7c157e567747855c534568c0813e20f423..cc090e8562baeb9ea90acfc77ed691f76862967d 100644 (file)
@@ -69,7 +69,7 @@
 
 %define                rel             1
 %define                basever         5.1
-%define                postver         .12
+%define                postver         .15
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -123,7 +123,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v5.x/linux-%{basever}.tar.xz
 # Source0-md5: 15fbdff95ff98483069ac6e215b9f4f9
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v5.x/patch-%{version}.xz
-# Patch0-md5:  e72efeff316e384ab47ebcc804a83f02
+# Patch0-md5:  aed4686410e23561f67f5c512d0a6245
 %endif
 Source1:       kernel.sysconfig
 
This page took 1.516807 seconds and 4 git commands to generate.