]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- fix symbol visibility breakage in 4.2 auto/th/kernel-4.2.1-2 auto/th/kernel-nopae-4.2.1-2
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 27 Sep 2015 18:43:44 +0000 (20:43 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 27 Sep 2015 18:43:44 +0000 (20:43 +0200)
- rel 2

kernel-small_fixes.patch
kernel.spec

index 01e03aa64da497ac17ba88984c47f9e05ec251da..905698f15e67cf7faa0c6367450f78374a4b159e 100644 (file)
@@ -97,3 +97,43 @@ index 28011fb1..c6ded6b 100644
        .pkts_acked     = bictcp_acked,
        .owner          = THIS_MODULE,
        .name           = "cubic",
+From: Tim Gardner <tim.gardner@canonical.com>
+
+commit 1dadafa86a779884f14a6e7a3ddde1a57b0a0a65 upstream.
+
+Commit 37b1ef31a568fc02e53587620226e5f3c66454c8 ("workqueue: move
+flush_scheduled_work() to workqueue.h") moved the exported non GPL
+flush_scheduled_work() from a function to an inline wrapper.
+Unfortunately, it directly calls flush_workqueue() which is a GPL function.
+This has the effect of changing the licensing requirement for this function
+and makes it unavailable to non GPL modules.
+
+See commit ad7b1f841f8a54c6d61ff181451f55b68175e15a ("workqueue: Make
+schedule_work() available again to non GPL modules") for precedent.
+
+Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
+Signed-off-by: Tejun Heo <tj@kernel.org>
+Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
+
+---
+ kernel/workqueue.c |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/kernel/workqueue.c
++++ b/kernel/workqueue.c
+@@ -2614,7 +2614,7 @@ void flush_workqueue(struct workqueue_st
+ out_unlock:
+       mutex_unlock(&wq->mutex);
+ }
+-EXPORT_SYMBOL_GPL(flush_workqueue);
++EXPORT_SYMBOL(flush_workqueue);
+ /**
+  * drain_workqueue - drain a workqueue
+
+
+--
+To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
+the body of a message to majordomo@vger.kernel.org
+More majordomo info at  http://vger.kernel.org/majordomo-info.html
+Please read the FAQ at  http://www.tux.org/lkml/
index 3fe77d8083c6618d5847ea9183fff42830120c08..ae70fc517c549e3d8c20732c6c6aa1680b465bd3 100644 (file)
@@ -69,7 +69,7 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             1
+%define                rel             2
 %define                basever         4.2
 %define                postver         .1
 
This page took 0.082906 seconds and 4 git commands to generate.