]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- added wistron-nx patch (fix wistron_btns module wrt. NX protection)
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 16 Nov 2013 20:04:19 +0000 (21:04 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 16 Nov 2013 20:04:19 +0000 (21:04 +0100)
kernel.spec
linux-wistron-nx.patch [new file with mode: 0644]

index a265efb897018a75c43c9a8bf029ca77e8197642..deaa9bff7d11b708f6e43716f947e4640f071f9b 100644 (file)
@@ -144,6 +144,7 @@ Source58:   kernel-inittmpfs.config
 Patch3:                kernel-fbcondecor.patch
 Patch4:                kernel-fbcon-margins.patch
 Patch5:                linux-wistron-amilo8210.patch
+Patch6:                linux-wistron-nx.patch
 
 # netfilter related stuff mostly based on patch-o-matic-ng
 # snapshot 20070806 with some fixes. Some modules
@@ -635,6 +636,7 @@ cd linux-%{basever}
 %endif
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 ## netfilter
 #
diff --git a/linux-wistron-nx.patch b/linux-wistron-nx.patch
new file mode 100644 (file)
index 0000000..1ab8ed3
--- /dev/null
@@ -0,0 +1,26 @@
+--- linux-3.10/drivers/input/misc/wistron_btns.c.orig  2013-11-16 09:05:55.612742472 +0100
++++ linux-3.10/drivers/input/misc/wistron_btns.c       2013-11-16 09:24:37.356028732 +0100
+@@ -33,6 +33,7 @@
+ #include <linux/types.h>
+ #include <linux/platform_device.h>
+ #include <linux/leds.h>
++#include <asm/cacheflush.h>
+ /* How often we poll keys - msecs */
+ #define POLL_INTERVAL_DEFAULT 500 /* when idle */
+@@ -124,6 +125,7 @@
+       if (entry_point >= 0xF0000) {
+               bios_code_map_base = base;
+               bios_entry_point = bios_code_map_base + (entry_point & 0xFFFF);
++              set_memory_x((unsigned long)bios_code_map_base, 0x10000 >> PAGE_SHIFT);
+       } else {
+               iounmap(base);
+               bios_code_map_base = ioremap(entry_point & ~0x3FFF, 0x4000);
+@@ -134,6 +136,7 @@
+                       goto err;
+               }
+               bios_entry_point = bios_code_map_base + (entry_point & 0x3FFF);
++              set_memory_x((unsigned long)bios_code_map_base, 0x4000 >> PAGE_SHIFT);
+       }
+       /* The Windows driver maps 0x10000 bytes, we keep only one page... */
+       bios_data_map_base = ioremap(0x400, 0xc00);
This page took 0.31967 seconds and 4 git commands to generate.