]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- up to 4.19.20 auto/th/kernel-4.19-4.19.20-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 7 Feb 2019 12:06:01 +0000 (13:06 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 7 Feb 2019 12:06:01 +0000 (13:06 +0100)
kernel-small_fixes.patch
kernel.spec

index 5fcf48ab9e00060302ea72f256a091861e15d1f1..6d08eeea1e47c96e7731d644ef28e2c78f057f66 100644 (file)
@@ -162,68 +162,6 @@ index 76c92e31afc0..abb5d382f64d 100644
 -- 
 cgit 1.2-0.3.lf.el7
 
-From 9c9e935fc038342c48461aabca666f1b544e32b1 Mon Sep 17 00:00:00 2001
-From: Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>
-Date: Sun, 27 Jan 2019 23:51:37 +0900
-Subject: [PATCH v3] oom, oom_reaper: do not enqueue same task twice
-
-Arkadiusz reported that enabling memcg's group oom killing causes
-strange memcg statistics where there is no task in a memcg despite
-the number of tasks in that memcg is not 0. It turned out that there
-is a bug in wake_oom_reaper() which allows enqueuing same task twice
-which makes impossible to decrease the number of tasks in that memcg
-due to a refcount leak.
-
-This bug existed since the OOM reaper became invokable from
-task_will_free_mem(current) path in out_of_memory() in Linux 4.7,
-but memcg's group oom killing made it easier to trigger this bug by
-calling wake_oom_reaper() on the same task from one out_of_memory()
-request.
-
-Fix this bug using an approach used by commit 855b018325737f76
-("oom, oom_reaper: disable oom_reaper for oom_kill_allocating_task").
-As a side effect of this patch, this patch also avoids enqueuing
-multiple threads sharing memory via task_will_free_mem(current) path.
-
-Signed-off-by: Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>
-Reported-by: Arkadiusz Miśkiewicz <arekm@maven.pl>
-Tested-by: Arkadiusz Miśkiewicz <arekm@maven.pl>
-Fixes: af8e15cc85a25315 ("oom, oom_reaper: do not enqueue task if it is on the oom_reaper_list head")
----
- include/linux/sched/coredump.h | 1 +
- mm/oom_kill.c                  | 4 ++--
- 2 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/include/linux/sched/coredump.h b/include/linux/sched/coredump.h
-index ec912d0..ecdc654 100644
---- a/include/linux/sched/coredump.h
-+++ b/include/linux/sched/coredump.h
-@@ -71,6 +71,7 @@ static inline int get_dumpable(struct mm_struct *mm)
- #define MMF_HUGE_ZERO_PAGE    23      /* mm has ever used the global huge zero page */
- #define MMF_DISABLE_THP               24      /* disable THP for all VMAs */
- #define MMF_OOM_VICTIM                25      /* mm is the oom victim */
-+#define MMF_OOM_REAP_QUEUED   26      /* mm was queued for oom_reaper */
- #define MMF_DISABLE_THP_MASK  (1 << MMF_DISABLE_THP)
- #define MMF_INIT_MASK         (MMF_DUMPABLE_MASK | MMF_DUMP_FILTER_MASK |\
-diff --git a/mm/oom_kill.c b/mm/oom_kill.c
-index f0e8cd9..059e617 100644
---- a/mm/oom_kill.c
-+++ b/mm/oom_kill.c
-@@ -647,8 +647,8 @@ static int oom_reaper(void *unused)
- static void wake_oom_reaper(struct task_struct *tsk)
- {
--      /* tsk is already queued? */
--      if (tsk == oom_reaper_list || tsk->oom_reaper_list)
-+      /* mm is already queued? */
-+      if (test_and_set_bit(MMF_OOM_REAP_QUEUED, &tsk->signal->oom_mm->flags))
-               return;
-       get_task_struct(tsk);
--- 
-1.8.3.1
-
 From: Dave Chinner <dchinner@redhat.com>
 
 This reverts commit a76cf1a474d7dbcd9336b5f5afb0162baa142cf0.
index 770240e93be0f08c76f063edaeb98ccc29a53650..9364547b56b3ca567f7e1c6e89baf02ed29b54ca 100644 (file)
@@ -68,9 +68,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             2
+%define                rel             1
 %define                basever         4.19
-%define                postver         .19
+%define                postver         .20
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       -%{basever}
@@ -122,7 +122,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: 740a90cf810c2105df8ee12e5d0bb900
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  687b992be5e0514397acc6713ea121c0
+# Patch0-md5:  b7f5c27b35761abc61b184b6e980d1b9
 %endif
 Source1:       kernel.sysconfig
 
This page took 0.061913 seconds and 4 git commands to generate.