]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- up to 4.20.7
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 7 Feb 2019 14:55:52 +0000 (15:55 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 7 Feb 2019 14:55:52 +0000 (15:55 +0100)
kernel-small_fixes.patch
kernel.spec

index eb20ac48716edec153380aa72049667a3a91eec8..1398e42d044da0d0eff49402b4286ba237d15d68 100644 (file)
@@ -162,65 +162,4 @@ index 76c92e31afc0..abb5d382f64d 100644
 -- 
 cgit 1.2-0.3.lf.el7
 
-From 9c9e935fc038342c48461aabca666f1b544e32b1 Mon Sep 17 00:00:00 2001
-From: Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>
-Date: Sun, 27 Jan 2019 23:51:37 +0900
-Subject: [PATCH v3] oom, oom_reaper: do not enqueue same task twice
-
-Arkadiusz reported that enabling memcg's group oom killing causes
-strange memcg statistics where there is no task in a memcg despite
-the number of tasks in that memcg is not 0. It turned out that there
-is a bug in wake_oom_reaper() which allows enqueuing same task twice
-which makes impossible to decrease the number of tasks in that memcg
-due to a refcount leak.
-
-This bug existed since the OOM reaper became invokable from
-task_will_free_mem(current) path in out_of_memory() in Linux 4.7,
-but memcg's group oom killing made it easier to trigger this bug by
-calling wake_oom_reaper() on the same task from one out_of_memory()
-request.
-
-Fix this bug using an approach used by commit 855b018325737f76
-("oom, oom_reaper: disable oom_reaper for oom_kill_allocating_task").
-As a side effect of this patch, this patch also avoids enqueuing
-multiple threads sharing memory via task_will_free_mem(current) path.
-
-Signed-off-by: Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>
-Reported-by: Arkadiusz Miśkiewicz <arekm@maven.pl>
-Tested-by: Arkadiusz Miśkiewicz <arekm@maven.pl>
-Fixes: af8e15cc85a25315 ("oom, oom_reaper: do not enqueue task if it is on the oom_reaper_list head")
----
- include/linux/sched/coredump.h | 1 +
- mm/oom_kill.c                  | 4 ++--
- 2 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/include/linux/sched/coredump.h b/include/linux/sched/coredump.h
-index ec912d0..ecdc654 100644
---- a/include/linux/sched/coredump.h
-+++ b/include/linux/sched/coredump.h
-@@ -71,6 +71,7 @@ static inline int get_dumpable(struct mm_struct *mm)
- #define MMF_HUGE_ZERO_PAGE    23      /* mm has ever used the global huge zero page */
- #define MMF_DISABLE_THP               24      /* disable THP for all VMAs */
- #define MMF_OOM_VICTIM                25      /* mm is the oom victim */
-+#define MMF_OOM_REAP_QUEUED   26      /* mm was queued for oom_reaper */
- #define MMF_DISABLE_THP_MASK  (1 << MMF_DISABLE_THP)
- #define MMF_INIT_MASK         (MMF_DUMPABLE_MASK | MMF_DUMP_FILTER_MASK |\
-diff --git a/mm/oom_kill.c b/mm/oom_kill.c
-index f0e8cd9..059e617 100644
---- a/mm/oom_kill.c
-+++ b/mm/oom_kill.c
-@@ -647,8 +647,8 @@ static int oom_reaper(void *unused)
- static void wake_oom_reaper(struct task_struct *tsk)
- {
--      /* tsk is already queued? */
--      if (tsk == oom_reaper_list || tsk->oom_reaper_list)
-+      /* mm is already queued? */
-+      if (test_and_set_bit(MMF_OOM_REAP_QUEUED, &tsk->signal->oom_mm->flags))
-               return;
-       get_task_struct(tsk);
--- 
-1.8.3.1
 
index b5b6d269e55cc0278f568ab7f0165b94fba7a726..4f4bfe22f8611a01b544b519dace23b0c2aa1326 100644 (file)
@@ -69,7 +69,7 @@
 
 %define                rel             1
 %define                basever         4.20
-%define                postver         .6
+%define                postver         .7
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -121,7 +121,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: d39dd4ba2d5861c54b90d49be19eaf31
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  b8faceed2182f048279e400846df8ab7
+# Patch0-md5:  ea5939ea08cf6f11964465ab884741d0
 %endif
 Source1:       kernel.sysconfig
 
This page took 0.062358 seconds and 4 git commands to generate.