]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- up to 4.4.161 auto/th/kernel-4.4-4.4.161-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 14 Oct 2018 15:25:18 +0000 (17:25 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 14 Oct 2018 15:25:18 +0000 (17:25 +0200)
kernel-zph.patch
kernel.spec

index e61e33bc2d0a9f99ca056c1f766bde576d4608e1..7b109fc89f7f303bd5fc6f0686a2011f86f785d7 100644 (file)
@@ -28,13 +28,13 @@ diff -Nur linux-2.6.26.3/net/ipv4/tcp_input.c linux-2.6.26.3-zph/net/ipv4/tcp_in
 +++ linux-2.6.26.3-zph/net/ipv4/tcp_input.c    2008-08-21 17:06:55.000000000 +0300
 @@ -3900,6 +3900,8 @@
        struct tcp_sock *tp = tcp_sk(sk);
-       int eaten = -1;
        bool fragstolen = false;
+       int eaten = -1;
 +      struct inet_sock *inet = inet_sk(sk);
 +      struct iphdr *iph = ip_hdr(skb);
  
        if (TCP_SKB_CB(skb)->seq == TCP_SKB_CB(skb)->end_seq)
-               goto drop;
+               __kfree_skb(skb);
 @@ -3914,6 +3916,12 @@
                                             4 - tp->rx_opt.tstamp_ok);
        }
index b55b68e9a2598c918a25b4992d4d34cc52090bb4..9a24986f55e7141252200d1d14b726cee3fec373 100644 (file)
@@ -72,7 +72,7 @@
 
 %define                rel             1
 %define                basever         4.4
-%define                postver         .160
+%define                postver         .161
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       -%{basever}
@@ -124,7 +124,7 @@ Source0:    http://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: 9a78fa2eb6c68ca5a40ed5af08142599
 %if "%{postver}" != ".0"
 Patch0:                http://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  ff6ae28e7c8e0d4fc20d3c9da8bfa0e0
+# Patch0-md5:  eeaeff4e336aae6f4c1a268a4f4d5fb6
 %endif
 Source1:       kernel.sysconfig
 
This page took 2.061815 seconds and 4 git commands to generate.