]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- rel 1; updated aufs5 patch auto/th/kernel-5.4.0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 26 Nov 2019 21:00:59 +0000 (22:00 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 26 Nov 2019 21:00:59 +0000 (22:00 +0100)
kernel-aufs5.patch
kernel.spec

index df36e30835b2334f3cc0b2d46e7cb3b1046fc4b4..422443a409964e8b83b203685700b251ea3649fc 100644 (file)
@@ -6,9 +6,9 @@ index bfb1c6095c7a..bddba5bb307e 100644
 --- a/fs/Kconfig
 +++ b/fs/Kconfig
 @@ -261,6 +261,7 @@ source "fs/romfs/Kconfig"
- source "fs/pstore/Kconfig"
  source "fs/sysv/Kconfig"
  source "fs/ufs/Kconfig"
+ source "fs/erofs/Kconfig"
 +source "fs/aufs/Kconfig"
  
  endif # MISC_FILESYSTEMS
@@ -17,10 +17,10 @@ diff --git a/fs/Makefile b/fs/Makefile
 index d60089fd689b..924c16a40b00 100644
 --- a/fs/Makefile
 +++ b/fs/Makefile
-@@ -130,3 +130,4 @@ obj-$(CONFIG_F2FS_FS)              += f2fs/
- obj-$(CONFIG_CEPH_FS)         += ceph/
+@@ -132,3 +132,4 @@ obj-$(CONFIG_CEPH_FS)              += ceph/
  obj-$(CONFIG_PSTORE)          += pstore/
  obj-$(CONFIG_EFIVAR_FS)               += efivarfs/
+ obj-$(CONFIG_EROFS_FS)                += erofs/
 +obj-$(CONFIG_AUFS_FS)           += aufs/
 SPDX-License-Identifier: GPL-2.0
 aufs5.x-rcN base patch
@@ -799,14 +799,6 @@ index b07b53f24ff5..34b9bbf4c556 100644
  
  /*
   * Variant of alloc_empty_file() that doesn't check and modify nr_files.
-@@ -327,6 +328,7 @@ void flush_delayed_fput(void)
- {
-       delayed_fput(NULL);
- }
-+EXPORT_SYMBOL_GPL(flush_delayed_fput);
- static DECLARE_DELAYED_WORK(delayed_fput_work, delayed_fput);
 @@ -374,6 +376,7 @@ void __fput_sync(struct file *file)
  }
  
@@ -855,11 +847,9 @@ index 34c8093ddb1d..2b64af58b643 100644
  
  static void lock_mnt_tree(struct mount *mnt)
  {
-diff --git a/fs/notify/group.c b/fs/notify/group.c
-index 0391190305cc..0b9f7f6d8390 100644
---- a/fs/notify/group.c
-+++ b/fs/notify/group.c
-@@ -99,6 +99,7 @@ void fsnotify_get_group(struct fsnotify_group *group)
+--- linux-5.4/fs/notify/group.c~       2019-11-25 01:32:01.000000000 +0100
++++ linux-5.4/fs/notify/group.c        2019-11-26 20:14:34.917150671 +0100
+@@ -99,6 +99,7 @@ void fsnotify_get_group(struct fsnotify_
  {
        refcount_inc(&group->refcnt);
  }
@@ -867,58 +857,6 @@ index 0391190305cc..0b9f7f6d8390 100644
  
  /*
   * Drop a reference to a group.  Free it if it's through.
-@@ -108,6 +109,7 @@ void fsnotify_put_group(struct fsnotify_group *group)
-       if (refcount_dec_and_test(&group->refcnt))
-               fsnotify_final_destroy_group(group);
- }
-+EXPORT_SYMBOL_GPL(fsnotify_put_group);
- /*
-  * Create a new fsnotify_group and hold a reference for the group returned.
-@@ -137,6 +139,7 @@ struct fsnotify_group *fsnotify_alloc_group(const struct fsnotify_ops *ops)
-       return group;
- }
-+EXPORT_SYMBOL_GPL(fsnotify_alloc_group);
- int fsnotify_fasync(int fd, struct file *file, int on)
- {
-diff --git a/fs/notify/mark.c b/fs/notify/mark.c
-index 99ddd126f6f0..2154d69a2c7a 100644
---- a/fs/notify/mark.c
-+++ b/fs/notify/mark.c
-@@ -276,6 +276,7 @@ void fsnotify_put_mark(struct fsnotify_mark *mark)
-       queue_delayed_work(system_unbound_wq, &reaper_work,
-                          FSNOTIFY_REAPER_DELAY);
- }
-+EXPORT_SYMBOL_GPL(fsnotify_put_mark);
- /*
-  * Get mark reference when we found the mark via lockless traversal of object
-@@ -430,6 +431,7 @@ void fsnotify_destroy_mark(struct fsnotify_mark *mark,
-       mutex_unlock(&group->mark_mutex);
-       fsnotify_free_mark(mark);
- }
-+EXPORT_SYMBOL_GPL(fsnotify_destroy_mark);
- /*
-  * Sorting function for lists of fsnotify marks.
-@@ -685,6 +687,7 @@ int fsnotify_add_mark(struct fsnotify_mark *mark, fsnotify_connp_t *connp,
-       mutex_unlock(&group->mark_mutex);
-       return ret;
- }
-+EXPORT_SYMBOL_GPL(fsnotify_add_mark);
- /*
-  * Given a list of marks, find the mark associated with given group. If found
-@@ -809,6 +812,7 @@ void fsnotify_init_mark(struct fsnotify_mark *mark,
-       mark->group = group;
-       WRITE_ONCE(mark->connector, NULL);
- }
-+EXPORT_SYMBOL_GPL(fsnotify_init_mark);
- /*
-  * Destroy all marks in destroy_list, waits for SRCU period to finish before
 diff --git a/fs/open.c b/fs/open.c
 index a59abe3c669a..78809163ba03 100644
 --- a/fs/open.c
index a2470c933da7741870a7a20596c52e6f0ec71304..9844531ae5bd3850d802bf98cc8714885d35d4e6 100644 (file)
@@ -67,7 +67,7 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             0.1
+%define                rel             1
 %define                basever         5.4
 %define                postver         .0
 
This page took 0.109262 seconds and 4 git commands to generate.