]> git.pld-linux.org Git - packages/kernel.git/commitdiff
fix for pcie regression on mvebu
authorJan Palus <atler@pld-linux.org>
Fri, 4 Feb 2022 16:01:57 +0000 (17:01 +0100)
committerJan Palus <atler@pld-linux.org>
Fri, 4 Feb 2022 16:01:57 +0000 (17:01 +0100)
see https://lore.kernel.org/linux-pci/20220203154728.GA96160@bhelgaas/T/#m1e9498ed2ebeaabf39c1b714c88f23812a88c279

kernel.spec
mvebu-pcie.patch [new file with mode: 0644]

index 2e0f80bf0e00184dcba1db6c207b8d1c4d73ba95..d3f3a73f17084e923d3a9c3097e0444dacbac3b6 100644 (file)
@@ -215,6 +215,7 @@ Patch7000:  kernel-inittmpfs.patch
 Patch8000:     rpi-sound.patch
 Patch8001:     kernel-pinebook-pro.patch
 Patch8002:     atheros-disallow-retrain-nongen1-pcie.patch
+Patch8003:     mvebu-pcie.patch
 
 # Do not remove this line, please. It is easier for me to uncomment two lines, then patch
 # kernel.spec every time.
@@ -666,6 +667,7 @@ cd linux-%{basever}
 %patch8000 -p1
 %patch8001 -p1
 %patch8002 -p1
+%patch8003 -p1
 %endif
 
 %if %{with rt}
diff --git a/mvebu-pcie.patch b/mvebu-pcie.patch
new file mode 100644 (file)
index 0000000..9b9e0d6
--- /dev/null
@@ -0,0 +1,12 @@
+--- linux-5.16/drivers/pci/controller/pci-mvebu.c.orig 2022-02-04 16:52:46.089869659 +0100
++++ linux-5.16/drivers/pci/controller/pci-mvebu.c      2022-02-04 17:00:31.993825135 +0100
+@@ -1288,7 +1288,8 @@
+                * indirectly via kernel emulated PCI bridge driver.
+                */
+               mvebu_pcie_setup_hw(port);
+-              mvebu_pcie_set_local_dev_nr(port, 0);
++              mvebu_pcie_set_local_dev_nr(port, 1);
++              mvebu_pcie_set_local_bus_nr(port, 0);
+       }
+       pcie->nports = i;
This page took 1.557276 seconds and 4 git commands to generate.