]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- 4.9.8 auto/th/kernel-4.9.8-1 auto/th/kernel-nopae-4.9.8-1
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 6 Feb 2017 06:42:55 +0000 (07:42 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 6 Feb 2017 06:42:55 +0000 (07:42 +0100)
kernel-small_fixes.patch
kernel.spec

index 1bc4a8f87929ca94eb7247b4d6f51ced14645cd5..d4b603499b05f64e51b96e527678c26a94700ef8 100644 (file)
                                exit
                        fi
                done
-
-From:   Eric Sandeen <sandeen@redhat.com>
-Subject: [PATCH] xfs: don't wrap ID in xfs_dq_get_next_id
-Message-ID: <f52de68d-abe6-1960-c0ef-1d199346f689@redhat.com>
-Date:   Fri, 16 Dec 2016 18:05:20 -0600
-
-The GETNEXTQOTA ioctl takes whatever ID is sent in,
-and looks for the next active quota for an user
-equal or higher to that ID.
-
-But if we are at the maximum ID and then ask for the "next"
-one, we may wrap back to zero.  In this case, userspace
-may loop forever, because it will start querying again
-at zero.
-
-We'll fix this in userspace as well, but for the kernel,
-return -ENOENT if we ask for the next quota ID
-past UINT_MAX so the caller knows to stop.
-
-Signed-off-by: Eric Sandeen <sandeen@redhat.com>
----
-
-diff --git a/fs/xfs/xfs_dquot.c b/fs/xfs/xfs_dquot.c
-index 7a30b8f..dbeddd9 100644
---- a/fs/xfs/xfs_dquot.c
-+++ b/fs/xfs/xfs_dquot.c
-@@ -710,6 +710,10 @@
-       /* Simple advance */
-       next_id = *id + 1;
-+      /* If we'd wrap past the max ID, stop */
-+      if (next_id < *id)
-+              return -ENOENT;
-+
-       /* If new ID is within the current chunk, advancing it sufficed */
-       if (next_id % mp->m_quotainfo->qi_dqperchunk) {
-               *id = next_id;
-
-
index a2ea8ca6999f78afbdd56cb9c665792df49440a5..fbdb3fd7cc28f6a26a7796ca0b85edfb733973a9 100644 (file)
@@ -73,7 +73,7 @@
 
 %define                rel             1
 %define                basever         4.9
-%define                postver         .7
+%define                postver         .8
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -125,7 +125,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: 0a68ef3615c64bd5ee54a3320e46667d
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  e1f02eaa546e2f2c46b4c89b2b3c282f
+# Patch0-md5:  96c8ec21e9c75afce14f718d90478040
 %endif
 Source1:       kernel.sysconfig
 
This page took 0.249578 seconds and 4 git commands to generate.