]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- 4.9.114 auto/th/kernel-4.9-4.9.114-1
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 24 Jul 2018 22:28:26 +0000 (00:28 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 24 Jul 2018 22:28:26 +0000 (00:28 +0200)
kernel-aufs4.patch
kernel.spec

index c117b634054a51dbe6a4ae46c238a9f0efe240ee..f409e97405564c299faa85cb27437fd46b7194f7 100644 (file)
@@ -38277,7 +38277,7 @@ index 6ee9235..f64161f 100644
        struct inode    *inode;
        int             error;
  
-@@ -665,9 +678,16 @@ static int loop_change_fd(struct loop_device *lo, struct block_device *bdev,
+@@ -665,13 +678,20 @@ static int loop_change_fd(struct loop_device *lo, struct block_device *bdev,
        file = fget(arg);
        if (!file)
                goto out;
@@ -38288,6 +38288,10 @@ index 6ee9235..f64161f 100644
 +              get_file(file);
 +      }
  
+       error = loop_validate_file(file, bdev);
+       if (error)
+               goto out_putf;
        inode = file->f_mapping->host;
        old_file = lo->lo_backing_file;
 +      old_virt_file = lo->lo_backing_virt_file;
@@ -38321,7 +38325,7 @@ index 6ee9235..f64161f 100644
  static int loop_set_fd(struct loop_device *lo, fmode_t mode,
                       struct block_device *bdev, unsigned int arg)
  {
--      struct file     *file, *f;
+-      struct file     *file;
 +      struct file     *file, *f, *virt_file = NULL;
        struct inode    *inode;
        struct address_space *mapping;
index 325418bce0ad9575f7eb5bcd26e8900226ce0ca3..715642eddc2e8e8decddca736d163486a41541fd 100644 (file)
@@ -73,7 +73,7 @@
 
 %define                rel             1
 %define                basever         4.9
-%define                postver         .112
+%define                postver         .114
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       -%{basever}
@@ -125,7 +125,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: 0a68ef3615c64bd5ee54a3320e46667d
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  aa970105962eae5046c464e5e5b283fd
+# Patch0-md5:  9b83fef1ec18f9fb18d70cba04c8306f
 %endif
 Source1:       kernel.sysconfig
 
This page took 1.746222 seconds and 4 git commands to generate.