]> git.pld-linux.org Git - packages/kernel.git/commitdiff
rt patch updated
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Wed, 2 Nov 2016 09:49:05 +0000 (10:49 +0100)
committerJacek Konieczny <j.konieczny@eggsoft.pl>
Wed, 2 Nov 2016 09:49:05 +0000 (10:49 +0100)
kernel-rt.patch
kernel.spec

index 0ce35b8d58a58f83c3f0c6baa475aa5f7746db43..96ec6ba9eae86eee90b73072ad25b2e03b90e522 100644 (file)
@@ -305,7 +305,7 @@ index 000000000000..6f2aeabf7faa
 +
 +These data are also reset when the wakeup histogram is reset.
 diff --git a/Makefile b/Makefile
-index 95421b688f23..336590d1c969 100644
+index b6ee4ce561f8..3b2614a0fa1b 100644
 --- a/Makefile
 +++ b/Makefile
 @@ -783,6 +783,9 @@ KBUILD_CFLAGS   += $(call cc-option,-Werror=strict-prototypes)
@@ -4024,7 +4024,7 @@ index bb3ed488f7b5..628c6c13c482 100644
  
  void blk_mq_init_cpu_notifier(struct blk_mq_cpu_notifier *notifier,
 diff --git a/block/blk-mq.c b/block/blk-mq.c
-index 839b1e17481b..0e205b886246 100644
+index c3e461ec40e4..03dfc2c91595 100644
 --- a/block/blk-mq.c
 +++ b/block/blk-mq.c
 @@ -92,7 +92,7 @@ EXPORT_SYMBOL_GPL(blk_mq_freeze_queue_start);
@@ -4324,7 +4324,7 @@ index 3cf77afd142c..dc32e72132f1 100644
        if (ACPI_FAILURE(status)) {
                goto exit;
 diff --git a/drivers/acpi/acpica/hwxface.c b/drivers/acpi/acpica/hwxface.c
-index 5f97468df8ff..8c017f15da7d 100644
+index b2e50d8007fe..ff007084dc48 100644
 --- a/drivers/acpi/acpica/hwxface.c
 +++ b/drivers/acpi/acpica/hwxface.c
 @@ -374,7 +374,7 @@ acpi_status acpi_write_bit_register(u32 register_id, u32 value)
@@ -11235,7 +11235,7 @@ index ea448a344767..3e1c9d589dfa 100644
  
  static inline struct usba_ep *to_usba_ep(struct usb_ep *ep)
 diff --git a/fs/aio.c b/fs/aio.c
-index 155f84253f33..dd8d6f234a0b 100644
+index fe4f49212b99..c3194afdc3df 100644
 --- a/fs/aio.c
 +++ b/fs/aio.c
 @@ -40,6 +40,7 @@
@@ -11255,7 +11255,7 @@ index 155f84253f33..dd8d6f234a0b 100644
  
        /*
         * signals when all in-flight requests are done
-@@ -253,6 +254,7 @@ static int __init aio_setup(void)
+@@ -258,6 +259,7 @@ static int __init aio_setup(void)
                .mount          = aio_mount,
                .kill_sb        = kill_anon_super,
        };
@@ -11263,7 +11263,7 @@ index 155f84253f33..dd8d6f234a0b 100644
        aio_mnt = kern_mount(&aio_fs);
        if (IS_ERR(aio_mnt))
                panic("Failed to create aio fs mount.");
-@@ -568,9 +570,9 @@ static int kiocb_cancel(struct aio_kiocb *kiocb)
+@@ -573,9 +575,9 @@ static int kiocb_cancel(struct aio_kiocb *kiocb)
        return cancel(&kiocb->common);
  }
  
@@ -11275,7 +11275,7 @@ index 155f84253f33..dd8d6f234a0b 100644
  
        pr_debug("freeing %p\n", ctx);
  
-@@ -589,8 +591,8 @@ static void free_ioctx_reqs(struct percpu_ref *ref)
+@@ -594,8 +596,8 @@ static void free_ioctx_reqs(struct percpu_ref *ref)
        if (ctx->rq_wait && atomic_dec_and_test(&ctx->rq_wait->count))
                complete(&ctx->rq_wait->comp);
  
@@ -11286,7 +11286,7 @@ index 155f84253f33..dd8d6f234a0b 100644
  }
  
  /*
-@@ -598,9 +600,9 @@ static void free_ioctx_reqs(struct percpu_ref *ref)
+@@ -603,9 +605,9 @@ static void free_ioctx_reqs(struct percpu_ref *ref)
   * and ctx->users has dropped to 0, so we know no more kiocbs can be submitted -
   * now it's safe to cancel any that need to be.
   */
@@ -11298,7 +11298,7 @@ index 155f84253f33..dd8d6f234a0b 100644
        struct aio_kiocb *req;
  
        spin_lock_irq(&ctx->ctx_lock);
-@@ -619,6 +621,14 @@ static void free_ioctx_users(struct percpu_ref *ref)
+@@ -624,6 +626,14 @@ static void free_ioctx_users(struct percpu_ref *ref)
        percpu_ref_put(&ctx->reqs);
  }
  
@@ -17088,7 +17088,7 @@ index fc1ef736253c..83c666537a7a 100644
        return r;
  }
 diff --git a/kernel/events/core.c b/kernel/events/core.c
-index 12ecd4f0329f..560ea99875d3 100644
+index bc6371b0e4fb..388de1dc27d9 100644
 --- a/kernel/events/core.c
 +++ b/kernel/events/core.c
 @@ -802,6 +802,7 @@ static void __perf_mux_hrtimer_init(struct perf_cpu_context *cpuctx, int cpu)
@@ -17099,7 +17099,7 @@ index 12ecd4f0329f..560ea99875d3 100644
  }
  
  static int perf_mux_hrtimer_restart(struct perf_cpu_context *cpuctx)
-@@ -7219,6 +7220,7 @@ static void perf_swevent_init_hrtimer(struct perf_event *event)
+@@ -7240,6 +7241,7 @@ static void perf_swevent_init_hrtimer(struct perf_event *event)
  
        hrtimer_init(&hwc->hrtimer, CLOCK_MONOTONIC, HRTIMER_MODE_REL);
        hwc->hrtimer.function = perf_swevent_hrtimer;
@@ -17121,7 +17121,7 @@ index ffba5df4abd5..e199407f8831 100644
        spin_unlock(&sighand->siglock);
  
 diff --git a/kernel/fork.c b/kernel/fork.c
-index 8860d1f50d24..1e2599a403a5 100644
+index 7161ebe67cbb..3b880312b385 100644
 --- a/kernel/fork.c
 +++ b/kernel/fork.c
 @@ -108,7 +108,7 @@ int max_threads;           /* tunable limit on nr_threads */
@@ -17183,7 +17183,7 @@ index 8860d1f50d24..1e2599a403a5 100644
  /*
   * Decrement the use count and release all resources for an mm.
   */
-@@ -1241,6 +1267,9 @@ static void rt_mutex_init_task(struct task_struct *p)
+@@ -1239,6 +1265,9 @@ static void rt_mutex_init_task(struct task_struct *p)
   */
  static void posix_cpu_timers_init(struct task_struct *tsk)
  {
@@ -17193,7 +17193,7 @@ index 8860d1f50d24..1e2599a403a5 100644
        tsk->cputime_expires.prof_exp = 0;
        tsk->cputime_expires.virt_exp = 0;
        tsk->cputime_expires.sched_exp = 0;
-@@ -1366,15 +1395,16 @@ static struct task_struct *copy_process(unsigned long clone_flags,
+@@ -1364,15 +1393,16 @@ static struct task_struct *copy_process(unsigned long clone_flags,
        spin_lock_init(&p->alloc_lock);
  
        init_sigpending(&p->pending);
@@ -25903,10 +25903,10 @@ index 22c57e191a23..d536824cbd36 100644
  
        /* Get the next period (per cpu) */
 diff --git a/kernel/time/timekeeping.c b/kernel/time/timekeeping.c
-index 4ff237dbc006..ecdc1d8c1ed9 100644
+index 445601c580d6..8744b0d87479 100644
 --- a/kernel/time/timekeeping.c
 +++ b/kernel/time/timekeeping.c
-@@ -2050,8 +2050,10 @@ EXPORT_SYMBOL(hardpps);
+@@ -2070,8 +2070,10 @@ EXPORT_SYMBOL(hardpps);
   */
  void xtime_update(unsigned long ticks)
  {
@@ -28941,11 +28941,11 @@ index 1afec32de6f2..11fa431046a8 100644
        dump_stack();
 diff --git a/localversion-rt b/localversion-rt
 new file mode 100644
-index 000000000000..e1d836252017
+index 000000000000..a3b2408c1da6
 --- /dev/null
 +++ b/localversion-rt
 @@ -0,0 +1 @@
-+-rt33
++-rt37
 diff --git a/mm/Kconfig b/mm/Kconfig
 index 97a4e06b15c0..9614351e68b8 100644
 --- a/mm/Kconfig
index 7a3a30ffbda3500f9a750ccc7e37a316945e0fe6..5f695510cbcdd0fa71a91c3048614ce8ec1aa75d 100644 (file)
@@ -222,7 +222,7 @@ Patch250:   kernel-fix_256colors_menuconfig.patch
 Patch400:      kernel-virtio-gl-accel.patch
 
 # https://rt.wiki.kernel.org/
-# https://www.kernel.org/pub/linux/kernel/projects/rt/4.4/patch-4.4.23-rt33.patch.xz
+# https://www.kernel.org/pub/linux/kernel/projects/rt/4.4/patch-4.4.27-rt37.patch.xz
 Patch500:      kernel-rt.patch
 
 Patch2000:     kernel-small_fixes.patch
This page took 0.126014 seconds and 4 git commands to generate.