]> git.pld-linux.org Git - packages/kernel.git/commitdiff
fixed ohci pcmcia driver not to define the same symbol twice. it should kernel-2_2_18-12
authorMichal Moskal <michal@moskal.me>
Wed, 24 Jan 2001 13:25:49 +0000 (13:25 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
compile now.

Changed files:
    kernel-pcmcia.patch -> 1.1
    kernel.spec -> 1.150

kernel-pcmcia.patch [new file with mode: 0644]
kernel.spec

diff --git a/kernel-pcmcia.patch b/kernel-pcmcia.patch
new file mode 100644 (file)
index 0000000..012c2d4
--- /dev/null
@@ -0,0 +1,32 @@
+diff -ur linux/drivers/ieee1394/ohci1394.h linux-/drivers/ieee1394/ohci1394.h
+--- linux/drivers/ieee1394/ohci1394.h  Wed Jan 24 14:03:08 2001
++++ linux-/drivers/ieee1394/ohci1394.h Wed Jan 24 13:52:25 2001
+@@ -276,6 +276,8 @@
+         return readl(ohci->registers + offset);
+ }
++/* I guess it should be in ohci*.c ... */
++#ifndef OTHER_FILE
+ /* This structure is not properly initialized ... it is taken from
+    the lynx_csr_rom written by Andreas ... Some fields in the root
+    directory and the module dependent info needs to be modified
+@@ -348,7 +350,7 @@
+         0x314c5630,
+         0x33000000
+ };
+-
++#endif
+ /* 2 KiloBytes of register space */
+ #define OHCI1394_REGISTER_SIZE                0x800       
+diff -ur linux/pcmcia-cs-3.1.24/clients/ohci1394_stub.c linux-/pcmcia-cs-3.1.24/clients/ohci1394_stub.c
+--- linux/pcmcia-cs-3.1.24/clients/ohci1394_stub.c     Thu Jan 18 02:11:30 2001
++++ linux-/pcmcia-cs-3.1.24/clients/ohci1394_stub.c    Wed Jan 24 13:52:54 2001
+@@ -56,6 +56,7 @@
+ #include <../drivers/ieee1394/ieee1394_types.h>
+ #include <../drivers/ieee1394/hosts.h>
+ #include <../drivers/ieee1394/ieee1394_core.h>
++#define OTHER_FILE
+ #include <../drivers/ieee1394/ohci1394.h>
+ #include <pcmcia/driver_ops.h>
index 8e5fe420067d40d9830ca6320fbc2fb2562a103e..479311ecfeb683a4f701308c9890012b15fe10df 100644 (file)
@@ -61,6 +61,7 @@ Patch16:      linux-raw.patch
 Patch17:       linux-i815-support.patch
 Patch18:       kernel-ide-geometry.patch
 #Patch:                linux-2.2.18pre21.ext3.diff
+Patch19:       kernel-pcmcia.patch
 
 ExclusiveOS:   Linux
 URL:           http://www.kernel.org/
@@ -315,6 +316,7 @@ Pakiet zawiera kod 
 %patch15 -p1
 %patch16 -p1
 %patch18 -p1
+%patch19 -p1
 %ifarch %{ix86}
 cd ..
 rm -rf i2c-%{i2c_version}
This page took 0.083273 seconds and 4 git commands to generate.