]> git.pld-linux.org Git - packages/kernel.git/commitdiff
Revert "- drop ancient patch"
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 31 Jul 2017 18:06:31 +0000 (20:06 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 31 Jul 2017 18:06:31 +0000 (20:06 +0200)
This reverts commit 294f635766f4f49c437764a990a8df4106534c30.

kernel.spec
linux-wistron-nx.patch [new file with mode: 0644]

index d0468c1fbe389a5c87901f1503c53c10aee7f188..cd3ba33376c50d1e7f9f1e2edb92098d98c81b2d 100644 (file)
@@ -152,6 +152,7 @@ Source58:   kernel-inittmpfs.config
 
 # http://dev.gentoo.org/~spock/projects/fbcondecor/archive/fbcondecor-0.9.4-2.6.25-rc6.patch
 Patch3:                kernel-fbcondecor.patch
+Patch6:                linux-wistron-nx.patch
 
 # netfilter related stuff mostly based on patch-o-matic-ng
 # snapshot 20070806 with some fixes. Some modules
@@ -632,6 +633,7 @@ cd linux-%{basever}
 %if %{with fbcondecor}
 %patch3 -p1
 %endif
+%patch6 -p1
 
 ## netfilter
 #
diff --git a/linux-wistron-nx.patch b/linux-wistron-nx.patch
new file mode 100644 (file)
index 0000000..1ab8ed3
--- /dev/null
@@ -0,0 +1,26 @@
+--- linux-3.10/drivers/input/misc/wistron_btns.c.orig  2013-11-16 09:05:55.612742472 +0100
++++ linux-3.10/drivers/input/misc/wistron_btns.c       2013-11-16 09:24:37.356028732 +0100
+@@ -33,6 +33,7 @@
+ #include <linux/types.h>
+ #include <linux/platform_device.h>
+ #include <linux/leds.h>
++#include <asm/cacheflush.h>
+ /* How often we poll keys - msecs */
+ #define POLL_INTERVAL_DEFAULT 500 /* when idle */
+@@ -124,6 +125,7 @@
+       if (entry_point >= 0xF0000) {
+               bios_code_map_base = base;
+               bios_entry_point = bios_code_map_base + (entry_point & 0xFFFF);
++              set_memory_x((unsigned long)bios_code_map_base, 0x10000 >> PAGE_SHIFT);
+       } else {
+               iounmap(base);
+               bios_code_map_base = ioremap(entry_point & ~0x3FFF, 0x4000);
+@@ -134,6 +136,7 @@
+                       goto err;
+               }
+               bios_entry_point = bios_code_map_base + (entry_point & 0x3FFF);
++              set_memory_x((unsigned long)bios_code_map_base, 0x4000 >> PAGE_SHIFT);
+       }
+       /* The Windows driver maps 0x10000 bytes, we keep only one page... */
+       bios_data_map_base = ioremap(0x400, 0xc00);
This page took 0.069401 seconds and 4 git commands to generate.