]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- deduplicated x86 config wrt. multiarch config, added debuginfo bcond
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 24 Jan 2019 04:36:20 +0000 (05:36 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 24 Jan 2019 04:36:20 +0000 (05:36 +0100)
kernel-multiarch.config
kernel-x86.config
kernel.spec

index 9fc3ed346db13a77b32c8fd15172e326c83b5f8b..379c23d9b63738fb5d4da076e3ee8cb6d6f13d3f 100644 (file)
@@ -11010,7 +11010,7 @@ TCP_MD5SIG all=y
 #-
 NF_SOCKET_IPV4 all=m
 NF_TPROXY_IPV4 all=m
-NF_TABLES_IPV4 all=m
+NF_TABLES_IPV4 all=y
 NFT_CHAIN_ROUTE_IPV4 all=m
 NFT_REJECT_IPV4 all=m
 NFT_DUP_IPV4 all=m
@@ -11084,7 +11084,7 @@ IPV6_SEG6_HMAC all=y
 #-
 NF_SOCKET_IPV6 all=m
 NF_TPROXY_IPV6 all=m
-NF_TABLES_IPV6 all=m
+NF_TABLES_IPV6 all=y
 NFT_CHAIN_ROUTE_IPV6 all=m
 NFT_CHAIN_NAT_IPV6 all=m
 NFT_MASQ_IPV6 all=m
@@ -11215,7 +11215,7 @@ NF_CT_NETLINK_TIMEOUT all=m
 NF_CT_NETLINK_HELPER all=m
 NETFILTER_NETLINK_GLUE_CT all=y
 NF_NAT all=m
-NF_NAT_REDIRECT all=m
+NF_NAT_REDIRECT all=y
 NF_TABLES all=m
 NF_TABLES_SET all=m
 NF_TABLES_INET all=y
index 43718adb90ececc95da01b18c1e31cd425a051fa..9db14869ad9a7b7775815fc03cd3881030d99597 100644 (file)
@@ -286,11 +286,6 @@ EFI_CAPSULE_QUIRK_QUARK_CSH i386=y
 #-
 AMD_IOMMU x86_64=y
 
-#-
-#- *** FILE: drivers/media/pci/ivtv/Kconfig ***
-#-
-VIDEO_IVTV_DEPRECATED_IOCTLS all=n
-
 #-
 #- *** FILE: drivers/media/pci/sta2x11/Kconfig ***
 #-
@@ -315,20 +310,6 @@ CS89x0_PLATFORM all=y
 #-
 VMD all=m
 
-#-
-#- *** FILE: drivers/pci/pcie/Kconfig ***
-#-
-#- file drivers/pci/pcie/aer/Kconfig goes here
-PCIEASPM_DEFAULT all=y
-PCIEASPM_POWERSAVE all=n
-PCIEASPM_POWER_SUPERSAVE all=n
-PCIEASPM_PERFORMANCE all=n
-
-#-
-#- *** FILE: drivers/platform/x86/Kconfig ***
-#-
-INTEL_TURBO_MAX_3 all=y
-
 #-
 #- *** FILE: drivers/staging/comedi/Kconfig ***
 #-
@@ -346,7 +327,6 @@ COMEDI_DAS08_ISA all=m
 IRQ_TIME_ACCOUNTING x86=n
 #- file kernel/rcu/Kconfig goes here
 #- file usr/Kconfig goes here
-PC104 all=y
 #- file arch/Kconfig goes here
 #- Do not forget to sign required modules with scripts/sign-file
 #- file block/Kconfig goes here
@@ -370,8 +350,6 @@ DEBUG_STACK_USAGE x86=n
 DEBUG_PER_CPU_MAPS x86=n
 DEBUG_STACKOVERFLOW x86=n
 #- file lib/Kconfig.kasan goes here
-KCOV all=n
-WW_MUTEX_SELFTEST all=m
 #- file kernel/rcu/Kconfig.debug goes here
 #- file kernel/trace/Kconfig goes here
 MEMTEST x86=n
@@ -400,12 +378,6 @@ PAGE_TABLE_ISOLATION x86_64=y
 #- file security/yama/Kconfig goes here
 #- file security/integrity/Kconfig goes here
 
-#-
-#- *** FILE: sound/x86/Kconfig ***
-#-
-SND_X86 all=y
-HDMI_LPE_AUDIO all=m
-
 #-
 #- *** PROBABLY REMOVED OPTIONS ***
 #-
index 45574ca44408198a07a21f8670fb7c2970ca9e5e..8f4a2257da0181fbae17c30c5854081db24d18ee 100644 (file)
@@ -16,8 +16,9 @@
 #
 # Conditional build:
 %bcond_without source          # don't build kernel-source package
-%bcond_without doc                     # don't build kernel-doc package
+%bcond_without doc             # don't build kernel-doc package
 %bcond_without pcmcia          # don't build pcmcia
+%bcond_without debuginfo       # debug info files
 
 %bcond_with    verbose         # verbose build (V=1)
 
@@ -838,6 +839,7 @@ BuildConfig() {
                CONFIG_HIGHMEM64G=y
                CONFIG_X86_PAE=y
                CONFIG_NUMA=n
+               CONFIG_PAGE_TABLE_ISOLATION=y
        %endif
 %endif
 
@@ -891,7 +893,7 @@ EOCONFIG
 
 cd %{objdir}
 install -d arch/%{target_arch_dir}
-BuildConfig > %{defconfig}
+BuildConfig %{!?with_debuginfo:| %{__sed} -e 's/CONFIG_DEBUG_INFO=y/# CONFIG_DEBUG_INFO is not set/'} > %{defconfig}
 ln -sf %{defconfig} .config
 cd -
 
@@ -997,6 +999,7 @@ if cp -al %{srcdir}/COPYING $RPM_BUILD_ROOT/COPYING 2>/dev/null; then
 fi
 
 cp -a$l %{srcdir}/* $RPM_BUILD_ROOT%{_kernelsrcdir}
+%{__rm} -r $RPM_BUILD_ROOT%{_kernelsrcdir}/scripts/kconfig/tests
 cp -a %{objdir}/Module.symvers $RPM_BUILD_ROOT%{_kernelsrcdir}
 cp -aL %{objdir}/.config $RPM_BUILD_ROOT%{_kernelsrcdir}
 cp -a %{objdir}/include $RPM_BUILD_ROOT%{_kernelsrcdir}
@@ -1041,7 +1044,7 @@ done
 %if %{with doc}
 # move to %{_docdir} so we wouldn't depend on any kernel package for dirs
 install -d $RPM_BUILD_ROOT%{_docdir}
-mv $RPM_BUILD_ROOT{%{_kernelsrcdir}/Documentation,%{_docdir}/%{name}-%{version}}
+%{__mv} $RPM_BUILD_ROOT{%{_kernelsrcdir}/Documentation,%{_docdir}/%{name}-%{version}}
 
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/dontdiff
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/Makefile
This page took 0.085914 seconds and 4 git commands to generate.