]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- rel 2; fix for adjtimex failed for set_frequency... error auto/th/kernel-3.14-3.14.33-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 19 Feb 2015 18:00:45 +0000 (19:00 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 19 Feb 2015 18:00:45 +0000 (19:00 +0100)
kernel-small_fixes.patch
kernel.spec

index 5c0de9dc69173692d54668458550909557c8ebd4..4c8ae25d2c427a9bafcb20437d166aaaafd85550 100644 (file)
@@ -112,3 +112,71 @@ index 4e565c8..732648b 100644
        spin_lock_init(&group->fanotify_data.access_lock);
 -- 
 cgit v0.10.1
+From 29183a70b0b828500816bd794b3fe192fce89f73 Mon Sep 17 00:00:00 2001
+From: John Stultz <john.stultz@linaro.org>
+Date: Mon, 9 Feb 2015 23:30:36 -0800
+Subject: ntp: Fixup adjtimex freq validation on 32-bit systems
+
+Additional validation of adjtimex freq values to avoid
+potential multiplication overflows were added in commit
+5e5aeb4367b (time: adjtimex: Validate the ADJ_FREQUENCY values)
+
+Unfortunately the patch used LONG_MAX/MIN instead of
+LLONG_MAX/MIN, which was fine on 64-bit systems, but being
+much smaller on 32-bit systems caused false positives
+resulting in most direct frequency adjustments to fail w/
+EINVAL.
+
+ntpd only does direct frequency adjustments at startup, so
+the issue was not as easily observed there, but other time
+sync applications like ptpd and chrony were more effected by
+the bug.
+
+See bugs:
+
+  https://bugzilla.kernel.org/show_bug.cgi?id=92481
+  https://bugzilla.redhat.com/show_bug.cgi?id=1188074
+
+This patch changes the checks to use LLONG_MAX for
+clarity, and additionally the checks are disabled
+on 32-bit systems since LLONG_MAX/PPM_SCALE is always
+larger then the 32-bit long freq value, so multiplication
+overflows aren't possible there.
+
+Reported-by: Josh Boyer <jwboyer@fedoraproject.org>
+Reported-by: George Joseph <george.joseph@fairview5.com>
+Tested-by: George Joseph <george.joseph@fairview5.com>
+Signed-off-by: John Stultz <john.stultz@linaro.org>
+Signed-off-by: Peter Zijlstra (Intel) <peterz@infradead.org>
+Cc: <stable@vger.kernel.org> # v3.19+
+Cc: Linus Torvalds <torvalds@linux-foundation.org>
+Cc: Sasha Levin <sasha.levin@oracle.com>
+Link: http://lkml.kernel.org/r/1423553436-29747-1-git-send-email-john.stultz@linaro.org
+[ Prettified the changelog and the comments a bit. ]
+Signed-off-by: Ingo Molnar <mingo@kernel.org>
+
+diff --git a/kernel/time/ntp.c b/kernel/time/ntp.c
+index 4b585e0..0f60b08 100644
+--- a/kernel/time/ntp.c
++++ b/kernel/time/ntp.c
+@@ -633,10 +633,14 @@ int ntp_validate_timex(struct timex *txc)
+       if ((txc->modes & ADJ_SETOFFSET) && (!capable(CAP_SYS_TIME)))
+               return -EPERM;
+-      if (txc->modes & ADJ_FREQUENCY) {
+-              if (LONG_MIN / PPM_SCALE > txc->freq)
++      /*
++       * Check for potential multiplication overflows that can
++       * only happen on 64-bit systems:
++       */
++      if ((txc->modes & ADJ_FREQUENCY) && (BITS_PER_LONG == 64)) {
++              if (LLONG_MIN / PPM_SCALE > txc->freq)
+                       return -EINVAL;
+-              if (LONG_MAX / PPM_SCALE < txc->freq)
++              if (LLONG_MAX / PPM_SCALE < txc->freq)
+                       return -EINVAL;
+       }
+-- 
+cgit v0.10.2
+
index e37f5501937844d60f307336a550027afb95ad50..f6f7472c64fc02802e4bef319613bca108201774 100644 (file)
@@ -68,7 +68,7 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             1
+%define                rel             2
 %define                basever         3.14
 %define                postver         .33
 
This page took 0.062918 seconds and 4 git commands to generate.