]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- up to 3.10.55 auto/th/kernel-3.10-3.10.55-1
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 20 Sep 2014 20:44:39 +0000 (22:44 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 20 Sep 2014 20:44:39 +0000 (22:44 +0200)
- raid fix applied upstream

kernel-small_fixes.patch
kernel-vserver-2.3.patch
kernel.spec

index 1c46d483446b59699952ecddd6f5fd3fecd73be9..5c0de9dc69173692d54668458550909557c8ebd4 100644 (file)
@@ -112,74 +112,3 @@ index 4e565c8..732648b 100644
        spin_lock_init(&group->fanotify_data.access_lock);
 -- 
 cgit v0.10.1
-
-
-Hi all,
- There is a risk of data loss with md/raid6 arrays running on Linux since
- 2.6.32.
- If:
-   - the array is doubly degraded
-   - one or both failed devices are being recovered, and
-   - the array is written to
-
- then it is possible for data on the array to be lost.  The patch below fixes
- the problem.  If you apply the patch to an older kernel which has separate
- handle_stripe5() and handle_stripe6() functions, be sure that patch changes
- handle_stripe6().
-
- There is no risk to an optimal array or a singly-degraded array.  There is
- also no risk on a doubly-degraded array which is not recovering a device or
- is not receiving write requests.
-
- If you have data on a RAID6 array, please consider how to avoid corruption,
- possibly by applying the patch, possibly by removing any hot spares so
- recovery does not automatically start.
-
- This patch will be sent upstream shortly and will subsequently appear in
- future "-stable" kernels.
-
-NeilBrown
-
-From f94e37dce722ec7b6666fd04be357f422daa02b5 Mon Sep 17 00:00:00 2001
-From: NeilBrown <neilb@suse.de>
-Date: Wed, 13 Aug 2014 09:57:07 +1000
-Subject: [PATCH] md/raid6: avoid data corruption during recovery of
- double-degraded RAID6
-
-During recovery of a double-degraded RAID6 it is possible for
-some blocks not to be recovered properly, leading to corruption.
-
-If a write happens to one block in a stripe that would be written to a
-missing device, and at the same time that stripe is recovering data
-to the other missing device, then that recovered data may not be written.
-
-This patch skips, in the double-degraded case, an optimisation that is
-only safe for single-degraded arrays.
-
-Bug was introduced in 2.6.32 and fix is suitable for any kernel since
-then.  In an older kernel with separate handle_stripe5() and
-handle_stripe6() functions that patch must change handle_stripe6().
-
-Cc: stable@vger.kernel.org (2.6.32+)
-Fixes: 6c0069c0ae9659e3a91b68eaed06a5c6c37f45c8
-Cc: Yuri Tikhonov <yur@emcraft.com>
-Cc: Dan Williams <dan.j.williams@intel.com>
-Reported-by: "Manibalan P" <pmanibalan@amiindia.co.in>
-Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1090423
-Signed-off-by: NeilBrown <neilb@suse.de>
-
-diff --git a/drivers/md/raid5.c b/drivers/md/raid5.c
-index 6b2d615d1094..183588b11fc1 100644
---- a/drivers/md/raid5.c
-+++ b/drivers/md/raid5.c
-@@ -3817,6 +3817,8 @@ static void handle_stripe(struct stripe_head *sh)
-                               set_bit(R5_Wantwrite, &dev->flags);
-                               if (prexor)
-                                       continue;
-+                              if (s.failed > 1)
-+                                      continue;
-                               if (!test_bit(R5_Insync, &dev->flags) ||
-                                   ((i == sh->pd_idx || i == sh->qd_idx)  &&
-                                    s.failed == 0))
-
-
index b311248d1d6fd267829195ebacf689c500415e44..4fb7855c71bc7f14a372bd8a0bcfec52edb1a7b5 100644 (file)
@@ -4257,9 +4257,9 @@ diff -NurpP --minimal linux-3.10.53/fs/namei.c linux-3.10.53-vs2.3.6.8/fs/namei.
 --- linux-3.10.53/fs/namei.c   2014-08-30 13:38:57.000000000 +0000
 +++ linux-3.10.53-vs2.3.6.8/fs/namei.c 2014-08-30 14:03:54.000000000 +0000
 @@ -34,9 +34,19 @@
- #include <linux/device_cgroup.h>
  #include <linux/fs_struct.h>
  #include <linux/posix_acl.h>
+ #include <linux/hash.h>
 +#include <linux/proc_fs.h>
 +#include <linux/magic.h>
 +#include <linux/vserver/inode.h>
index 1c9bbd48d52a9797eb0754025910059f6a537664..261d983871aca7d2fbb5abee9a56e1e373503992 100644 (file)
@@ -69,9 +69,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             2
+%define                rel             1
 %define                basever         3.10
-%define                postver         .54
+%define                postver         .55
 
 %define                versuffix       -%{basever}
 
@@ -116,7 +116,7 @@ Source0:    http://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
 # Source0-md5: 4f25cd5bec5f8d5a7d935b3f2ccb8481
 %if "%{postver}" != ".0"
 Patch0:                http://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
-# Patch0-md5:  aef1e3fb108cce7a8292b7419d0cae0f
+# Patch0-md5:  cfe6bac0660275dc3ecf6cf942d9f68d
 %endif
 Source1:       kernel.sysconfig
 
This page took 1.424997 seconds and 4 git commands to generate.