]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- rel 3; v2 version of the patch auto/th/kernel-4.20.3-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 26 Jan 2019 13:24:12 +0000 (14:24 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 26 Jan 2019 13:24:12 +0000 (14:24 +0100)
kernel-small_fixes.patch
kernel.spec

index 196102743c4119649f651a8f1394ee3b49f7070e..c210e45163935ea3ea8116b204708bf6e5d29dbd 100644 (file)
@@ -162,113 +162,73 @@ index 76c92e31afc0..abb5d382f64d 100644
 -- 
 cgit 1.2-0.3.lf.el7
 
-From 48744b6339cf649a69b55997e138c17df1ecc897 Mon Sep 17 00:00:00 2001\r
-From: Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>\r
-Date: Sat, 26 Jan 2019 20:00:51 +0900\r
-Subject: [PATCH] oom, oom_reaper: do not enqueue same task twice\r
-\r
-Arkadiusz reported that enabling memcg's group oom killing causes\r
-strange memcg statistics where there is no task in a memcg despite\r
-the number of tasks in that memcg is not 0. It turned out that there\r
-is a bug in wake_oom_reaper() which allows enqueuing same task twice\r
-which makes impossible to decrease the number of tasks in that memcg\r
-due to a refcount leak.\r
-\r
-This bug existed since the OOM reaper became invokable from\r
-task_will_free_mem(current) path in out_of_memory() in Linux 4.7,\r
-but memcg's group oom killing made it easier to trigger this bug by\r
-calling wake_oom_reaper() on the same task from one out_of_memory()\r
-request.\r
-\r
-Fix this bug using an approach used by commit 855b018325737f76\r
-("oom, oom_reaper: disable oom_reaper for oom_kill_allocating_task").\r
-Since task_will_free_mem(p) == false if p->mm == NULL, we can assume that\r
-p->mm != NULL when wake_oom_reaper() is called from task_will_free_mem()\r
-paths. As a side effect of this patch, this patch also avoids enqueuing\r
-multiple threads sharing memory via task_will_free_mem(current) path.\r
-\r
-Signed-off-by: Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>\r
-Reported-by: Arkadiusz Miśkiewicz <a.miskiewicz@gmail.com>\r
-Fixes: af8e15cc85a25315 ("oom, oom_reaper: do not enqueue task if it is on the oom_reaper_list head")\r
----\r
- mm/oom_kill.c | 28 +++++++++++++---------------\r
- 1 file changed, 13 insertions(+), 15 deletions(-)\r
-\r
-diff --git a/mm/oom_kill.c b/mm/oom_kill.c\r
-index f0e8cd9..457f240 100644\r
---- a/mm/oom_kill.c\r
-+++ b/mm/oom_kill.c\r
-@@ -505,14 +505,6 @@ bool __oom_reap_task_mm(struct mm_struct *mm)\r
-       struct vm_area_struct *vma;\r
-       bool ret = true;\r
\r
--      /*\r
--       * Tell all users of get_user/copy_from_user etc... that the content\r
--       * is no longer stable. No barriers really needed because unmapping\r
--       * should imply barriers already and the reader would hit a page fault\r
--       * if it stumbled over a reaped memory.\r
--       */\r
--      set_bit(MMF_UNSTABLE, &mm->flags);\r
--\r
-       for (vma = mm->mmap ; vma; vma = vma->vm_next) {\r
-               if (!can_madv_dontneed_vma(vma))\r
-                       continue;\r
-@@ -645,10 +637,15 @@ static int oom_reaper(void *unused)\r
-       return 0;\r
- }\r
\r
--static void wake_oom_reaper(struct task_struct *tsk)\r
-+static void wake_oom_reaper(struct task_struct *tsk, struct mm_struct *mm)\r
- {\r
--      /* tsk is already queued? */\r
--      if (tsk == oom_reaper_list || tsk->oom_reaper_list)\r
-+      /*\r
-+       * Tell all users of get_user/copy_from_user etc... that the content\r
-+       * is no longer stable. No barriers really needed because unmapping\r
-+       * should imply barriers already and the reader would hit a page fault\r
-+       * if it stumbled over a reaped memory.\r
-+       */\r
-+      if (test_and_set_bit(MMF_UNSTABLE, &mm->flags))\r
-               return;\r
\r
-       get_task_struct(tsk);\r
-@@ -668,7 +665,8 @@ static int __init oom_init(void)\r
- }\r
- subsys_initcall(oom_init)\r
- #else\r
--static inline void wake_oom_reaper(struct task_struct *tsk)\r
-+static inline void wake_oom_reaper(struct task_struct *tsk,\r
-+                                 struct mm_struct *mm)\r
- {\r
- }\r
- #endif /* CONFIG_MMU */\r
-@@ -915,7 +913,7 @@ static void __oom_kill_process(struct task_struct *victim)\r
-       rcu_read_unlock();\r
\r
-       if (can_oom_reap)\r
--              wake_oom_reaper(victim);\r
-+              wake_oom_reaper(victim, mm);\r
\r
-       mmdrop(mm);\r
-       put_task_struct(victim);\r
-@@ -955,7 +953,7 @@ static void oom_kill_process(struct oom_control *oc, const char *message)\r
-       task_lock(p);\r
-       if (task_will_free_mem(p)) {\r
-               mark_oom_victim(p);\r
--              wake_oom_reaper(p);\r
-+              wake_oom_reaper(p, p->mm);\r
-               task_unlock(p);\r
-               put_task_struct(p);\r
-               return;\r
-@@ -1085,7 +1083,7 @@ bool out_of_memory(struct oom_control *oc)\r
-        */\r
-       if (task_will_free_mem(current)) {\r
-               mark_oom_victim(current);\r
--              wake_oom_reaper(current);\r
-+              wake_oom_reaper(current, current->mm);\r
-               return true;\r
-       }\r
\r
--- \r
-1.8.3.1\r
-\r
+
+From 9c9e935fc038342c48461aabca666f1b544e32b1 Mon Sep 17 00:00:00 2001
+From: Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>
+Date: Sat, 26 Jan 2019 21:57:25 +0900
+Subject: [PATCH v2] oom, oom_reaper: do not enqueue same task twice
+
+Arkadiusz reported that enabling memcg's group oom killing causes
+strange memcg statistics where there is no task in a memcg despite
+the number of tasks in that memcg is not 0. It turned out that there
+is a bug in wake_oom_reaper() which allows enqueuing same task twice
+which makes impossible to decrease the number of tasks in that memcg
+due to a refcount leak.
+
+This bug existed since the OOM reaper became invokable from
+task_will_free_mem(current) path in out_of_memory() in Linux 4.7,
+but memcg's group oom killing made it easier to trigger this bug by
+calling wake_oom_reaper() on the same task from one out_of_memory()
+request.
+
+Fix this bug using an approach used by commit 855b018325737f76
+("oom, oom_reaper: disable oom_reaper for oom_kill_allocating_task").
+As a side effect of this patch, this patch also avoids enqueuing
+multiple threads sharing memory via task_will_free_mem(current) path.
+
+Signed-off-by: Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>
+Reported-by: Arkadiusz Miśkiewicz <arekm@maven.pl>
+Tested-by: Arkadiusz Miśkiewicz <arekm@maven.pl>
+Fixes: af8e15cc85a25315 ("oom, oom_reaper: do not enqueue task if it is on the oom_reaper_list head")
+---
+ mm/oom_kill.c | 17 +++++++----------
+ 1 file changed, 7 insertions(+), 10 deletions(-)
+
+diff --git a/mm/oom_kill.c b/mm/oom_kill.c
+index f0e8cd9..057bfee 100644
+--- a/mm/oom_kill.c
++++ b/mm/oom_kill.c
+@@ -505,14 +505,6 @@ bool __oom_reap_task_mm(struct mm_struct *mm)
+       struct vm_area_struct *vma;
+       bool ret = true;
+-      /*
+-       * Tell all users of get_user/copy_from_user etc... that the content
+-       * is no longer stable. No barriers really needed because unmapping
+-       * should imply barriers already and the reader would hit a page fault
+-       * if it stumbled over a reaped memory.
+-       */
+-      set_bit(MMF_UNSTABLE, &mm->flags);
+-
+       for (vma = mm->mmap ; vma; vma = vma->vm_next) {
+               if (!can_madv_dontneed_vma(vma))
+                       continue;
+@@ -647,8 +639,13 @@ static int oom_reaper(void *unused)
+ static void wake_oom_reaper(struct task_struct *tsk)
+ {
+-      /* tsk is already queued? */
+-      if (tsk == oom_reaper_list || tsk->oom_reaper_list)
++      /*
++       * Tell all users of get_user/copy_from_user etc... that the content
++       * is no longer stable. No barriers really needed because unmapping
++       * should imply barriers already and the reader would hit a page fault
++       * if it stumbled over a reaped memory.
++       */
++      if (test_and_set_bit(MMF_UNSTABLE, &tsk->signal->oom_mm->flags))
+               return;
+       get_task_struct(tsk);
+-- 
+1.8.3.1
+
index 166a18e1ae6dc54a3ab254d670ece6cc1410e9e2..16f7c40e96eb798025c7fd43cb6136b22a378779 100644 (file)
@@ -67,7 +67,7 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             2
+%define                rel             3
 %define                basever         4.20
 %define                postver         .3
 
This page took 1.17216 seconds and 4 git commands to generate.