]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- 4.4.143 auto/th/kernel-4.4-4.4.143-1
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 24 Jul 2018 22:22:27 +0000 (00:22 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 24 Jul 2018 22:22:27 +0000 (00:22 +0200)
kernel-aufs4.patch
kernel.spec

index 32030d7bd318a8b0ea0839da2f14b97c63a02435..31d98cdae1c16b9485c1aab63940b0a2232b45ee 100644 (file)
@@ -35701,7 +35701,7 @@ index abfdd2b..a2e3c43 100644
        struct inode    *inode;
        int             error;
  
-@@ -670,9 +683,16 @@ static int loop_change_fd(struct loop_device *lo, struct block_device *bdev,
+@@ -670,13 +683,20 @@ static int loop_change_fd(struct loop_device *lo, struct block_device *bdev,
        file = fget(arg);
        if (!file)
                goto out;
@@ -35712,6 +35712,10 @@ index abfdd2b..a2e3c43 100644
 +              get_file(file);
 +      }
  
+       error = loop_validate_file(file, bdev);
+       if (error)
+               goto out_putf;
        inode = file->f_mapping->host;
        old_file = lo->lo_backing_file;
 +      old_virt_file = lo->lo_backing_virt_file;
@@ -35745,7 +35749,7 @@ index abfdd2b..a2e3c43 100644
  static int loop_set_fd(struct loop_device *lo, fmode_t mode,
                       struct block_device *bdev, unsigned int arg)
  {
--      struct file     *file, *f;
+-      struct file     *file;
 +      struct file     *file, *f, *virt_file = NULL;
        struct inode    *inode;
        struct address_space *mapping;
index d811e3f1a1c8d99d925a3420aa5c2e893c2863ef..a255a169013ccaf235f248b1387773b112d2769f 100644 (file)
@@ -72,7 +72,7 @@
 
 %define                rel             1
 %define                basever         4.4
-%define                postver         .140
+%define                postver         .143
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       -%{basever}
@@ -124,7 +124,7 @@ Source0:    http://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: 9a78fa2eb6c68ca5a40ed5af08142599
 %if "%{postver}" != ".0"
 Patch0:                http://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  5714c26e071c171bc1f29be9892d6f3b
+# Patch0-md5:  f0f3159f75e5775e8939974b99566340
 %endif
 Source1:       kernel.sysconfig
 
This page took 0.102334 seconds and 4 git commands to generate.