]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
just be more precise when updating shebangs
[packages/kernel.git] / kernel.spec
index ffb4d6a1360f5974199bb0728280ab9f1d6d79dd..486cee1ea72baf8c1b7f32965cf034741e79b81d 100644 (file)
@@ -72,7 +72,7 @@
 %endif
 
 %define                rel             0.1
-%define                basever         5.9
+%define                basever         5.10
 %define                postver         .0
 
 # define this to '-%{basever}' for longterm branch
@@ -124,10 +124,10 @@ Epoch:            3
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       https://www.kernel.org/pub/linux/kernel/v5.x/linux-%{basever}.tar.xz
-# Source0-md5: 0959d759fd19e146367221aff504ad91
+# Source0-md5: 753adc474bf799d569dec4f165ed92c3
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v5.x/patch-%{version}.xz
-# Patch0-md5:  1f276bf9d1bc12215179a4681c29a573
+# Patch0-md5:  d7f9892b339f14f5d2afa6bfb842b1f4
 %endif
 Source1:       kernel.sysconfig
 
@@ -225,6 +225,9 @@ Patch2003:  kernel-regressions.patch
 # based on ftp://ftp.leg.uct.ac.za/pub/linux/rip/tmpfs_root-2.6.30.diff.gz
 Patch7000:     kernel-inittmpfs.patch
 
+# ARM only
+Patch8000:     rpi-wm8804.patch
+
 # Do not remove this line, please. It is easier for me to uncomment two lines, then patch
 # kernel.spec every time.
 #Patch50000:   kernel-usb_reset.patch
@@ -247,6 +250,7 @@ BuildRequires:      hostname
 BuildRequires: kmod >= %{kmod_ver}
 BuildRequires: libstdc++-devel
 BuildRequires: openssl-devel
+BuildRequires: openssl-tools
 BuildRequires: perl-base
 BuildRequires: rpm-build >= 4.5-24
 BuildRequires: rpmbuild(macros) >= 1.743
@@ -691,6 +695,10 @@ cd linux-%{basever}
 %patch7000 -p1
 %endif
 
+%ifarch %{arm} aarch64
+%patch8000 -p1
+%endif
+
 %if %{with rt}
 %patch500 -p1
 rm -f localversion-rt
@@ -717,13 +725,13 @@ sed -i 's#EXTRAVERSION =.*#EXTRAVERSION = %{?alt_kernel:.%{alt_kernel}}#g' Makef
 find '(' -name '*~' -o -name '*.orig' -o -name '.gitignore' ')' -print0 | xargs -0 -r -l512 rm -f
 
 find -name '*.py' -print0 | \
-       xargs -0 %{__sed} -i -e '1s,/usr/bin/python,%{__python},' \
-                            -e '1s,/usr/bin/env python,%{__python},' \
-                            -e '1s,/usr/bin/env python3,%{__python3},'
+       xargs -0 %{__sed} -i -e '1s,/usr/bin/python$,%{__python},' \
+                            -e '1s,/usr/bin/env python$,%{__python},' \
+                            -e '1s,/usr/bin/env python3$,%{__python3},'
 
-%{__sed} -i -e '1s,/usr/bin/python,%{__python},' \
-           -e '1s,/usr/bin/env python,%{__python},' \
-           -e '1s,/usr/bin/env python3,%{__python3},' \
+%{__sed} -i -e '1s,/usr/bin/python$,%{__python},' \
+           -e '1s,/usr/bin/env python$,%{__python},' \
+           -e '1s,/usr/bin/env python3$,%{__python3},' \
        drivers/staging/greybus/tools/lbtest \
        scripts/bloat-o-meter \
        scripts/diffconfig \
@@ -1442,7 +1450,6 @@ fi
 %endif
 %exclude %dir %{_kernelsrcdir}/arch/um
 %{_kernelsrcdir}/arch/*/kernel/asm-offsets*
-%{_kernelsrcdir}/arch/*/kernel/module.lds
 %{_kernelsrcdir}/arch/*/kernel/sigframe*.h
 %{_kernelsrcdir}/drivers/media/pci/bt8xx/bttv.h
 %{_kernelsrcdir}/kernel/bounds.c
@@ -1466,7 +1473,6 @@ fi
 %{_kernelsrcdir}/scripts/mod/modpost.h
 %attr(755,root,root) %{_kernelsrcdir}/scripts/mkcompile_h
 %{_kernelsrcdir}/scripts/mkmakefile
-%{_kernelsrcdir}/scripts/module-common.lds
 %attr(755,root,root) %{_kernelsrcdir}/scripts/setlocalversion
 %{_kernelsrcdir}/scripts/subarch.include
 %{_kernelsrcdir}/scripts/*.c
This page took 0.141536 seconds and 4 git commands to generate.