]> git.pld-linux.org Git - packages/kernel.git/commitdiff
just be more precise when updating shebangs
authorJan Palus <atler@pld-linux.org>
Mon, 14 Dec 2020 23:39:13 +0000 (00:39 +0100)
committerJan Palus <atler@pld-linux.org>
Mon, 14 Dec 2020 23:40:52 +0000 (00:40 +0100)
kernel.spec

index 6a7402da4e6472f8aeb6f9f8c839e33e01ce933c..486cee1ea72baf8c1b7f32965cf034741e79b81d 100644 (file)
@@ -725,13 +725,13 @@ sed -i 's#EXTRAVERSION =.*#EXTRAVERSION = %{?alt_kernel:.%{alt_kernel}}#g' Makef
 find '(' -name '*~' -o -name '*.orig' -o -name '.gitignore' ')' -print0 | xargs -0 -r -l512 rm -f
 
 find -name '*.py' -print0 | \
-       xargs -0 %{__sed} -i -e '1s,/usr/bin/python,%{__python},' \
-                            -e '1s,/usr/bin/env python,%{__python},' \
-                            -e '1s,/usr/bin/env python3,%{__python3},'
+       xargs -0 %{__sed} -i -e '1s,/usr/bin/python$,%{__python},' \
+                            -e '1s,/usr/bin/env python$,%{__python},' \
+                            -e '1s,/usr/bin/env python3$,%{__python3},'
 
-%{__sed} -i -e '1s,/usr/bin/python,%{__python},' \
-           -e '1s,/usr/bin/env python,%{__python},' \
-           -e '1s,/usr/bin/env python3,%{__python3},' \
+%{__sed} -i -e '1s,/usr/bin/python$,%{__python},' \
+           -e '1s,/usr/bin/env python$,%{__python},' \
+           -e '1s,/usr/bin/env python3$,%{__python3},' \
        drivers/staging/greybus/tools/lbtest \
        scripts/bloat-o-meter \
        scripts/diffconfig \
@@ -741,10 +741,6 @@ find -name '*.py' -print0 | \
        tools/kvm/kvm_stat/kvm_stat \
        tools/testing/selftests/exec/binfmt_script
 
-%{__sed} -i -e '1s,/usr/bin/python23,%{__python3},' \
-       scripts/bpf_helpers_doc.py \
-       scripts/checkkconfigsymbols.py
-
 find -name '*.pl' -print0 | \
        xargs -0 %{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' \
 
This page took 0.0585 seconds and 4 git commands to generate.