]> git.pld-linux.org Git - packages/kernel-tools.git/blob - kernel-tools.spec
- up to 4.11.2
[packages/kernel-tools.git] / kernel-tools.spec
1 # TODO:
2 # - redefine: PACKAGE_BUGREPORT=cpufreq@vger.kernel.org
3 # - add -n python-perf?
4 # - add bcond to disable building docs (perf docs)
5 # - install of perf links perf binary again
6
7 # Conditional build:
8 %bcond_without  verbose         # verbose build (V=1)
9 %bcond_without  cpupower        # cpupower tools
10 %bcond_without  perf            # perf tools
11 %bcond_without  gtk             # GTK+ 2.x perf support
12 %bcond_without  libunwind       # libunwind perf support
13 %bcond_without  multilib        # multilib perf support
14 %bcond_without  usbip           # usbip utils
15
16 %ifarch x32
17 %undefine       with_libunwind
18 %endif
19 %ifnarch %{x8664}
20 %undefine       with_multilib
21 %endif
22
23 %define         basever         4.11
24 %define         postver         .2
25 Summary:        Assortment of tools for the Linux kernel
26 Summary(pl.UTF-8):      Zestaw narzędzi dla jądra Linuksa
27 Name:           kernel-tools
28 Version:        %{basever}%{postver}
29 Release:        1
30 License:        GPL v2
31 Group:          Applications/System
32 Source0:        https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
33 # Source0-md5:  251a5deee0fa6daf3f356b1bbda9eab8
34 Source1:        cpupower.service
35 Source2:        cpupower.config
36 %if "%{postver}" != ".0"
37 Patch0:         https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
38 # Patch0-md5:   e0aae229c24dbc16021617de6955f8b8
39 %endif
40 Patch1:         x32.patch
41 URL:            http://www.kernel.org/
42 BuildRequires:  bison
43 BuildRequires:  flex
44 BuildRequires:  gettext-tools
45 BuildRequires:  ncurses-devel
46 BuildRequires:  pciutils-devel
47 BuildRequires:  pkgconfig
48 BuildRequires:  rpmbuild(macros) >= 1.647
49 BuildRequires:  tar >= 1:1.22
50 BuildRequires:  xz
51 %if %{with perf}
52 BuildRequires:  asciidoc
53 BuildRequires:  audit-libs-devel
54 BuildRequires:  binutils-devel
55 BuildRequires:  docbook-dtd45-xml
56 BuildRequires:  docbook-style-xsl
57 BuildRequires:  elfutils-devel
58 BuildRequires:  linux-libc-headers >= 7:4.8
59 %if %{with multilib}
60 BuildRequires:  gcc-multilib-32
61 BuildRequires:  gcc-multilib-x32
62 %endif
63 %{?with_libunwind:BuildRequires:        libunwind-devel >= 0.99}
64 BuildRequires:  numactl-devel
65 BuildRequires:  perl-devel >= 5.1
66 BuildRequires:  python-devel
67 BuildRequires:  rpm-pythonprov
68 BuildRequires:  slang-devel
69 BuildRequires:  xmlto
70 %if %{with gtk}
71 BuildRequires:  gtk+2-devel >= 2.0
72 %endif
73 %endif
74 %if %{with usbip}
75 BuildRequires:  autoconf >= 2.59
76 BuildRequires:  automake >= 1:1.9
77 BuildRequires:  gcc >= 6:4.0
78 BuildRequires:  libtool >= 2:2
79 BuildRequires:  libwrap-devel
80 BuildRequires:  udev-devel
81 %endif
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 # otherwise /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
85 %define         _enable_debug_packages  0
86
87 %define         makeopts        CC="%{__cc}" %{?with_verbose:V=1}
88
89 %description
90 This package contains the software from tools/ subdirectory from Linux
91 kernel source and the supporting documentation.
92
93 %description -l pl.UTF-8
94 Ten pakiet zawiera oprogramowanie z podkatalogu tools/ ze źródeł jądra
95 Linuksa oraz związaną z nim dokumentację.
96
97 %package cpupower
98 Summary:        cpupower - Shows and sets processor power related values
99 Summary(pl.UTF-8):      cpupower - wyświetlanie i ustawianie wartości związanych z zużyciem energii przez procesor
100 Group:          Applications/System
101 Requires(post,preun,postun):    systemd-units >= 38
102 Requires:       %{name}-cpupower-libs = %{version}-%{release}
103 Requires:       systemd-units >= 0.38
104 Provides:       cpupowerutils = 1:009-0.6.p1
105 Obsoletes:      cpupowerutils < 1:009-0.6.p1
106 Obsoletes:      cpuspeed < 1:1.5-16
107
108 %description cpupower
109 cpupower is a collection of tools to examine and tune power saving
110 related features of your processor.
111
112 %description cpupower -l pl.UTF-8
113 cpupower to zbiór narzędzi do sprawdzania i ustawiania opcji procesora
114 związanych z oszczędzaniem energii.
115
116 %package cpupower-libs
117 Summary:        cpupower library
118 Summary(pl.UTF-8):      Biblioteka cpupower
119 Group:          Libraries
120
121 %description cpupower-libs
122 cpupower library.
123
124 %description cpupower-libs -l pl.UTF-8
125 Biblioteka cpupower.
126
127 %package cpupower-libs-devel
128 Summary:        Development files for the cpupower library
129 Summary(pl.UTF-8):      Pliki programistyczne biblioteki cpupower
130 Group:          Development/Libraries
131 Requires:       %{name}-cpupower-libs = %{version}-%{release}
132 Provides:       cpupowerutils-devel = 1:009-0.6.p1
133 Obsoletes:      cpupowerutils-devel < 1:009-0.6.p1
134 Conflicts:      cpufrequtils-devel
135
136 %description cpupower-libs-devel
137 Development files for the cpupower library.
138
139 %description cpupower-libs-devel -l pl.UTF-8
140 Pliki programistyczne biblioteki cpupower.
141
142 %package hv
143 Summary:        Hyper-V virtualization tools
144 Summary(pl.UTF-8):      Narzędzia do wirtualizacji Hyper-V
145 Group:          Applications/System
146
147 %description hv
148 Hyper-V virtualization tools.
149
150 %description hv -l pl.UTF-8
151 Narzędzia do wirtualizacji Hyper-V.
152
153 %package perf
154 Summary:        perf profiler tool
155 Summary(pl.UTF-8):      Narzędzie profilujące perf
156 Group:          Applications/System
157 Suggests:       binutils
158 Obsoletes:      perf-core
159 Obsoletes:      perf-slang
160
161 %description perf
162 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
163 away CPU hardware differences in Linux performance measurements and
164 presents a simple commandline interface. Perf is based on the
165 perf_events interface exported by recent versions of the Linux kernel.
166
167 This package contains core files, scripts and text interface (TUI).
168
169 %description perf -l pl.UTF-8
170 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
171 odseparowujące od różnic sprzętowych między pomiarami wydajności w
172 zależności od procesora oraz udostępniające prosty interfejs linii
173 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
174 przez nowe wersje jądra Linuksa.
175
176 Ten pakiet zawiera podstawowe pliki, skrypty oraz interfejs tekstowy
177 (TUI).
178
179 %package perf-vdso32
180 Summary:        perf profiler tool - VDSO 32-bit ABI reader
181 Summary(pl.UTF-8):      Narzędzie profilujące perf - odczyt VDSO dla ABI 32-bitowego
182 Group:          Applications/System
183 Requires:       %{name}-perf = %{version}-%{release}
184
185 %description perf-vdso32
186 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
187 away CPU hardware differences in Linux performance measurements and
188 presents a simple commandline interface. Perf is based on the
189 perf_events interface exported by recent versions of the Linux kernel.
190
191 This package contains perf-read-vdso32 tool for reading the 32-bit
192 compatibility VDSO in 64-bit mode.
193
194 %description perf-vdso32 -l pl.UTF-8
195 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
196 odseparowujące od różnic sprzętowych między pomiarami wydajności w
197 zależności od procesora oraz udostępniające prosty interfejs linii
198 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
199 przez nowe wersje jądra Linuksa.
200
201 Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
202 binariów 32-bitowych w trybie 64-bitowym.
203
204 %package perf-vdsox32
205 Summary:        perf profiler tool - VDSO x32 ABI reader
206 Summary(pl.UTF-8):      Narzędzie profilujące perf - odczyt VDSO dla ABI x32
207 Group:          Applications/System
208 Requires:       %{name}-perf = %{version}-%{release}
209
210 %description perf-vdsox32
211 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
212 away CPU hardware differences in Linux performance measurements and
213 presents a simple commandline interface. Perf is based on the
214 perf_events interface exported by recent versions of the Linux kernel.
215
216 This package contains perf-read-vdso32 tool for reading the x32 mode
217 32-bit compatibility VDSO in 64-bit mode.
218
219 %description perf-vdsox32 -l pl.UTF-8
220 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
221 odseparowujące od różnic sprzętowych między pomiarami wydajności w
222 zależności od procesora oraz udostępniające prosty interfejs linii
223 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
224 przez nowe wersje jądra Linuksa.
225
226 Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
227 binariów ABI x32 w trybie 64-bitowym.
228
229 %package perf-gtk
230 Summary:        perf profiler tool (GTK+ 2 GUI)
231 Summary(pl.UTF-8):      Narzędzie profilujące perf (interfejs graficzny GTK+ 2)
232 Group:          X11/Applications
233 Requires:       %{name}-perf = %{version}-%{release}
234
235 %description perf-gtk
236 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
237 away CPU hardware differences in Linux performance measurements and
238 presents a simple commandline interface. Perf is based on the
239 perf_events interface exported by recent versions of the Linux kernel.
240
241 This package contains GTK+ 2 based GUI.
242
243 %description perf-gtk -l pl.UTF-8
244 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
245 odseparowujące od różnic sprzętowych między pomiarami wydajności w
246 zależności od procesora oraz udostępniające prosty interfejs linii
247 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
248 przez nowe wersje jądra Linuksa.
249
250 Ten pakiet zawiera graficzny interfejs oparty na GTK+ 2.
251
252 %package -n bash-completion-perf
253 Summary:        Bash completion for perf command
254 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla polecenia perf
255 Group:          Applications/Shells
256 Requires:       %{name}-perf
257 Requires:       bash-completion
258 %if "%{_rpmversion}" >= "5"
259 BuildArch:      noarch
260 %endif
261
262 %description -n bash-completion-perf
263 Bash completion for perf command.
264
265 %description -n bash-completion-perf -l pl.UTF-8
266 Bashowe uzupełnianie parametrów dla polecenia perf.
267
268 %package -n usbip
269 Summary:        USB device sharing system over IP network
270 Summary(pl.UTF-8):      System współdzielenia urządzeń USB po sieci IP
271 Group:          Networking/Utilities
272 Requires:       usbip-libs = %{version}-%{release}
273 # /lib/hwdata/usb.ids (note: only uncompressed file supported)
274 Requires:       hwdata >= 0.243-2
275
276 %description -n usbip
277 The USB/IP Project aims to develop a general USB device sharing system
278 over IP network. To share USB devices between computers with their
279 full functionality, USB/IP encapsulates "USB requests" into IP packets
280 and transmits them between computers. Original USB device drivers and
281 applications can be also used for remote USB devices without any
282 modification of them. A computer can use remote USB devices as if they
283 were directly attached; for example, we can:
284  - USB storage devices: fdisk, mkfs, mount/umount, file operations,
285    play a DVD movie and record a DVD-R media.
286  - USB keyboards and USB mice: use with Linux console and X Window
287    System.
288  - USB webcams and USB speakers: view webcam, capture image data and
289    play some music.
290  - USB printers, USB scanners, USB serial converters and USB Ethernet
291    interfaces: ok, use fine.
292
293 %description -n usbip -l pl.UTF-8
294 Projekt USB/IP ma na celu stworzenie ogólnego systemu współdzielenia
295 urządzeń USB po sieci IP. W celu współdzielenia urządzeń USB między
296 komputerami z zachowaniem pełnej funkcjonalności, USB/IP obudowuje
297 żądania SUB w pakiety IP i przesyła je między komputerami. Oryginalne
298 sterowniki urządzeń USB oraz aplikacje mogą być używane bez żadnych
299 modyfikacji. Komputer może wykorzystywać zdaln urządzenia USB tak,
300 jakby były podłączone bezpośrednio. Przykładowe możliwości:
301  - urządzenia USB do przechowywania danych: można używać programów
302    fdisk, mkfs, mount/umount, operacji na plikach, odtwarzać filmy
303    DVD oraz nagrywać nośniki DVD-R
304  - klawiatury i myszy USB: można ich używać na linuksowej konsoli oraz
305    w systemie X Window
306  - kamery i głośniki USB: można oglądać obraz z kamery, robić zdjęcia
307    i odtwarzać muzykę
308  - drukarki, skanery, konwertery portów szeregowych oraz interfejsy
309    sieciowe USB: można ich normalnie używać
310
311 %package -n usbip-libs
312 Summary:        USB/IP library
313 Summary(pl.UTF-8):      Biblioteka USB/IP
314 Group:          Libraries
315
316 %description -n usbip-libs
317 USB over IP library.
318
319 %description -n usbip-libs -l pl.UTF-8
320 Biblioteka USB po IP.
321
322 %package -n usbip-devel
323 Summary:        Header files for usbip library
324 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki usbip
325 Group:          Development/Libraries
326 Requires:       usbip-libs = %{version}-%{release}
327
328 %description -n usbip-devel
329 This package contains the header files needed to develop programs
330 which make use of USB/IP.
331
332 %description -n usbip-devel -l pl.UTF-8
333 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
334 wykorzystujących USB/IP.
335
336 %package -n usbip-static
337 Summary:        Static usbip library
338 Summary(pl.UTF-8):      Statyczna biblioteka usbip
339 Group:          Development/Libraries
340 Requires:       usbip-devel = %{version}-%{release}
341
342 %description -n usbip-static
343 Static usbip library.
344
345 %description -n usbip-static -l pl.UTF-8
346 Statyczna biblioteka usbip.
347
348 %prep
349 %setup -qc
350 cd linux-%{basever}
351
352 %if "%{postver}" != ".0"
353 %patch0 -p1
354 %endif
355
356 %patch1 -p1
357
358 %{__sed} -i -e '/^CFLAGS = /s/ -g / $(OPTFLAGS) /' tools/hv/Makefile
359 %{__sed} -i -e '/^CFLAGS+=/s/ -O1 / $(OPTFLAGS) /' tools/thermal/tmon/Makefile
360 %{__sed} -i -e 's#libexec/perf-core#%{_datadir}/perf-core#g' tools/perf/Makefile.config
361
362 %build
363 cd linux-%{basever}
364
365 # Simple Disk Sleep Monitor
366 %{__make} -C tools/laptop/dslm \
367         %{makeopts} \
368         EXTRA_CFLAGS="%{rpmcflags}"
369
370 # tools common (used eg. by tools/vm)
371 %{__make} -C tools/lib/api \
372         %{makeopts} \
373         EXTRA_CFLAGS="%{rpmcflags}"
374
375 # lsgpio
376 CFLAGS="%{rpmcflags}" \
377 %{__make} -C tools/gpio -j1 \
378         %{makeopts}
379
380 # HyperV is Windows based, x86 specific
381 %ifarch %{ix86} %{x8664} x32
382 %{__make} -C tools/hv \
383         CC="%{__cc}" \
384         OPTFLAGS="%{rpmcflags}"
385 %endif
386
387 CFLAGS="%{rpmcflags}" \
388 %{__make} -C tools/iio \
389         CC="%{__cc}"
390
391 %{__make} -C tools/laptop/freefall \
392         CC="%{__cc}" \
393         CFLAGS="%{rpmcflags}"
394
395 %ifarch %{ix86}
396 # drivers/lguest is x86-32 only
397 %{__make} -C tools/lguest \
398         CC="%{__cc}" \
399         CFLAGS="%{rpmcflags} -Wall -U_FORTIFY_SOURCE -Iinclude"
400 %endif
401
402 CFLAGS="%{rpmcflags}" \
403 %{__make} -C tools/net \
404         CC="%{__cc}"
405
406 # perf
407 %if %{with perf}
408 %{__make} -C tools/perf all man \
409 %ifarch %{x8664}
410         IS_X86_64=1 \
411         %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
412 %endif
413         %{!?with_gtk:NO_GTK2=1} \
414         %{!?with_libunwind:NO_LIBUNWIND=1} \
415         %{makeopts} \
416         CFLAGS_OPTIMIZE="%{rpmcflags}" \
417         WERROR=0 \
418         prefix=%{_prefix} \
419         perfexecdir=%{_datadir}/perf-core \
420         lib=%{_lib} \
421         template_dir=%{_datadir}/perf-core/templates
422 %endif
423
424 # cpupower
425 %if %{with cpupower}
426 %{__make} -C tools/power/cpupower \
427         %{makeopts} \
428         CPUFREQ_BENCH=false \
429         OPTIMIZATION="%{rpmcflags}" \
430         STRIPCMD=true
431
432 %ifarch %{ix86} x32
433 %{__make} -C tools/power/cpupower/debug/i386 centrino-decode powernow-k8-decode \
434         CC="%{__cc}" \
435         CFLAGS="%{rpmcflags}"
436 %endif
437
438 %ifarch %{x8664} x32
439 %{__make} -C tools/power/cpupower/debug/x86_64 centrino-decode powernow-k8-decode \
440         CC="%{__cc}" \
441         CFLAGS="%{rpmcflags}"
442 %endif
443 %endif
444
445 %ifarch %{ix86} %{x8664} x32
446 %{__make} -C tools/power/x86/x86_energy_perf_policy \
447         CC="%{__cc}" \
448         CFLAGS="%{rpmcflags}"
449 CFLAGS="%{rpmcflags}" \
450 %{__make} -C tools/power/x86/turbostat \
451         CC="%{__cc}"
452 %endif
453
454 %{__make} -C tools/thermal/tmon \
455         CC="%{__cc}" \
456         OPTFLAGS="%{rpmcflags}"
457
458 # usbip-utils
459 %if %{with usbip}
460 cd tools/usb/usbip
461 %{__libtoolize}
462 %{__aclocal}
463 %{__autoconf}
464 %{__autoheader}
465 %{__automake}
466 %configure \
467         --disable-silent-rules \
468         --with-usbids-dir=/lib/hwdata
469 %{__make}
470 cd ../../..
471 %endif
472
473 # page-types, slabinfo
474 %{__make} -C tools/vm page-types slabinfo \
475         CC="%{__cc}" \
476         CFLAGS="%{rpmcflags} -Wall -Wextra -I../lib"
477
478 # gen_init_cpio
479 %{__make} -C usr gen_init_cpio \
480         %{makeopts} \
481         CFLAGS="%{rpmcflags}"
482
483 %install
484 rm -rf $RPM_BUILD_ROOT
485
486 cd linux-%{basever}
487
488 %if %{with cpupower}
489 %{__make} -C tools/power/cpupower install \
490         DESTDIR=$RPM_BUILD_ROOT \
491         libdir=%{_libdir} \
492         mandir=%{_mandir} \
493         CPUFREQ_BENCH=false
494
495 %find_lang cpupower
496 mv cpupower.lang ..
497
498 install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{systemdunitdir}}
499 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/cpupower.service
500 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/cpupower
501
502 %ifarch %{ix86} x32
503 install -p tools/power/cpupower/debug/i386/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
504 %endif
505 %ifarch %{x8664} x32
506 install -p tools/power/cpupower/debug/x86_64/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
507 %endif
508 %endif
509
510 %if %{with perf}
511 %{__make} -C tools/perf -j1 install install-man \
512 %ifarch %{x8664}
513         IS_X86_64=1 \
514         %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
515 %endif
516         %{!?with_gtk:NO_GTK2=1} \
517         %{!?with_libunwind:NO_LIBUNWIND=1} \
518         CC="%{__cc}" \
519         CFLAGS_OPTIMIZE="%{rpmcflags}" \
520         WERROR=0 \
521         %{?with_verbose:V=1} \
522         prefix=%{_prefix} \
523         perfexecdir=%{_datadir}/perf-core \
524         template_dir=%{_datadir}/perf-core/templates \
525         lib=%{_lib} \
526         DESTDIR=$RPM_BUILD_ROOT
527
528 %py_comp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
529 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
530
531 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/perf-core/tests
532 %endif
533
534 %if %{with usbip}
535 %{__make} -C tools/usb/usbip install \
536         DESTDIR=$RPM_BUILD_ROOT
537
538 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libusbip.la
539 %endif
540
541 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man8}
542
543 install -p tools/laptop/dslm/dslm $RPM_BUILD_ROOT%{_sbindir}
544
545 install -p tools/gpio/lsgpio $RPM_BUILD_ROOT%{_bindir}
546
547 %ifarch %{ix86} %{x8664} x32
548 install -p tools/hv/hv_{fcopy,kvp,vss}_daemon $RPM_BUILD_ROOT%{_sbindir}
549 # TODO: PLD-specific hv_get_dhcp_info,hv_get_dns_info,hv_set_ifconfig
550 %{__sed} -e '1s,/usr/bin/env python,%{__python},' tools/hv/lsvmbus >$RPM_BUILD_ROOT%{_bindir}/lsvmbus
551 chmod 755 $RPM_BUILD_ROOT%{_bindir}/lsvmbus
552 %endif
553
554 install -p tools/iio/{iio_event_monitor,iio_generic_buffer,lsiio} $RPM_BUILD_ROOT%{_bindir}
555
556 install -p tools/laptop/freefall/freefall $RPM_BUILD_ROOT%{_sbindir}
557
558 %ifarch %{ix86}
559 install -p tools/lguest/lguest $RPM_BUILD_ROOT%{_bindir}
560 %endif
561
562 install -p tools/net/{bpf_asm,bpf_dbg,bpf_jit_disasm} $RPM_BUILD_ROOT%{_bindir}
563
564 install -p tools/thermal/tmon/tmon $RPM_BUILD_ROOT%{_bindir}
565 cp -p tools/thermal/tmon/tmon.8 $RPM_BUILD_ROOT%{_mandir}/man8
566
567 install -p tools/vm/slabinfo $RPM_BUILD_ROOT%{_bindir}
568 install -p tools/vm/page-types $RPM_BUILD_ROOT%{_sbindir}
569
570 %ifarch %{ix86} %{x8664} x32
571 install -d $RPM_BUILD_ROOT%{_mandir}/man8
572 %{__make} -C tools/power/x86/x86_energy_perf_policy install \
573         DESTDIR=$RPM_BUILD_ROOT
574
575 %{__make} -C tools/power/x86/turbostat install \
576         DESTDIR=$RPM_BUILD_ROOT
577 %endif
578
579 # gen_init_cpio
580 install -p usr/gen_init_cpio $RPM_BUILD_ROOT%{_bindir}/gen_init_cpio
581
582 %clean
583 rm -rf $RPM_BUILD_ROOT
584
585 %post   cpupower-libs -p /sbin/ldconfig
586 %postun cpupower-libs -p /sbin/ldconfig
587
588 %post cpupower
589 %systemd_post cpupower.service
590
591 %preun cpupower
592 %systemd_preun cpupower.service
593
594 %postun cpupower
595 %systemd_reload
596
597 %post   -n usbip-libs -p /sbin/ldconfig
598 %postun -n usbip-libs -p /sbin/ldconfig
599
600 %files
601 %defattr(644,root,root,755)
602 %attr(755,root,root) %{_bindir}/bpf_asm
603 %attr(755,root,root) %{_bindir}/bpf_dbg
604 %attr(755,root,root) %{_bindir}/bpf_jit_disasm
605 %attr(755,root,root) %{_bindir}/gen_init_cpio
606 %attr(755,root,root) %{_bindir}/iio_event_monitor
607 %attr(755,root,root) %{_bindir}/iio_generic_buffer
608 %attr(755,root,root) %{_bindir}/lsgpio
609 %attr(755,root,root) %{_bindir}/lsiio
610 %attr(755,root,root) %{_bindir}/slabinfo
611 %attr(755,root,root) %{_bindir}/tmon
612 %attr(755,root,root) %{_sbindir}/dslm
613 %attr(755,root,root) %{_sbindir}/freefall
614 %attr(755,root,root) %{_sbindir}/page-types
615 %{_mandir}/man8/tmon.8*
616 %ifarch %{ix86}
617 %doc linux-%{basever}/tools/lguest/lguest.txt
618 %attr(755,root,root) %{_bindir}/lguest
619 %endif
620 %ifarch %{ix86} %{x8664} x32
621 %attr(755,root,root) %{_bindir}/centrino-decode
622 %attr(755,root,root) %{_bindir}/powernow-k8-decode
623 %endif
624 %ifarch %{ix86} %{x8664} x32
625 %attr(755,root,root) %{_bindir}/turbostat
626 %attr(755,root,root) %{_bindir}/x86_energy_perf_policy
627 %{_mandir}/man8/turbostat.8*
628 %{_mandir}/man8/x86_energy_perf_policy.8*
629 %endif
630
631 %files cpupower -f cpupower.lang
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_bindir}/cpupower
634 %{_mandir}/man1/cpupower*.1*
635 %{systemdunitdir}/cpupower.service
636 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cpupower
637
638 %files cpupower-libs
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_libdir}/libcpupower.so.*.*.*
641 %attr(755,root,root) %ghost %{_libdir}/libcpupower.so.0
642
643 %files cpupower-libs-devel
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_libdir}/libcpupower.so
646 %{_includedir}/cpufreq.h
647 %{_includedir}/cpuidle.h
648
649 %ifarch %{ix86} %{x8664} x32
650 %files hv
651 %defattr(644,root,root,755)
652 # TODO: PLDify these scripts and move to bindir
653 %doc linux-%{basever}/tools/hv/hv_{get_dhcp_info,get_dns_info,set_ifconfig}.sh
654 %attr(755,root,root) %{_bindir}/lsvmbus
655 %attr(755,root,root) %{_sbindir}/hv_fcopy_daemon
656 %attr(755,root,root) %{_sbindir}/hv_kvp_daemon
657 %attr(755,root,root) %{_sbindir}/hv_vss_daemon
658 %endif
659
660 %if %{with perf}
661 %files perf
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_bindir}/perf
664 %attr(755,root,root) %{_bindir}/trace
665 %{_mandir}/man1/perf*.1*
666 %dir %{_datadir}/perf-core
667 %attr(755,root,root) %{_datadir}/perf-core/perf-archive
668 %attr(755,root,root) %{_datadir}/perf-core/perf-with-kcore
669
670 %dir %{_datadir}/perf-core/scripts
671
672 %dir %{_datadir}/perf-core/scripts/perl
673 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util
674 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib
675 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf
676 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace
677 %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace/*.pm
678 %dir %{_datadir}/perf-core/scripts/perl/bin
679 %attr(755,root,root) %{_datadir}/perf-core/scripts/perl/bin/*
680 %{_datadir}/perf-core/scripts/perl/*.pl
681
682 %dir %{_datadir}/perf-core/scripts/python
683 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util
684 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib
685 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf
686 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace
687 %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/*.py*
688 %dir %{_datadir}/perf-core/scripts/python/bin
689 %attr(755,root,root) %{_datadir}/perf-core/scripts/python/bin/*
690 %{_datadir}/perf-core/scripts/python/*.py*
691
692 %dir %{_libdir}/traceevent
693 %dir %{_libdir}/traceevent/plugins
694 %attr(755,root,root) %{_libdir}/traceevent/plugins/plugin_*.so
695
696 %if %{with multilib}
697 %files perf-vdso32
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_bindir}/perf-read-vdso32
700
701 %files perf-vdsox32
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_bindir}/perf-read-vdsox32
704 %endif
705
706 %if %{with gtk}
707 %files perf-gtk
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_libdir}/libperf-gtk.so
710 %endif
711
712 %files -n bash-completion-perf
713 %defattr(644,root,root,755)
714 /etc/bash_completion.d/perf
715 %endif
716
717 %if %{with usbip}
718 %files -n usbip
719 %defattr(644,root,root,755)
720 %doc linux-%{basever}/tools/usb/usbip/{AUTHORS,README}
721 %attr(755,root,root) %{_sbindir}/usbip
722 %attr(755,root,root) %{_sbindir}/usbipd
723 %{_mandir}/man8/usbip.8*
724 %{_mandir}/man8/usbipd.8*
725
726 %files -n usbip-libs
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_libdir}/libusbip.so.*.*.*
729 %attr(755,root,root) %ghost %{_libdir}/libusbip.so.0
730
731 %files -n usbip-devel
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_libdir}/libusbip.so
734 %{_includedir}/usbip
735
736 %files -n usbip-static
737 %defattr(644,root,root,755)
738 %{_libdir}/libusbip.a
739 %endif
This page took 0.096691 seconds and 4 git commands to generate.