]> git.pld-linux.org Git - packages/kernel-tools.git/blob - kernel-tools.spec
- rebuild with perl 5.24.0
[packages/kernel-tools.git] / kernel-tools.spec
1 # TODO:
2 # - redefine: PACKAGE_BUGREPORT=cpufreq@vger.kernel.org
3 # - add -n python-perf?
4 # - add bcond to disable building docs (perf docs)
5 # - install of perf links perf binary again
6
7 # Conditional build:
8 %bcond_without  verbose         # verbose build (V=1)
9 %bcond_without  cpupower        # cpupower tools
10 %bcond_without  perf            # perf tools
11 %bcond_without  gtk             # GTK+ 2.x perf support
12 %bcond_without  libunwind       # libunwind perf support
13 %bcond_without  multilib        # multilib perf support
14 %bcond_without  usbip           # usbip utils
15
16 %ifarch x32
17 %undefine       with_libunwind
18 %endif
19 %ifnarch %{x8664}
20 %undefine       with_multilib
21 %endif
22
23 %define         basever         4.8
24 %define         postver         .1
25 Summary:        Assortment of tools for the Linux kernel
26 Summary(pl.UTF-8):      Zestaw narzędzi dla jądra Linuksa
27 Name:           kernel-tools
28 Version:        %{basever}%{postver}
29 Release:        3
30 License:        GPL v2
31 Group:          Applications/System
32 Source0:        https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
33 # Source0-md5:  c1af0afbd3df35c1ccdc7a5118cd2d07
34 Source1:        cpupower.service
35 Source2:        cpupower.config
36 %if "%{postver}" != ".0"
37 Patch0:         https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
38 # Patch0-md5:   349734be5387f1605074515ad7207627
39 %endif
40 Patch1:         x32.patch
41 Patch2:         %{name}-format.patch
42 URL:            http://www.kernel.org/
43 BuildRequires:  bison
44 BuildRequires:  flex
45 BuildRequires:  gettext-tools
46 BuildRequires:  ncurses-devel
47 BuildRequires:  pciutils-devel
48 BuildRequires:  pkgconfig
49 BuildRequires:  rpmbuild(macros) >= 1.647
50 BuildRequires:  tar >= 1:1.22
51 BuildRequires:  xz
52 %if %{with perf}
53 BuildRequires:  asciidoc
54 BuildRequires:  audit-libs-devel
55 BuildRequires:  binutils-devel
56 BuildRequires:  docbook-dtd45-xml
57 BuildRequires:  docbook-style-xsl
58 BuildRequires:  elfutils-devel
59 %if %{with multilib}
60 BuildRequires:  gcc-multilib-32
61 BuildRequires:  gcc-multilib-x32
62 %endif
63 %{?with_libunwind:BuildRequires:        libunwind-devel >= 0.99}
64 BuildRequires:  numactl-devel
65 BuildRequires:  perl-devel >= 5.1
66 BuildRequires:  python-devel
67 BuildRequires:  rpm-pythonprov
68 BuildRequires:  slang-devel
69 BuildRequires:  xmlto
70 %if %{with gtk}
71 BuildRequires:  gtk+2-devel >= 2.0
72 %endif
73 %endif
74 %if %{with usbip}
75 BuildRequires:  autoconf >= 2.59
76 BuildRequires:  automake >= 1:1.9
77 BuildRequires:  gcc >= 6:4.0
78 BuildRequires:  libtool >= 2:2
79 BuildRequires:  libwrap-devel
80 BuildRequires:  udev-devel
81 %endif
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 # otherwise /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
85 %define         _enable_debug_packages  0
86
87 %define         makeopts        CC="%{__cc}" %{?with_verbose:V=1}
88
89 %description
90 This package contains the software from tools/ subdirectory from Linux
91 kernel source and the supporting documentation.
92
93 %description -l pl.UTF-8
94 Ten pakiet zawiera oprogramowanie z podkatalogu tools/ ze źródeł jądra
95 Linuksa oraz związaną z nim dokumentację.
96
97 %package cpupower
98 Summary:        cpupower - Shows and sets processor power related values
99 Summary(pl.UTF-8):      cpupower - wyświetlanie i ustawianie wartości związanych z zużyciem energii przez procesor
100 Group:          Applications/System
101 Requires(post,preun,postun):    systemd-units >= 38
102 Requires:       %{name}-cpupower-libs = %{version}-%{release}
103 Requires:       systemd-units >= 0.38
104 Provides:       cpupowerutils = 1:009-0.6.p1
105 Obsoletes:      cpupowerutils < 1:009-0.6.p1
106 Obsoletes:      cpuspeed < 1:1.5-16
107
108 %description cpupower
109 cpupower is a collection of tools to examine and tune power saving
110 related features of your processor.
111
112 %description cpupower -l pl.UTF-8
113 cpupower to zbiór narzędzi do sprawdzania i ustawiania opcji procesora
114 związanych z oszczędzaniem energii.
115
116 %package cpupower-libs
117 Summary:        cpupower library
118 Summary(pl.UTF-8):      Biblioteka cpupower
119 Group:          Libraries
120
121 %description cpupower-libs
122 cpupower library.
123
124 %description cpupower-libs -l pl.UTF-8
125 Biblioteka cpupower.
126
127 %package cpupower-libs-devel
128 Summary:        Development files for the cpupower library
129 Summary(pl.UTF-8):      Pliki programistyczne biblioteki cpupower
130 Group:          Development/Libraries
131 Requires:       %{name}-cpupower-libs = %{version}-%{release}
132 Provides:       cpupowerutils-devel = 1:009-0.6.p1
133 Obsoletes:      cpupowerutils-devel < 1:009-0.6.p1
134 Conflicts:      cpufrequtils-devel
135
136 %description cpupower-libs-devel
137 Development files for the cpupower library.
138
139 %description cpupower-libs-devel -l pl.UTF-8
140 Pliki programistyczne biblioteki cpupower.
141
142 %package hv
143 Summary:        Hyper-V virtualization tools
144 Summary(pl.UTF-8):      Narzędzia do wirtualizacji Hyper-V
145 Group:          Applications/System
146
147 %description hv
148 Hyper-V virtualization tools.
149
150 %description hv -l pl.UTF-8
151 Narzędzia do wirtualizacji Hyper-V.
152
153 %package perf
154 Summary:        perf profiler tool
155 Summary(pl.UTF-8):      Narzędzie profilujące perf
156 Group:          Applications/System
157 Suggests:       binutils
158 Obsoletes:      perf-core
159 Obsoletes:      perf-slang
160
161 %description perf
162 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
163 away CPU hardware differences in Linux performance measurements and
164 presents a simple commandline interface. Perf is based on the
165 perf_events interface exported by recent versions of the Linux kernel.
166
167 This package contains core files, scripts and text interface (TUI).
168
169 %description perf -l pl.UTF-8
170 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
171 odseparowujące od różnic sprzętowych między pomiarami wydajności w
172 zależności od procesora oraz udostępniające prosty interfejs linii
173 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
174 przez nowe wersje jądra Linuksa.
175
176 Ten pakiet zawiera podstawowe pliki, skrypty oraz interfejs tekstowy
177 (TUI).
178
179 %package perf-vdso32
180 Summary:        perf profiler tool - VDSO 32-bit ABI reader
181 Summary(pl.UTF-8):      Narzędzie profilujące perf - odczyt VDSO dla ABI 32-bitowego
182 Group:          Applications/System
183 Requires:       %{name}-perf = %{version}-%{release}
184
185 %description perf-vdso32
186 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
187 away CPU hardware differences in Linux performance measurements and
188 presents a simple commandline interface. Perf is based on the
189 perf_events interface exported by recent versions of the Linux kernel.
190
191 This package contains perf-read-vdso32 tool for reading the 32-bit
192 compatibility VDSO in 64-bit mode.
193
194 %description perf-vdso32 -l pl.UTF-8
195 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
196 odseparowujące od różnic sprzętowych między pomiarami wydajności w
197 zależności od procesora oraz udostępniające prosty interfejs linii
198 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
199 przez nowe wersje jądra Linuksa.
200
201 Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
202 binariów 32-bitowych w trybie 64-bitowym.
203
204 %package perf-vdsox32
205 Summary:        perf profiler tool - VDSO x32 ABI reader
206 Summary(pl.UTF-8):      Narzędzie profilujące perf - odczyt VDSO dla ABI x32
207 Group:          Applications/System
208 Requires:       %{name}-perf = %{version}-%{release}
209
210 %description perf-vdsox32
211 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
212 away CPU hardware differences in Linux performance measurements and
213 presents a simple commandline interface. Perf is based on the
214 perf_events interface exported by recent versions of the Linux kernel.
215
216 This package contains perf-read-vdso32 tool for reading the x32 mode
217 32-bit compatibility VDSO in 64-bit mode.
218
219 %description perf-vdsox32 -l pl.UTF-8
220 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
221 odseparowujące od różnic sprzętowych między pomiarami wydajności w
222 zależności od procesora oraz udostępniające prosty interfejs linii
223 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
224 przez nowe wersje jądra Linuksa.
225
226 Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
227 binariów ABI x32 w trybie 64-bitowym.
228
229 %package perf-gtk
230 Summary:        perf profiler tool (GTK+ 2 GUI)
231 Summary(pl.UTF-8):      Narzędzie profilujące perf (interfejs graficzny GTK+ 2)
232 Group:          X11/Applications
233 Requires:       %{name}-perf = %{version}-%{release}
234
235 %description perf-gtk
236 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
237 away CPU hardware differences in Linux performance measurements and
238 presents a simple commandline interface. Perf is based on the
239 perf_events interface exported by recent versions of the Linux kernel.
240
241 This package contains GTK+ 2 based GUI.
242
243 %description perf-gtk -l pl.UTF-8
244 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
245 odseparowujące od różnic sprzętowych między pomiarami wydajności w
246 zależności od procesora oraz udostępniające prosty interfejs linii
247 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
248 przez nowe wersje jądra Linuksa.
249
250 Ten pakiet zawiera graficzny interfejs oparty na GTK+ 2.
251
252 %package -n bash-completion-perf
253 Summary:        Bash completion for perf command
254 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla polecenia perf
255 Group:          Applications/Shells
256 Requires:       %{name}-perf
257 Requires:       bash-completion
258 %if "%{_rpmversion}" >= "5"
259 BuildArch:      noarch
260 %endif
261
262 %description -n bash-completion-perf
263 Bash completion for perf command.
264
265 %description -n bash-completion-perf -l pl.UTF-8
266 Bashowe uzupełnianie parametrów dla polecenia perf.
267
268 %package -n usbip
269 Summary:        USB device sharing system over IP network
270 Summary(pl.UTF-8):      System współdzielenia urządzeń USB po sieci IP
271 Group:          Networking/Utilities
272 Requires:       usbip-libs = %{version}-%{release}
273 # /lib/hwdata/usb.ids (note: only uncompressed file supported)
274 Requires:       hwdata >= 0.243-2
275
276 %description -n usbip
277 The USB/IP Project aims to develop a general USB device sharing system
278 over IP network. To share USB devices between computers with their
279 full functionality, USB/IP encapsulates "USB requests" into IP packets
280 and transmits them between computers. Original USB device drivers and
281 applications can be also used for remote USB devices without any
282 modification of them. A computer can use remote USB devices as if they
283 were directly attached; for example, we can:
284  - USB storage devices: fdisk, mkfs, mount/umount, file operations,
285    play a DVD movie and record a DVD-R media.
286  - USB keyboards and USB mice: use with Linux console and X Window
287    System.
288  - USB webcams and USB speakers: view webcam, capture image data and
289    play some music.
290  - USB printers, USB scanners, USB serial converters and USB Ethernet
291    interfaces: ok, use fine.
292
293 %description -n usbip -l pl.UTF-8
294 Projekt USB/IP ma na celu stworzenie ogólnego systemu współdzielenia
295 urządzeń USB po sieci IP. W celu współdzielenia urządzeń USB między
296 komputerami z zachowaniem pełnej funkcjonalności, USB/IP obudowuje
297 żądania SUB w pakiety IP i przesyła je między komputerami. Oryginalne
298 sterowniki urządzeń USB oraz aplikacje mogą być używane bez żadnych
299 modyfikacji. Komputer może wykorzystywać zdaln urządzenia USB tak,
300 jakby były podłączone bezpośrednio. Przykładowe możliwości:
301  - urządzenia USB do przechowywania danych: można używać programów
302    fdisk, mkfs, mount/umount, operacji na plikach, odtwarzać filmy
303    DVD oraz nagrywać nośniki DVD-R
304  - klawiatury i myszy USB: można ich używać na linuksowej konsoli oraz
305    w systemie X Window
306  - kamery i głośniki USB: można oglądać obraz z kamery, robić zdjęcia
307    i odtwarzać muzykę
308  - drukarki, skanery, konwertery portów szeregowych oraz interfejsy
309    sieciowe USB: można ich normalnie używać
310
311 %package -n usbip-libs
312 Summary:        USB/IP library
313 Summary(pl.UTF-8):      Biblioteka USB/IP
314 Group:          Libraries
315
316 %description -n usbip-libs
317 USB over IP library.
318
319 %description -n usbip-libs -l pl.UTF-8
320 Biblioteka USB po IP.
321
322 %package -n usbip-devel
323 Summary:        Header files for usbip library
324 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki usbip
325 Group:          Development/Libraries
326 Requires:       usbip-libs = %{version}-%{release}
327
328 %description -n usbip-devel
329 This package contains the header files needed to develop programs
330 which make use of USB/IP.
331
332 %description -n usbip-devel -l pl.UTF-8
333 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
334 wykorzystujących USB/IP.
335
336 %package -n usbip-static
337 Summary:        Static usbip library
338 Summary(pl.UTF-8):      Statyczna biblioteka usbip
339 Group:          Development/Libraries
340 Requires:       usbip-devel = %{version}-%{release}
341
342 %description -n usbip-static
343 Static usbip library.
344
345 %description -n usbip-static -l pl.UTF-8
346 Statyczna biblioteka usbip.
347
348 %prep
349 %setup -qc
350 cd linux-%{basever}
351
352 %if "%{postver}" != ".0"
353 %patch0 -p1
354 %endif
355
356 %patch1 -p1
357 %patch2 -p1
358
359 %{__sed} -i -e '/^CFLAGS = /s/ -g / $(OPTFLAGS) /' tools/hv/Makefile
360 %{__sed} -i -e '/^CFLAGS+=/s/ -O1 / $(OPTFLAGS) /' tools/thermal/tmon/Makefile
361 %{__sed} -i -e 's#libexec/perf-core#%{_datadir}/perf-core#g' tools/perf/Makefile.config
362
363 %build
364 cd linux-%{basever}
365
366 # Simple Disk Sleep Monitor
367 %{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags} Documentation/laptops/dslm.c -o dslm
368
369 # tools common (used eg. by tools/vm)
370 %{__make} -C tools/lib/api \
371         %{makeopts} \
372         EXTRA_CFLAGS="%{rpmcflags}"
373
374 # lsgpio
375 CFLAGS="%{rpmcflags}" \
376 %{__make} -C tools/gpio -j1 \
377         %{makeopts}
378
379 # HyperV is Windows based, x86 specific
380 %ifarch %{ix86} %{x8664} x32
381 %{__make} -C tools/hv \
382         CC="%{__cc}" \
383         OPTFLAGS="%{rpmcflags}"
384 %endif
385
386 CFLAGS="%{rpmcflags}" \
387 %{__make} -C tools/iio \
388         CC="%{__cc}"
389
390 %{__make} -C tools/laptop/freefall \
391         CC="%{__cc}" \
392         CFLAGS="%{rpmcflags}"
393
394 %ifarch %{ix86}
395 # drivers/lguest is x86-32 only
396 %{__make} -C tools/lguest \
397         CC="%{__cc}" \
398         CFLAGS="%{rpmcflags} -Wall -U_FORTIFY_SOURCE -Iinclude"
399 %endif
400
401 CFLAGS="%{rpmcflags}" \
402 %{__make} -C tools/net \
403         CC="%{__cc}"
404
405 # perf
406 %if %{with perf}
407 %{__make} -C tools/perf all man \
408 %ifarch %{x8664}
409         IS_X86_64=1 \
410         %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
411 %endif
412         %{!?with_gtk:NO_GTK2=1} \
413         %{!?with_libunwind:NO_LIBUNWIND=1} \
414         %{makeopts} \
415         CFLAGS_OPTIMIZE="%{rpmcflags}" \
416         WERROR=0 \
417         prefix=%{_prefix} \
418         perfexecdir=%{_datadir}/perf-core \
419         lib=%{_lib} \
420         template_dir=%{_datadir}/perf-core/templates
421 %endif
422
423 # cpupower
424 %if %{with cpupower}
425 %{__make} -C tools/power/cpupower \
426         %{makeopts} \
427         CPUFREQ_BENCH=false \
428         OPTIMIZATION="%{rpmcflags}" \
429         STRIPCMD=true
430
431 %ifarch %{ix86} x32
432 %{__make} -C tools/power/cpupower/debug/i386 centrino-decode powernow-k8-decode \
433         CC="%{__cc}" \
434         CFLAGS="%{rpmcflags}"
435 %endif
436
437 %ifarch %{x8664} x32
438 %{__make} -C tools/power/cpupower/debug/x86_64 centrino-decode powernow-k8-decode \
439         CC="%{__cc}" \
440         CFLAGS="%{rpmcflags}"
441 %endif
442 %endif
443
444 %ifarch %{ix86} %{x8664} x32
445 %{__make} -C tools/power/x86/x86_energy_perf_policy \
446         CC="%{__cc}" \
447         CFLAGS="%{rpmcflags}"
448 CFLAGS="%{rpmcflags}" \
449 %{__make} -C tools/power/x86/turbostat \
450         CC="%{__cc}"
451 %endif
452
453 %{__make} -C tools/thermal/tmon \
454         CC="%{__cc}" \
455         OPTFLAGS="%{rpmcflags}"
456
457 # usbip-utils
458 %if %{with usbip}
459 cd tools/usb/usbip
460 %{__libtoolize}
461 %{__aclocal}
462 %{__autoconf}
463 %{__autoheader}
464 %{__automake}
465 %configure \
466         --disable-silent-rules \
467         --with-usbids-dir=/lib/hwdata
468 %{__make}
469 cd ../../..
470 %endif
471
472 # page-types, slabinfo
473 %{__make} -C tools/vm page-types slabinfo \
474         CC="%{__cc}" \
475         CFLAGS="%{rpmcflags} -Wall -Wextra -I../lib"
476
477 # gen_init_cpio
478 %{__make} -C usr gen_init_cpio \
479         %{makeopts} \
480         CFLAGS="%{rpmcflags}"
481
482 %install
483 rm -rf $RPM_BUILD_ROOT
484
485 cd linux-%{basever}
486
487 %if %{with cpupower}
488 %{__make} -C tools/power/cpupower install \
489         DESTDIR=$RPM_BUILD_ROOT \
490         libdir=%{_libdir} \
491         mandir=%{_mandir} \
492         CPUFREQ_BENCH=false
493
494 %find_lang cpupower
495 mv cpupower.lang ..
496
497 install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{systemdunitdir}}
498 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/cpupower.service
499 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/cpupower
500
501 %ifarch %{ix86} x32
502 install -p tools/power/cpupower/debug/i386/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
503 %endif
504 %ifarch %{x8664} x32
505 install -p tools/power/cpupower/debug/x86_64/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
506 %endif
507 %endif
508
509 %if %{with perf}
510 %{__make} -C tools/perf -j1 install install-man \
511 %ifarch %{x8664}
512         IS_X86_64=1 \
513         %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
514 %endif
515         %{!?with_gtk:NO_GTK2=1} \
516         %{!?with_libunwind:NO_LIBUNWIND=1} \
517         CC="%{__cc}" \
518         CFLAGS_OPTIMIZE="%{rpmcflags}" \
519         WERROR=0 \
520         %{?with_verbose:V=1} \
521         prefix=%{_prefix} \
522         perfexecdir=%{_datadir}/perf-core \
523         template_dir=%{_datadir}/perf-core/templates \
524         lib=%{_lib} \
525         DESTDIR=$RPM_BUILD_ROOT
526
527 %py_comp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
528 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
529
530 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/perf-core/tests
531 %endif
532
533 %if %{with usbip}
534 %{__make} -C tools/usb/usbip install \
535         DESTDIR=$RPM_BUILD_ROOT
536
537 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libusbip.la
538 %endif
539
540 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man8}
541
542 install -p dslm $RPM_BUILD_ROOT%{_sbindir}
543
544 install -p tools/gpio/lsgpio $RPM_BUILD_ROOT%{_bindir}
545
546 %ifarch %{ix86} %{x8664} x32
547 install -p tools/hv/hv_{fcopy,kvp,vss}_daemon $RPM_BUILD_ROOT%{_sbindir}
548 # TODO: PLD-specific hv_get_dhcp_info,hv_get_dns_info,hv_set_ifconfig
549 %{__sed} -e '1s,/usr/bin/env python,%{__python},' tools/hv/lsvmbus >$RPM_BUILD_ROOT%{_bindir}/lsvmbus
550 chmod 755 $RPM_BUILD_ROOT%{_bindir}/lsvmbus
551 %endif
552
553 install -p tools/iio/{iio_event_monitor,iio_generic_buffer,lsiio} $RPM_BUILD_ROOT%{_bindir}
554
555 install -p tools/laptop/freefall/freefall $RPM_BUILD_ROOT%{_sbindir}
556
557 %ifarch %{ix86}
558 install -p tools/lguest/lguest $RPM_BUILD_ROOT%{_bindir}
559 %endif
560
561 install -p tools/net/{bpf_asm,bpf_dbg,bpf_jit_disasm} $RPM_BUILD_ROOT%{_bindir}
562
563 install -p tools/thermal/tmon/tmon $RPM_BUILD_ROOT%{_bindir}
564 cp -p tools/thermal/tmon/tmon.8 $RPM_BUILD_ROOT%{_mandir}/man8
565
566 install -p tools/vm/slabinfo $RPM_BUILD_ROOT%{_bindir}
567 install -p tools/vm/page-types $RPM_BUILD_ROOT%{_sbindir}
568
569 %ifarch %{ix86} %{x8664} x32
570 install -d $RPM_BUILD_ROOT%{_mandir}/man8
571 %{__make} -C tools/power/x86/x86_energy_perf_policy install \
572         DESTDIR=$RPM_BUILD_ROOT
573
574 %{__make} -C tools/power/x86/turbostat install \
575         DESTDIR=$RPM_BUILD_ROOT
576 %endif
577
578 # gen_init_cpio
579 install -p usr/gen_init_cpio $RPM_BUILD_ROOT%{_bindir}/gen_init_cpio
580
581 %clean
582 rm -rf $RPM_BUILD_ROOT
583
584 %post   cpupower-libs -p /sbin/ldconfig
585 %postun cpupower-libs -p /sbin/ldconfig
586
587 %post cpupower
588 %systemd_post cpupower.service
589
590 %preun cpupower
591 %systemd_preun cpupower.service
592
593 %postun cpupower
594 %systemd_reload
595
596 %post   -n usbip-libs -p /sbin/ldconfig
597 %postun -n usbip-libs -p /sbin/ldconfig
598
599 %files
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_bindir}/bpf_asm
602 %attr(755,root,root) %{_bindir}/bpf_dbg
603 %attr(755,root,root) %{_bindir}/bpf_jit_disasm
604 %attr(755,root,root) %{_bindir}/gen_init_cpio
605 %attr(755,root,root) %{_bindir}/iio_event_monitor
606 %attr(755,root,root) %{_bindir}/iio_generic_buffer
607 %attr(755,root,root) %{_bindir}/lsgpio
608 %attr(755,root,root) %{_bindir}/lsiio
609 %attr(755,root,root) %{_bindir}/slabinfo
610 %attr(755,root,root) %{_bindir}/tmon
611 %attr(755,root,root) %{_sbindir}/dslm
612 %attr(755,root,root) %{_sbindir}/freefall
613 %attr(755,root,root) %{_sbindir}/page-types
614 %{_mandir}/man8/tmon.8*
615 %ifarch %{ix86}
616 %doc linux-%{basever}/tools/lguest/lguest.txt
617 %attr(755,root,root) %{_bindir}/lguest
618 %endif
619 %ifarch %{ix86} %{x8664} x32
620 %attr(755,root,root) %{_bindir}/centrino-decode
621 %attr(755,root,root) %{_bindir}/powernow-k8-decode
622 %endif
623 %ifarch %{ix86} %{x8664} x32
624 %attr(755,root,root) %{_bindir}/turbostat
625 %attr(755,root,root) %{_bindir}/x86_energy_perf_policy
626 %{_mandir}/man8/turbostat.8*
627 %{_mandir}/man8/x86_energy_perf_policy.8*
628 %endif
629
630 %files cpupower -f cpupower.lang
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_bindir}/cpupower
633 %{_mandir}/man1/cpupower*.1*
634 %{systemdunitdir}/cpupower.service
635 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cpupower
636
637 %files cpupower-libs
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_libdir}/libcpupower.so.*.*.*
640 %attr(755,root,root) %ghost %{_libdir}/libcpupower.so.0
641
642 %files cpupower-libs-devel
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_libdir}/libcpupower.so
645 %{_includedir}/cpufreq.h
646 %{_includedir}/cpuidle.h
647
648 %ifarch %{ix86} %{x8664} x32
649 %files hv
650 %defattr(644,root,root,755)
651 # TODO: PLDify these scripts and move to bindir
652 %doc linux-%{basever}/tools/hv/hv_{get_dhcp_info,get_dns_info,set_ifconfig}.sh
653 %attr(755,root,root) %{_bindir}/lsvmbus
654 %attr(755,root,root) %{_sbindir}/hv_fcopy_daemon
655 %attr(755,root,root) %{_sbindir}/hv_kvp_daemon
656 %attr(755,root,root) %{_sbindir}/hv_vss_daemon
657 %endif
658
659 %if %{with perf}
660 %files perf
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_bindir}/perf
663 %attr(755,root,root) %{_bindir}/trace
664 %{_mandir}/man1/perf*.1*
665 %dir %{_datadir}/perf-core
666 %attr(755,root,root) %{_datadir}/perf-core/perf-archive
667 %attr(755,root,root) %{_datadir}/perf-core/perf-with-kcore
668
669 %dir %{_datadir}/perf-core/scripts
670
671 %dir %{_datadir}/perf-core/scripts/perl
672 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util
673 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib
674 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf
675 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace
676 %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace/*.pm
677 %dir %{_datadir}/perf-core/scripts/perl/bin
678 %attr(755,root,root) %{_datadir}/perf-core/scripts/perl/bin/*
679 %{_datadir}/perf-core/scripts/perl/*.pl
680
681 %dir %{_datadir}/perf-core/scripts/python
682 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util
683 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib
684 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf
685 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace
686 %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/*.py*
687 %dir %{_datadir}/perf-core/scripts/python/bin
688 %attr(755,root,root) %{_datadir}/perf-core/scripts/python/bin/*
689 %{_datadir}/perf-core/scripts/python/*.py*
690
691 %dir %{_libdir}/traceevent
692 %dir %{_libdir}/traceevent/plugins
693 %attr(755,root,root) %{_libdir}/traceevent/plugins/plugin_*.so
694
695 %if %{with multilib}
696 %files perf-vdso32
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_bindir}/perf-read-vdso32
699
700 %files perf-vdsox32
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_bindir}/perf-read-vdsox32
703 %endif
704
705 %if %{with gtk}
706 %files perf-gtk
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_libdir}/libperf-gtk.so
709 %endif
710
711 %files -n bash-completion-perf
712 %defattr(644,root,root,755)
713 /etc/bash_completion.d/perf
714 %endif
715
716 %if %{with usbip}
717 %files -n usbip
718 %defattr(644,root,root,755)
719 %doc linux-%{basever}/tools/usb/usbip/{AUTHORS,README}
720 %attr(755,root,root) %{_sbindir}/usbip
721 %attr(755,root,root) %{_sbindir}/usbipd
722 %{_mandir}/man8/usbip.8*
723 %{_mandir}/man8/usbipd.8*
724
725 %files -n usbip-libs
726 %defattr(644,root,root,755)
727 %attr(755,root,root) %{_libdir}/libusbip.so.*.*.*
728 %attr(755,root,root) %ghost %{_libdir}/libusbip.so.0
729
730 %files -n usbip-devel
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_libdir}/libusbip.so
733 %{_includedir}/usbip
734
735 %files -n usbip-static
736 %defattr(644,root,root,755)
737 %{_libdir}/libusbip.a
738 %endif
This page took 0.097174 seconds and 4 git commands to generate.