]> git.pld-linux.org Git - packages/kernel-tools.git/blob - kernel-tools.spec
- more WERROR=0
[packages/kernel-tools.git] / kernel-tools.spec
1 # TODO:
2 # - redefine: PACKAGE_BUGREPORT=cpufreq@vger.kernel.org
3 # -n python-perf?
4
5 # Conditional build:
6 %bcond_without  verbose         # verbose build (V=1)
7 %bcond_without  perf            # perf tools
8
9 %define         rel             3
10 %define         basever 3.9
11 %define         postver .5
12 Summary:        Assortment of tools for the Linux kernel
13 Summary(pl.UTF-8):      Zestaw narzędzi dla jądra Linuksa
14 Name:           kernel-tools
15 Version:        %{basever}%{postver}
16 Release:        %{rel}
17 License:        GPL v2
18 Group:          Applications/System
19 Source0:        http://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
20 # Source0-md5:  4348c9b6b2eb3144d601e87c19d5d909
21 %if "%{postver}" != ".0"
22 Patch0:         http://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
23 # Patch0-md5:   aa22187ae5cd482a69097e9e59244491
24 %endif
25 Source1:        cpupower.service
26 Source2:        cpupower.config
27 URL:            http://www.kernel.org/
28 BuildRequires:  rpmbuild(macros) >= 1.647
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 %if %{with perf}
32 BuildRequires:  asciidoc
33 BuildRequires:  audit-libs-devel
34 BuildRequires:  binutils-devel
35 BuildRequires:  bison
36 BuildRequires:  docbook-style-xsl
37 BuildRequires:  elfutils-devel
38 BuildRequires:  flex
39 BuildRequires:  gtk+2-devel >= 2.0
40 BuildRequires:  libunwind-devel >= 0.99
41 BuildRequires:  newt-devel
42 BuildRequires:  perl-devel >= 5.1
43 BuildRequires:  pkgconfig
44 BuildRequires:  python-devel
45 BuildRequires:  rpm-pythonprov
46 BuildRequires:  slang-devel
47 BuildRequires:  xmlto
48 %endif
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         makeopts        CC="%{__cc}" %{?with_verbose:V=1}
52
53 %description
54 This package contains the software from tools/ subdirectory from Linux
55 kernel source and the supporting documentation.
56
57 %description -l pl.UTF-8
58 Ten pakiet zawiera oprogramowanie z podkatalogu tools/ ze źródeł jądra
59 Linuksa oraz związaną z nim dokumentację.
60
61 %package cpupower
62 Summary:        cpupower - Shows and sets processor power related values
63 Summary(pl.UTF-8):      cpupower - wyświetlanie i ustawianie wartości związanych z zużyciem energii przez procesor
64 Group:          Applications/System
65 Requires(post,preun,postun):    systemd-units >= 38
66 Requires:       %{name}-cpupower-libs = %{version}-%{release}
67 Requires:       systemd-units >= 0.38
68 Provides:       cpufreq-utils = 1:009-0.6.p1
69 Provides:       cpufrequtils = 1:009-0.6.p1
70 Provides:       cpupowerutils = 1:009-0.6.p1
71 Obsoletes:      cpufreq-utils < 1:009-0.6.p1
72 Obsoletes:      cpufrequtils < 1:009-0.6.p1
73 Obsoletes:      cpupowerutils < 1:009-0.6.p1
74 Obsoletes:      cpuspeed < 1:1.5-16
75
76 %description cpupower
77 cpupower is a collection of tools to examine and tune power saving
78 related features of your processor.
79
80 %description cpupower -l pl.UTF-8
81 cpupower to zbiór narzędzi do sprawdzania i ustawiania opcji procesora
82 związanych z oszczędzaniem energii.
83
84 %package cpupower-libs
85 Summary:        cpupower library
86 Summary(pl.UTF-8):      Biblioteka cpupower
87 Group:          Libraries
88
89 %description cpupower-libs
90 cpupower library.
91
92 %description cpupower-libs -l pl.UTF-8
93 Biblioteka cpupower.
94
95 %package cpupower-libs-devel
96 Summary:        Development files for the cpupower library
97 Summary(pl.UTF-8):      Pliki programistyczne biblioteki cpupower
98 Group:          Development/Libraries
99 Requires:       %{name} = %{version}-%{release}
100 Requires:       %{name}-cpupower-libs = %{version}-%{release}
101 Provides:       cpufrequtils-devel = 1:009-0.6.p1
102 Provides:       cpupowerutils-devel = 1:009-0.6.p1
103 Obsoletes:      cpufrequtils-devel < 1:009-0.6.p1
104 Obsoletes:      cpupowerutils-devel < 1:009-0.6.p1
105
106 %description cpupower-libs-devel
107 Development files for the cpupower library.
108
109 %description cpupower-libs-devel -l pl.UTF-8
110 Pliki programistyczne biblioteki cpupower.
111
112 %package perf-core
113 Summary:        perf profiler tool (core package)
114 Summary(pl.UTF-8):      Narzędzie profilujące perf (podstawowe narzędzia)
115 Group:          Applications/System
116
117 %description perf-core
118 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
119 away CPU hardware differences in Linux performance measurements and
120 presents a simple commandline interface. Perf is based on the
121 perf_events interface exported by recent versions of the Linux kernel.
122
123 This package contains core files and scripts.
124
125 %description perf-core -l pl.UTF-8
126 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
127 odseparowujące od różnic sprzętowych między pomiarami wydajności w
128 zależności od procesora oraz udostępniające prosty interfejs linii
129 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
130 przez nowe wersje jądra Linuksa.
131
132 Ten pakiet zawiera podstawowe pliki i skrypty.
133
134 %package perf-gtk
135 Summary:        perf profiler tool (GTK+ GUI)
136 Summary(pl.UTF-8):      Narzędzie profilujące perf (interfejs graficzny GTK+)
137 Group:          X11/Applications
138 Requires:       %{name}-perf-core = %{version}-%{release}
139 Provides:       %{name}-perf = %{version}-%{release}
140
141 %description perf-gtk
142 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
143 away CPU hardware differences in Linux performance measurements and
144 presents a simple commandline interface. Perf is based on the
145 perf_events interface exported by recent versions of the Linux kernel.
146
147 This package contains GTK+ based GUI.
148
149 %description perf-gtk -l pl.UTF-8
150 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
151 odseparowujące od różnic sprzętowych między pomiarami wydajności w
152 zależności od procesora oraz udostępniające prosty interfejs linii
153 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
154 przez nowe wersje jądra Linuksa.
155
156 Ten pakiet zawiera graficzny interfejs oparty na GTK+.
157
158 %package perf-slang
159 Summary:        perf profiler tool (Slang TUI)
160 Summary(pl.UTF-8):      Narzędzie profilujące perf (interfejs tekstowy Slang)
161 Group:          X11/Applications
162 Requires:       %{name}-perf-core = %{version}-%{release}
163 Provides:       %{name}-perf = %{version}-%{release}
164
165 %description perf-slang
166 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
167 away CPU hardware differences in Linux performance measurements and
168 presents a simple commandline interface. Perf is based on the
169 perf_events interface exported by recent versions of the Linux kernel.
170
171 This package contains Slang based TUI.
172
173 %description perf-slang -l pl.UTF-8
174 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
175 odseparowujące od różnic sprzętowych między pomiarami wydajności w
176 zależności od procesora oraz udostępniające prosty interfejs linii
177 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
178 przez nowe wersje jądra Linuksa.
179
180 Ten pakiet zawiera tekstowy interfejs oparty na bibliotece Slang.
181
182 %package -n bash-completion-perf
183 Summary:        Bash completion for perf command
184 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla polecenia perf
185 Group:          Applications/Shells
186 Requires:       %{name}-perf
187 Requires:       bash-completion
188
189 %description -n bash-completion-perf
190 Bash completion for perf command.
191
192 %description -n bash-completion-perf -l pl.UTF-8
193 Bashowe uzupełnianie parametrów dla polecenia perf.
194
195 %prep
196 %setup -qc
197 cd linux-%{basever}
198
199 %if "%{postver}" != ".0"
200 %patch0 -p1
201 %endif
202
203 %build
204 cd linux-%{basever}
205
206 # cpupower
207 %{__make} -C tools/power/cpupower \
208         %{makeopts} \
209         CPUFREQ_BENCH=false \
210         OPTIMIZATION="%{rpmcflags}" \
211         STRIPCMD=true
212
213 %ifarch %{ix86}
214 %{__make} -C tools/power/cpupower/debug/i386 centrino-decode powernow-k8-decode \
215         CC="%{__cc}" \
216         CFLAGS="%{rpmcflags}"
217 %endif
218
219 %ifarch %{x8664}
220 %{__make} -C tools/power/cpupower/debug/x86_64 centrino-decode powernow-k8-decode \
221         CC="%{__cc}" \
222         CFLAGS="%{rpmcflags}"
223 %endif
224
225 %ifarch %{ix86} %{x8664}
226 %{__make} -C tools/power/x86/x86_energy_perf_policy \
227         CC="%{__cc}" \
228         CFLAGS="%{rpmcflags}"
229 %{__make} -C tools/power/x86/turbostat \
230         CC="%{__cc}" \
231         CFLAGS="%{rpmcflags} -Wall -I../../../../arch/x86/include/uapi/"
232 %endif
233
234 # slabinfo
235 %{__make} -C tools/vm \
236         CC="%{__cc}" \
237         CFLAGS="%{rpmcflags} -Wall -Wextra"
238
239 %if %{with perf}
240 # perf slang version
241 PWD=${PWD:-$(pwd)}
242 install -d $PWD/perf-{slang,gtk}
243 %{__make} -C tools/perf all man \
244         O=$PWD/perf-slang \
245         NO_GTK2=1 \
246         %{makeopts} \
247         CFLAGS_OPTIMIZE="%{rpmcflags}" \
248         WERROR=0 \
249         prefix=%{_prefix} \
250         perfexecdir=%{_datadir}/perf-core \
251         template_dir=%{_datadir}/perf-core/templates
252
253 # perf gtk version
254 %{__make} -C tools/perf all man \
255         O=$PWD/perf-gtk \
256         %{makeopts} \
257         CFLAGS_OPTIMIZE="%{rpmcflags}" \
258         WERROR=0 \
259         prefix=%{_prefix} \
260         perfexecdir=%{_datadir}/perf-core \
261         template_dir=%{_datadir}/perf-core/templates
262 %endif
263
264 # gen_init_cpio
265 %{__make} -C usr gen_init_cpio \
266         %{makeopts} \
267         CFLAGS="%{rpmcflags}"
268
269 %install
270 rm -rf $RPM_BUILD_ROOT
271 cd linux-%{basever}
272
273 %{__make} -C tools/power/cpupower install \
274         DESTDIR=$RPM_BUILD_ROOT \
275         libdir=%{_libdir} \
276         mandir=%{_mandir} \
277         CPUFREQ_BENCH=false
278
279 %find_lang cpupower
280 mv cpupower.lang ..
281
282 install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{systemdunitdir}}
283 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/cpupower.service
284 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/cpupower
285
286 %ifarch %{ix86}
287 install -p tools/power/cpupower/debug/i386/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
288 %endif
289 %ifarch %{x8664}
290 install -p tools/power/cpupower/debug/x86_64/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
291 %endif
292
293 install tools/vm/slabinfo $RPM_BUILD_ROOT%{_bindir}
294
295 %ifarch %{ix86} %{x8664}
296 install -d $RPM_BUILD_ROOT%{_mandir}/man8
297 # broken makefile, install manually
298 %if 0
299 %{__make} install \
300         -C tools/power/x86/x86_energy_perf_policy \
301         DESTDIR=$RPM_BUILD_ROOT
302 %else
303 cd tools/power/x86/x86_energy_perf_policy
304 install -p x86_energy_perf_policy $RPM_BUILD_ROOT%{_bindir}
305 install -p x86_energy_perf_policy.8 $RPM_BUILD_ROOT%{_mandir}/man8
306 cd -
307 %endif
308
309 # broken makefile, install manually
310 %if 0
311 %{__make} install \
312         -C tools/power/x86/turbostat \
313         DESTDIR=$RPM_BUILD_ROOT
314 %else
315 cd tools/power/x86/turbostat
316 install -p turbostat.8 $RPM_BUILD_ROOT%{_mandir}/man8
317 cd -
318 install -p turbostat $RPM_BUILD_ROOT%{_bindir}/turbostat
319 %endif
320 %endif
321
322 %if %{with perf}
323 # perf slang
324 PWD=${PWD:-$(pwd)}
325 # perf slang version
326 %{__make} -j1 install install-man \
327         -C tools/perf \
328         O=$PWD/perf-slang \
329         NO_GTK2=1 \
330         CC="%{__cc}" \
331         CFLAGS_OPTIMIZE="%{rpmcflags}" \
332         WERROR=0 \
333         %{?with_verbose:V=1} \
334         prefix=%{_prefix} \
335         perfexecdir=%{_datadir}/perf-core \
336         template_dir=%{_datadir}/perf-core/templates \
337         DESTDIR=$RPM_BUILD_ROOT
338 %{__mv} $RPM_BUILD_ROOT%{_bindir}/perf{,_slang}
339
340 # perf gtk
341 %{__make} -j1 install install-man \
342         -C tools/perf \
343         O=$PWD/perf-gtk \
344         CC="%{__cc}" \
345         CFLAGS_OPTIMIZE="%{rpmcflags}" \
346         WERROR=0 \
347         %{?with_verbose:V=1} \
348         prefix=%{_prefix} \
349         perfexecdir=%{_datadir}/perf-core \
350         template_dir=%{_datadir}/perf-core/templates \
351         DESTDIR=$RPM_BUILD_ROOT
352 %{__mv} $RPM_BUILD_ROOT%{_bindir}/perf{,_gtk}
353
354 %py_comp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
355 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
356 %endif
357
358 # gen_init_cpio
359 install -p usr/gen_init_cpio $RPM_BUILD_ROOT%{_bindir}/gen_init_cpio
360
361 rm -r $RPM_BUILD_ROOT%{_datadir}/perf-core/tests
362
363 %clean
364 rm -rf $RPM_BUILD_ROOT
365
366 %post   cpupower-libs -p /sbin/ldconfig
367 %postun cpupower-libs -p /sbin/ldconfig
368
369 %post cpupower
370 %systemd_post cpupower.service
371
372 %preun cpupower
373 %systemd_preun cpupower.service
374
375 %postun cpupower
376 %systemd_reload
377
378 %files
379 %defattr(644,root,root,755)
380 %attr(755,root,root) %{_bindir}/gen_init_cpio
381 %attr(755,root,root) %{_bindir}/slabinfo
382 %ifarch %{ix86} %{x8664}
383 %attr(755,root,root) %{_bindir}/centrino-decode
384 %attr(755,root,root) %{_bindir}/powernow-k8-decode
385 %endif
386 %ifarch %{ix86} %{x8664}
387 %attr(755,root,root) %{_bindir}/turbostat
388 %attr(755,root,root) %{_bindir}/x86_energy_perf_policy
389 %{_mandir}/man8/turbostat.8*
390 %{_mandir}/man8/x86_energy_perf_policy.8*
391 %endif
392
393 %files cpupower -f cpupower.lang
394 %defattr(644,root,root,755)
395 %attr(755,root,root) %{_bindir}/cpupower
396 %{_mandir}/man1/cpupower*.1*
397 %{systemdunitdir}/cpupower.service
398 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cpupower
399
400 %files cpupower-libs
401 %defattr(644,root,root,755)
402 %attr(755,root,root) %{_libdir}/libcpupower.so.*.*.*
403 %attr(755,root,root) %ghost %{_libdir}/libcpupower.so.0
404
405 %files cpupower-libs-devel
406 %defattr(644,root,root,755)
407 %attr(755,root,root) %{_libdir}/libcpupower.so
408 %{_includedir}/cpufreq.h
409
410 %if %{with perf}
411 %files perf-core
412 %defattr(644,root,root,755)
413 %{_mandir}/man1/perf*.1*
414 %dir %{_datadir}/perf-core
415 %attr(755,root,root) %{_datadir}/perf-core/perf-archive
416
417 %dir %{_datadir}/perf-core/scripts
418
419 %dir %{_datadir}/perf-core/scripts/perl
420 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util
421 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib
422 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf
423 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace
424 %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace/*.pm
425 %dir %{_datadir}/perf-core/scripts/perl/bin
426 %attr(755,root,root) %{_datadir}/perf-core/scripts/perl/bin/*
427 %{_datadir}/perf-core/scripts/perl/*.pl
428
429 %dir %{_datadir}/perf-core/scripts/python
430 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util
431 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib
432 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf
433 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace
434 %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/*.py*
435 %dir %{_datadir}/perf-core/scripts/python/bin
436 %attr(755,root,root) %{_datadir}/perf-core/scripts/python/bin/*
437 %{_datadir}/perf-core/scripts/python/*.py*
438
439 %files perf-gtk
440 %defattr(644,root,root,755)
441 %attr(755,root,root) %{_bindir}/perf_gtk
442
443 %files perf-slang
444 %defattr(644,root,root,755)
445 %attr(755,root,root) %{_bindir}/perf_slang
446
447 %files -n bash-completion-perf
448 %defattr(644,root,root,755)
449 /etc/bash_completion.d/perf
450 %endif
This page took 0.070377 seconds and 4 git commands to generate.