]> git.pld-linux.org Git - packages/kernel-tools.git/blob - kernel-tools.spec
up to 3.8.6
[packages/kernel-tools.git] / kernel-tools.spec
1 # TODO:
2 # - redefine: PACKAGE_BUGREPORT=cpufreq@vger.kernel.org
3 # -n python-perf?
4
5 # Conditional build:
6 %bcond_without  verbose         # verbose build (V=1)
7 %bcond_without  perf            # perf tools
8
9 %define         rel             1
10 %define         basever 3.8
11 %define         postver .6
12 Summary:        Assortment of tools for the Linux kernel
13 Summary(pl.UTF-8):      Zestaw narzędzi dla jądra Linuksa
14 Name:           kernel-tools
15 Version:        %{basever}%{postver}
16 Release:        %{rel}
17 License:        GPL v2
18 Group:          Applications/System
19 Source0:        http://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
20 # Source0-md5:  1c738edfc54e7c65faeb90c436104e2f
21 %if "%{postver}" != ".0"
22 Patch0:         http://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.bz2
23 # Patch0-md5:   ab255ca10073bbaab3218e024d9f8568
24 %endif
25 Source1:        cpupower.service
26 Source2:        cpupower.config
27 URL:            http://www.kernel.org/
28 BuildRequires:  rpmbuild(macros) >= 1.647
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 %if %{with perf}
32 BuildRequires:  asciidoc
33 BuildRequires:  audit-libs-devel
34 BuildRequires:  binutils-devel
35 BuildRequires:  bison
36 BuildRequires:  docbook-style-xsl
37 BuildRequires:  elfutils-devel
38 BuildRequires:  flex
39 BuildRequires:  gtk+2-devel >= 2.0
40 BuildRequires:  libunwind-devel >= 0.99
41 BuildRequires:  newt-devel
42 BuildRequires:  perl-devel >= 5.1
43 BuildRequires:  pkgconfig
44 BuildRequires:  python-devel
45 BuildRequires:  rpm-pythonprov
46 BuildRequires:  slang-devel
47 BuildRequires:  xmlto
48 %endif
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         makeopts        CC="%{__cc}" %{?with_verbose:V=1}
52
53 %description
54 This package contains the software from tools/ subdirectory from Linux
55 kernel source and the supporting documentation.
56
57 %description -l pl.UTF-8
58 Ten pakiet zawiera oprogramowanie z podkatalogu tools/ ze źródeł jądra
59 Linuksa oraz związaną z nim dokumentację.
60
61 %package cpupower
62 Summary:        cpupower - Shows and sets processor power related values
63 Summary(pl.UTF-8):      cpupower - wyświetlanie i ustawianie wartości związanych z zużyciem energii przez procesor
64 Group:          Applications/System
65 Requires(post,preun,postun):    systemd-units >= 38
66 Requires:       %{name}-cpupower-libs = %{version}-%{release}
67 Requires:       systemd-units >= 0.38
68 Provides:       cpufreq-utils = 1:009-0.6.p1
69 Provides:       cpufrequtils = 1:009-0.6.p1
70 Provides:       cpupowerutils = 1:009-0.6.p1
71 Obsoletes:      cpufreq-utils < 1:009-0.6.p1
72 Obsoletes:      cpufrequtils < 1:009-0.6.p1
73 Obsoletes:      cpupowerutils < 1:009-0.6.p1
74 Obsoletes:      cpuspeed < 1:1.5-16
75
76 %description cpupower
77 cpupower is a collection of tools to examine and tune power saving
78 related features of your processor.
79
80 %description cpupower -l pl.UTF-8
81 cpupower to zbiór narzędzi do sprawdzania i ustawiania opcji procesora
82 związanych z oszczędzaniem energii.
83
84 %package cpupower-libs
85 Summary:        cpupower library
86 Summary(pl.UTF-8):      Biblioteka cpupower
87 Group:          Libraries
88
89 %description cpupower-libs
90 cpupower library.
91
92 %description cpupower-libs -l pl.UTF-8
93 Biblioteka cpupower.
94
95 %package cpupower-libs-devel
96 Summary:        Development files for the cpupower library
97 Summary(pl.UTF-8):      Pliki programistyczne biblioteki cpupower
98 Group:          Development/Libraries
99 Requires:       %{name} = %{version}-%{release}
100 Requires:       %{name}-cpupower-libs = %{version}-%{release}
101 Provides:       cpufrequtils-devel = 1:009-0.6.p1
102 Provides:       cpupowerutils-devel = 1:009-0.6.p1
103 Obsoletes:      cpufrequtils-devel < 1:009-0.6.p1
104 Obsoletes:      cpupowerutils-devel < 1:009-0.6.p1
105
106 %description cpupower-libs-devel
107 Development files for the cpupower library.
108
109 %description cpupower-libs-devel -l pl.UTF-8
110 Pliki programistyczne biblioteki cpupower.
111
112 %package perf-core
113 Summary:        perf profiler tool (core package)
114 Summary(pl.UTF-8):      Narzędzie profilujące perf (podstawowe narzędzia)
115 Group:          Applications/System
116
117 %description perf-core
118 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
119 away CPU hardware differences in Linux performance measurements and
120 presents a simple commandline interface. Perf is based on the
121 perf_events interface exported by recent versions of the Linux kernel.
122
123 This package contains core files and scripts.
124
125 %description perf-core -l pl.UTF-8
126 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
127 odseparowujące od różnic sprzętowych między pomiarami wydajności w
128 zależności od procesora oraz udostępniające prosty interfejs linii
129 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
130 przez nowe wersje jądra Linuksa.
131
132 Ten pakiet zawiera podstawowe pliki i skrypty.
133
134 %package perf-gtk
135 Summary:        perf profiler tool (GTK+ GUI)
136 Summary(pl.UTF-8):      Narzędzie profilujące perf (interfejs graficzny GTK+)
137 Group:          X11/Applications
138 Requires:       %{name}-perf-core = %{version}-%{release}
139 Provides:       %{name}-perf = %{version}-%{release}
140
141 %description perf-gtk
142 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
143 away CPU hardware differences in Linux performance measurements and
144 presents a simple commandline interface. Perf is based on the
145 perf_events interface exported by recent versions of the Linux kernel.
146
147 This package contains GTK+ based GUI.
148
149 %description perf-gtk -l pl.UTF-8
150 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
151 odseparowujące od różnic sprzętowych między pomiarami wydajności w
152 zależności od procesora oraz udostępniające prosty interfejs linii
153 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
154 przez nowe wersje jądra Linuksa.
155
156 Ten pakiet zawiera graficzny interfejs oparty na GTK+.
157
158 %package perf-slang
159 Summary:        perf profiler tool (Slang TUI)
160 Summary(pl.UTF-8):      Narzędzie profilujące perf (interfejs tekstowy Slang)
161 Group:          X11/Applications
162 Requires:       %{name}-perf-core = %{version}-%{release}
163 Provides:       %{name}-perf = %{version}-%{release}
164
165 %description perf-slang
166 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
167 away CPU hardware differences in Linux performance measurements and
168 presents a simple commandline interface. Perf is based on the
169 perf_events interface exported by recent versions of the Linux kernel.
170
171 This package contains Slang based TUI.
172
173 %description perf-slang -l pl.UTF-8
174 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
175 odseparowujące od różnic sprzętowych między pomiarami wydajności w
176 zależności od procesora oraz udostępniające prosty interfejs linii
177 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
178 przez nowe wersje jądra Linuksa.
179
180 Ten pakiet zawiera tekstowy interfejs oparty na bibliotece Slang.
181
182 %package -n bash-completion-perf
183 Summary:        Bash completion for perf command
184 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla polecenia perf
185 Group:          Applications/Shells
186 Requires:       %{name}-perf
187 Requires:       bash-completion
188
189 %description -n bash-completion-perf
190 Bash completion for perf command.
191
192 %description -n bash-completion-perf -l pl.UTF-8
193 Bashowe uzupełnianie parametrów dla polecenia perf.
194
195 %prep
196 %setup -qc
197 cd linux-%{basever}
198
199 %if "%{postver}" != ".0"
200 %patch0 -p1
201 %endif
202
203 %build
204 cd linux-%{basever}
205
206 # cpupower
207 %{__make} -C tools/power/cpupower \
208         %{makeopts} \
209         CPUFREQ_BENCH=false \
210         OPTIMIZATION="%{rpmcflags}" \
211         STRIPCMD=true
212
213 %ifarch %{ix86}
214 %{__make} -C tools/power/cpupower/debug/i386 centrino-decode powernow-k8-decode \
215         CC="%{__cc}" \
216         CFLAGS="%{rpmcflags}"
217 %endif
218
219 %ifarch %{x8664}
220 %{__make} -C tools/power/cpupower/debug/x86_64 centrino-decode powernow-k8-decode \
221         CC="%{__cc}" \
222         CFLAGS="%{rpmcflags}"
223 %endif
224
225 %ifarch %{ix86} %{x8664}
226 %{__make} -C tools/power/x86/x86_energy_perf_policy \
227         CC="%{__cc}" \
228         CFLAGS="%{rpmcflags}"
229 %{__make} -C tools/power/x86/turbostat \
230         CC="%{__cc}" \
231         CFLAGS="%{rpmcflags} -Wall"
232 %endif
233
234 # slabinfo
235 %{__make} -C tools/vm \
236         CC="%{__cc}" \
237         CFLAGS="%{rpmcflags} -Wall -Wextra"
238
239 %if %{with perf}
240 # perf slang version
241 PWD=${PWD:-$(pwd)}
242 install -d $PWD/perf-{slang,gtk}
243 %{__make} -C tools/perf all man \
244         O=$PWD/perf-slang \
245         NO_GTK2=1 \
246         %{makeopts} \
247         CFLAGS_OPTIMIZE="%{rpmcflags}" \
248         prefix=%{_prefix} \
249         perfexecdir=%{_datadir}/perf-core \
250         template_dir=%{_datadir}/perf-core/templates
251
252 # perf gtk version
253 %{__make} -C tools/perf all man \
254         O=$PWD/perf-gtk \
255         %{makeopts} \
256         CFLAGS_OPTIMIZE="%{rpmcflags}" \
257         prefix=%{_prefix} \
258         perfexecdir=%{_datadir}/perf-core \
259         template_dir=%{_datadir}/perf-core/templates
260 %endif
261
262 # gen_init_cpio
263 %{__make} -C usr gen_init_cpio \
264         %{makeopts} \
265         CFLAGS="%{rpmcflags}"
266
267 %install
268 rm -rf $RPM_BUILD_ROOT
269 cd linux-%{basever}
270
271 %{__make} -C tools/power/cpupower install \
272         DESTDIR=$RPM_BUILD_ROOT \
273         libdir=%{_libdir} \
274         mandir=%{_mandir} \
275         CPUFREQ_BENCH=false
276
277 %find_lang cpupower
278 mv cpupower.lang ..
279
280 install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{systemdunitdir}}
281 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/cpupower.service
282 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/cpupower
283
284 %ifarch %{ix86}
285 install -p tools/power/cpupower/debug/i386/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
286 %endif
287 %ifarch %{x8664}
288 install -p tools/power/cpupower/debug/x86_64/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
289 %endif
290
291 install tools/vm/slabinfo $RPM_BUILD_ROOT%{_bindir}
292
293 %ifarch %{ix86} %{x8664}
294 install -d $RPM_BUILD_ROOT%{_mandir}/man8
295 # broken makefile, install manually
296 %if 0
297 %{__make} install \
298         -C tools/power/x86/x86_energy_perf_policy \
299         DESTDIR=$RPM_BUILD_ROOT
300 %else
301 cd tools/power/x86/x86_energy_perf_policy
302 install -p x86_energy_perf_policy $RPM_BUILD_ROOT%{_bindir}
303 install -p x86_energy_perf_policy.8 $RPM_BUILD_ROOT%{_mandir}/man8
304 cd -
305 %endif
306
307 # broken makefile, install manually
308 %if 0
309 %{__make} install \
310         -C tools/power/x86/turbostat \
311         DESTDIR=$RPM_BUILD_ROOT
312 %else
313 cd tools/power/x86/turbostat
314 install -p turbostat.8 $RPM_BUILD_ROOT%{_mandir}/man8
315 cd -
316 install -p turbostat $RPM_BUILD_ROOT%{_bindir}/turbostat
317 %endif
318 %endif
319
320 %if %{with perf}
321 # perf slang
322 PWD=${PWD:-$(pwd)}
323 # perf slang version
324 %{__make} -j1 install install-man \
325         -C tools/perf \
326         O=$PWD/perf-slang \
327         NO_GTK2=1 \
328         CC="%{__cc}" \
329         CFLAGS_OPTIMIZE="%{rpmcflags}" \
330         %{?with_verbose:V=1} \
331         prefix=%{_prefix} \
332         perfexecdir=%{_datadir}/perf-core \
333         template_dir=%{_datadir}/perf-core/templates \
334         DESTDIR=$RPM_BUILD_ROOT
335 %{__mv} $RPM_BUILD_ROOT%{_bindir}/perf{,_slang}
336
337 # perf gtk
338 %{__make} -j1 install install-man \
339         -C tools/perf \
340         O=$PWD/perf-gtk \
341         CC="%{__cc}" \
342         CFLAGS_OPTIMIZE="%{rpmcflags}" \
343         %{?with_verbose:V=1} \
344         prefix=%{_prefix} \
345         perfexecdir=%{_datadir}/perf-core \
346         template_dir=%{_datadir}/perf-core/templates \
347         DESTDIR=$RPM_BUILD_ROOT
348 %{__mv} $RPM_BUILD_ROOT%{_bindir}/perf{,_gtk}
349
350 %py_comp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
351 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
352 %endif
353
354 # gen_init_cpio
355 install -p usr/gen_init_cpio $RPM_BUILD_ROOT%{_bindir}/gen_init_cpio
356
357 rm -r $RPM_BUILD_ROOT%{_datadir}/perf-core/tests
358
359 %clean
360 rm -rf $RPM_BUILD_ROOT
361
362 %post   cpupower-libs -p /sbin/ldconfig
363 %postun cpupower-libs -p /sbin/ldconfig
364
365 %post cpupower
366 %systemd_post cpupower.service
367
368 %preun cpupower
369 %systemd_preun cpupower.service
370
371 %postun cpupower
372 %systemd_reload
373
374 %files
375 %defattr(644,root,root,755)
376 %attr(755,root,root) %{_bindir}/gen_init_cpio
377 %attr(755,root,root) %{_bindir}/slabinfo
378 %ifarch %{ix86} %{x8664}
379 %attr(755,root,root) %{_bindir}/centrino-decode
380 %attr(755,root,root) %{_bindir}/powernow-k8-decode
381 %endif
382 %ifarch %{ix86} %{x8664}
383 %attr(755,root,root) %{_bindir}/turbostat
384 %attr(755,root,root) %{_bindir}/x86_energy_perf_policy
385 %{_mandir}/man8/turbostat.8*
386 %{_mandir}/man8/x86_energy_perf_policy.8*
387 %endif
388
389 %files cpupower -f cpupower.lang
390 %defattr(644,root,root,755)
391 %attr(755,root,root) %{_bindir}/cpupower
392 %{_mandir}/man1/cpupower*.1*
393 %{systemdunitdir}/cpupower.service
394 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cpupower
395
396 %files cpupower-libs
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_libdir}/libcpupower.so.*.*.*
399 %attr(755,root,root) %ghost %{_libdir}/libcpupower.so.0
400
401 %files cpupower-libs-devel
402 %defattr(644,root,root,755)
403 %attr(755,root,root) %{_libdir}/libcpupower.so
404 %{_includedir}/cpufreq.h
405
406 %if %{with perf}
407 %files perf-core
408 %defattr(644,root,root,755)
409 %{_mandir}/man1/perf*.1*
410 %dir %{_datadir}/perf-core
411 %attr(755,root,root) %{_datadir}/perf-core/perf-archive
412
413 %dir %{_datadir}/perf-core/scripts
414
415 %dir %{_datadir}/perf-core/scripts/perl
416 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util
417 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib
418 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf
419 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace
420 %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace/*.pm
421 %dir %{_datadir}/perf-core/scripts/perl/bin
422 %attr(755,root,root) %{_datadir}/perf-core/scripts/perl/bin/*
423 %{_datadir}/perf-core/scripts/perl/*.pl
424
425 %dir %{_datadir}/perf-core/scripts/python
426 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util
427 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib
428 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf
429 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace
430 %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/*.py*
431 %dir %{_datadir}/perf-core/scripts/python/bin
432 %attr(755,root,root) %{_datadir}/perf-core/scripts/python/bin/*
433 %{_datadir}/perf-core/scripts/python/*.py*
434
435 %files perf-gtk
436 %defattr(644,root,root,755)
437 %attr(755,root,root) %{_bindir}/perf_gtk
438
439 %files perf-slang
440 %defattr(644,root,root,755)
441 %attr(755,root,root) %{_bindir}/perf_slang
442
443 %files -n bash-completion-perf
444 %defattr(644,root,root,755)
445 /etc/bash_completion.d/perf
446 %endif
This page took 0.101278 seconds and 4 git commands to generate.