]> git.pld-linux.org Git - packages/kernel-tools.git/blob - kernel-tools.spec
- up to 4.13.9
[packages/kernel-tools.git] / kernel-tools.spec
1 # TODO:
2 # - redefine: PACKAGE_BUGREPORT=cpufreq@vger.kernel.org
3 # - add -n python-perf?
4 # - add bcond to disable building docs (perf docs)
5 # - install of perf links perf binary again
6
7 # Conditional build:
8 %bcond_without  verbose         # verbose build (V=1)
9 %bcond_without  cpupower        # cpupower tools
10 %bcond_without  perf            # perf tools
11 %bcond_without  gtk             # GTK+ 2.x perf support
12 %bcond_without  libunwind       # libunwind perf support
13 %bcond_without  multilib        # multilib perf support
14 %bcond_without  usbip           # usbip utils
15
16 %ifarch x32
17 %undefine       with_libunwind
18 %endif
19 %ifnarch %{x8664}
20 %undefine       with_multilib
21 %endif
22
23 %define         basever         4.13
24 %define         postver         .9
25 Summary:        Assortment of tools for the Linux kernel
26 Summary(pl.UTF-8):      Zestaw narzędzi dla jądra Linuksa
27 Name:           kernel-tools
28 Version:        %{basever}%{postver}
29 Release:        1
30 License:        GPL v2
31 Group:          Applications/System
32 Source0:        https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
33 # Source0-md5:  ab1a2abc6f37b752dd2595338bec4e78
34 Source1:        cpupower.service
35 Source2:        cpupower.config
36 %if "%{postver}" != ".0"
37 Patch0:         https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
38 # Patch0-md5:   65ff24fbf4cbfff46af62393ddc901d9
39 %endif
40 Patch1:         x32.patch
41 Patch2:         %{name}-lguest-update.patch
42 Patch3:         %{name}-perf-update.patch
43 URL:            http://www.kernel.org/
44 BuildRequires:  bison
45 BuildRequires:  flex
46 BuildRequires:  gettext-tools
47 BuildRequires:  linux-libc-headers >= 7:4.12
48 BuildRequires:  ncurses-devel
49 BuildRequires:  pciutils-devel
50 BuildRequires:  pkgconfig
51 BuildRequires:  rpmbuild(macros) >= 1.647
52 BuildRequires:  tar >= 1:1.22
53 BuildRequires:  xz
54 %if %{with perf}
55 BuildRequires:  asciidoc
56 BuildRequires:  audit-libs-devel
57 BuildRequires:  binutils-devel
58 BuildRequires:  docbook-dtd45-xml
59 BuildRequires:  docbook-style-xsl
60 BuildRequires:  elfutils-devel
61 %if %{with multilib}
62 BuildRequires:  gcc-multilib-32
63 BuildRequires:  gcc-multilib-x32
64 %endif
65 %{?with_libunwind:BuildRequires:        libunwind-devel >= 0.99}
66 BuildRequires:  numactl-devel
67 BuildRequires:  perl-devel >= 5.1
68 BuildRequires:  python-devel
69 BuildRequires:  rpm-pythonprov
70 BuildRequires:  slang-devel
71 BuildRequires:  xmlto
72 %if %{with gtk}
73 BuildRequires:  gtk+2-devel >= 2.0
74 %endif
75 %endif
76 %if %{with usbip}
77 BuildRequires:  autoconf >= 2.59
78 BuildRequires:  automake >= 1:1.9
79 BuildRequires:  gcc >= 6:4.0
80 BuildRequires:  libtool >= 2:2
81 BuildRequires:  libwrap-devel
82 BuildRequires:  udev-devel
83 %endif
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 # otherwise /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
87 %define         _enable_debug_packages  0
88
89 %define         makeopts        CC="%{__cc}" %{?with_verbose:V=1}
90
91 %description
92 This package contains the software from tools/ subdirectory from Linux
93 kernel source and the supporting documentation.
94
95 %description -l pl.UTF-8
96 Ten pakiet zawiera oprogramowanie z podkatalogu tools/ ze źródeł jądra
97 Linuksa oraz związaną z nim dokumentację.
98
99 %package cpupower
100 Summary:        cpupower - Shows and sets processor power related values
101 Summary(pl.UTF-8):      cpupower - wyświetlanie i ustawianie wartości związanych z zużyciem energii przez procesor
102 Group:          Applications/System
103 Requires(post,preun,postun):    systemd-units >= 38
104 Requires:       %{name}-cpupower-libs = %{version}-%{release}
105 Requires:       systemd-units >= 0.38
106 Provides:       cpupowerutils = 1:009-0.6.p1
107 Obsoletes:      cpupowerutils < 1:009-0.6.p1
108 Obsoletes:      cpuspeed < 1:1.5-16
109
110 %description cpupower
111 cpupower is a collection of tools to examine and tune power saving
112 related features of your processor.
113
114 %description cpupower -l pl.UTF-8
115 cpupower to zbiór narzędzi do sprawdzania i ustawiania opcji procesora
116 związanych z oszczędzaniem energii.
117
118 %package cpupower-libs
119 Summary:        cpupower library
120 Summary(pl.UTF-8):      Biblioteka cpupower
121 Group:          Libraries
122
123 %description cpupower-libs
124 cpupower library.
125
126 %description cpupower-libs -l pl.UTF-8
127 Biblioteka cpupower.
128
129 %package cpupower-libs-devel
130 Summary:        Development files for the cpupower library
131 Summary(pl.UTF-8):      Pliki programistyczne biblioteki cpupower
132 Group:          Development/Libraries
133 Requires:       %{name}-cpupower-libs = %{version}-%{release}
134 Provides:       cpupowerutils-devel = 1:009-0.6.p1
135 Obsoletes:      cpupowerutils-devel < 1:009-0.6.p1
136 Conflicts:      cpufrequtils-devel
137
138 %description cpupower-libs-devel
139 Development files for the cpupower library.
140
141 %description cpupower-libs-devel -l pl.UTF-8
142 Pliki programistyczne biblioteki cpupower.
143
144 %package hv
145 Summary:        Hyper-V virtualization tools
146 Summary(pl.UTF-8):      Narzędzia do wirtualizacji Hyper-V
147 Group:          Applications/System
148
149 %description hv
150 Hyper-V virtualization tools.
151
152 %description hv -l pl.UTF-8
153 Narzędzia do wirtualizacji Hyper-V.
154
155 %package perf
156 Summary:        perf profiler tool
157 Summary(pl.UTF-8):      Narzędzie profilujące perf
158 Group:          Applications/System
159 Suggests:       binutils
160 Obsoletes:      perf-core
161 Obsoletes:      perf-slang
162
163 %description perf
164 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
165 away CPU hardware differences in Linux performance measurements and
166 presents a simple commandline interface. Perf is based on the
167 perf_events interface exported by recent versions of the Linux kernel.
168
169 This package contains core files, scripts and text interface (TUI).
170
171 %description perf -l pl.UTF-8
172 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
173 odseparowujące od różnic sprzętowych między pomiarami wydajności w
174 zależności od procesora oraz udostępniające prosty interfejs linii
175 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
176 przez nowe wersje jądra Linuksa.
177
178 Ten pakiet zawiera podstawowe pliki, skrypty oraz interfejs tekstowy
179 (TUI).
180
181 %package perf-vdso32
182 Summary:        perf profiler tool - VDSO 32-bit ABI reader
183 Summary(pl.UTF-8):      Narzędzie profilujące perf - odczyt VDSO dla ABI 32-bitowego
184 Group:          Applications/System
185 Requires:       %{name}-perf = %{version}-%{release}
186
187 %description perf-vdso32
188 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
189 away CPU hardware differences in Linux performance measurements and
190 presents a simple commandline interface. Perf is based on the
191 perf_events interface exported by recent versions of the Linux kernel.
192
193 This package contains perf-read-vdso32 tool for reading the 32-bit
194 compatibility VDSO in 64-bit mode.
195
196 %description perf-vdso32 -l pl.UTF-8
197 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
198 odseparowujące od różnic sprzętowych między pomiarami wydajności w
199 zależności od procesora oraz udostępniające prosty interfejs linii
200 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
201 przez nowe wersje jądra Linuksa.
202
203 Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
204 binariów 32-bitowych w trybie 64-bitowym.
205
206 %package perf-vdsox32
207 Summary:        perf profiler tool - VDSO x32 ABI reader
208 Summary(pl.UTF-8):      Narzędzie profilujące perf - odczyt VDSO dla ABI x32
209 Group:          Applications/System
210 Requires:       %{name}-perf = %{version}-%{release}
211
212 %description perf-vdsox32
213 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
214 away CPU hardware differences in Linux performance measurements and
215 presents a simple commandline interface. Perf is based on the
216 perf_events interface exported by recent versions of the Linux kernel.
217
218 This package contains perf-read-vdso32 tool for reading the x32 mode
219 32-bit compatibility VDSO in 64-bit mode.
220
221 %description perf-vdsox32 -l pl.UTF-8
222 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
223 odseparowujące od różnic sprzętowych między pomiarami wydajności w
224 zależności od procesora oraz udostępniające prosty interfejs linii
225 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
226 przez nowe wersje jądra Linuksa.
227
228 Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
229 binariów ABI x32 w trybie 64-bitowym.
230
231 %package perf-gtk
232 Summary:        perf profiler tool (GTK+ 2 GUI)
233 Summary(pl.UTF-8):      Narzędzie profilujące perf (interfejs graficzny GTK+ 2)
234 Group:          X11/Applications
235 Requires:       %{name}-perf = %{version}-%{release}
236
237 %description perf-gtk
238 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
239 away CPU hardware differences in Linux performance measurements and
240 presents a simple commandline interface. Perf is based on the
241 perf_events interface exported by recent versions of the Linux kernel.
242
243 This package contains GTK+ 2 based GUI.
244
245 %description perf-gtk -l pl.UTF-8
246 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
247 odseparowujące od różnic sprzętowych między pomiarami wydajności w
248 zależności od procesora oraz udostępniające prosty interfejs linii
249 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
250 przez nowe wersje jądra Linuksa.
251
252 Ten pakiet zawiera graficzny interfejs oparty na GTK+ 2.
253
254 %package -n bash-completion-perf
255 Summary:        Bash completion for perf command
256 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla polecenia perf
257 Group:          Applications/Shells
258 Requires:       %{name}-perf
259 Requires:       bash-completion
260 %if "%{_rpmversion}" >= "5"
261 BuildArch:      noarch
262 %endif
263
264 %description -n bash-completion-perf
265 Bash completion for perf command.
266
267 %description -n bash-completion-perf -l pl.UTF-8
268 Bashowe uzupełnianie parametrów dla polecenia perf.
269
270 %package -n usbip
271 Summary:        USB device sharing system over IP network
272 Summary(pl.UTF-8):      System współdzielenia urządzeń USB po sieci IP
273 Group:          Networking/Utilities
274 Requires:       usbip-libs = %{version}-%{release}
275 # /lib/hwdata/usb.ids (note: only uncompressed file supported)
276 Requires:       hwdata >= 0.243-2
277
278 %description -n usbip
279 The USB/IP Project aims to develop a general USB device sharing system
280 over IP network. To share USB devices between computers with their
281 full functionality, USB/IP encapsulates "USB requests" into IP packets
282 and transmits them between computers. Original USB device drivers and
283 applications can be also used for remote USB devices without any
284 modification of them. A computer can use remote USB devices as if they
285 were directly attached; for example, we can:
286  - USB storage devices: fdisk, mkfs, mount/umount, file operations,
287    play a DVD movie and record a DVD-R media.
288  - USB keyboards and USB mice: use with Linux console and X Window
289    System.
290  - USB webcams and USB speakers: view webcam, capture image data and
291    play some music.
292  - USB printers, USB scanners, USB serial converters and USB Ethernet
293    interfaces: ok, use fine.
294
295 %description -n usbip -l pl.UTF-8
296 Projekt USB/IP ma na celu stworzenie ogólnego systemu współdzielenia
297 urządzeń USB po sieci IP. W celu współdzielenia urządzeń USB między
298 komputerami z zachowaniem pełnej funkcjonalności, USB/IP obudowuje
299 żądania SUB w pakiety IP i przesyła je między komputerami. Oryginalne
300 sterowniki urządzeń USB oraz aplikacje mogą być używane bez żadnych
301 modyfikacji. Komputer może wykorzystywać zdaln urządzenia USB tak,
302 jakby były podłączone bezpośrednio. Przykładowe możliwości:
303  - urządzenia USB do przechowywania danych: można używać programów
304    fdisk, mkfs, mount/umount, operacji na plikach, odtwarzać filmy
305    DVD oraz nagrywać nośniki DVD-R
306  - klawiatury i myszy USB: można ich używać na linuksowej konsoli oraz
307    w systemie X Window
308  - kamery i głośniki USB: można oglądać obraz z kamery, robić zdjęcia
309    i odtwarzać muzykę
310  - drukarki, skanery, konwertery portów szeregowych oraz interfejsy
311    sieciowe USB: można ich normalnie używać
312
313 %package -n usbip-libs
314 Summary:        USB/IP library
315 Summary(pl.UTF-8):      Biblioteka USB/IP
316 Group:          Libraries
317
318 %description -n usbip-libs
319 USB over IP library.
320
321 %description -n usbip-libs -l pl.UTF-8
322 Biblioteka USB po IP.
323
324 %package -n usbip-devel
325 Summary:        Header files for usbip library
326 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki usbip
327 Group:          Development/Libraries
328 Requires:       usbip-libs = %{version}-%{release}
329
330 %description -n usbip-devel
331 This package contains the header files needed to develop programs
332 which make use of USB/IP.
333
334 %description -n usbip-devel -l pl.UTF-8
335 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
336 wykorzystujących USB/IP.
337
338 %package -n usbip-static
339 Summary:        Static usbip library
340 Summary(pl.UTF-8):      Statyczna biblioteka usbip
341 Group:          Development/Libraries
342 Requires:       usbip-devel = %{version}-%{release}
343
344 %description -n usbip-static
345 Static usbip library.
346
347 %description -n usbip-static -l pl.UTF-8
348 Statyczna biblioteka usbip.
349
350 %prep
351 %setup -qc
352 cd linux-%{basever}
353
354 %if "%{postver}" != ".0"
355 %patch0 -p1
356 %endif
357
358 %patch1 -p1
359 %patch2 -p1
360 %patch3 -p1
361
362 %{__sed} -i -e '/^CFLAGS = /s/ -g / $(OPTFLAGS) /' tools/hv/Makefile
363 %{__sed} -i -e '/^CFLAGS+=/s/ -O1 / $(OPTFLAGS) /' tools/thermal/tmon/Makefile
364 %{__sed} -i -e 's#libexec/perf-core#%{_datadir}/perf-core#g' tools/perf/Makefile.config
365
366 %build
367 cd linux-%{basever}
368
369 # Simple Disk Sleep Monitor
370 %{__make} -C tools/laptop/dslm \
371         %{makeopts} \
372         EXTRA_CFLAGS="%{rpmcflags}"
373
374 # tools common (used eg. by tools/vm)
375 %{__make} -C tools/lib/api \
376         %{makeopts} \
377         EXTRA_CFLAGS="%{rpmcflags}"
378
379 # lsgpio
380 CFLAGS="%{rpmcflags}" \
381 %{__make} -C tools/gpio -j1 \
382         %{makeopts}
383
384 # HyperV is Windows based, x86 specific
385 %ifarch %{ix86} %{x8664} x32
386 %{__make} -C tools/hv \
387         CC="%{__cc}" \
388         OPTFLAGS="%{rpmcflags}"
389 %endif
390
391 CFLAGS="%{rpmcflags}" \
392 %{__make} -C tools/iio \
393         CC="%{__cc}"
394
395 %{__make} -C tools/laptop/freefall \
396         CC="%{__cc}" \
397         CFLAGS="%{rpmcflags}"
398
399 %ifarch %{ix86}
400 # drivers/lguest is x86-32 only
401 %{__make} -C tools/lguest \
402         CC="%{__cc}" \
403         CFLAGS="%{rpmcflags} -Wall -U_FORTIFY_SOURCE -Iinclude"
404 %endif
405
406 CFLAGS="%{rpmcflags}" \
407 %{__make} -C tools/net \
408         CC="%{__cc}"
409
410 # perf
411 %if %{with perf}
412 %{__make} -C tools/perf all man \
413 %ifarch %{x8664}
414         IS_X86_64=1 \
415         %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
416 %endif
417         %{!?with_gtk:NO_GTK2=1} \
418         %{!?with_libunwind:NO_LIBUNWIND=1} \
419         %{makeopts} \
420         CFLAGS_OPTIMIZE="%{rpmcflags}" \
421         WERROR=0 \
422         prefix=%{_prefix} \
423         perfexecdir=%{_datadir}/perf-core \
424         lib=%{_lib} \
425         template_dir=%{_datadir}/perf-core/templates
426 %endif
427
428 # cpupower
429 %if %{with cpupower}
430 %{__make} -C tools/power/cpupower \
431         %{makeopts} \
432         CPUFREQ_BENCH=false \
433         OPTIMIZATION="%{rpmcflags}" \
434         STRIPCMD=true
435
436 %ifarch %{ix86} x32
437 %{__make} -C tools/power/cpupower/debug/i386 centrino-decode powernow-k8-decode \
438         CC="%{__cc}" \
439         CFLAGS="%{rpmcflags}"
440 %endif
441
442 %ifarch %{x8664} x32
443 %{__make} -C tools/power/cpupower/debug/x86_64 centrino-decode powernow-k8-decode \
444         CC="%{__cc}" \
445         CFLAGS="%{rpmcflags}"
446 %endif
447 %endif
448
449 %ifarch %{ix86} %{x8664} x32
450 %{__make} -C tools/power/x86/x86_energy_perf_policy \
451         CC="%{__cc}" \
452         CFLAGS="%{rpmcflags}"
453 CFLAGS="%{rpmcflags}" \
454 %{__make} -C tools/power/x86/turbostat \
455         CC="%{__cc}"
456 %endif
457
458 %{__make} -C tools/thermal/tmon \
459         CC="%{__cc}" \
460         OPTFLAGS="%{rpmcflags}"
461
462 # usbip-utils
463 %if %{with usbip}
464 cd tools/usb/usbip
465 %{__libtoolize}
466 %{__aclocal}
467 %{__autoconf}
468 %{__autoheader}
469 %{__automake}
470 %configure \
471         --disable-silent-rules \
472         --with-usbids-dir=/lib/hwdata
473 %{__make}
474 cd ../../..
475 %endif
476
477 # page-types, slabinfo
478 %{__make} -C tools/vm page-types slabinfo \
479         CC="%{__cc}" \
480         CFLAGS="%{rpmcflags} -Wall -Wextra -I../lib"
481
482 # gen_init_cpio
483 %{__make} -C usr gen_init_cpio \
484         %{makeopts} \
485         CFLAGS="%{rpmcflags}"
486
487 %install
488 rm -rf $RPM_BUILD_ROOT
489
490 cd linux-%{basever}
491
492 %if %{with cpupower}
493 %{__make} -C tools/power/cpupower install \
494         DESTDIR=$RPM_BUILD_ROOT \
495         libdir=%{_libdir} \
496         mandir=%{_mandir} \
497         CPUFREQ_BENCH=false
498
499 %find_lang cpupower
500 mv cpupower.lang ..
501
502 install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{systemdunitdir}}
503 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/cpupower.service
504 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/cpupower
505
506 %ifarch %{ix86} x32
507 install -p tools/power/cpupower/debug/i386/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
508 %endif
509 %ifarch %{x8664} x32
510 install -p tools/power/cpupower/debug/x86_64/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
511 %endif
512 %endif
513
514 %if %{with perf}
515 %{__make} -C tools/perf -j1 install install-man \
516 %ifarch %{x8664}
517         IS_X86_64=1 \
518         %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
519 %endif
520         %{!?with_gtk:NO_GTK2=1} \
521         %{!?with_libunwind:NO_LIBUNWIND=1} \
522         CC="%{__cc}" \
523         CFLAGS_OPTIMIZE="%{rpmcflags}" \
524         WERROR=0 \
525         %{?with_verbose:V=1} \
526         prefix=%{_prefix} \
527         perfexecdir=%{_datadir}/perf-core \
528         template_dir=%{_datadir}/perf-core/templates \
529         lib=%{_lib} \
530         DESTDIR=$RPM_BUILD_ROOT
531
532 %py_comp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
533 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
534
535 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/perf-core/tests
536 %endif
537
538 %if %{with usbip}
539 %{__make} -C tools/usb/usbip install \
540         DESTDIR=$RPM_BUILD_ROOT
541
542 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libusbip.la
543 %endif
544
545 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man8}
546
547 install -p tools/laptop/dslm/dslm $RPM_BUILD_ROOT%{_sbindir}
548
549 install -p tools/gpio/lsgpio $RPM_BUILD_ROOT%{_bindir}
550
551 %ifarch %{ix86} %{x8664} x32
552 install -p tools/hv/hv_{fcopy,kvp,vss}_daemon $RPM_BUILD_ROOT%{_sbindir}
553 # TODO: PLD-specific hv_get_dhcp_info,hv_get_dns_info,hv_set_ifconfig
554 %{__sed} -e '1s,/usr/bin/env python,%{__python},' tools/hv/lsvmbus >$RPM_BUILD_ROOT%{_bindir}/lsvmbus
555 chmod 755 $RPM_BUILD_ROOT%{_bindir}/lsvmbus
556 %endif
557
558 install -p tools/iio/{iio_event_monitor,iio_generic_buffer,lsiio} $RPM_BUILD_ROOT%{_bindir}
559
560 install -p tools/laptop/freefall/freefall $RPM_BUILD_ROOT%{_sbindir}
561
562 %ifarch %{ix86}
563 install -p tools/lguest/lguest $RPM_BUILD_ROOT%{_bindir}
564 %endif
565
566 install -p tools/net/{bpf_asm,bpf_dbg,bpf_jit_disasm} $RPM_BUILD_ROOT%{_bindir}
567
568 install -p tools/thermal/tmon/tmon $RPM_BUILD_ROOT%{_bindir}
569 cp -p tools/thermal/tmon/tmon.8 $RPM_BUILD_ROOT%{_mandir}/man8
570
571 install -p tools/vm/slabinfo $RPM_BUILD_ROOT%{_bindir}
572 install -p tools/vm/page-types $RPM_BUILD_ROOT%{_sbindir}
573
574 %ifarch %{ix86} %{x8664} x32
575 install -d $RPM_BUILD_ROOT%{_mandir}/man8
576 %{__make} -C tools/power/x86/x86_energy_perf_policy install \
577         DESTDIR=$RPM_BUILD_ROOT
578
579 %{__make} -C tools/power/x86/turbostat install \
580         DESTDIR=$RPM_BUILD_ROOT
581 %endif
582
583 # gen_init_cpio
584 install -p usr/gen_init_cpio $RPM_BUILD_ROOT%{_bindir}/gen_init_cpio
585
586 %clean
587 rm -rf $RPM_BUILD_ROOT
588
589 %post   cpupower-libs -p /sbin/ldconfig
590 %postun cpupower-libs -p /sbin/ldconfig
591
592 %post cpupower
593 %systemd_post cpupower.service
594
595 %preun cpupower
596 %systemd_preun cpupower.service
597
598 %postun cpupower
599 %systemd_reload
600
601 %post   -n usbip-libs -p /sbin/ldconfig
602 %postun -n usbip-libs -p /sbin/ldconfig
603
604 %files
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_bindir}/bpf_asm
607 %attr(755,root,root) %{_bindir}/bpf_dbg
608 %attr(755,root,root) %{_bindir}/bpf_jit_disasm
609 %attr(755,root,root) %{_bindir}/gen_init_cpio
610 %attr(755,root,root) %{_bindir}/iio_event_monitor
611 %attr(755,root,root) %{_bindir}/iio_generic_buffer
612 %attr(755,root,root) %{_bindir}/lsgpio
613 %attr(755,root,root) %{_bindir}/lsiio
614 %attr(755,root,root) %{_bindir}/slabinfo
615 %attr(755,root,root) %{_bindir}/tmon
616 %attr(755,root,root) %{_sbindir}/dslm
617 %attr(755,root,root) %{_sbindir}/freefall
618 %attr(755,root,root) %{_sbindir}/page-types
619 %{_mandir}/man8/tmon.8*
620 %ifarch %{ix86}
621 %doc linux-%{basever}/tools/lguest/lguest.txt
622 %attr(755,root,root) %{_bindir}/lguest
623 %endif
624 %ifarch %{ix86} %{x8664} x32
625 %attr(755,root,root) %{_bindir}/centrino-decode
626 %attr(755,root,root) %{_bindir}/powernow-k8-decode
627 %endif
628 %ifarch %{ix86} %{x8664} x32
629 %attr(755,root,root) %{_bindir}/turbostat
630 %attr(755,root,root) %{_bindir}/x86_energy_perf_policy
631 %{_mandir}/man8/turbostat.8*
632 %{_mandir}/man8/x86_energy_perf_policy.8*
633 %endif
634
635 %files cpupower -f cpupower.lang
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_bindir}/cpupower
638 %{_mandir}/man1/cpupower*.1*
639 %{systemdunitdir}/cpupower.service
640 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cpupower
641
642 %files cpupower-libs
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_libdir}/libcpupower.so.*.*.*
645 %attr(755,root,root) %ghost %{_libdir}/libcpupower.so.0
646
647 %files cpupower-libs-devel
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/libcpupower.so
650 %{_includedir}/cpufreq.h
651 %{_includedir}/cpuidle.h
652
653 %ifarch %{ix86} %{x8664} x32
654 %files hv
655 %defattr(644,root,root,755)
656 # TODO: PLDify these scripts and move to bindir
657 %doc linux-%{basever}/tools/hv/hv_{get_dhcp_info,get_dns_info,set_ifconfig}.sh
658 %attr(755,root,root) %{_bindir}/lsvmbus
659 %attr(755,root,root) %{_sbindir}/hv_fcopy_daemon
660 %attr(755,root,root) %{_sbindir}/hv_kvp_daemon
661 %attr(755,root,root) %{_sbindir}/hv_vss_daemon
662 %endif
663
664 %if %{with perf}
665 %files perf
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_bindir}/perf
668 %attr(755,root,root) %{_bindir}/trace
669 %{_mandir}/man1/perf*.1*
670 %dir %{_datadir}/perf-core
671 %attr(755,root,root) %{_datadir}/perf-core/perf-archive
672 %attr(755,root,root) %{_datadir}/perf-core/perf-with-kcore
673
674 %dir %{_datadir}/perf-core/scripts
675
676 %dir %{_datadir}/perf-core/scripts/perl
677 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util
678 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib
679 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf
680 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace
681 %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace/*.pm
682 %dir %{_datadir}/perf-core/scripts/perl/bin
683 %attr(755,root,root) %{_datadir}/perf-core/scripts/perl/bin/*
684 %{_datadir}/perf-core/scripts/perl/*.pl
685
686 %dir %{_datadir}/perf-core/scripts/python
687 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util
688 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib
689 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf
690 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace
691 %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/*.py*
692 %dir %{_datadir}/perf-core/scripts/python/bin
693 %attr(755,root,root) %{_datadir}/perf-core/scripts/python/bin/*
694 %{_datadir}/perf-core/scripts/python/*.py*
695
696 %dir %{_libdir}/traceevent
697 %dir %{_libdir}/traceevent/plugins
698 %attr(755,root,root) %{_libdir}/traceevent/plugins/plugin_*.so
699
700 %if %{with multilib}
701 %files perf-vdso32
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_bindir}/perf-read-vdso32
704
705 %files perf-vdsox32
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_bindir}/perf-read-vdsox32
708 %endif
709
710 %if %{with gtk}
711 %files perf-gtk
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_libdir}/libperf-gtk.so
714 %endif
715
716 %files -n bash-completion-perf
717 %defattr(644,root,root,755)
718 /etc/bash_completion.d/perf
719 %endif
720
721 %if %{with usbip}
722 %files -n usbip
723 %defattr(644,root,root,755)
724 %doc linux-%{basever}/tools/usb/usbip/{AUTHORS,README}
725 %attr(755,root,root) %{_sbindir}/usbip
726 %attr(755,root,root) %{_sbindir}/usbipd
727 %{_mandir}/man8/usbip.8*
728 %{_mandir}/man8/usbipd.8*
729
730 %files -n usbip-libs
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_libdir}/libusbip.so.*.*.*
733 %attr(755,root,root) %ghost %{_libdir}/libusbip.so.0
734
735 %files -n usbip-devel
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_libdir}/libusbip.so
738 %{_includedir}/usbip
739
740 %files -n usbip-static
741 %defattr(644,root,root,755)
742 %{_libdir}/libusbip.a
743 %endif
This page took 0.154378 seconds and 4 git commands to generate.