]> git.pld-linux.org Git - packages/kernel-tools.git/blob - kernel-tools.spec
a4ffb4c9d94531ca593ec6d82555556e5cfc2230
[packages/kernel-tools.git] / kernel-tools.spec
1 # TODO:
2 # - redefine: PACKAGE_BUGREPORT=cpufreq@vger.kernel.org
3 # - add -n python-perf?
4 # - without perf bcond does not work (it still builds it)
5 # - add bcond to disable building docs (perf docs)
6 # - install of perf compiles things over again
7
8 # Conditional build:
9 %bcond_without  verbose         # verbose build (V=1)
10 %bcond_without  perf            # perf tools
11 %bcond_without  gtk             # gtk perf version
12
13 %define         basever         3.10
14 %define         postver         .33
15 Summary:        Assortment of tools for the Linux kernel
16 Summary(pl.UTF-8):      Zestaw narzędzi dla jądra Linuksa
17 Name:           kernel-tools
18 Version:        %{basever}%{postver}
19 Release:        1
20 License:        GPL v2
21 Group:          Applications/System
22 Source0:        https://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
23 # Source0-md5:  4f25cd5bec5f8d5a7d935b3f2ccb8481
24 %if "%{postver}" != ".0"
25 Patch0:         https://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
26 # Patch0-md5:   2a453acf41c3f28122a7cabd3d4acbf5
27 %endif
28 Source1:        cpupower.service
29 Source2:        cpupower.config
30 Source3:        perf.sh
31 URL:            http://www.kernel.org/
32 BuildRequires:  gettext-tools
33 BuildRequires:  pciutils-devel
34 BuildRequires:  rpmbuild(macros) >= 1.647
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 %if %{with perf}
38 BuildRequires:  asciidoc
39 BuildRequires:  audit-libs-devel
40 BuildRequires:  binutils-devel
41 BuildRequires:  bison
42 BuildRequires:  docbook-dtd45-xml
43 BuildRequires:  docbook-style-xsl
44 BuildRequires:  elfutils-devel
45 BuildRequires:  flex
46 BuildRequires:  libunwind-devel >= 0.99
47 BuildRequires:  perl-devel >= 5.1
48 BuildRequires:  python-devel
49 BuildRequires:  rpm-pythonprov
50 BuildRequires:  slang-devel
51 BuildRequires:  xmlto
52 %if %{with gtk}
53 BuildRequires:  gtk+2-devel >= 2.0
54 BuildRequires:  pkgconfig
55 %endif
56 %endif
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         makeopts        CC="%{__cc}" %{?with_verbose:V=1}
60
61 %description
62 This package contains the software from tools/ subdirectory from Linux
63 kernel source and the supporting documentation.
64
65 %description -l pl.UTF-8
66 Ten pakiet zawiera oprogramowanie z podkatalogu tools/ ze źródeł jądra
67 Linuksa oraz związaną z nim dokumentację.
68
69 %package cpupower
70 Summary:        cpupower - Shows and sets processor power related values
71 Summary(pl.UTF-8):      cpupower - wyświetlanie i ustawianie wartości związanych z zużyciem energii przez procesor
72 Group:          Applications/System
73 Requires(post,preun,postun):    systemd-units >= 38
74 Requires:       %{name}-cpupower-libs = %{version}-%{release}
75 Requires:       systemd-units >= 0.38
76 Provides:       cpufreq-utils = 1:009-0.6.p1
77 Provides:       cpufrequtils = 1:009-0.6.p1
78 Provides:       cpupowerutils = 1:009-0.6.p1
79 Obsoletes:      cpufreq-utils < 1:009-0.6.p1
80 Obsoletes:      cpufrequtils < 1:009-0.6.p1
81 Obsoletes:      cpupowerutils < 1:009-0.6.p1
82 Obsoletes:      cpuspeed < 1:1.5-16
83
84 %description cpupower
85 cpupower is a collection of tools to examine and tune power saving
86 related features of your processor.
87
88 %description cpupower -l pl.UTF-8
89 cpupower to zbiór narzędzi do sprawdzania i ustawiania opcji procesora
90 związanych z oszczędzaniem energii.
91
92 %package cpupower-libs
93 Summary:        cpupower library
94 Summary(pl.UTF-8):      Biblioteka cpupower
95 Group:          Libraries
96
97 %description cpupower-libs
98 cpupower library.
99
100 %description cpupower-libs -l pl.UTF-8
101 Biblioteka cpupower.
102
103 %package cpupower-libs-devel
104 Summary:        Development files for the cpupower library
105 Summary(pl.UTF-8):      Pliki programistyczne biblioteki cpupower
106 Group:          Development/Libraries
107 Requires:       %{name} = %{version}-%{release}
108 Requires:       %{name}-cpupower-libs = %{version}-%{release}
109 Provides:       cpufrequtils-devel = 1:009-0.6.p1
110 Provides:       cpupowerutils-devel = 1:009-0.6.p1
111 Obsoletes:      cpufrequtils-devel < 1:009-0.6.p1
112 Obsoletes:      cpupowerutils-devel < 1:009-0.6.p1
113
114 %description cpupower-libs-devel
115 Development files for the cpupower library.
116
117 %description cpupower-libs-devel -l pl.UTF-8
118 Pliki programistyczne biblioteki cpupower.
119
120 %package perf-core
121 Summary:        perf profiler tool (core package)
122 Summary(pl.UTF-8):      Narzędzie profilujące perf (podstawowe narzędzia)
123 Group:          Applications/System
124 Suggests:       binutils
125
126 %description perf-core
127 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
128 away CPU hardware differences in Linux performance measurements and
129 presents a simple commandline interface. Perf is based on the
130 perf_events interface exported by recent versions of the Linux kernel.
131
132 This package contains core files and scripts.
133
134 %description perf-core -l pl.UTF-8
135 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
136 odseparowujące od różnic sprzętowych między pomiarami wydajności w
137 zależności od procesora oraz udostępniające prosty interfejs linii
138 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
139 przez nowe wersje jądra Linuksa.
140
141 Ten pakiet zawiera podstawowe pliki i skrypty.
142
143 %package perf-gtk
144 Summary:        perf profiler tool (GTK+ GUI)
145 Summary(pl.UTF-8):      Narzędzie profilujące perf (interfejs graficzny GTK+)
146 Group:          X11/Applications
147 Requires:       %{name}-perf-core = %{version}-%{release}
148 Provides:       %{name}-perf = %{version}-%{release}
149
150 %description perf-gtk
151 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
152 away CPU hardware differences in Linux performance measurements and
153 presents a simple commandline interface. Perf is based on the
154 perf_events interface exported by recent versions of the Linux kernel.
155
156 This package contains GTK+ based GUI.
157
158 %description perf-gtk -l pl.UTF-8
159 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
160 odseparowujące od różnic sprzętowych między pomiarami wydajności w
161 zależności od procesora oraz udostępniające prosty interfejs linii
162 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
163 przez nowe wersje jądra Linuksa.
164
165 Ten pakiet zawiera graficzny interfejs oparty na GTK+.
166
167 %package perf-slang
168 Summary:        perf profiler tool (Slang TUI)
169 Summary(pl.UTF-8):      Narzędzie profilujące perf (interfejs tekstowy Slang)
170 Group:          X11/Applications
171 Requires:       %{name}-perf-core = %{version}-%{release}
172 Provides:       %{name}-perf = %{version}-%{release}
173
174 %description perf-slang
175 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
176 away CPU hardware differences in Linux performance measurements and
177 presents a simple commandline interface. Perf is based on the
178 perf_events interface exported by recent versions of the Linux kernel.
179
180 This package contains Slang based TUI.
181
182 %description perf-slang -l pl.UTF-8
183 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
184 odseparowujące od różnic sprzętowych między pomiarami wydajności w
185 zależności od procesora oraz udostępniające prosty interfejs linii
186 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
187 przez nowe wersje jądra Linuksa.
188
189 Ten pakiet zawiera tekstowy interfejs oparty na bibliotece Slang.
190
191 %package -n bash-completion-perf
192 Summary:        Bash completion for perf command
193 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla polecenia perf
194 Group:          Applications/Shells
195 Requires:       %{name}-perf
196 Requires:       bash-completion
197 %if "%{_rpmversion}" >= "5"
198 BuildArch:      noarch
199 %endif
200
201 %description -n bash-completion-perf
202 Bash completion for perf command.
203
204 %description -n bash-completion-perf -l pl.UTF-8
205 Bashowe uzupełnianie parametrów dla polecenia perf.
206
207 %prep
208 %setup -qc
209 cd linux-%{basever}
210
211 %if "%{postver}" != ".0"
212 %patch0 -p1
213 %endif
214
215 %build
216 cd linux-%{basever}
217
218 # Simple Disk Sleep Monitor
219 %{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags} Documentation/laptops/dslm.c -o dslm
220
221 # cpupower
222 %{__make} -C tools/power/cpupower \
223         %{makeopts} \
224         CPUFREQ_BENCH=false \
225         OPTIMIZATION="%{rpmcflags}" \
226         STRIPCMD=true
227
228 %ifarch %{ix86}
229 %{__make} -C tools/power/cpupower/debug/i386 centrino-decode powernow-k8-decode \
230         CC="%{__cc}" \
231         CFLAGS="%{rpmcflags}"
232 %endif
233
234 %ifarch %{x8664}
235 %{__make} -C tools/power/cpupower/debug/x86_64 centrino-decode powernow-k8-decode \
236         CC="%{__cc}" \
237         CFLAGS="%{rpmcflags}"
238 %endif
239
240 %ifarch %{ix86} %{x8664}
241 %{__make} -C tools/power/x86/x86_energy_perf_policy \
242         CC="%{__cc}" \
243         CFLAGS="%{rpmcflags}"
244 CFLAGS="%{rpmcflags}" \
245 %{__make} -C tools/power/x86/turbostat \
246         CC="%{__cc}"
247 %endif
248
249 # page-types, slabinfo
250 %{__make} -C tools/vm page-types slabinfo \
251         CC="%{__cc}" \
252         CFLAGS="%{rpmcflags} -Wall -Wextra -I../lib"
253
254 %if %{with perf}
255 # perf slang version
256 PWD=${PWD:-$(pwd)}
257 install -d $PWD/perf-{slang,gtk}
258 %{__make} -C tools/perf all man \
259         O=$PWD/perf-slang \
260         NO_GTK2=1 \
261         %{makeopts} \
262         CFLAGS_OPTIMIZE="%{rpmcflags}" \
263         WERROR=0 \
264         prefix=%{_prefix} \
265         perfexecdir=%{_datadir}/perf-core \
266         template_dir=%{_datadir}/perf-core/templates
267
268 %if %{with gtk}
269 # perf gtk version
270 %{__make} -C tools/perf all man \
271         O=$PWD/perf-gtk \
272         %{makeopts} \
273         CFLAGS_OPTIMIZE="%{rpmcflags}" \
274         WERROR=0 \
275         prefix=%{_prefix} \
276         perfexecdir=%{_datadir}/perf-core \
277         template_dir=%{_datadir}/perf-core/templates
278 %endif
279 %endif
280
281 # gen_init_cpio
282 %{__make} -C usr gen_init_cpio \
283         %{makeopts} \
284         CFLAGS="%{rpmcflags}"
285
286 %install
287 rm -rf $RPM_BUILD_ROOT
288
289 cd linux-%{basever}
290 install -d $RPM_BUILD_ROOT%{_sbindir}
291
292 %{__make} -C tools/power/cpupower install \
293         DESTDIR=$RPM_BUILD_ROOT \
294         libdir=%{_libdir} \
295         mandir=%{_mandir} \
296         CPUFREQ_BENCH=false
297
298 %find_lang cpupower
299 mv cpupower.lang ..
300
301 install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{systemdunitdir}}
302 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/cpupower.service
303 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/cpupower
304
305 %ifarch %{ix86}
306 install -p tools/power/cpupower/debug/i386/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
307 %endif
308 %ifarch %{x8664}
309 install -p tools/power/cpupower/debug/x86_64/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
310 %endif
311
312 install -p tools/vm/slabinfo $RPM_BUILD_ROOT%{_bindir}
313 install -p tools/vm/page-types $RPM_BUILD_ROOT%{_sbindir}
314 install -p dslm $RPM_BUILD_ROOT%{_sbindir}
315
316 %ifarch %{ix86} %{x8664}
317 install -d $RPM_BUILD_ROOT%{_mandir}/man8
318 # broken makefile, install manually
319 %if 0
320 %{__make} install \
321         -C tools/power/x86/x86_energy_perf_policy \
322         DESTDIR=$RPM_BUILD_ROOT
323 %else
324 cd tools/power/x86/x86_energy_perf_policy
325 install -p x86_energy_perf_policy $RPM_BUILD_ROOT%{_bindir}
326 cp -p x86_energy_perf_policy.8 $RPM_BUILD_ROOT%{_mandir}/man8
327 cd -
328 %endif
329
330 # broken makefile, install manually
331 %if 0
332 %{__make} install \
333         -C tools/power/x86/turbostat \
334         DESTDIR=$RPM_BUILD_ROOT
335 %else
336 cd tools/power/x86/turbostat
337 cp -p turbostat.8 $RPM_BUILD_ROOT%{_mandir}/man8
338 cd -
339 install -p turbostat $RPM_BUILD_ROOT%{_bindir}/turbostat
340 %endif
341 %endif
342
343 %if %{with perf}
344 # perf slang
345 PWD=${PWD:-$(pwd)}
346 # perf slang version
347 %{__make} -j1 install install-man \
348         -C tools/perf \
349         O=$PWD/perf-slang \
350         NO_GTK2=1 \
351         CC="%{__cc}" \
352         CFLAGS_OPTIMIZE="%{rpmcflags}" \
353         WERROR=0 \
354         %{?with_verbose:V=1} \
355         prefix=%{_prefix} \
356         perfexecdir=%{_datadir}/perf-core \
357         template_dir=%{_datadir}/perf-core/templates \
358         DESTDIR=$RPM_BUILD_ROOT
359 %{__mv} $RPM_BUILD_ROOT%{_bindir}/perf{,_slang}
360
361 %if %{with gtk}
362 # perf gtk
363 %{__make} -j1 install install-man \
364         -C tools/perf \
365         O=$PWD/perf-gtk \
366         CC="%{__cc}" \
367         CFLAGS_OPTIMIZE="%{rpmcflags}" \
368         WERROR=0 \
369         %{?with_verbose:V=1} \
370         prefix=%{_prefix} \
371         perfexecdir=%{_datadir}/perf-core \
372         template_dir=%{_datadir}/perf-core/templates \
373         DESTDIR=$RPM_BUILD_ROOT
374 %{__mv} $RPM_BUILD_ROOT%{_bindir}/perf{,_gtk}
375 %endif
376
377 %py_comp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
378 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
379
380 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/perf-core/tests
381
382 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/perf
383 %endif
384
385 # gen_init_cpio
386 install -p usr/gen_init_cpio $RPM_BUILD_ROOT%{_bindir}/gen_init_cpio
387
388 %clean
389 rm -rf $RPM_BUILD_ROOT
390
391 %post   cpupower-libs -p /sbin/ldconfig
392 %postun cpupower-libs -p /sbin/ldconfig
393
394 %post cpupower
395 %systemd_post cpupower.service
396
397 %preun cpupower
398 %systemd_preun cpupower.service
399
400 %postun cpupower
401 %systemd_reload
402
403 %files
404 %defattr(644,root,root,755)
405 %attr(755,root,root) %{_bindir}/gen_init_cpio
406 %attr(755,root,root) %{_bindir}/slabinfo
407 %attr(755,root,root) %{_sbindir}/dslm
408 %attr(755,root,root) %{_sbindir}/page-types
409 %ifarch %{ix86} %{x8664}
410 %attr(755,root,root) %{_bindir}/centrino-decode
411 %attr(755,root,root) %{_bindir}/powernow-k8-decode
412 %endif
413 %ifarch %{ix86} %{x8664}
414 %attr(755,root,root) %{_bindir}/turbostat
415 %attr(755,root,root) %{_bindir}/x86_energy_perf_policy
416 %{_mandir}/man8/turbostat.8*
417 %{_mandir}/man8/x86_energy_perf_policy.8*
418 %endif
419
420 %files cpupower -f cpupower.lang
421 %defattr(644,root,root,755)
422 %attr(755,root,root) %{_bindir}/cpupower
423 %{_mandir}/man1/cpupower*.1*
424 %{systemdunitdir}/cpupower.service
425 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cpupower
426
427 %files cpupower-libs
428 %defattr(644,root,root,755)
429 %attr(755,root,root) %{_libdir}/libcpupower.so.*.*.*
430 %attr(755,root,root) %ghost %{_libdir}/libcpupower.so.0
431
432 %files cpupower-libs-devel
433 %defattr(644,root,root,755)
434 %attr(755,root,root) %{_libdir}/libcpupower.so
435 %{_includedir}/cpufreq.h
436
437 %if %{with perf}
438 %files perf-core
439 %defattr(644,root,root,755)
440 %attr(755,root,root) %{_bindir}/perf
441 %{_mandir}/man1/perf*.1*
442 %dir %{_datadir}/perf-core
443 %attr(755,root,root) %{_datadir}/perf-core/perf-archive
444
445 %dir %{_datadir}/perf-core/scripts
446
447 %dir %{_datadir}/perf-core/scripts/perl
448 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util
449 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib
450 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf
451 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace
452 %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace/*.pm
453 %dir %{_datadir}/perf-core/scripts/perl/bin
454 %attr(755,root,root) %{_datadir}/perf-core/scripts/perl/bin/*
455 %{_datadir}/perf-core/scripts/perl/*.pl
456
457 %dir %{_datadir}/perf-core/scripts/python
458 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util
459 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib
460 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf
461 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace
462 %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/*.py*
463 %dir %{_datadir}/perf-core/scripts/python/bin
464 %attr(755,root,root) %{_datadir}/perf-core/scripts/python/bin/*
465 %{_datadir}/perf-core/scripts/python/*.py*
466
467 %if %{with gtk}
468 %files perf-gtk
469 %defattr(644,root,root,755)
470 %attr(755,root,root) %{_bindir}/perf_gtk
471 %endif
472
473 %files perf-slang
474 %defattr(644,root,root,755)
475 %attr(755,root,root) %{_bindir}/perf_slang
476
477 %files -n bash-completion-perf
478 %defattr(644,root,root,755)
479 /etc/bash_completion.d/perf
480 %endif
This page took 0.097492 seconds and 2 git commands to generate.