]> git.pld-linux.org Git - packages/kernel-tools.git/blob - kernel-tools.spec
- up to 4.13.11
[packages/kernel-tools.git] / kernel-tools.spec
1 # TODO:
2 # - redefine: PACKAGE_BUGREPORT=cpufreq@vger.kernel.org
3 # - add -n python-perf?
4 # - add bcond to disable building docs (perf docs)
5 # - install of perf links perf binary again
6
7 # Conditional build:
8 %bcond_without  verbose         # verbose build (V=1)
9 %bcond_without  cpupower        # cpupower tools
10 %bcond_without  perf            # perf tools
11 %bcond_without  gtk             # GTK+ 2.x perf support
12 %bcond_without  libunwind       # libunwind perf support
13 %bcond_without  multilib        # multilib perf support
14 %bcond_without  usbip           # usbip utils
15
16 %ifarch x32
17 %undefine       with_libunwind
18 %endif
19 %ifnarch %{x8664}
20 %undefine       with_multilib
21 %endif
22
23 %define         basever         4.13
24 %define         postver         .11
25 Summary:        Assortment of tools for the Linux kernel
26 Summary(pl.UTF-8):      Zestaw narzędzi dla jądra Linuksa
27 Name:           kernel-tools
28 Version:        %{basever}%{postver}
29 Release:        1
30 License:        GPL v2
31 Group:          Applications/System
32 Source0:        https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
33 # Source0-md5:  ab1a2abc6f37b752dd2595338bec4e78
34 Source1:        cpupower.service
35 Source2:        cpupower.config
36 %if "%{postver}" != ".0"
37 Patch0:         https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
38 # Patch0-md5:   f03030893fae6a5620ba1056a9e3b931
39 %endif
40 Patch1:         x32.patch
41 Patch2:         %{name}-lguest-update.patch
42 Patch3:         %{name}-perf-update.patch
43 Patch4:         binutils-2.29.patch
44 URL:            http://www.kernel.org/
45 BuildRequires:  bison
46 BuildRequires:  flex
47 BuildRequires:  gettext-tools
48 BuildRequires:  linux-libc-headers >= 7:4.12
49 BuildRequires:  ncurses-devel
50 BuildRequires:  pciutils-devel
51 BuildRequires:  pkgconfig
52 BuildRequires:  rpmbuild(macros) >= 1.647
53 BuildRequires:  tar >= 1:1.22
54 BuildRequires:  xz
55 %if %{with perf}
56 BuildRequires:  asciidoc
57 BuildRequires:  audit-libs-devel
58 BuildRequires:  binutils-devel >= 4:2.29
59 BuildRequires:  docbook-dtd45-xml
60 BuildRequires:  docbook-style-xsl
61 BuildRequires:  elfutils-devel
62 %if %{with multilib}
63 BuildRequires:  gcc-multilib-32
64 BuildRequires:  gcc-multilib-x32
65 %endif
66 %{?with_libunwind:BuildRequires:        libunwind-devel >= 0.99}
67 BuildRequires:  numactl-devel
68 BuildRequires:  perl-devel >= 5.1
69 BuildRequires:  python-devel
70 BuildRequires:  rpm-pythonprov
71 BuildRequires:  slang-devel
72 BuildRequires:  xmlto
73 %if %{with gtk}
74 BuildRequires:  gtk+2-devel >= 2.0
75 %endif
76 %endif
77 %if %{with usbip}
78 BuildRequires:  autoconf >= 2.59
79 BuildRequires:  automake >= 1:1.9
80 BuildRequires:  gcc >= 6:4.0
81 BuildRequires:  libtool >= 2:2
82 BuildRequires:  libwrap-devel
83 BuildRequires:  udev-devel
84 %endif
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 # otherwise /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
88 %define         _enable_debug_packages  0
89
90 %define         makeopts        CC="%{__cc}" %{?with_verbose:V=1}
91
92 %description
93 This package contains the software from tools/ subdirectory from Linux
94 kernel source and the supporting documentation.
95
96 %description -l pl.UTF-8
97 Ten pakiet zawiera oprogramowanie z podkatalogu tools/ ze źródeł jądra
98 Linuksa oraz związaną z nim dokumentację.
99
100 %package cpupower
101 Summary:        cpupower - Shows and sets processor power related values
102 Summary(pl.UTF-8):      cpupower - wyświetlanie i ustawianie wartości związanych z zużyciem energii przez procesor
103 Group:          Applications/System
104 Requires(post,preun,postun):    systemd-units >= 38
105 Requires:       %{name}-cpupower-libs = %{version}-%{release}
106 Requires:       systemd-units >= 0.38
107 Provides:       cpupowerutils = 1:009-0.6.p1
108 Obsoletes:      cpupowerutils < 1:009-0.6.p1
109 Obsoletes:      cpuspeed < 1:1.5-16
110
111 %description cpupower
112 cpupower is a collection of tools to examine and tune power saving
113 related features of your processor.
114
115 %description cpupower -l pl.UTF-8
116 cpupower to zbiór narzędzi do sprawdzania i ustawiania opcji procesora
117 związanych z oszczędzaniem energii.
118
119 %package cpupower-libs
120 Summary:        cpupower library
121 Summary(pl.UTF-8):      Biblioteka cpupower
122 Group:          Libraries
123
124 %description cpupower-libs
125 cpupower library.
126
127 %description cpupower-libs -l pl.UTF-8
128 Biblioteka cpupower.
129
130 %package cpupower-libs-devel
131 Summary:        Development files for the cpupower library
132 Summary(pl.UTF-8):      Pliki programistyczne biblioteki cpupower
133 Group:          Development/Libraries
134 Requires:       %{name}-cpupower-libs = %{version}-%{release}
135 Provides:       cpupowerutils-devel = 1:009-0.6.p1
136 Obsoletes:      cpupowerutils-devel < 1:009-0.6.p1
137 Conflicts:      cpufrequtils-devel
138
139 %description cpupower-libs-devel
140 Development files for the cpupower library.
141
142 %description cpupower-libs-devel -l pl.UTF-8
143 Pliki programistyczne biblioteki cpupower.
144
145 %package hv
146 Summary:        Hyper-V virtualization tools
147 Summary(pl.UTF-8):      Narzędzia do wirtualizacji Hyper-V
148 Group:          Applications/System
149
150 %description hv
151 Hyper-V virtualization tools.
152
153 %description hv -l pl.UTF-8
154 Narzędzia do wirtualizacji Hyper-V.
155
156 %package perf
157 Summary:        perf profiler tool
158 Summary(pl.UTF-8):      Narzędzie profilujące perf
159 Group:          Applications/System
160 Suggests:       binutils
161 Obsoletes:      perf-core
162 Obsoletes:      perf-slang
163
164 %description perf
165 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
166 away CPU hardware differences in Linux performance measurements and
167 presents a simple commandline interface. Perf is based on the
168 perf_events interface exported by recent versions of the Linux kernel.
169
170 This package contains core files, scripts and text interface (TUI).
171
172 %description perf -l pl.UTF-8
173 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
174 odseparowujące od różnic sprzętowych między pomiarami wydajności w
175 zależności od procesora oraz udostępniające prosty interfejs linii
176 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
177 przez nowe wersje jądra Linuksa.
178
179 Ten pakiet zawiera podstawowe pliki, skrypty oraz interfejs tekstowy
180 (TUI).
181
182 %package perf-vdso32
183 Summary:        perf profiler tool - VDSO 32-bit ABI reader
184 Summary(pl.UTF-8):      Narzędzie profilujące perf - odczyt VDSO dla ABI 32-bitowego
185 Group:          Applications/System
186 Requires:       %{name}-perf = %{version}-%{release}
187
188 %description perf-vdso32
189 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
190 away CPU hardware differences in Linux performance measurements and
191 presents a simple commandline interface. Perf is based on the
192 perf_events interface exported by recent versions of the Linux kernel.
193
194 This package contains perf-read-vdso32 tool for reading the 32-bit
195 compatibility VDSO in 64-bit mode.
196
197 %description perf-vdso32 -l pl.UTF-8
198 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
199 odseparowujące od różnic sprzętowych między pomiarami wydajności w
200 zależności od procesora oraz udostępniające prosty interfejs linii
201 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
202 przez nowe wersje jądra Linuksa.
203
204 Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
205 binariów 32-bitowych w trybie 64-bitowym.
206
207 %package perf-vdsox32
208 Summary:        perf profiler tool - VDSO x32 ABI reader
209 Summary(pl.UTF-8):      Narzędzie profilujące perf - odczyt VDSO dla ABI x32
210 Group:          Applications/System
211 Requires:       %{name}-perf = %{version}-%{release}
212
213 %description perf-vdsox32
214 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
215 away CPU hardware differences in Linux performance measurements and
216 presents a simple commandline interface. Perf is based on the
217 perf_events interface exported by recent versions of the Linux kernel.
218
219 This package contains perf-read-vdso32 tool for reading the x32 mode
220 32-bit compatibility VDSO in 64-bit mode.
221
222 %description perf-vdsox32 -l pl.UTF-8
223 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
224 odseparowujące od różnic sprzętowych między pomiarami wydajności w
225 zależności od procesora oraz udostępniające prosty interfejs linii
226 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
227 przez nowe wersje jądra Linuksa.
228
229 Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
230 binariów ABI x32 w trybie 64-bitowym.
231
232 %package perf-gtk
233 Summary:        perf profiler tool (GTK+ 2 GUI)
234 Summary(pl.UTF-8):      Narzędzie profilujące perf (interfejs graficzny GTK+ 2)
235 Group:          X11/Applications
236 Requires:       %{name}-perf = %{version}-%{release}
237
238 %description perf-gtk
239 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
240 away CPU hardware differences in Linux performance measurements and
241 presents a simple commandline interface. Perf is based on the
242 perf_events interface exported by recent versions of the Linux kernel.
243
244 This package contains GTK+ 2 based GUI.
245
246 %description perf-gtk -l pl.UTF-8
247 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
248 odseparowujące od różnic sprzętowych między pomiarami wydajności w
249 zależności od procesora oraz udostępniające prosty interfejs linii
250 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
251 przez nowe wersje jądra Linuksa.
252
253 Ten pakiet zawiera graficzny interfejs oparty na GTK+ 2.
254
255 %package -n bash-completion-perf
256 Summary:        Bash completion for perf command
257 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla polecenia perf
258 Group:          Applications/Shells
259 Requires:       %{name}-perf
260 Requires:       bash-completion
261 %if "%{_rpmversion}" >= "5"
262 BuildArch:      noarch
263 %endif
264
265 %description -n bash-completion-perf
266 Bash completion for perf command.
267
268 %description -n bash-completion-perf -l pl.UTF-8
269 Bashowe uzupełnianie parametrów dla polecenia perf.
270
271 %package -n usbip
272 Summary:        USB device sharing system over IP network
273 Summary(pl.UTF-8):      System współdzielenia urządzeń USB po sieci IP
274 Group:          Networking/Utilities
275 Requires:       usbip-libs = %{version}-%{release}
276 # /lib/hwdata/usb.ids (note: only uncompressed file supported)
277 Requires:       hwdata >= 0.243-2
278
279 %description -n usbip
280 The USB/IP Project aims to develop a general USB device sharing system
281 over IP network. To share USB devices between computers with their
282 full functionality, USB/IP encapsulates "USB requests" into IP packets
283 and transmits them between computers. Original USB device drivers and
284 applications can be also used for remote USB devices without any
285 modification of them. A computer can use remote USB devices as if they
286 were directly attached; for example, we can:
287  - USB storage devices: fdisk, mkfs, mount/umount, file operations,
288    play a DVD movie and record a DVD-R media.
289  - USB keyboards and USB mice: use with Linux console and X Window
290    System.
291  - USB webcams and USB speakers: view webcam, capture image data and
292    play some music.
293  - USB printers, USB scanners, USB serial converters and USB Ethernet
294    interfaces: ok, use fine.
295
296 %description -n usbip -l pl.UTF-8
297 Projekt USB/IP ma na celu stworzenie ogólnego systemu współdzielenia
298 urządzeń USB po sieci IP. W celu współdzielenia urządzeń USB między
299 komputerami z zachowaniem pełnej funkcjonalności, USB/IP obudowuje
300 żądania SUB w pakiety IP i przesyła je między komputerami. Oryginalne
301 sterowniki urządzeń USB oraz aplikacje mogą być używane bez żadnych
302 modyfikacji. Komputer może wykorzystywać zdaln urządzenia USB tak,
303 jakby były podłączone bezpośrednio. Przykładowe możliwości:
304  - urządzenia USB do przechowywania danych: można używać programów
305    fdisk, mkfs, mount/umount, operacji na plikach, odtwarzać filmy
306    DVD oraz nagrywać nośniki DVD-R
307  - klawiatury i myszy USB: można ich używać na linuksowej konsoli oraz
308    w systemie X Window
309  - kamery i głośniki USB: można oglądać obraz z kamery, robić zdjęcia
310    i odtwarzać muzykę
311  - drukarki, skanery, konwertery portów szeregowych oraz interfejsy
312    sieciowe USB: można ich normalnie używać
313
314 %package -n usbip-libs
315 Summary:        USB/IP library
316 Summary(pl.UTF-8):      Biblioteka USB/IP
317 Group:          Libraries
318
319 %description -n usbip-libs
320 USB over IP library.
321
322 %description -n usbip-libs -l pl.UTF-8
323 Biblioteka USB po IP.
324
325 %package -n usbip-devel
326 Summary:        Header files for usbip library
327 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki usbip
328 Group:          Development/Libraries
329 Requires:       usbip-libs = %{version}-%{release}
330
331 %description -n usbip-devel
332 This package contains the header files needed to develop programs
333 which make use of USB/IP.
334
335 %description -n usbip-devel -l pl.UTF-8
336 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
337 wykorzystujących USB/IP.
338
339 %package -n usbip-static
340 Summary:        Static usbip library
341 Summary(pl.UTF-8):      Statyczna biblioteka usbip
342 Group:          Development/Libraries
343 Requires:       usbip-devel = %{version}-%{release}
344
345 %description -n usbip-static
346 Static usbip library.
347
348 %description -n usbip-static -l pl.UTF-8
349 Statyczna biblioteka usbip.
350
351 %prep
352 %setup -qc
353 cd linux-%{basever}
354
355 %if "%{postver}" != ".0"
356 %patch0 -p1
357 %endif
358
359 %patch1 -p1
360 %patch2 -p1
361 %patch3 -p1
362 %patch4 -p1
363
364 %{__sed} -i -e '/^CFLAGS = /s/ -g / $(OPTFLAGS) /' tools/hv/Makefile
365 %{__sed} -i -e '/^CFLAGS+=/s/ -O1 / $(OPTFLAGS) /' tools/thermal/tmon/Makefile
366 %{__sed} -i -e 's#libexec/perf-core#%{_datadir}/perf-core#g' tools/perf/Makefile.config
367
368 %build
369 cd linux-%{basever}
370
371 # Simple Disk Sleep Monitor
372 %{__make} -C tools/laptop/dslm \
373         %{makeopts} \
374         EXTRA_CFLAGS="%{rpmcflags}"
375
376 # tools common (used eg. by tools/vm)
377 %{__make} -C tools/lib/api \
378         %{makeopts} \
379         EXTRA_CFLAGS="%{rpmcflags}"
380
381 # lsgpio
382 CFLAGS="%{rpmcflags}" \
383 %{__make} -C tools/gpio -j1 \
384         %{makeopts}
385
386 # HyperV is Windows based, x86 specific
387 %ifarch %{ix86} %{x8664} x32
388 %{__make} -C tools/hv \
389         CC="%{__cc}" \
390         OPTFLAGS="%{rpmcflags}"
391 %endif
392
393 CFLAGS="%{rpmcflags}" \
394 %{__make} -C tools/iio \
395         CC="%{__cc}"
396
397 %{__make} -C tools/laptop/freefall \
398         CC="%{__cc}" \
399         CFLAGS="%{rpmcflags}"
400
401 %ifarch %{ix86}
402 # drivers/lguest is x86-32 only
403 %{__make} -C tools/lguest \
404         CC="%{__cc}" \
405         CFLAGS="%{rpmcflags} -Wall -U_FORTIFY_SOURCE -Iinclude"
406 %endif
407
408 CFLAGS="%{rpmcflags}" \
409 %{__make} -C tools/net \
410         CC="%{__cc}"
411
412 # perf
413 %if %{with perf}
414 %{__make} -C tools/perf all man \
415 %ifarch %{x8664}
416         IS_X86_64=1 \
417         %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
418 %endif
419         %{!?with_gtk:NO_GTK2=1} \
420         %{!?with_libunwind:NO_LIBUNWIND=1} \
421         %{makeopts} \
422         CFLAGS_OPTIMIZE="%{rpmcflags}" \
423         WERROR=0 \
424         prefix=%{_prefix} \
425         perfexecdir=%{_datadir}/perf-core \
426         lib=%{_lib} \
427         template_dir=%{_datadir}/perf-core/templates
428 %endif
429
430 # cpupower
431 %if %{with cpupower}
432 %{__make} -C tools/power/cpupower \
433         %{makeopts} \
434         CPUFREQ_BENCH=false \
435         OPTIMIZATION="%{rpmcflags}" \
436         STRIPCMD=true
437
438 %ifarch %{ix86} x32
439 %{__make} -C tools/power/cpupower/debug/i386 centrino-decode powernow-k8-decode \
440         CC="%{__cc}" \
441         CFLAGS="%{rpmcflags}"
442 %endif
443
444 %ifarch %{x8664} x32
445 %{__make} -C tools/power/cpupower/debug/x86_64 centrino-decode powernow-k8-decode \
446         CC="%{__cc}" \
447         CFLAGS="%{rpmcflags}"
448 %endif
449 %endif
450
451 %ifarch %{ix86} %{x8664} x32
452 CFLAGS="%{rpmcflags}" \
453 %{__make} -C tools/power/x86/x86_energy_perf_policy \
454         CC="%{__cc}"
455
456 CFLAGS="%{rpmcflags}" \
457 %{__make} -C tools/power/x86/turbostat \
458         CC="%{__cc}"
459 %endif
460
461 %{__make} -C tools/thermal/tmon \
462         CC="%{__cc}" \
463         OPTFLAGS="%{rpmcflags}"
464
465 # usbip-utils
466 %if %{with usbip}
467 cd tools/usb/usbip
468 %{__libtoolize}
469 %{__aclocal}
470 %{__autoconf}
471 %{__autoheader}
472 %{__automake}
473 %configure \
474         --disable-silent-rules \
475         --with-usbids-dir=/lib/hwdata
476 %{__make}
477 cd ../../..
478 %endif
479
480 # page-types, slabinfo
481 %{__make} -C tools/vm page-types slabinfo \
482         CC="%{__cc}" \
483         CFLAGS="%{rpmcflags} -Wall -Wextra -I../lib"
484
485 # gen_init_cpio
486 %{__make} -C usr gen_init_cpio \
487         %{makeopts} \
488         CFLAGS="%{rpmcflags}"
489
490 %install
491 rm -rf $RPM_BUILD_ROOT
492
493 cd linux-%{basever}
494
495 %if %{with cpupower}
496 %{__make} -C tools/power/cpupower install \
497         DESTDIR=$RPM_BUILD_ROOT \
498         libdir=%{_libdir} \
499         mandir=%{_mandir} \
500         CPUFREQ_BENCH=false
501
502 %find_lang cpupower
503 mv cpupower.lang ..
504
505 install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{systemdunitdir}}
506 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/cpupower.service
507 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/cpupower
508
509 %ifarch %{ix86} x32
510 install -p tools/power/cpupower/debug/i386/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
511 %endif
512 %ifarch %{x8664} x32
513 install -p tools/power/cpupower/debug/x86_64/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
514 %endif
515 %endif
516
517 %if %{with perf}
518 %{__make} -C tools/perf -j1 install install-man \
519 %ifarch %{x8664}
520         IS_X86_64=1 \
521         %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
522 %endif
523         %{!?with_gtk:NO_GTK2=1} \
524         %{!?with_libunwind:NO_LIBUNWIND=1} \
525         CC="%{__cc}" \
526         CFLAGS_OPTIMIZE="%{rpmcflags}" \
527         WERROR=0 \
528         %{?with_verbose:V=1} \
529         prefix=%{_prefix} \
530         perfexecdir=%{_datadir}/perf-core \
531         template_dir=%{_datadir}/perf-core/templates \
532         lib=%{_lib} \
533         DESTDIR=$RPM_BUILD_ROOT
534
535 %py_comp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
536 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
537
538 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/perf-core/tests
539 %endif
540
541 %if %{with usbip}
542 %{__make} -C tools/usb/usbip install \
543         DESTDIR=$RPM_BUILD_ROOT
544
545 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libusbip.la
546 %endif
547
548 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man8}
549
550 install -p tools/laptop/dslm/dslm $RPM_BUILD_ROOT%{_sbindir}
551
552 install -p tools/gpio/lsgpio $RPM_BUILD_ROOT%{_bindir}
553
554 %ifarch %{ix86} %{x8664} x32
555 install -p tools/hv/hv_{fcopy,kvp,vss}_daemon $RPM_BUILD_ROOT%{_sbindir}
556 # TODO: PLD-specific hv_get_dhcp_info,hv_get_dns_info,hv_set_ifconfig
557 %{__sed} -e '1s,/usr/bin/env python,%{__python},' tools/hv/lsvmbus >$RPM_BUILD_ROOT%{_bindir}/lsvmbus
558 chmod 755 $RPM_BUILD_ROOT%{_bindir}/lsvmbus
559 %endif
560
561 install -p tools/iio/{iio_event_monitor,iio_generic_buffer,lsiio} $RPM_BUILD_ROOT%{_bindir}
562
563 install -p tools/laptop/freefall/freefall $RPM_BUILD_ROOT%{_sbindir}
564
565 %ifarch %{ix86}
566 install -p tools/lguest/lguest $RPM_BUILD_ROOT%{_bindir}
567 %endif
568
569 install -p tools/net/{bpf_asm,bpf_dbg,bpf_jit_disasm} $RPM_BUILD_ROOT%{_bindir}
570
571 install -p tools/thermal/tmon/tmon $RPM_BUILD_ROOT%{_bindir}
572 cp -p tools/thermal/tmon/tmon.8 $RPM_BUILD_ROOT%{_mandir}/man8
573
574 install -p tools/vm/slabinfo $RPM_BUILD_ROOT%{_bindir}
575 install -p tools/vm/page-types $RPM_BUILD_ROOT%{_sbindir}
576
577 %ifarch %{ix86} %{x8664} x32
578 install -d $RPM_BUILD_ROOT%{_mandir}/man8
579 %{__make} -C tools/power/x86/x86_energy_perf_policy install \
580         DESTDIR=$RPM_BUILD_ROOT
581
582 %{__make} -C tools/power/x86/turbostat install \
583         DESTDIR=$RPM_BUILD_ROOT
584 %endif
585
586 # gen_init_cpio
587 install -p usr/gen_init_cpio $RPM_BUILD_ROOT%{_bindir}/gen_init_cpio
588
589 %clean
590 rm -rf $RPM_BUILD_ROOT
591
592 %post   cpupower-libs -p /sbin/ldconfig
593 %postun cpupower-libs -p /sbin/ldconfig
594
595 %post cpupower
596 %systemd_post cpupower.service
597
598 %preun cpupower
599 %systemd_preun cpupower.service
600
601 %postun cpupower
602 %systemd_reload
603
604 %post   -n usbip-libs -p /sbin/ldconfig
605 %postun -n usbip-libs -p /sbin/ldconfig
606
607 %files
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_bindir}/bpf_asm
610 %attr(755,root,root) %{_bindir}/bpf_dbg
611 %attr(755,root,root) %{_bindir}/bpf_jit_disasm
612 %attr(755,root,root) %{_bindir}/gen_init_cpio
613 %attr(755,root,root) %{_bindir}/iio_event_monitor
614 %attr(755,root,root) %{_bindir}/iio_generic_buffer
615 %attr(755,root,root) %{_bindir}/lsgpio
616 %attr(755,root,root) %{_bindir}/lsiio
617 %attr(755,root,root) %{_bindir}/slabinfo
618 %attr(755,root,root) %{_bindir}/tmon
619 %attr(755,root,root) %{_sbindir}/dslm
620 %attr(755,root,root) %{_sbindir}/freefall
621 %attr(755,root,root) %{_sbindir}/page-types
622 %{_mandir}/man8/tmon.8*
623 %ifarch %{ix86}
624 %doc linux-%{basever}/tools/lguest/lguest.txt
625 %attr(755,root,root) %{_bindir}/lguest
626 %endif
627 %ifarch %{ix86} %{x8664} x32
628 %attr(755,root,root) %{_bindir}/centrino-decode
629 %attr(755,root,root) %{_bindir}/powernow-k8-decode
630 %endif
631 %ifarch %{ix86} %{x8664} x32
632 %attr(755,root,root) %{_bindir}/turbostat
633 %attr(755,root,root) %{_bindir}/x86_energy_perf_policy
634 %{_mandir}/man8/turbostat.8*
635 %{_mandir}/man8/x86_energy_perf_policy.8*
636 %endif
637
638 %files cpupower -f cpupower.lang
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_bindir}/cpupower
641 %{_mandir}/man1/cpupower*.1*
642 %{systemdunitdir}/cpupower.service
643 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cpupower
644
645 %files cpupower-libs
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_libdir}/libcpupower.so.*.*.*
648 %attr(755,root,root) %ghost %{_libdir}/libcpupower.so.0
649
650 %files cpupower-libs-devel
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_libdir}/libcpupower.so
653 %{_includedir}/cpufreq.h
654 %{_includedir}/cpuidle.h
655
656 %ifarch %{ix86} %{x8664} x32
657 %files hv
658 %defattr(644,root,root,755)
659 # TODO: PLDify these scripts and move to bindir
660 %doc linux-%{basever}/tools/hv/hv_{get_dhcp_info,get_dns_info,set_ifconfig}.sh
661 %attr(755,root,root) %{_bindir}/lsvmbus
662 %attr(755,root,root) %{_sbindir}/hv_fcopy_daemon
663 %attr(755,root,root) %{_sbindir}/hv_kvp_daemon
664 %attr(755,root,root) %{_sbindir}/hv_vss_daemon
665 %endif
666
667 %if %{with perf}
668 %files perf
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_bindir}/perf
671 %attr(755,root,root) %{_bindir}/trace
672 %{_mandir}/man1/perf*.1*
673 %dir %{_datadir}/perf-core
674 %attr(755,root,root) %{_datadir}/perf-core/perf-archive
675 %attr(755,root,root) %{_datadir}/perf-core/perf-with-kcore
676
677 %dir %{_datadir}/perf-core/scripts
678
679 %dir %{_datadir}/perf-core/scripts/perl
680 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util
681 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib
682 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf
683 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace
684 %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace/*.pm
685 %dir %{_datadir}/perf-core/scripts/perl/bin
686 %attr(755,root,root) %{_datadir}/perf-core/scripts/perl/bin/*
687 %{_datadir}/perf-core/scripts/perl/*.pl
688
689 %dir %{_datadir}/perf-core/scripts/python
690 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util
691 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib
692 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf
693 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace
694 %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/*.py*
695 %dir %{_datadir}/perf-core/scripts/python/bin
696 %attr(755,root,root) %{_datadir}/perf-core/scripts/python/bin/*
697 %{_datadir}/perf-core/scripts/python/*.py*
698
699 %dir %{_libdir}/traceevent
700 %dir %{_libdir}/traceevent/plugins
701 %attr(755,root,root) %{_libdir}/traceevent/plugins/plugin_*.so
702
703 %if %{with multilib}
704 %files perf-vdso32
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{_bindir}/perf-read-vdso32
707
708 %files perf-vdsox32
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_bindir}/perf-read-vdsox32
711 %endif
712
713 %if %{with gtk}
714 %files perf-gtk
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/libperf-gtk.so
717 %endif
718
719 %files -n bash-completion-perf
720 %defattr(644,root,root,755)
721 /etc/bash_completion.d/perf
722 %endif
723
724 %if %{with usbip}
725 %files -n usbip
726 %defattr(644,root,root,755)
727 %doc linux-%{basever}/tools/usb/usbip/{AUTHORS,README}
728 %attr(755,root,root) %{_sbindir}/usbip
729 %attr(755,root,root) %{_sbindir}/usbipd
730 %{_mandir}/man8/usbip.8*
731 %{_mandir}/man8/usbipd.8*
732
733 %files -n usbip-libs
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_libdir}/libusbip.so.*.*.*
736 %attr(755,root,root) %ghost %{_libdir}/libusbip.so.0
737
738 %files -n usbip-devel
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/libusbip.so
741 %{_includedir}/usbip
742
743 %files -n usbip-static
744 %defattr(644,root,root,755)
745 %{_libdir}/libusbip.a
746 %endif
This page took 0.07211 seconds and 3 git commands to generate.