]> git.pld-linux.org Git - packages/kde4-kig.git/blob - kde4-kig.spec
- disable doc on ix86, qt4 meinproc is broken, rel 12
[packages/kde4-kig.git] / kde4-kig.spec
1 %bcond_without  doc             # build handbooks
2
3 %define         _state          stable
4 %define         orgname         kig
5
6 %ifarch %{ix86}
7 %undefine       with_doc
8 %endif
9 Summary:        K Desktop Environment - Interactive Geometry
10 Summary(pl.UTF-8):      K Desktop Environment - Interaktywna geometria
11 Name:           kde4-kig
12 Version:        4.14.3
13 Release:        12
14 License:        GPL v2+
15 Group:          X11/Applications/Science
16 Source0:        http://download.kde.org/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
17 # Source0-md5:  2bc36c90f19b9fbebd7b3c7ac563acb3
18 Patch0:         no-doc.patch
19 URL:            http://www.kde.org/
20 BuildRequires:  automoc4
21 BuildRequires:  boost-python-devel
22 BuildRequires:  kde4-kdelibs-devel >= 4
23 BuildRequires:  python-devel >= 2
24 BuildRequires:  qt4-build >= 4
25 BuildRequires:  sed >= 4.0
26 Obsoletes:      kde4-kdeedu-kig < 4.6.99
27 Obsoletes:      kig <= 4.8.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Kig is an application for Interactive Geometry. It's intended to serve
32 two purposes:
33 - allow students to interactively explore mathematical figures and
34   concepts using the computer.
35 - serve as a WYSIWYG tool for drawing mathematical figures and
36   including them in other documents.
37
38 %description -l pl.UTF-8
39 Kig to aplikacja do interaktywnej geometrii. Ma służyć dwóm celom:
40 - umożliwić uczniom interaktywnie przeglądanie figur i pojęć
41   matematycznych przy użyciu komputera
42 - służyć jako narzędzie WYSIWYG do rysowania figur matematycznych i
43   włączania ich do innych dokumentów.
44
45 %prep
46 %setup -q -n %{orgname}-%{version}
47 %{!?with_doc:%patch0 -p1}
48
49 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' pykig/pykig.py
50
51 %build
52 install -d build
53 cd build
54 %cmake .. \
55         -DBoostPython_INCLUDE_DIRS=%{py_incdir} \
56         -DBoostPython_LIBRARIES="boost_python%(echo %{py_ver} | tr -d .);python%{py_ver}"
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} -C build install \
63         DESTDIR=$RPM_BUILD_ROOT \
64         kde_htmldir=%{_kdedocdir}
65
66 %if %{with doc}
67 %find_lang %{orgname} --with-kde
68 %endif
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files %{?with_doc:-f %{orgname}.lang}
74 %defattr(644,root,root,755)
75 %attr(755,root,root) %{_bindir}/kig
76 %attr(755,root,root) %{_bindir}/pykig.py
77 %attr(755,root,root) %{_libdir}/kde4/kigpart.so
78 %{_datadir}/appdata/kig.appdata.xml
79 %{_datadir}/apps/kig
80 %{_datadir}/kde4/services/kig_part.desktop
81 %{_desktopdir}/kde4/kig.desktop
82 %{_iconsdir}/hicolor/*x*/apps/kig.png
83 %{_iconsdir}/hicolor/scalable/apps/kig.svgz
84 %{_iconsdir}/hicolor/*x*/mimetypes/application-x-kig.png
85 %{_iconsdir}/hicolor/scalable/mimetypes/application-x-kig.svgz
86 %{?with_doc:%{_mandir}/man1/kig.1*}
87
88 # subpackage?
89 %{_datadir}/apps/katepart/syntax/python-kig.xml
This page took 0.082085 seconds and 3 git commands to generate.