]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blob - kde4-kdeplasma-addons.spec
- BR: soprano-devel
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
1
2 %bcond_without  marble  # don't build marble plasma support
3
4 %define         orgname kdeplasma-addons
5 %define         _state  stable
6 %define         _qtver  4.5.3
7
8 Summary:        KDE4 Plasmoids
9 Summary(pl.UTF-8):      Plazmoidy dla KDE4
10 Name:           kde4-kdeplasma-addons
11 Version:        4.3.4
12 Release:        1
13 License:        GPL v2
14 Group:          X11/Applications
15 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
16 # Source0-md5:  c03ab7099a8064ca85bb804408052a2b
17 #Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
18 Patch100:       %{name}-branch.diff
19 Patch0:         %{name}-pastebinpld.patch
20 URL:            http://www.kde.org/
21 BuildRequires:  OpenGL-GLU-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  QtCore-devel >= %{_qtver}
24 BuildRequires:  QtNetwork-devel >= %{_qtver}
25 BuildRequires:  QtOpenGL-devel >= %{_qtver}
26 BuildRequires:  QtScript-devel >= %{_qtver}
27 BuildRequires:  QtSvg-devel >= %{_qtver}
28 BuildRequires:  QtWebKit-devel >= %{_qtver}
29 BuildRequires:  automoc4 >= 0.9.88
30 BuildRequires:  cmake >= 2.6.3
31 BuildRequires:  eigen-devel >= 2.0.51
32 BuildRequires:  kde4-kdebase-workspace-devel >= %{version}
33 %{?with_marble:BuildRequires:   kde4-kdeedu-devel >= %{version}}
34 BuildRequires:  kde4-kdegraphics-devel >= %{version}
35 BuildRequires:  kde4-kdelibs-devel >= %{version}
36 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
37 BuildRequires:  phonon-devel >= 4.3.1
38 BuildRequires:  pkgconfig
39 BuildRequires:  python
40 BuildRequires:  python-modules
41 BuildRequires:  qimageblitz-devel
42 BuildRequires:  qt4-build >= %{_qtver}
43 BuildRequires:  qt4-qmake >= %{_qtver}
44 BuildRequires:  rpmbuild(macros) >= 1.293
45 BuildRequires:  soprano-devel
46 BuildRequires:  strigi-devel >= 0.6.5
47 BuildRequires:  xorg-lib-libXcomposite
48 BuildRequires:  xorg-lib-libXdamage
49 BuildRequires:  xorg-lib-libXrender
50 BuildRequires:  xorg-lib-libXtst-devel
51 Obsoletes:      kde4-kdeplasmoids
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 KDE4 plasmoids.
56
57 %description -l pl.UTF-8
58 Plazmoidy dla KDE4.
59
60 %package lancelot
61 Summary:        Lancelot Desktop Theme
62 Summary(pl.UTF-8):      Motyw pulpitu Lancelot
63 Group:          X11/Applications
64 Requires:       kde4-kdebase-workspace >= %{version}
65
66 %description lancelot
67 Lancelot Desktop Theme.
68
69 %description lancelot -l pl.UTF-8
70 Motyw pulpitu Lancelot.
71
72 %package devel
73 Summary:        Development files for KDE4 Plasmoids
74 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek plazmoidów dla KDE4
75 Group:          X11/Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       kde4-kdebase-workspace-devel >= %{version}
78 Requires:       kde4-kdegraphics-devel >= %{version}
79 Requires:       kde4-kdelibs-devel >= %{version}
80 Requires:       kde4-kdepimlibs-devel >= %{version}
81
82 %description devel
83 This package contains header files needed if you wish to build
84 applications based on KDE4 Plasmoids.
85
86 %description devel -l pl.UTF-8
87 Pakiet ten zawiera pliki nagłówkowe potrzebne do budowy aplikacji
88 opartych na plazmoidach dla KDE4.
89
90 %prep
91 %setup -q -n %{orgname}-%{version}
92 #%patch100 -p0
93 %patch0 -p1
94
95 %build
96 install -d build
97 cd build
98 %cmake \
99         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
100         -DLIB_INSTALL_DIR=%{_libdir} \
101         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
102 %if "%{_lib}" != "lib"
103         -DLIB_SUFFIX=64 \
104 %endif
105         ../
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} -C build install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %post   lancelot        -p /sbin/ldconfig
122 %postun lancelot        -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/kde4/krunner_*.so
127 %attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
128 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_*.so
129 %attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
130 %attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
131 %attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
132 %attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
133 %attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
134 %attr(755,root,root) %{_libdir}/kde4/plasma-applet_systemloadviewer.so
135 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_apodprovider.so
136 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_epodprovider.so
137 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_flickrprovider.so
138 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_oseiprovider.so
139 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_wcpotdprovider.so
140 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_mandelbrot.so
141 %if %{with marble}
142 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_marble.so
143 %endif
144 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_pattern.so
145 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_virus.so
146 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_weather.so
147 %attr(755,root,root) %ghost %{_libdir}/libconversion.so.?
148 %attr(755,root,root) %{_libdir}/libconversion.so.*.*.*
149 %attr(755,root,root) %{_libdir}/liblancelot.so
150 %attr(755,root,root) %ghost %{_libdir}/libocsclient.so.?
151 %attr(755,root,root) %{_libdir}/libocsclient.so.*.*.*
152 %attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so
153 %attr(755,root,root) %ghost %{_libdir}/libplasmapotdprovidercore.so.?
154 %attr(755,root,root) %{_libdir}/libplasmapotdprovidercore.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libplasmaweather.so.?
156 %attr(755,root,root) %{_libdir}/libplasmaweather.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/librtm.so.?
158 %attr(755,root,root) %{_libdir}/librtm.so.*.*.*
159 %{_datadir}/apps/desktoptheme/Aya
160 %{_datadir}/apps/desktoptheme/Elegance
161 %{_datadir}/apps/desktoptheme/Silicon
162 %dir %{_datadir}/apps/desktoptheme/default/stylesheets
163 %{_datadir}/apps/desktoptheme/default/stylesheets/*
164 %dir %{_datadir}/apps/desktoptheme/default/weatherstation
165 %{_datadir}/apps/desktoptheme/default/weatherstation/*
166 %dir %{_datadir}/apps/desktoptheme/default/weather/
167 %{_datadir}/apps/desktoptheme/default/weather/wind-arrows.svgz
168 %{_datadir}/apps/desktoptheme/default/widgets/*
169 %{_datadir}/apps/desktoptheme/heron
170 %{_datadir}/apps/desktoptheme/slim-glow
171 %{_datadir}/kde4/services/*.desktop
172 %{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
173 %{_datadir}/kde4/servicetypes/plasma_potdprovider.desktop
174 %{_datadir}/config/comic.knsrc
175 %{_datadir}/config/virus_wallpaper.knsrc
176 %dir %{_datadir}/apps/desktoptheme/default/rssnow
177 %{_datadir}/apps/desktoptheme/default/rssnow/background.svgz
178 %{_datadir}/apps/desktoptheme/default/rssnow/left.svgz
179 %{_datadir}/apps/desktoptheme/default/rssnow/right.svgz
180 %{_datadir}/apps/desktoptheme/default/rssnow/rssnow.svgz
181 %dir %{_datadir}/apps/desktoptheme/default/bubblemon
182 %{_datadir}/apps/desktoptheme/default/bubblemon/bubble.svg
183 %dir %{_datadir}/apps/desktoptheme/default/fifteenPuzzle
184 %{_datadir}/apps/desktoptheme/default/fifteenPuzzle/greensquare.svgz
185 %{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
186
187 %dir %{_datadir}/apps/rssnow
188 %{_datadir}/apps/rssnow/feeds
189 %{_iconsdir}/*/*x*/apps/previewer.png
190 %{_datadir}/kde4/services/ServiceMenus/preview.desktop
191 %dir %{_datadir}/apps/bball
192 %{_datadir}/apps/bball/bball.svgz
193 %{_datadir}/apps/bball/bounce.ogg
194 %{_datadir}/apps/bball/football.svgz
195 #%{_datadir}/apps/plasma-bluemarble
196 %{_datadir}/apps/plasma
197 %{_datadir}/apps/plasma-applet-opendesktop
198 %{_datadir}/apps/plasma_pastebin
199 %{_datadir}/apps/plasma_wallpaper_pattern
200
201 %files lancelot
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_bindir}/lancelot
204 %attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
205 %attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
206 %{_datadir}/apps/desktoptheme/default/lancelot
207 #%{_datadir}/apps/desktoptheme/air/
208
209 %{_datadir}/dbus-1/services/org.kde.lancelot.service
210 %{_datadir}/mime/packages/lancelotpart-mime.xml
211 %{_datadir}/apps/lancelot
212 %{_iconsdir}/hicolor/*x*/apps/lancelot.png
213 %{_iconsdir}/hicolor/*x*/apps/lancelot-part.png
214
215 %files devel
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_libdir}/*.so
218 %{_includedir}/conversion
219 %{_includedir}/lancelot
220 %{_datadir}/apps/cmake/modules/*.cmake
This page took 0.07953 seconds and 4 git commands to generate.