]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blob - kde4-kdeplasma-addons.spec
- merged from DEVEL
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
1
2 %bcond_without  marble  # don't build marble plasma support
3
4 %define         orgname kdeplasma-addons
5 %define         _state  stable
6 %define         _qtver  4.5.2
7
8 Summary:        KDE4 Plasmoids
9 Summary(pl.UTF-8):      Plazmoidy dla KDE4
10 Name:           kde4-kdeplasma-addons
11 Version:        4.3.0
12 Release:        1
13 License:        GPL v2
14 Group:          X11/Applications
15 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
16 # Source0-md5:  abfbe2d32c444689b5bf4e5346b33c9e
17 #Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
18 #Patch100: %{name}-branch.diff
19 Patch0:         %{name}-pastebinpld.patch
20 URL:            http://www.kde.org/
21 BuildRequires:  OpenGL-GLU-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  QtCore-devel >= %{_qtver}
24 BuildRequires:  QtNetwork-devel >= %{_qtver}
25 BuildRequires:  QtOpenGL-devel >= %{_qtver}
26 BuildRequires:  QtScript-devel >= %{_qtver}
27 BuildRequires:  QtSvg-devel >= %{_qtver}
28 BuildRequires:  QtWebKit-devel >= %{_qtver}
29 BuildRequires:  automoc4 >= 0.9.88
30 BuildRequires:  cmake >= 2.6.3
31 BuildRequires:  eigen-devel >= 2.0.51
32 BuildRequires:  kde4-kdebase-workspace-devel >= %{version}
33 BuildRequires:  kde4-kdegraphics-devel >= %{version}
34 BuildRequires:  kde4-kdelibs-devel >= %{version}
35 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
36 %{?with_marble:BuildRequires:   kde4-kdeedu-devel >= %{version}}
37 BuildRequires:  phonon-devel >= 4.3.1
38 BuildRequires:  qt4-build >= %{_qtver}
39 BuildRequires:  qt4-qmake >= %{_qtver}
40 BuildRequires:  rpmbuild(macros) >= 1.293
41 BuildRequires:  strigi-devel >= 0.6.5
42 BuildRequires:  xorg-lib-libXcomposite
43 BuildRequires:  xorg-lib-libXdamage
44 BuildRequires:  xorg-lib-libXrender
45 BuildRequires:  xorg-lib-libXtst-devel
46 Obsoletes:      kde4-kdeplasmoids
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 KDE4 plasmoids.
51
52 %description -l pl.UTF-8
53 Plazmoidy dla KDE4.
54
55 %package lancelot
56 Summary:        Lancelot Desktop Theme
57 Summary(pl.UTF-8):      Motyw pulpitu Lancelot
58 Group:          X11/Applications
59 Requires:       kde4-kdebase-workspace >= %{version}
60
61 %description lancelot
62 Lancelot Desktop Theme.
63
64 %description lancelot -l pl.UTF-8
65 Motyw pulpitu Lancelot.
66
67 %package devel
68 Summary:        Development files for KDE4 Plasmoids
69 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek plazmoidów dla KDE4
70 Group:          X11/Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       kde4-kdebase-workspace-devel >= %{version}-%{release}
73 Requires:       kde4-kdegraphics-devel >= %{version}-%{release}
74 Requires:       kde4-kdelibs-devel >= %{version}-%{release}
75 Requires:       kde4-kdepimlibs-devel >= %{version}-%{release}
76
77 %description devel
78 This package contains header files needed if you wish to build
79 applications based on KDE4 Plasmoids.
80
81 %description devel -l pl.UTF-8
82 Pakiet ten zawiera pliki nagłówkowe potrzebne do budowy aplikacji
83 opartych na plazmoidach dla KDE4.
84
85 %prep
86 %setup -q -n %{orgname}-%{version}
87 #%patch100 -p0
88 %patch0 -p1
89
90 %build
91 install -d build
92 cd build
93 %cmake \
94         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
95         -DLIB_INSTALL_DIR=%{_libdir} \
96         -DCMAKE_BUILD_TYPE=%{!?debug:release}%{?debug:debug} \
97 %if "%{_lib}" != "lib"
98         -DLIB_SUFFIX=64 \
99 %endif
100         ../
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} -C build install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %post   lancelot        -p /sbin/ldconfig
117 %postun lancelot        -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/kde4/krunner_*.so
122 %attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
123 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_*.so
124 %attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
125 %attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
126 %attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
127 %attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
128 %attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
129 %attr(755,root,root) %{_libdir}/kde4/plasma-applet_systemloadviewer.so
130 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_apodprovider.so
131 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_epodprovider.so
132 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_flickrprovider.so
133 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_oseiprovider.so
134 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_wcpotdprovider.so
135 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_mandelbrot.so
136 %if %{with marble}
137 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_marble.so
138 %endif
139 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_pattern.so
140 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_virus.so
141 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_weather.so
142 %attr(755,root,root) %ghost %{_libdir}/libconversion.so.?
143 %attr(755,root,root) %{_libdir}/libconversion.so.*.*.*
144 %attr(755,root,root) %{_libdir}/liblancelot.so
145 %attr(755,root,root) %ghost %{_libdir}/libocsclient.so.?
146 %attr(755,root,root) %{_libdir}/libocsclient.so.*.*.*
147 %attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so
148 %attr(755,root,root) %ghost %{_libdir}/libplasmapotdprovidercore.so.?
149 %attr(755,root,root) %{_libdir}/libplasmapotdprovidercore.so.*.*.*
150 %attr(755,root,root) %ghost %{_libdir}/libplasmaweather.so.?
151 %attr(755,root,root) %{_libdir}/libplasmaweather.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/librtm.so.?
153 %attr(755,root,root) %{_libdir}/librtm.so.*.*.*
154 %{_datadir}/apps/desktoptheme/Aya
155 %{_datadir}/apps/desktoptheme/Elegance
156 %{_datadir}/apps/desktoptheme/Silicon
157 %dir %{_datadir}/apps/desktoptheme/default/stylesheets
158 %{_datadir}/apps/desktoptheme/default/stylesheets/*
159 %dir %{_datadir}/apps/desktoptheme/default/weatherstation
160 %{_datadir}/apps/desktoptheme/default/weatherstation/*
161 %dir %{_datadir}/apps/desktoptheme/default/weather/
162 %{_datadir}/apps/desktoptheme/default/weather/wind-arrows.svgz
163 %{_datadir}/apps/desktoptheme/default/widgets/*
164 %{_datadir}/apps/desktoptheme/heron
165 %{_datadir}/apps/desktoptheme/slim-glow
166 %{_datadir}/kde4/services/*.desktop
167 %{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
168 %{_datadir}/kde4/servicetypes/plasma_potdprovider.desktop
169 %{_datadir}/config/comic.knsrc
170 %{_datadir}/config/virus_wallpaper.knsrc
171 %dir %{_datadir}/apps/desktoptheme/default/rssnow
172 %{_datadir}/apps/desktoptheme/default/rssnow/background.svgz
173 %{_datadir}/apps/desktoptheme/default/rssnow/left.svgz
174 %{_datadir}/apps/desktoptheme/default/rssnow/right.svgz
175 %{_datadir}/apps/desktoptheme/default/rssnow/rssnow.svgz
176 %dir %{_datadir}/apps/desktoptheme/default/bubblemon
177 %{_datadir}/apps/desktoptheme/default/bubblemon/bubble.svg
178 %dir %{_datadir}/apps/desktoptheme/default/fifteenPuzzle
179 %{_datadir}/apps/desktoptheme/default/fifteenPuzzle/greensquare.svgz
180 %{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
181
182 %dir %{_datadir}/apps/rssnow
183 %{_datadir}/apps/rssnow/feeds
184 %{_iconsdir}/*/*x*/apps/previewer.png
185 %{_datadir}/kde4/services/ServiceMenus/preview.desktop
186 %dir %{_datadir}/apps/bball
187 %{_datadir}/apps/bball/bball.svgz
188 %{_datadir}/apps/bball/bounce.ogg
189 %{_datadir}/apps/bball/football.svgz
190 #%{_datadir}/apps/plasma-bluemarble
191 %{_datadir}/apps/plasma
192 %{_datadir}/apps/plasma-applet-opendesktop
193 %{_datadir}/apps/plasma_pastebin
194 %{_datadir}/apps/plasma_wallpaper_pattern
195
196 %files lancelot
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_bindir}/lancelot
199 %attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
200 %attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
201 %{_datadir}/apps/desktoptheme/default/lancelot
202 #%{_datadir}/apps/desktoptheme/air/
203
204 %{_datadir}/dbus-1/services/org.kde.lancelot.service
205 %{_datadir}/mime/packages/lancelotpart-mime.xml
206 %{_datadir}/apps/lancelot
207 %{_iconsdir}/hicolor/*x*/apps/lancelot.png
208 %{_iconsdir}/hicolor/*x*/apps/lancelot-part.png
209
210 %files devel
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_libdir}/*.so
213 %{_includedir}/conversion
214 %{_includedir}/lancelot
215 %{_datadir}/apps/cmake/modules/*.cmake
This page took 0.051113 seconds and 4 git commands to generate.