]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blob - kde4-kdeplasma-addons.spec
- release 5
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
1 %define         orgname kdeplasma-addons
2 %define         _state  stable
3 %define         _qtver  4.4.3
4
5 Summary:        KDE4 Plasmoids
6 Summary(pl.UTF-8):      Plazmoidy dla KDE4
7 Name:           kde4-kdeplasma-addons
8 Version:        4.2.0
9 Release:        5
10 License:        GPL v2
11 Group:          X11/Applications
12 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
13 # Source0-md5:  d98f805f4c9b7af7278067f9e544b2ec
14 Patch0:         %{name}-pastebinpld.patch
15 URL:            http://www.kde.org/
16 BuildRequires:  OpenGL-GLU-devel
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  QtCore-devel >= %{_qtver}
19 BuildRequires:  QtNetwork-devel >= %{_qtver}
20 BuildRequires:  QtOpenGL-devel >= %{_qtver}
21 BuildRequires:  QtScript-devel >= %{_qtver}
22 BuildRequires:  QtSvg-devel >= %{_qtver}
23 BuildRequires:  QtWebKit-devel >= %{_qtver}
24 BuildRequires:  automoc4 >= 0.9.88
25 BuildRequires:  cmake >= 2.6.2
26 BuildRequires:  kde4-kdebase-workspace-devel >= %{version}
27 BuildRequires:  kde4-kdelibs-devel >= %{version}
28 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
29 BuildRequires:  phonon-devel >= 4.3.0
30 BuildRequires:  qt4-build >= %{_qtver}
31 BuildRequires:  qt4-qmake >= %{_qtver}
32 BuildRequires:  rpmbuild(macros) >= 1.293
33 BuildRequires:  strigi-devel >= 0.6.3
34 BuildRequires:  xorg-lib-libXtst-devel
35 Obsoletes:      kde4-kdeplasmoids
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 KDE4 plasmoids.
40
41 %description -l pl.UTF-8
42 Plazmoidy dla KDE4.
43
44 %package lancelot
45 Summary:        Lancelot Desktop Theme
46 Summary(pl.UTF-8):      Motyw pulpitu Lancelot
47 Group:          X11/Applications
48 Requires:       kde4-kdebase-workspace >= %{version}
49
50 %description lancelot
51 Lancelot Desktop Theme.
52
53 %description lancelot -l pl.UTF-8
54 Motyw pulpitu Lancelot.
55
56 %prep
57 %setup -q -n %{orgname}-%{version}
58 %patch0 -p1
59
60 %build
61 install -d build
62 cd build
63 %cmake \
64         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
65         -DCMAKE_BUILD_TYPE=%{!?debug:release}%{?debug:debug} \
66 %if "%{_lib}" != "lib"
67         -DLIB_SUFFIX=64 \
68 %endif
69         ../
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} -C build install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post   -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %post   lancelot        -p /sbin/ldconfig
86 %postun lancelot        -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/kde4/krunner_*.so
91 %attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
92 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_*.so
93 %attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
94 %attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
95 %attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
96 %attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
97 %attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
98 %attr(755,root,root) %ghost %{_libdir}/libplasmaconverter.so.?
99 %attr(755,root,root) %{_libdir}/libplasmaconverter.so.*.*.*
100 %{_datadir}/apps/desktoptheme/Aya
101 %{_datadir}/apps/desktoptheme/Elegance
102 %{_datadir}/apps/desktoptheme/Silicon
103 %dir %{_datadir}/apps/desktoptheme/default/stylesheets
104 %{_datadir}/apps/desktoptheme/default/stylesheets/*
105 %dir %{_datadir}/apps/desktoptheme/default/weatherstation
106 %{_datadir}/apps/desktoptheme/default/weatherstation/*
107 %{_datadir}/apps/desktoptheme/default/widgets/*
108 %{_datadir}/apps/desktoptheme/heron
109 %{_datadir}/apps/desktoptheme/slim-glow
110 %{_datadir}/kde4/services/*.desktop
111 %{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
112 #%{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
113 %{_datadir}/config/comic.knsrc
114 %dir %{_datadir}/apps/desktoptheme/default/rssnow
115 %{_datadir}/apps/desktoptheme/default/rssnow/background.svgz
116 %{_datadir}/apps/desktoptheme/default/rssnow/left.svgz
117 %{_datadir}/apps/desktoptheme/default/rssnow/right.svgz
118 %{_datadir}/apps/desktoptheme/default/rssnow/rssnow.svgz
119 %dir %{_datadir}/apps/rssnow
120 %{_datadir}/apps/rssnow/feeds
121 %{_iconsdir}/*/*x*/apps/previewer.png
122 #%{_iconsdir}/oxygen/scalable/apps/bball.svgz
123 %{_datadir}/kde4/services/ServiceMenus/preview.desktop
124 %dir %{_datadir}/apps/bball
125 %{_datadir}/apps/bball/bball.svgz
126 %{_datadir}/apps/bball/bounce.ogg
127 %{_datadir}/apps/bball/football.svgz
128 %{_datadir}/apps/plasma/services/tweet.operations
129
130 %files lancelot
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/lancelot
133 %attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
134 %attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
135 %{_datadir}/apps/desktoptheme/default/lancelot
136 %{_datadir}/dbus-1/services/org.kde.lancelot.service
137 %{_datadir}/mime/packages/lancelotpart-mime.xml
138 %{_iconsdir}/hicolor/*x*/apps/lancelot.png
139 %{_iconsdir}/hicolor/*x*/apps/lancelot-part.png
This page took 0.067161 seconds and 3 git commands to generate.