]> git.pld-linux.org Git - packages/kde4-kdebase-runtime.git/blob - kde4-kdebase-runtime.spec
- rel 2; locale patch was merged upstream
[packages/kde4-kdebase-runtime.git] / kde4-kdebase-runtime.spec
1 # TODO
2 # - l10n != %lang glibc locales (et = etiopia not estonia!)
3 #
4 # Conditional build:
5 #
6 %define         _state          stable
7 %define         orgname         kde-runtime
8 %define         qtver           4.8.1
9 %define         atticaver       0.2.0
10
11 Summary:        KDE 4 base runtime components
12 Summary(pl.UTF-8):      Komponenty uruchomieniowe podstawowej części KDE 4
13 Name:           kde4-kdebase-runtime
14 Version:        4.9.0
15 Release:        2
16 License:        GPL
17 Group:          X11/Applications
18 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
19 # Source0-md5:  52149a5030efde91933407bf4ca728c9
20 Source1:        kdebase-searchproviders.tar.bz2
21 # Source1-md5:  126c3524b5367f5096a628acbf9dc86f
22 Source2:        l10n-iso639-1
23 Patch100:       %{name}-branch.diff
24 Patch0:         %{name}-rpc.patch
25 URL:            http://www.kde.org/
26 BuildRequires:  OpenEXR-devel
27 BuildRequires:  alsa-lib-devel
28 BuildRequires:  attica-devel >= %{atticaver}
29 BuildRequires:  automoc4 >= 0.9.88
30 BuildRequires:  bzip2-devel
31 BuildRequires:  clucene-core-devel >= 0.9.21
32 BuildRequires:  cmake >= 2.8.0
33 BuildRequires:  docbook-dtd42-xml
34 BuildRequires:  docbook-style-xsl
35 BuildRequires:  exiv2-devel >= 0.18.2
36 BuildRequires:  kde4-nepomuk-core >= %{version}
37 BuildRequires:  kde4-kdelibs-devel >= %{version}
38 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
39 BuildRequires:  libcanberra-devel
40 BuildRequires:  libjpeg-devel
41 BuildRequires:  libqzeitgeist-devel >= 0.8
42 BuildRequires:  libsmbclient-devel
43 BuildRequires:  libssh-devel >= 1:0.4.0
44 BuildRequires:  libtirpc-devel
45 BuildRequires:  ntrack-devel
46 BuildRequires:  openslp-devel
47 BuildRequires:  phonon-devel >= 4.4.3
48 BuildRequires:  pkgconfig
49 BuildRequires:  pulseaudio-devel
50 BuildRequires:  qt4-build >= %{qtver}
51 BuildRequires:  qt4-qmake >= %{qtver}
52 BuildRequires:  rpmbuild(macros) >= 1.600
53 BuildRequires:  shared-desktop-ontologies-devel >= 0.7.1
54 BuildRequires:  shared-mime-info
55 BuildRequires:  soprano-devel >= 2.6.51
56 BuildRequires:  strigi-devel >= 0.7.0
57 BuildRequires:  xine-lib-devel
58 BuildRequires:  xz-devel
59 Requires:       attica >= %{atticaver}
60 Provides:       dbus(org.freedesktop.Notifications)
61 Obsoletes:      kdebase4-runtime
62 Conflicts:      kdebase4-runtime
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 KDE 4 runtime components.
67
68 %description -l pl.UTF-8
69 Komponenty uruchomieniowe podstawowej części KDE 4.
70
71 %package devel
72 Summary:        Development files for KDE 4 runtime components
73 Summary(pl.UTF-8):      Pliki programistyczne komponentów uruchomieniowych KDE 4
74 Group:          X11/Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       kde4-kdelibs-devel >= %{version}
77
78 %description devel
79 Development files for KDE 4 runtime components.
80
81 %description devel -l pl.UTF-8
82 Pliki programistyczne komponentów uruchomieniowych KDE 4.
83
84 %package -n kde4-phonon
85 Summary:        KDE 4 Phonon plugins
86 Summary(pl.UTF-8):      Wtyczki KDE 4 dla Phonona
87 Group:          X11/Applications
88
89 %description -n kde4-phonon
90 KDE 4 Phonon plugins.
91
92 %description -n kde4-phonon -l pl.UTF-8
93 Wtyczki KDE 4 dla Phonona.
94
95 %prep
96 %setup -q -n %{orgname}-%{version} -a1
97 #%patch100 -p1
98 %patch0 -p1
99
100 %build
101 install -d build
102 cd build
103 %cmake \
104         -DLIBEXEC_INSTALL_DIR=%{_libdir}/kde4/libexec \
105         ../
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} -C build install \
113         DESTDIR=$RPM_BUILD_ROOT \
114         kde_htmldir=%{_kdedocdir}
115
116 install -d $RPM_BUILD_ROOT%{_datadir}/kde4/services/searchproviders/pld
117 cp -a kdebase-searchproviders/*.desktop $RPM_BUILD_ROOT%{_datadir}/kde4/services/searchproviders/pld
118
119 collect_l10n_files() {
120         while read country language comment; do
121                 [ "$country" != "#" ] || continue
122                 if [ "$language" = "-" ]; then
123                         # no mapping. just add for now
124                         echo >&2 "No mapping for $country $comment, adding without %%lang tag"
125                         echo "%{_datadir}/locale/l10n/$country"
126                 else
127                         echo "%lang($language) %{_datadir}/locale/l10n/$country"
128                 fi
129         done
130 } < %{SOURCE2}
131 collect_l10n_files > %{name}.files
132
133 rm -f $RPM_BUILD_ROOT%{_datadir}/icons/default.kde4
134 # provided (conflicts) by hicolor-icon-theme
135 rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files -f %{name}.files
144 %defattr(644,root,root,755)
145 %{_sysconfdir}/xdg/menus/kde-information.menu
146 %attr(755,root,root) %{_bindir}/kcmshell4
147 %attr(755,root,root) %{_bindir}/kde-cp
148 %attr(755,root,root) %{_bindir}/kde-mv
149 %attr(755,root,root) %{_bindir}/kde-open
150 %attr(755,root,root) %{_bindir}/kde4-menu
151 %attr(755,root,root) %{_bindir}/kdebugdialog
152 %attr(755,root,root) %{_bindir}/kfile4
153 %attr(755,root,root) %{_bindir}/kiconfinder
154 %attr(755,root,root) %{_bindir}/khelpcenter
155 %attr(755,root,root) %{_bindir}/khotnewstuff4
156 %attr(755,root,root) %{_bindir}/khotnewstuff-upload
157 %attr(755,root,root) %{_bindir}/kioclient
158 %attr(755,root,root) %{_bindir}/kmimetypefinder
159 %attr(755,root,root) %{_bindir}/knotify4
160 %attr(755,root,root) %{_bindir}/kquitapp
161 %attr(755,root,root) %{_bindir}/kreadconfig
162 %attr(755,root,root) %{_bindir}/kstart
163 %attr(755,root,root) %{_bindir}/kde4
164 %attr(755,root,root) %{_bindir}/kwalletd
165 %attr(755,root,root) %{_bindir}/ksvgtopng
166 %attr(755,root,root) %{_bindir}/keditfiletype
167 %attr(755,root,root) %{_bindir}/kglobalaccel
168 %attr(755,root,root) %{_bindir}/ktraderclient
169 %attr(755,root,root) %{_bindir}/ktrash
170 %attr(755,root,root) %{_bindir}/kuiserver
171 %attr(755,root,root) %{_bindir}/kwriteconfig
172 %attr(755,root,root) %{_bindir}/solid-hardware
173 %attr(755,root,root) %{_bindir}/nepomukcontroller
174 %attr(755,root,root) %{_bindir}/plasma-remote-helper
175 %attr(755,root,root) %{_bindir}/plasmapkg
176 %attr(755,root,root) %{_libdir}/attica_kde.so
177 %attr(755,root,root) %{_libdir}/libkdeinit4_kcmshell4.so
178 %attr(755,root,root) %{_libdir}/libkdeinit4_khelpcenter.so
179 %attr(755,root,root) %{_libdir}/libkdeinit4_kuiserver.so
180 %attr(755,root,root) %{_libdir}/libkdeinit4_kwalletd.so
181 %attr(755,root,root) %{_libdir}/libkdeinit4_kglobalaccel.so
182 %attr(755,root,root) %{_libdir}/libknotifyplugin.so
183 # Is it ok to add those files to main package?
184 %attr(755,root,root) %ghost %{_libdir}/libkwalletbackend.so.?
185 %attr(755,root,root) %{_libdir}/libkwalletbackend.so.*.*.*
186 %attr(755,root,root) %ghost %{_libdir}/libmolletnetwork.so.?
187 %attr(755,root,root) %{_libdir}/libmolletnetwork.so.4.*.*
188 %attr(755,root,root) %{_libdir}/kde4/comicbookthumbnail.so
189 %attr(755,root,root) %{_libdir}/kde4/cursorthumbnail.so
190 %attr(755,root,root) %{_libdir}/kde4/djvuthumbnail.so
191 %attr(755,root,root) %{_libdir}/kde4/exrthumbnail.so
192 %attr(755,root,root) %{_libdir}/kde4/htmlthumbnail.so
193 %attr(755,root,root) %{_libdir}/kde4/imagethumbnail.so
194 #%attr(755,root,root) %{_libdir}/kde4/jpegrotatedthumbnail.so
195 %attr(755,root,root) %{_libdir}/kde4/jpegthumbnail.so
196 %attr(755,root,root) %{_libdir}/kde4/kcm_cgi.so
197 %attr(755,root,root) %{_libdir}/kde4/kcm_componentchooser.so
198 %attr(755,root,root) %{_libdir}/kde4/kcm_device_automounter.so
199 %attr(755,root,root) %{_libdir}/kde4/kcm_emoticons.so
200 %attr(755,root,root) %{_libdir}/kde4/kcm_filetypes.so
201 %attr(755,root,root) %{_libdir}/kde4/kcm_icons.so
202 %attr(755,root,root) %{_libdir}/kde4/kcm_kded.so
203 %attr(755,root,root) %{_libdir}/kde4/kcm_kdnssd.so
204 %attr(755,root,root) %{_libdir}/kde4/kcm_knotify.so
205 %attr(755,root,root) %{_libdir}/kde4/kcm_locale.so
206 %attr(755,root,root) %{_libdir}/kde4/kcm_nepomuk.so
207 %attr(755,root,root) %{_libdir}/kde4/kcm_trash.so
208 #%attr(755,root,root) %{_libdir}/kde4/kded_activitymanager.so
209 %attr(755,root,root) %{_libdir}/kde4/kded_device_automounter.so
210 %attr(755,root,root) %{_libdir}/kde4/kded_kpasswdserver.so
211 %attr(755,root,root) %{_libdir}/kde4/kded_ktimezoned.so
212 %attr(755,root,root) %{_libdir}/kde4/kded_remotedirnotify.so
213 %attr(755,root,root) %{_libdir}/kde4/kded_soliduiserver.so
214 %attr(755,root,root) %{_libdir}/kde4/kded_desktopnotifier.so
215 %attr(755,root,root) %{_libdir}/kde4/kded_nepomuksearchmodule.so
216 %attr(755,root,root) %{_libdir}/kde4/kded_networkstatus.so
217 %attr(755,root,root) %{_libdir}/kde4/kded_networkwatcher.so
218 %attr(755,root,root) %{_libdir}/kde4/kded_recentdocumentsnotifier.so
219 %attr(755,root,root) %{_libdir}/kde4/kded_solidautoeject.so
220 %attr(755,root,root) %{_libdir}/kde4/kio_applications.so
221 %attr(755,root,root) %{_libdir}/kde4/kio_bookmarks.so
222 %attr(755,root,root) %{_libdir}/kde4/kio_desktop.so
223 %attr(755,root,root) %{_libdir}/kde4/kio_about.so
224 %attr(755,root,root) %{_libdir}/kde4/kio_archive.so
225 %attr(755,root,root) %{_libdir}/kde4/kio_cgi.so
226 %attr(755,root,root) %{_libdir}/kde4/kio_filter.so
227 %attr(755,root,root) %{_libdir}/kde4/kio_finger.so
228 %attr(755,root,root) %{_libdir}/kde4/kio_fish.so
229 %attr(755,root,root) %{_libdir}/kde4/kio_floppy.so
230 %attr(755,root,root) %{_libdir}/kde4/kio_info.so
231 %attr(755,root,root) %{_libdir}/kde4/kio_man.so
232 %attr(755,root,root) %{_libdir}/kde4/kio_nepomuksearch.so
233 %attr(755,root,root) %{_libdir}/kde4/kio_network.so
234 %attr(755,root,root) %{_libdir}/kde4/kio_nfs.so
235 %attr(755,root,root) %{_libdir}/kde4/kio_recentdocuments.so
236 %attr(755,root,root) %{_libdir}/kde4/kio_remote.so
237 %attr(755,root,root) %{_libdir}/kde4/kio_settings.so
238 %attr(755,root,root) %{_libdir}/kde4/kio_sftp.so
239 %attr(755,root,root) %{_libdir}/kde4/kio_smb.so
240 %attr(755,root,root) %{_libdir}/kde4/kio_thumbnail.so
241 %attr(755,root,root) %{_libdir}/kde4/kio_timeline.so
242 %attr(755,root,root) %{_libdir}/kde4/kio_trash.so
243 %attr(755,root,root) %{_libdir}/kde4/kio_nepomuk.so
244 %attr(755,root,root) %{_libdir}/kde4/libkmanpart.so
245 %attr(755,root,root) %{_libdir}/kde4/fixhosturifilter.so
246 %attr(755,root,root) %{_libdir}/kde4/kcm_attica.so
247 %attr(755,root,root) %{_libdir}/kde4/kcm_phonon.so
248 %attr(755,root,root) %{_libdir}/kde4/kcmspellchecking.so
249 %attr(755,root,root) %{_libdir}/kde4/kshorturifilter.so
250 %attr(755,root,root) %{_libdir}/kde4/kuriikwsfilter.so
251 %attr(755,root,root) %{_libdir}/kde4/kurisearchfilter.so
252 %attr(755,root,root) %{_libdir}/kde4/localdomainurifilter.so
253 %attr(755,root,root) %{_libdir}/kde4/librenaudioplugin.so
254 %attr(755,root,root) %{_libdir}/kde4/librenimageplugin.so
255 %attr(755,root,root) %{_libdir}/kde4/plasma-kpart.so
256 %attr(755,root,root) %{_libdir}/kde4/plasma_appletscript_declarative.so
257 %attr(755,root,root) %{_libdir}/kde4/plasma_appletscript_simple_javascript.so
258 %attr(755,root,root) %{_libdir}/kde4/plasma_containment_newspaper.so
259 %attr(755,root,root) %{_libdir}/kde4/plasma_dataenginescript_javascript.so
260 %attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_javascriptaddon.so
261 %attr(755,root,root) %{_libdir}/kde4/plasma_runnerscript_javascript.so
262 %attr(755,root,root) %{_libdir}/kde4/svgthumbnail.so
263 %attr(755,root,root) %{_libdir}/kde4/textthumbnail.so
264 %attr(755,root,root) %{_libdir}/kde4/windowsexethumbnail.so
265 %attr(755,root,root) %{_libdir}/kde4/windowsimagethumbnail.so
266
267 %attr(755,root,root) %{_libdir}/kde4/imports
268
269 %attr(755,root,root) %{_libdir}/kde4/libexec/drkonqi
270 #%attr(755,root,root) %{_libdir}/kde4/libexec/installdbgsymbols.sh
271 %attr(755,root,root) %{_libdir}/kde4/libexec/kdeeject
272 %attr(755,root,root) %{_libdir}/kde4/libexec/kdesu
273 %attr(755,root,root) %{_libdir}/kde4/libexec/kdesud
274 %attr(755,root,root) %{_libdir}/kde4/libexec/kdontchangethehostname
275 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_docbookdig.pl
276 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_htdig.pl
277 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_htsearch.pl
278 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_indexbuilder
279 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_mansearch.pl
280 %attr(755,root,root) %{_libdir}/kde4/libexec/kioexec
281 #%attr(755,root,root) %{_libdir}/kde4/libexec/klocaldomainurifilterhelper
282 %attr(755,root,root) %{_libdir}/kde4/libexec/knetattach
283 %attr(755,root,root) %{_libdir}/kde4/libexec/kcmremotewidgetshelper
284 %{_sysconfdir}/dbus-1/system.d/org.kde.kcontrol.kcmremotewidgets.conf
285 %{_datadir}/dbus-1/system-services/org.kde.kcontrol.kcmremotewidgets.service
286 %{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
287 %{_desktopdir}/kde4/nepomukcontroller.desktop
288 %{_datadir}/apps/drkonqi
289 %dir %{_datadir}/apps/kcm_componentchooser
290 %{_datadir}/apps/hardwarenotifications
291 %{_datadir}/apps/kcm_componentchooser/kcm_browser.desktop
292 %{_datadir}/apps/kcm_componentchooser/kcm_filemanager.desktop
293 %{_datadir}/apps/kcm_componentchooser/kcm_kemail.desktop
294 %{_datadir}/apps/kcm_componentchooser/kcm_terminal.desktop
295 %{_datadir}/apps/kcm_componentchooser/kcm_wm.desktop
296 %{_datadir}/apps/kcmlocale
297 %{_datadir}/apps/kconf_update/kuriikwsfilter.upd
298 %{_datadir}/apps/kde/kde.notifyrc
299 %dir %{_datadir}/apps/kglobalaccel
300 %{_datadir}/apps/kglobalaccel/kglobalaccel.notifyrc
301 %{_datadir}/apps/khelpcenter
302 %{_datadir}/apps/kio_bookmarks
303 %{_datadir}/apps/kio_finger
304 %{_datadir}/apps/kio_info
305 #%{_datadir}/apps/kio_thumbnail
306 %dir %{_datadir}/apps/konqueror/dirtree
307 %dir %{_datadir}/apps/konqueror/dirtree/remote
308 %{_datadir}/apps/konqueror/dirtree/remote/smb-network.desktop
309 %dir %{_datadir}/apps/remoteview
310 %{_datadir}/apps/remoteview/smb-network.desktop
311 %{_datadir}/config.kcfg/khelpcenter.kcfg
312 %{_datadir}/config.kcfg/jpegcreatorsettings.kcfg
313 %{_datadir}/config/khotnewstuff.knsrc
314 %{_datadir}/config/icons.knsrc
315 %{_datadir}/config/emoticons.knsrc
316 %{_datadir}/config/kshorturifilterrc
317 %{_datadir}/config/khotnewstuff_upload.knsrc
318 %{_datadir}/dbus-1/services/org.kde.knotify.service
319 %{_datadir}/dbus-1/services/org.kde.kuiserver.service
320 %{_datadir}/dbus-1/interfaces/*.xml
321 %{_datadir}/emoticons/kde4
322 %{_datadir}/kde4/services/about.protocol
323 %{_datadir}/kde4/services/applications.protocol
324 %{_datadir}/kde4/services/ar.protocol
325 %{_datadir}/kde4/services/kcm_attica.desktop
326 %{_datadir}/kde4/services/bookmarks.protocol
327 %{_datadir}/kde4/services/bzip.protocol
328 %{_datadir}/kde4/services/bzip2.protocol
329 %{_datadir}/kde4/services/cgi.protocol
330 %{_datadir}/kde4/services/comicbookthumbnail.desktop
331 %{_datadir}/kde4/services/componentchooser.desktop
332 %{_datadir}/kde4/services/cursorthumbnail.desktop
333 %{_datadir}/kde4/services/device_automounter_kcm.desktop
334 %{_datadir}/kde4/services/djvuthumbnail.desktop
335 %{_datadir}/kde4/services/emoticons.desktop
336 %{_datadir}/kde4/services/exrthumbnail.desktop
337 %{_datadir}/kde4/services/finger.protocol
338 %{_datadir}/kde4/services/fish.protocol
339 %{_datadir}/kde4/services/fixhosturifilter.desktop
340 %{_datadir}/kde4/services/floppy.protocol
341 %{_datadir}/kde4/services/gzip.protocol
342 %{_datadir}/kde4/services/htmlthumbnail.desktop
343 %{_datadir}/kde4/services/icons.desktop
344 #%{_datadir}/kde4/services/jpegrotatedthumbnail.desktop
345 %{_datadir}/kde4/services/imagethumbnail.desktop
346 %{_datadir}/kde4/services/info.protocol
347 %{_datadir}/kde4/services/jpegthumbnail.desktop
348 %{_datadir}/kde4/services/kcm_kdnssd.desktop
349 %{_datadir}/kde4/services/kcmcgi.desktop
350 %{_datadir}/kde4/services/kcmkded.desktop
351 %{_datadir}/kde4/services/kcmnotify.desktop
352 %{_datadir}/kde4/services/kcmtrash.desktop
353 %{_datadir}/kde4/services/kded/device_automounter.desktop
354 %{_datadir}/kde4/services/kded/kpasswdserver.desktop
355 %{_datadir}/kde4/services/kded/ktimezoned.desktop
356 %{_datadir}/kde4/services/kded/nepomuksearchmodule.desktop
357 %{_datadir}/kde4/services/kded/networkstatus.desktop
358 %{_datadir}/kde4/services/kded/remotedirnotify.desktop
359 %{_datadir}/kde4/services/kded/soliduiserver.desktop
360 %{_datadir}/kde4/services/khelpcenter.desktop
361 %{_datadir}/kde4/services/kmanpart.desktop
362 %{_datadir}/kde4/services/knotify4.desktop
363 %{_datadir}/kde4/services/kshorturifilter.desktop
364 %{_datadir}/kde4/services/kuiserver.desktop
365 %{_datadir}/kde4/services/kuriikwsfilter.desktop
366 %{_datadir}/kde4/services/kurisearchfilter.desktop
367 %{_datadir}/kde4/services/kwalletd.desktop
368 %{_datadir}/kde4/services/language.desktop
369 %{_datadir}/kde4/services/localdomainurifilter.desktop
370 %{_datadir}/kde4/services/lzma.protocol
371 %{_datadir}/kde4/services/man.protocol
372 %{_datadir}/kde4/services/nepomuk.protocol
373 %{_datadir}/kde4/services/nfs.protocol
374 %{_datadir}/kde4/services/programs.protocol
375 %{_datadir}/kde4/services/remote.protocol
376 %{_datadir}/kde4/services/renaudiodlg.desktop
377 %{_datadir}/kde4/services/renimagedlg.desktop
378 %{_datadir}/kde4/services/searchproviders
379 %{_datadir}/kde4/services/settings.protocol
380 %{_datadir}/kde4/services/sftp.protocol
381 %{_datadir}/kde4/services/smb.protocol
382 %{_datadir}/kde4/services/svgthumbnail.desktop
383 %{_datadir}/kde4/services/tar.protocol
384 %{_datadir}/kde4/services/textthumbnail.desktop
385 %{_datadir}/kde4/services/thumbnail.protocol
386 %{_datadir}/kde4/services/timeline.protocol
387 %{_datadir}/kde4/services/trash.protocol
388 %{_datadir}/kde4/services/zip.protocol
389 %{_datadir}/kde4/services/xz.protocol
390 %{_datadir}/kde4/services/desktop.protocol
391 %{_datadir}/kde4/services/kded/desktopnotifier.desktop
392 %{_datadir}/kde4/services/desktopthumbnail.desktop
393 %{_datadir}/kde4/services/directorythumbnail.desktop
394 %{_datadir}/kde4/services/filetypes.desktop
395 %{_datadir}/kde4/services/kded/networkwatcher.desktop
396 %{_datadir}/kde4/services/kded/solidautoeject.desktop
397 %{_datadir}/kde4/services/kded/recentdocumentsnotifier.desktop
398 %{_datadir}/kde4/services/kglobalaccel.desktop
399 %{_datadir}/kde4/services/network.protocol
400 %{_datadir}/kde4/services/kcm_nepomuk.desktop
401 %{_datadir}/kde4/services/nepomuksearch.protocol
402 %{_datadir}/kde4/services/plasma-containment-newspaper.desktop
403 %{_datadir}/kde4/services/plasma-kpart.desktop
404 %{_datadir}/kde4/services/plasma-packagestructure-javascript-addon.desktop
405 %{_datadir}/kde4/services/plasma-scriptengine-applet-declarative.desktop
406 %{_datadir}/kde4/services/plasma-scriptengine-applet-simple-javascript.desktop
407 %{_datadir}/kde4/services/plasma-scriptengine-dataengine-javascript.desktop
408 %{_datadir}/kde4/services/plasma-scriptengine-runner-javascript.desktop
409 %{_datadir}/kde4/services/recentdocuments.protocol
410 %{_datadir}/kde4/services/windowsexethumbnail.desktop
411 %{_datadir}/kde4/services/windowsimagethumbnail.desktop
412 %{_datadir}/kde4/servicetypes/knotifynotifymethod.desktop
413 %{_datadir}/kde4/servicetypes/plasma-javascriptaddon.desktop
414 %{_datadir}/kde4/servicetypes/searchprovider.desktop
415 %{_datadir}/kde4/servicetypes/thumbcreator.desktop
416 %{_datadir}/desktop-directories
417 %{_datadir}/mime/packages/network.xml
418 %{_datadir}/autostart/nepomukcontroller.desktop
419
420 #%{_datadir}/locale/en_US/*
421 %dir %{_datadir}/locale/l10n
422 %{_datadir}/locale/l10n/C
423 %{_datadir}/locale/l10n/caribbean.desktop
424 %{_datadir}/locale/l10n/centralafrica.desktop
425 %{_datadir}/locale/l10n/centralamerica.desktop
426 %{_datadir}/locale/l10n/centralasia.desktop
427 %{_datadir}/locale/l10n/centraleurope.desktop
428 %{_datadir}/locale/l10n/eastafrica.desktop
429 %{_datadir}/locale/l10n/eastasia.desktop
430 %{_datadir}/locale/l10n/easteurope.desktop
431 %{_datadir}/locale/l10n/middleeast.desktop
432 %{_datadir}/locale/l10n/northafrica.desktop
433 %{_datadir}/locale/l10n/northamerica.desktop
434 %{_datadir}/locale/l10n/northeurope.desktop
435 %{_datadir}/locale/l10n/oceania.desktop
436 %{_datadir}/locale/l10n/southafrica.desktop
437 %{_datadir}/locale/l10n/southamerica.desktop
438 %{_datadir}/locale/l10n/southasia.desktop
439 %{_datadir}/locale/l10n/southeastasia.desktop
440 %{_datadir}/locale/l10n/southeurope.desktop
441 %{_datadir}/locale/l10n/westafrica.desktop
442 %{_datadir}/locale/l10n/westeurope.desktop
443 # really?
444 %{_datadir}/locale/currency
445
446 %{_desktopdir}/kde4/Help.desktop
447 %{_desktopdir}/kde4/knetattach.desktop
448 %lang(en) %{_kdedocdir}/en/kcontrol/*
449 %lang(en) %{_kdedocdir}/en/kdebugdialog
450 %lang(en) %{_kdedocdir}/en/kdesu
451 %lang(en) %{_kdedocdir}/en/khelpcenter
452 %lang(en) %{_kdedocdir}/en/kioslave/bzip2
453 %lang(en) %{_kdedocdir}/en/kioslave/bookmarks
454 %lang(en) %{_kdedocdir}/en/kioslave/cgi
455 %lang(en) %{_kdedocdir}/en/kioslave/finger
456 %lang(en) %{_kdedocdir}/en/kioslave/fish
457 %lang(en) %{_kdedocdir}/en/kioslave/floppy
458 %lang(en) %{_kdedocdir}/en/kioslave/gzip
459 %lang(en) %{_kdedocdir}/en/kioslave/info
460 %lang(en) %{_kdedocdir}/en/kioslave/man
461 %lang(en) %{_kdedocdir}/en/kioslave/nfs
462 %lang(en) %{_kdedocdir}/en/kioslave/sftp
463 %lang(en) %{_kdedocdir}/en/kioslave/smb
464 %lang(en) %{_kdedocdir}/en/kioslave/tar
465 %lang(en) %{_kdedocdir}/en/kioslave/thumbnail
466 %lang(en) %{_kdedocdir}/en/knetattach
467 %lang(en) %{_kdedocdir}/en/network
468 %lang(en) %{_mandir}/man1/kdesu.1*
469 %lang(en) %{_mandir}/man8/nepomuk*.8*
470
471 %{_datadir}/sounds/*
472 %{_iconsdir}/hicolor/*/*/*.png
473 %dir %{_datadir}/apps/ksmserver
474 %dir %{_datadir}/apps/ksmserver/windowmanagers
475 %{_datadir}/apps/ksmserver/windowmanagers/compiz-custom.desktop
476 %{_datadir}/apps/ksmserver/windowmanagers/compiz.desktop
477 %{_datadir}/apps/ksmserver/windowmanagers/metacity.desktop
478 %{_datadir}/apps/ksmserver/windowmanagers/openbox.desktop
479 %{_datadir}/apps/kio_docfilter
480 %dir %{_datadir}/apps/konqsidebartng
481 %dir %{_datadir}/apps/konqsidebartng/virtual_folders
482 %dir %{_datadir}/apps/konqsidebartng/virtual_folders/remote
483 %{_datadir}/apps/konqsidebartng/virtual_folders/remote/virtualfolder_network.desktop
484 %{_datadir}/apps/kwalletd
485 %{_datadir}/apps/remoteview/network.desktop
486
487 # dir owned by kdelibs
488 %{_datadir}/apps/desktoptheme/default/*
489 %{_datadir}/apps/desktoptheme/oxygen
490 %{_datadir}/apps/desktoptheme/appdashboard
491
492 %files devel
493 %defattr(644,root,root,755)
494 %{_includedir}/knotify*.h
495 %attr(755,root,root) %{_libdir}/libkwalletbackend.so
496 %attr(755,root,root) %{_libdir}/libmolletnetwork.so
497 %{_datadir}/apps/cmake/modules/FindCLucene.cmake
498 %{_datadir}/apps/cmake/modules/FindSLP.cmake
499
500 %files -n kde4-phonon
501 %defattr(644,root,root,755)
502 %attr(755,root,root) %{_libdir}/kconf_update_bin/phonon_devicepreference_update
503 %attr(755,root,root) %{_libdir}/kconf_update_bin/phonon_deviceuids_update
504 %attr(755,root,root) %{_libdir}/kde4/kded_phononserver.so
505 %attr(755,root,root) %{_libdir}/kde4/kcm_phononxine.so
506 %{_datadir}/kde4/services/kcm_phonon.desktop
507 %{_datadir}/kde4/services/spellchecking.desktop
508 %{_datadir}/kde4/servicetypes/phononbackend.desktop
509 %{_datadir}/kde4/services/kcm_phononxine.desktop
510
511 %dir %{_libdir}/kde4/plugins/phonon_platform
512 %{_libdir}/kde4/plugins/phonon_platform/kde.so
513 %dir %{_datadir}/apps/kcm_phonon
514 %{_datadir}/apps/kcm_phonon/listview-background.png
515 %{_datadir}/apps/kconf_update/devicepreference.upd
516 %dir %{_datadir}/apps/libphonon
517 %{_datadir}/apps/libphonon/hardwaredatabase
518 %dir %{_datadir}/apps/phonon
519 %{_datadir}/apps/phonon/phonon.notifyrc
520 %dir %{_datadir}/apps/kio_desktop
521 %dir %{_datadir}/apps/kio_desktop/DesktopLinks
522 %{_datadir}/apps/kio_desktop/DesktopLinks/Home.desktop
523 %{_datadir}/apps/kio_desktop/directory.desktop
524 %{_datadir}/apps/kio_desktop/directory.trash
525 %{_datadir}/kde4/services/kded/phononserver.desktop
This page took 0.057442 seconds and 3 git commands to generate.