]> git.pld-linux.org Git - packages/kde4-kdebase-runtime.git/blob - kde4-kdebase-runtime.spec
- up to 4.7.0
[packages/kde4-kdebase-runtime.git] / kde4-kdebase-runtime.spec
1 # TODO
2 # - l10n != %lang glibc locales (et = etiopia not estonia!)
3 #
4 # Conditional build:
5 #
6 %define         _state          stable
7 %define         orgname         kde-runtime
8 %define         qtver           4.7.3
9 %define         atticaver       0.2.0
10
11 Summary:        KDE 4 base runtime components
12 Summary(pl.UTF-8):      Komponenty uruchomieniowe podstawowej części KDE 4
13 Name:           kde4-kdebase-runtime
14 Version:        4.7.0
15 Release:        1
16 License:        GPL
17 Group:          X11/Applications
18 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
19 # Source0-md5:  c4e0fe5c417d276daf41fb07f816f584
20 Source1:        kdebase-searchproviders.tar.bz2
21 # Source1-md5:  126c3524b5367f5096a628acbf9dc86f
22 Source2:        l10n-iso639-1
23 Patch100:       %{name}-branch.diff
24 Patch0:         %{name}-rpc.patch
25 URL:            http://www.kde.org/
26 BuildRequires:  OpenEXR-devel
27 BuildRequires:  alsa-lib-devel
28 BuildRequires:  attica-devel >= %{atticaver}
29 BuildRequires:  automoc4 >= 0.9.88
30 BuildRequires:  bzip2-devel
31 BuildRequires:  clucene-core-devel >= 0.9.21
32 BuildRequires:  cmake >= 2.8.0
33 BuildRequires:  exiv2-devel >= 0.18.2
34 BuildRequires:  kde4-kdelibs-devel >= %{version}
35 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
36 BuildRequires:  libcanberra-devel
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  libqzeitgeist-devel
39 BuildRequires:  libsmbclient-devel
40 BuildRequires:  libssh-devel >= 1:0.4.0
41 BuildRequires:  libtirpc-devel
42 BuildRequires:  ntrack-devel
43 BuildRequires:  openslp-devel
44 BuildRequires:  phonon-devel >= 4.4.3
45 BuildRequires:  pkgconfig
46 BuildRequires:  pulseaudio-devel
47 BuildRequires:  qt4-build >= %{qtver}
48 BuildRequires:  qt4-qmake >= %{qtver}
49 BuildRequires:  rpmbuild(macros) >= 1.600
50 BuildRequires:  shared-desktop-ontologies-devel >= 0.7.1
51 BuildRequires:  soprano-devel >= 2.6.51
52 BuildRequires:  strigi-devel >= 0.7.0
53 BuildRequires:  xine-lib-devel
54 BuildRequires:  xz-devel
55 Requires:       attica >= %{atticaver}
56 Provides:       dbus(org.freedesktop.Notifications)
57 Obsoletes:      kdebase4-runtime
58 Conflicts:      kdebase4-runtime
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 KDE 4 runtime components.
63
64 %description -l pl.UTF-8
65 Komponenty uruchomieniowe podstawowej części KDE 4.
66
67 %package devel
68 Summary:        Development files for KDE 4 runtime components
69 Summary(pl.UTF-8):      Pliki programistyczne komponentów uruchomieniowych KDE 4
70 Group:          X11/Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       kde4-kdelibs-devel >= %{version}
73
74 %description devel
75 Development files for KDE 4 runtime components.
76
77 %description devel -l pl.UTF-8
78 Pliki programistyczne komponentów uruchomieniowych KDE 4.
79
80 %package -n kde4-phonon
81 Summary:        KDE 4 Phonon plugins
82 Summary(pl.UTF-8):      Wtyczki KDE 4 dla Phonona
83 Group:          X11/Applications
84
85 %description -n kde4-phonon
86 KDE 4 Phonon plugins.
87
88 %description -n kde4-phonon -l pl.UTF-8
89 Wtyczki KDE 4 dla Phonona.
90
91 %prep
92 %setup -q -n %{orgname}-%{version} -a1
93 #%patch100 -p1
94 %patch0 -p1
95
96 %build
97 install -d build
98 cd build
99 %cmake \
100         -DLIBEXEC_INSTALL_DIR=%{_libdir}/kde4/libexec \
101         ../
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} -C build install \
109         DESTDIR=$RPM_BUILD_ROOT \
110         kde_htmldir=%{_kdedocdir}
111
112 install -d $RPM_BUILD_ROOT%{_datadir}/kde4/services/searchproviders/pld
113 cp -a kdebase-searchproviders/*.desktop $RPM_BUILD_ROOT%{_datadir}/kde4/services/searchproviders/pld
114
115 collect_l10n_files() {
116         while read country language comment; do
117                 [ "$country" != "#" ] || continue
118                 if [ "$language" = "-" ]; then
119                         # no mapping. just add for now
120                         echo >&2 "No mapping for $country $comment, adding without %%lang tag"
121                         echo "%{_datadir}/locale/l10n/$country"
122                 else
123                         echo "%lang($language) %{_datadir}/locale/l10n/$country"
124                 fi
125         done
126 } < %{SOURCE2}
127 collect_l10n_files > %{name}.files
128
129 rm -f $RPM_BUILD_ROOT%{_datadir}/icons/default.kde4
130 # provided (conflicts) by hicolor-icon-theme
131 rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -p /sbin/ldconfig
137 %postun -p /sbin/ldconfig
138
139 %files -f %{name}.files
140 %defattr(644,root,root,755)
141 %{_sysconfdir}/xdg/menus/kde-information.menu
142 %attr(755,root,root) %{_bindir}/kactivitymanagerd
143 %attr(755,root,root) %{_bindir}/kcmshell4
144 %attr(755,root,root) %{_bindir}/kde-cp
145 %attr(755,root,root) %{_bindir}/kde-mv
146 %attr(755,root,root) %{_bindir}/kde-open
147 %attr(755,root,root) %{_bindir}/kde4-menu
148 %attr(755,root,root) %{_bindir}/kdebugdialog
149 %attr(755,root,root) %{_bindir}/kfile4
150 %attr(755,root,root) %{_bindir}/kiconfinder
151 %attr(755,root,root) %{_bindir}/khelpcenter
152 %attr(755,root,root) %{_bindir}/khotnewstuff4
153 %attr(755,root,root) %{_bindir}/khotnewstuff-upload
154 %attr(755,root,root) %{_bindir}/kioclient
155 %attr(755,root,root) %{_bindir}/kmimetypefinder
156 %attr(755,root,root) %{_bindir}/knotify4
157 %attr(755,root,root) %{_bindir}/kquitapp
158 %attr(755,root,root) %{_bindir}/kreadconfig
159 %attr(755,root,root) %{_bindir}/kstart
160 %attr(755,root,root) %{_bindir}/kde4
161 %attr(755,root,root) %{_bindir}/kwalletd
162 %attr(755,root,root) %{_bindir}/ksvgtopng
163 %attr(755,root,root) %{_bindir}/keditfiletype
164 %attr(755,root,root) %{_bindir}/kglobalaccel
165 %attr(755,root,root) %{_bindir}/ktraderclient
166 %attr(755,root,root) %{_bindir}/ktrash
167 %attr(755,root,root) %{_bindir}/kuiserver
168 %attr(755,root,root) %{_bindir}/kwriteconfig
169 %attr(755,root,root) %{_bindir}/solid-hardware
170 %attr(755,root,root) %{_bindir}/nepomukbackup
171 %attr(755,root,root) %{_bindir}/nepomukcontroller
172 %attr(755,root,root) %{_bindir}/nepomukindexer
173 %attr(755,root,root) %{_bindir}/nepomukserver
174 %attr(755,root,root) %{_bindir}/nepomukservicestub
175 %attr(755,root,root) %{_bindir}/plasma-remote-helper
176 %attr(755,root,root) %{_bindir}/plasmapkg
177 %attr(755,root,root) %{_libdir}/attica_kde.so
178 %attr(755,root,root) %{_libdir}/libkdeinit4_kcmshell4.so
179 %attr(755,root,root) %{_libdir}/libkdeinit4_khelpcenter.so
180 %attr(755,root,root) %{_libdir}/libkdeinit4_kuiserver.so
181 %attr(755,root,root) %{_libdir}/libkdeinit4_kwalletd.so
182 %attr(755,root,root) %{_libdir}/libkdeinit4_kglobalaccel.so
183 %attr(755,root,root) %{_libdir}/libkdeinit4_nepomukserver.so
184 %attr(755,root,root) %{_libdir}/libknotifyplugin.so
185 %attr(755,root,root) %{_libdir}/libnepomukcommon.so
186 %attr(755,root,root) %{_libdir}/libnepomukdatamanagement.so
187 %attr(755,root,root) %{_libdir}/libnepomuksync.so.?
188 %attr(755,root,root) %{_libdir}/libnepomuksync.so.*.*.*
189 # Is it ok to add those files to main package?
190 %attr(755,root,root) %ghost %{_libdir}/libkwalletbackend.so.?
191 %attr(755,root,root) %{_libdir}/libkwalletbackend.so.*.*.*
192 %attr(755,root,root) %ghost %{_libdir}/libmolletnetwork.so.?
193 %attr(755,root,root) %{_libdir}/libmolletnetwork.so.4.*.*
194 %attr(755,root,root) %{_libdir}/kde4/comicbookthumbnail.so
195 %attr(755,root,root) %{_libdir}/kde4/cursorthumbnail.so
196 %attr(755,root,root) %{_libdir}/kde4/djvuthumbnail.so
197 %attr(755,root,root) %{_libdir}/kde4/exrthumbnail.so
198 %attr(755,root,root) %{_libdir}/kde4/htmlthumbnail.so
199 %attr(755,root,root) %{_libdir}/kde4/imagethumbnail.so
200 #%attr(755,root,root) %{_libdir}/kde4/jpegrotatedthumbnail.so
201 %attr(755,root,root) %{_libdir}/kde4/jpegthumbnail.so
202 %attr(755,root,root) %{_libdir}/kde4/kcm_cgi.so
203 %attr(755,root,root) %{_libdir}/kde4/kcm_componentchooser.so
204 %attr(755,root,root) %{_libdir}/kde4/kcm_device_automounter.so
205 %attr(755,root,root) %{_libdir}/kde4/kcm_emoticons.so
206 %attr(755,root,root) %{_libdir}/kde4/kcm_filetypes.so
207 %attr(755,root,root) %{_libdir}/kde4/kcm_icons.so
208 %attr(755,root,root) %{_libdir}/kde4/kcm_kded.so
209 %attr(755,root,root) %{_libdir}/kde4/kcm_kdnssd.so
210 %attr(755,root,root) %{_libdir}/kde4/kcm_knotify.so
211 %attr(755,root,root) %{_libdir}/kde4/kcm_locale.so
212 %attr(755,root,root) %{_libdir}/kde4/kcm_nepomuk.so
213 %attr(755,root,root) %{_libdir}/kde4/kcm_trash.so
214 #%attr(755,root,root) %{_libdir}/kde4/kded_activitymanager.so
215 %attr(755,root,root) %{_libdir}/kde4/kded_device_automounter.so
216 %attr(755,root,root) %{_libdir}/kde4/kded_kpasswdserver.so
217 %attr(755,root,root) %{_libdir}/kde4/kded_ktimezoned.so
218 %attr(755,root,root) %{_libdir}/kde4/kded_remotedirnotify.so
219 %attr(755,root,root) %{_libdir}/kde4/kded_soliduiserver.so
220 %attr(755,root,root) %{_libdir}/kde4/kded_desktopnotifier.so
221 %attr(755,root,root) %{_libdir}/kde4/kded_nepomuksearchmodule.so
222 %attr(755,root,root) %{_libdir}/kde4/kded_networkstatus.so
223 %attr(755,root,root) %{_libdir}/kde4/kded_networkwatcher.so
224 %attr(755,root,root) %{_libdir}/kde4/kded_solidautoeject.so
225 %attr(755,root,root) %{_libdir}/kde4/kio_applications.so
226 %attr(755,root,root) %{_libdir}/kde4/kio_bookmarks.so
227 %attr(755,root,root) %{_libdir}/kde4/kio_desktop.so
228 %attr(755,root,root) %{_libdir}/kde4/kio_about.so
229 %attr(755,root,root) %{_libdir}/kde4/kio_archive.so
230 %attr(755,root,root) %{_libdir}/kde4/kio_cgi.so
231 %attr(755,root,root) %{_libdir}/kde4/kio_filter.so
232 %attr(755,root,root) %{_libdir}/kde4/kio_finger.so
233 %attr(755,root,root) %{_libdir}/kde4/kio_fish.so
234 %attr(755,root,root) %{_libdir}/kde4/kio_floppy.so
235 %attr(755,root,root) %{_libdir}/kde4/kio_info.so
236 %attr(755,root,root) %{_libdir}/kde4/kio_man.so
237 %attr(755,root,root) %{_libdir}/kde4/kio_nepomuksearch.so
238 %attr(755,root,root) %{_libdir}/kde4/kio_network.so
239 %attr(755,root,root) %{_libdir}/kde4/kio_nfs.so
240 %attr(755,root,root) %{_libdir}/kde4/kio_remote.so
241 %attr(755,root,root) %{_libdir}/kde4/kio_settings.so
242 %attr(755,root,root) %{_libdir}/kde4/kio_sftp.so
243 %attr(755,root,root) %{_libdir}/kde4/kio_smb.so
244 %attr(755,root,root) %{_libdir}/kde4/kio_thumbnail.so
245 %attr(755,root,root) %{_libdir}/kde4/kio_timeline.so
246 %attr(755,root,root) %{_libdir}/kde4/kio_trash.so
247 %attr(755,root,root) %{_libdir}/kde4/kio_nepomuk.so
248 %attr(755,root,root) %{_libdir}/kde4/libkmanpart.so
249 %attr(755,root,root) %{_libdir}/kde4/fixhosturifilter.so
250 %attr(755,root,root) %{_libdir}/kde4/kcm_attica.so
251 %attr(755,root,root) %{_libdir}/kde4/kcm_phonon.so
252 %attr(755,root,root) %{_libdir}/kde4/kcmspellchecking.so
253 %attr(755,root,root) %{_libdir}/kde4/kshorturifilter.so
254 %attr(755,root,root) %{_libdir}/kde4/kuriikwsfilter.so
255 %attr(755,root,root) %{_libdir}/kde4/kurisearchfilter.so
256 %attr(755,root,root) %{_libdir}/kde4/localdomainurifilter.so
257 %attr(755,root,root) %{_libdir}/kde4/librenaudioplugin.so
258 %attr(755,root,root) %{_libdir}/kde4/librenimageplugin.so
259 #%attr(755,root,root) %{_libdir}/kde4/nepomukactivitiesservice.so
260 %attr(755,root,root) %{_libdir}/kde4/nepomukbackupsync.so
261 %attr(755,root,root) %{_libdir}/kde4/nepomukfilewatch.so
262 #%attr(755,root,root) %{_libdir}/kde4/nepomukmigration1.so
263 #%attr(755,root,root) %{_libdir}/kde4/nepomukontologyloader.so
264 %attr(755,root,root) %{_libdir}/kde4/nepomukqueryservice.so
265 #%attr(755,root,root) %{_libdir}/kde4/nepomukremovablestorageservice.so
266 %attr(755,root,root) %{_libdir}/kde4/nepomukstorage.so
267 %attr(755,root,root) %{_libdir}/kde4/nepomukstrigiservice.so
268 %attr(755,root,root) %{_libdir}/kde4/plasma-kpart.so
269 %attr(755,root,root) %{_libdir}/kde4/plasma_appletscript_declarative.so
270 %attr(755,root,root) %{_libdir}/kde4/plasma_appletscript_simple_javascript.so
271 %attr(755,root,root) %{_libdir}/kde4/plasma_containment_newspaper.so
272 %attr(755,root,root) %{_libdir}/kde4/plasma_dataenginescript_javascript.so
273 %attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_javascriptaddon.so
274 %attr(755,root,root) %{_libdir}/kde4/plasma_runnerscript_javascript.so
275 %attr(755,root,root) %{_libdir}/kde4/svgthumbnail.so
276 %attr(755,root,root) %{_libdir}/kde4/textthumbnail.so
277 %attr(755,root,root) %{_libdir}/kde4/windowsexethumbnail.so
278 %attr(755,root,root) %{_libdir}/kde4/windowsimagethumbnail.so
279
280 %attr(755,root,root) %{_libdir}/kde4/imports
281
282 %attr(755,root,root) %{_libdir}/kde4/libexec/drkonqi
283 #%attr(755,root,root) %{_libdir}/kde4/libexec/installdbgsymbols.sh
284 %attr(755,root,root) %{_libdir}/kde4/libexec/kdeeject
285 %attr(755,root,root) %{_libdir}/kde4/libexec/kdesu
286 %attr(755,root,root) %{_libdir}/kde4/libexec/kdesud
287 %attr(755,root,root) %{_libdir}/kde4/libexec/kdontchangethehostname
288 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_docbookdig.pl
289 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_htdig.pl
290 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_htsearch.pl
291 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_indexbuilder
292 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_mansearch.pl
293 %attr(755,root,root) %{_libdir}/kde4/libexec/kioexec
294 #%attr(755,root,root) %{_libdir}/kde4/libexec/klocaldomainurifilterhelper
295 %attr(755,root,root) %{_libdir}/kde4/libexec/knetattach
296 #%attr(755,root,root) %{_libdir}/strigi/strigiindex_nepomukbackend.so
297 %attr(755,root,root) %{_libdir}/kde4/libexec/kcmremotewidgetshelper
298 %{_sysconfdir}/dbus-1/system.d/org.kde.kcontrol.kcmremotewidgets.conf
299 %{_desktopdir}/kde4/nepomukbackup.desktop
300 %{_desktopdir}/kde4/nepomukcontroller.desktop
301 %{_datadir}/dbus-1/system-services/org.kde.kcontrol.kcmremotewidgets.service
302 %{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
303 %{_datadir}/apps/drkonqi
304 %dir %{_datadir}/apps/kcm_componentchooser
305 %{_datadir}/apps/hardwarenotifications
306 %{_datadir}/apps/kcm_componentchooser/kcm_browser.desktop
307 %{_datadir}/apps/kcm_componentchooser/kcm_filemanager.desktop
308 %{_datadir}/apps/kcm_componentchooser/kcm_kemail.desktop
309 %{_datadir}/apps/kcm_componentchooser/kcm_terminal.desktop
310 %{_datadir}/apps/kcm_componentchooser/kcm_wm.desktop
311 %{_datadir}/apps/kcmlocale
312 %{_datadir}/apps/kconf_update/kuriikwsfilter.upd
313 %{_datadir}/apps/kde/kde.notifyrc
314 %dir %{_datadir}/apps/kglobalaccel
315 %{_datadir}/apps/kglobalaccel/kglobalaccel.notifyrc
316 %{_datadir}/apps/khelpcenter
317 %{_datadir}/apps/kio_bookmarks
318 %{_datadir}/apps/kio_finger
319 %{_datadir}/apps/kio_info
320 #%{_datadir}/apps/kio_thumbnail
321 %dir %{_datadir}/apps/konqueror/dirtree
322 %dir %{_datadir}/apps/konqueror/dirtree/remote
323 %{_datadir}/apps/konqueror/dirtree/remote/smb-network.desktop
324 %dir %{_datadir}/apps/remoteview
325 %{_datadir}/apps/remoteview/smb-network.desktop
326 #%dir %{_datadir}/apps/nepomuk
327 #%dir %{_datadir}/apps/nepomuk/ontologies
328 #%{_datadir}/apps/nepomuk/ontologies/*
329 %{_datadir}/apps/nepomukfilewatch
330 %dir %{_datadir}/apps/nepomukstorage
331 %{_datadir}/apps/nepomukstorage/nepomukstorage.notifyrc
332 %dir %{_datadir}/apps/nepomukstrigiservice
333 %{_datadir}/apps/nepomukstrigiservice/nepomukstrigiservice.notifyrc
334 %{_datadir}/config.kcfg/khelpcenter.kcfg
335 %{_datadir}/config.kcfg/jpegcreatorsettings.kcfg
336 %{_datadir}/config/khotnewstuff.knsrc
337 %{_datadir}/config/icons.knsrc
338 %{_datadir}/config/emoticons.knsrc
339 %{_datadir}/config/kshorturifilterrc
340 %{_datadir}/config/khotnewstuff_upload.knsrc
341 %{_datadir}/dbus-1/services/org.kde.knotify.service
342 %{_datadir}/dbus-1/services/org.kde.kuiserver.service
343 %{_datadir}/dbus-1/interfaces/*.xml
344 %{_datadir}/emoticons/kde4
345 %{_datadir}/kde4/services/about.protocol
346 %{_datadir}/kde4/services/applications.protocol
347 %{_datadir}/kde4/services/ar.protocol
348 %{_datadir}/kde4/services/kcm_attica.desktop
349 %{_datadir}/kde4/services/bookmarks.protocol
350 %{_datadir}/kde4/services/bzip.protocol
351 %{_datadir}/kde4/services/bzip2.protocol
352 %{_datadir}/kde4/services/cgi.protocol
353 %{_datadir}/kde4/services/comicbookthumbnail.desktop
354 %{_datadir}/kde4/services/componentchooser.desktop
355 %{_datadir}/kde4/services/cursorthumbnail.desktop
356 %{_datadir}/kde4/services/device_automounter_kcm.desktop
357 %{_datadir}/kde4/services/djvuthumbnail.desktop
358 %{_datadir}/kde4/services/emoticons.desktop
359 %{_datadir}/kde4/services/exrthumbnail.desktop
360 %{_datadir}/kde4/services/finger.protocol
361 %{_datadir}/kde4/services/fish.protocol
362 %{_datadir}/kde4/services/fixhosturifilter.desktop
363 %{_datadir}/kde4/services/floppy.protocol
364 %{_datadir}/kde4/services/gzip.protocol
365 %{_datadir}/kde4/services/htmlthumbnail.desktop
366 %{_datadir}/kde4/services/icons.desktop
367 #%{_datadir}/kde4/services/jpegrotatedthumbnail.desktop
368 %{_datadir}/kde4/services/imagethumbnail.desktop
369 %{_datadir}/kde4/services/info.protocol
370 %{_datadir}/kde4/services/jpegthumbnail.desktop
371 %{_datadir}/kde4/services/kactivitymanagerd.desktop
372 %{_datadir}/kde4/services/kcm_kdnssd.desktop
373 %{_datadir}/kde4/services/kcmcgi.desktop
374 %{_datadir}/kde4/services/kcmkded.desktop
375 %{_datadir}/kde4/services/kcmnotify.desktop
376 %{_datadir}/kde4/services/kcmtrash.desktop
377 %{_datadir}/kde4/services/kded/activitymanager.desktop
378 %{_datadir}/kde4/services/kded/device_automounter.desktop
379 %{_datadir}/kde4/services/kded/kpasswdserver.desktop
380 %{_datadir}/kde4/services/kded/ktimezoned.desktop
381 %{_datadir}/kde4/services/kded/nepomuksearchmodule.desktop
382 %{_datadir}/kde4/services/kded/networkstatus.desktop
383 %{_datadir}/kde4/services/kded/remotedirnotify.desktop
384 %{_datadir}/kde4/services/kded/soliduiserver.desktop
385 %{_datadir}/kde4/services/khelpcenter.desktop
386 %{_datadir}/kde4/services/kmanpart.desktop
387 %{_datadir}/kde4/services/knotify4.desktop
388 %{_datadir}/kde4/services/kshorturifilter.desktop
389 %{_datadir}/kde4/services/kuiserver.desktop
390 %{_datadir}/kde4/services/kuriikwsfilter.desktop
391 %{_datadir}/kde4/services/kurisearchfilter.desktop
392 %{_datadir}/kde4/services/kwalletd.desktop
393 %{_datadir}/kde4/services/language.desktop
394 %{_datadir}/kde4/services/localdomainurifilter.desktop
395 %{_datadir}/kde4/services/lzma.protocol
396 %{_datadir}/kde4/services/man.protocol
397 %{_datadir}/kde4/services/nepomuk.protocol
398 %{_datadir}/kde4/services/nepomukactivitiesservice.desktop
399 %{_datadir}/kde4/services/nepomukbackupsync.desktop
400 %{_datadir}/kde4/services/nepomukremovablestorageservice.desktop
401 %{_datadir}/kde4/services/nfs.protocol
402 %{_datadir}/kde4/services/programs.protocol
403 %{_datadir}/kde4/services/remote.protocol
404 %{_datadir}/kde4/services/renaudiodlg.desktop
405 %{_datadir}/kde4/services/renimagedlg.desktop
406 %{_datadir}/kde4/services/searchproviders
407 %{_datadir}/kde4/services/settings.protocol
408 %{_datadir}/kde4/services/sftp.protocol
409 %{_datadir}/kde4/services/smb.protocol
410 %{_datadir}/kde4/services/svgthumbnail.desktop
411 %{_datadir}/kde4/services/tar.protocol
412 %{_datadir}/kde4/services/textthumbnail.desktop
413 %{_datadir}/kde4/services/thumbnail.protocol
414 %{_datadir}/kde4/services/timeline.protocol
415 %{_datadir}/kde4/services/trash.protocol
416 %{_datadir}/kde4/services/zip.protocol
417 %{_datadir}/kde4/services/xz.protocol
418 %{_datadir}/kde4/services/desktop.protocol
419 %{_datadir}/kde4/services/kded/desktopnotifier.desktop
420 %{_datadir}/kde4/services/desktopthumbnail.desktop
421 %{_datadir}/kde4/services/directorythumbnail.desktop
422 %{_datadir}/kde4/services/filetypes.desktop
423 %{_datadir}/kde4/services/kded/networkwatcher.desktop
424 %{_datadir}/kde4/services/kded/solidautoeject.desktop
425 %{_datadir}/kde4/services/kglobalaccel.desktop
426 %{_datadir}/kde4/services/network.protocol
427 %{_datadir}/kde4/services/kcm_nepomuk.desktop
428 %{_datadir}/kde4/services/nepomukfilewatch.desktop
429 #%{_daetadir}/kde4/services/nepomukmigration1.desktop
430 %{_datadir}/kde4/services/nepomukontologyloader.desktop
431 %{_datadir}/kde4/services/nepomukqueryservice.desktop
432 %{_datadir}/kde4/services/nepomuksearch.protocol
433 %{_datadir}/kde4/services/nepomukstorage.desktop
434 %{_datadir}/kde4/services/nepomukstrigiservice.desktop
435 %{_datadir}/kde4/services/plasma-containment-newspaper.desktop
436 %{_datadir}/kde4/services/plasma-kpart.desktop
437 %{_datadir}/kde4/services/plasma-packagestructure-javascript-addon.desktop
438 %{_datadir}/kde4/services/plasma-scriptengine-applet-declarative.desktop
439 %{_datadir}/kde4/services/plasma-scriptengine-applet-simple-javascript.desktop
440 %{_datadir}/kde4/services/plasma-scriptengine-dataengine-javascript.desktop
441 %{_datadir}/kde4/services/plasma-scriptengine-runner-javascript.desktop
442 %{_datadir}/kde4/services/windowsexethumbnail.desktop
443 %{_datadir}/kde4/services/windowsimagethumbnail.desktop
444 %{_datadir}/kde4/servicetypes/knotifynotifymethod.desktop
445 %{_datadir}/kde4/servicetypes/nepomukservice.desktop
446 %{_datadir}/kde4/servicetypes/plasma-javascriptaddon.desktop
447 %{_datadir}/kde4/servicetypes/searchprovider.desktop
448 %{_datadir}/kde4/servicetypes/thumbcreator.desktop
449 %{_datadir}/desktop-directories
450 %{_datadir}/mime/packages/network.xml
451 %{_datadir}/autostart/nepomukcontroller.desktop
452 %{_datadir}/autostart/nepomukserver.desktop
453
454 %dir %{_datadir}/ontology/kde
455 %{_datadir}/ontology/kde/*.ontology
456 %{_datadir}/ontology/kde/*.trig
457
458 #%{_datadir}/locale/en_US/*
459 %dir %{_datadir}/locale/l10n
460 %{_datadir}/locale/l10n/C
461 %{_datadir}/locale/l10n/caribbean.desktop
462 %{_datadir}/locale/l10n/centralafrica.desktop
463 %{_datadir}/locale/l10n/centralamerica.desktop
464 %{_datadir}/locale/l10n/centralasia.desktop
465 %{_datadir}/locale/l10n/centraleurope.desktop
466 %{_datadir}/locale/l10n/eastafrica.desktop
467 %{_datadir}/locale/l10n/eastasia.desktop
468 %{_datadir}/locale/l10n/easteurope.desktop
469 %{_datadir}/locale/l10n/middleeast.desktop
470 %{_datadir}/locale/l10n/northafrica.desktop
471 %{_datadir}/locale/l10n/northamerica.desktop
472 %{_datadir}/locale/l10n/northeurope.desktop
473 %{_datadir}/locale/l10n/oceania.desktop
474 %{_datadir}/locale/l10n/southafrica.desktop
475 %{_datadir}/locale/l10n/southamerica.desktop
476 %{_datadir}/locale/l10n/southasia.desktop
477 %{_datadir}/locale/l10n/southeastasia.desktop
478 %{_datadir}/locale/l10n/southeurope.desktop
479 %{_datadir}/locale/l10n/westafrica.desktop
480 %{_datadir}/locale/l10n/westeurope.desktop
481 # really?
482 %{_datadir}/locale/currency
483
484 %{_desktopdir}/kde4/Help.desktop
485 %{_desktopdir}/kde4/knetattach.desktop
486 %lang(en) %{_kdedocdir}/en/kcontrol/*
487 %lang(en) %{_kdedocdir}/en/kdebugdialog
488 %lang(en) %{_kdedocdir}/en/kdesu
489 %lang(en) %{_kdedocdir}/en/khelpcenter
490 %lang(en) %{_kdedocdir}/en/kioslave/bzip2
491 %lang(en) %{_kdedocdir}/en/kioslave/bookmarks
492 %lang(en) %{_kdedocdir}/en/kioslave/cgi
493 %lang(en) %{_kdedocdir}/en/kioslave/finger
494 %lang(en) %{_kdedocdir}/en/kioslave/fish
495 %lang(en) %{_kdedocdir}/en/kioslave/floppy
496 %lang(en) %{_kdedocdir}/en/kioslave/gzip
497 %lang(en) %{_kdedocdir}/en/kioslave/info
498 %lang(en) %{_kdedocdir}/en/kioslave/man
499 %lang(en) %{_kdedocdir}/en/kioslave/nfs
500 %lang(en) %{_kdedocdir}/en/kioslave/sftp
501 %lang(en) %{_kdedocdir}/en/kioslave/smb
502 %lang(en) %{_kdedocdir}/en/kioslave/tar
503 %lang(en) %{_kdedocdir}/en/kioslave/thumbnail
504 %lang(en) %{_kdedocdir}/en/knetattach
505 %lang(en) %{_kdedocdir}/en/network
506 %lang(en) %{_mandir}/man1/kdesu.1*
507 %lang(en) %{_mandir}/man8/nepomuk*.8*
508
509 %{_datadir}/sounds/*
510 %{_iconsdir}/hicolor/*/*/*.png
511 %dir %{_datadir}/apps/ksmserver
512 %dir %{_datadir}/apps/ksmserver/windowmanagers
513 %{_datadir}/apps/ksmserver/windowmanagers/compiz-custom.desktop
514 %{_datadir}/apps/ksmserver/windowmanagers/compiz.desktop
515 %{_datadir}/apps/ksmserver/windowmanagers/metacity.desktop
516 %{_datadir}/apps/ksmserver/windowmanagers/openbox.desktop
517 %{_datadir}/apps/kio_docfilter
518 %dir %{_datadir}/apps/konqsidebartng
519 %dir %{_datadir}/apps/konqsidebartng/virtual_folders
520 %dir %{_datadir}/apps/konqsidebartng/virtual_folders/remote
521 %{_datadir}/apps/konqsidebartng/virtual_folders/remote/virtualfolder_network.desktop
522 %{_datadir}/apps/kwalletd
523 %{_datadir}/apps/remoteview/network.desktop
524
525 # dir owned by kdelibs
526 %{_datadir}/apps/desktoptheme/default/*
527 %{_datadir}/apps/desktoptheme/oxygen
528 %{_datadir}/apps/desktoptheme/appdashboard
529
530 %files devel
531 %defattr(644,root,root,755)
532 %{_includedir}/knotify*.h
533 %{_includedir}/nepomuk
534 %{_libdir}/libkwalletbackend.so
535 %{_libdir}/libmolletnetwork.so
536 %{_libdir}/libnepomuksync.so
537 %{_datadir}/apps/cmake/modules/FindCLucene.cmake
538 %{_datadir}/apps/cmake/modules/FindSLP.cmake
539
540 %files -n kde4-phonon
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_libdir}/kconf_update_bin/phonon_devicepreference_update
543 %attr(755,root,root) %{_libdir}/kconf_update_bin/phonon_deviceuids_update
544 %attr(755,root,root) %{_libdir}/kde4/kded_phononserver.so
545 %attr(755,root,root) %{_libdir}/kde4/kcm_phononxine.so
546 %{_datadir}/kde4/services/kcm_phonon.desktop
547 %{_datadir}/kde4/services/spellchecking.desktop
548 %{_datadir}/kde4/servicetypes/phononbackend.desktop
549 %{_datadir}/kde4/services/kcm_phononxine.desktop
550
551 %dir %{_libdir}/kde4/plugins/phonon_platform
552 %{_libdir}/kde4/plugins/phonon_platform/kde.so
553 %dir %{_datadir}/apps/kcm_phonon
554 %{_datadir}/apps/kcm_phonon/listview-background.png
555 %{_datadir}/apps/kconf_update/devicepreference.upd
556 %dir %{_datadir}/apps/libphonon
557 %{_datadir}/apps/libphonon/hardwaredatabase
558 %dir %{_datadir}/apps/phonon
559 %{_datadir}/apps/phonon/phonon.notifyrc
560 %dir %{_datadir}/apps/kio_desktop
561 %dir %{_datadir}/apps/kio_desktop/DesktopLinks
562 %{_datadir}/apps/kio_desktop/DesktopLinks/Home.desktop
563 %{_datadir}/apps/kio_desktop/directory.desktop
564 %{_datadir}/apps/kio_desktop/directory.trash
565 %{_datadir}/kde4/services/kded/phononserver.desktop
This page took 0.175289 seconds and 3 git commands to generate.