]> git.pld-linux.org Git - packages/kde4-kdebase-runtime.git/blob - kde4-kdebase-runtime.spec
- up to 4.8.1
[packages/kde4-kdebase-runtime.git] / kde4-kdebase-runtime.spec
1 # TODO
2 # - l10n != %lang glibc locales (et = etiopia not estonia!)
3 #
4 # Conditional build:
5 #
6 %define         _state          stable
7 %define         orgname         kde-runtime
8 %define         qtver           4.8.0
9 %define         atticaver       0.2.0
10
11 Summary:        KDE 4 base runtime components
12 Summary(pl.UTF-8):      Komponenty uruchomieniowe podstawowej części KDE 4
13 Name:           kde4-kdebase-runtime
14 Version:        4.8.1
15 Release:        1
16 License:        GPL
17 Group:          X11/Applications
18 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/xz/%{orgname}-%{version}.tar.xz
19 # Source0-md5:  9fa9c4015f158d1b434a5b8653e65dcf
20 Source1:        kdebase-searchproviders.tar.bz2
21 # Source1-md5:  126c3524b5367f5096a628acbf9dc86f
22 Source2:        l10n-iso639-1
23 Patch100:       %{name}-branch.diff
24 Patch0:         %{name}-rpc.patch
25 URL:            http://www.kde.org/
26 BuildRequires:  OpenEXR-devel
27 BuildRequires:  alsa-lib-devel
28 BuildRequires:  attica-devel >= %{atticaver}
29 BuildRequires:  automoc4 >= 0.9.88
30 BuildRequires:  bzip2-devel
31 BuildRequires:  clucene-core-devel >= 0.9.21
32 BuildRequires:  cmake >= 2.8.0
33 BuildRequires:  docbook-dtd42-xml
34 BuildRequires:  docbook-style-xsl
35 BuildRequires:  exiv2-devel >= 0.18.2
36 BuildRequires:  kde4-kdelibs-devel >= %{version}
37 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
38 BuildRequires:  libcanberra-devel
39 BuildRequires:  libjpeg-devel
40 BuildRequires:  libqzeitgeist-devel >= 0.8
41 BuildRequires:  libsmbclient-devel
42 BuildRequires:  libssh-devel >= 1:0.4.0
43 BuildRequires:  libtirpc-devel
44 BuildRequires:  ntrack-devel
45 BuildRequires:  openslp-devel
46 BuildRequires:  phonon-devel >= 4.4.3
47 BuildRequires:  pkgconfig
48 BuildRequires:  pulseaudio-devel
49 BuildRequires:  qt4-build >= %{qtver}
50 BuildRequires:  qt4-qmake >= %{qtver}
51 BuildRequires:  rpmbuild(macros) >= 1.600
52 BuildRequires:  shared-desktop-ontologies-devel >= 0.7.1
53 BuildRequires:  shared-mime-info
54 BuildRequires:  soprano-devel >= 2.6.51
55 BuildRequires:  strigi-devel >= 0.7.0
56 BuildRequires:  xine-lib-devel
57 BuildRequires:  xz-devel
58 Requires:       attica >= %{atticaver}
59 Provides:       dbus(org.freedesktop.Notifications)
60 Obsoletes:      kdebase4-runtime
61 Conflicts:      kdebase4-runtime
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 KDE 4 runtime components.
66
67 %description -l pl.UTF-8
68 Komponenty uruchomieniowe podstawowej części KDE 4.
69
70 %package devel
71 Summary:        Development files for KDE 4 runtime components
72 Summary(pl.UTF-8):      Pliki programistyczne komponentów uruchomieniowych KDE 4
73 Group:          X11/Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       kde4-kdelibs-devel >= %{version}
76
77 %description devel
78 Development files for KDE 4 runtime components.
79
80 %description devel -l pl.UTF-8
81 Pliki programistyczne komponentów uruchomieniowych KDE 4.
82
83 %package -n kde4-phonon
84 Summary:        KDE 4 Phonon plugins
85 Summary(pl.UTF-8):      Wtyczki KDE 4 dla Phonona
86 Group:          X11/Applications
87
88 %description -n kde4-phonon
89 KDE 4 Phonon plugins.
90
91 %description -n kde4-phonon -l pl.UTF-8
92 Wtyczki KDE 4 dla Phonona.
93
94 %prep
95 %setup -q -n %{orgname}-%{version} -a1
96 #%patch100 -p1
97 %patch0 -p1
98
99 %build
100 install -d build
101 cd build
102 %cmake \
103         -DLIBEXEC_INSTALL_DIR=%{_libdir}/kde4/libexec \
104         ../
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} -C build install \
112         DESTDIR=$RPM_BUILD_ROOT \
113         kde_htmldir=%{_kdedocdir}
114
115 install -d $RPM_BUILD_ROOT%{_datadir}/kde4/services/searchproviders/pld
116 cp -a kdebase-searchproviders/*.desktop $RPM_BUILD_ROOT%{_datadir}/kde4/services/searchproviders/pld
117
118 collect_l10n_files() {
119         while read country language comment; do
120                 [ "$country" != "#" ] || continue
121                 if [ "$language" = "-" ]; then
122                         # no mapping. just add for now
123                         echo >&2 "No mapping for $country $comment, adding without %%lang tag"
124                         echo "%{_datadir}/locale/l10n/$country"
125                 else
126                         echo "%lang($language) %{_datadir}/locale/l10n/$country"
127                 fi
128         done
129 } < %{SOURCE2}
130 collect_l10n_files > %{name}.files
131
132 rm -f $RPM_BUILD_ROOT%{_datadir}/icons/default.kde4
133 # provided (conflicts) by hicolor-icon-theme
134 rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files -f %{name}.files
143 %defattr(644,root,root,755)
144 %{_sysconfdir}/xdg/menus/kde-information.menu
145 %attr(755,root,root) %{_bindir}/kcmshell4
146 %attr(755,root,root) %{_bindir}/kde-cp
147 %attr(755,root,root) %{_bindir}/kde-mv
148 %attr(755,root,root) %{_bindir}/kde-open
149 %attr(755,root,root) %{_bindir}/kde4-menu
150 %attr(755,root,root) %{_bindir}/kdebugdialog
151 %attr(755,root,root) %{_bindir}/kfile4
152 %attr(755,root,root) %{_bindir}/kiconfinder
153 %attr(755,root,root) %{_bindir}/khelpcenter
154 %attr(755,root,root) %{_bindir}/khotnewstuff4
155 %attr(755,root,root) %{_bindir}/khotnewstuff-upload
156 %attr(755,root,root) %{_bindir}/kioclient
157 %attr(755,root,root) %{_bindir}/kmimetypefinder
158 %attr(755,root,root) %{_bindir}/knotify4
159 %attr(755,root,root) %{_bindir}/kquitapp
160 %attr(755,root,root) %{_bindir}/kreadconfig
161 %attr(755,root,root) %{_bindir}/kstart
162 %attr(755,root,root) %{_bindir}/kde4
163 %attr(755,root,root) %{_bindir}/kwalletd
164 %attr(755,root,root) %{_bindir}/ksvgtopng
165 %attr(755,root,root) %{_bindir}/keditfiletype
166 %attr(755,root,root) %{_bindir}/kglobalaccel
167 %attr(755,root,root) %{_bindir}/ktraderclient
168 %attr(755,root,root) %{_bindir}/ktrash
169 %attr(755,root,root) %{_bindir}/kuiserver
170 %attr(755,root,root) %{_bindir}/kwriteconfig
171 %attr(755,root,root) %{_bindir}/solid-hardware
172 %attr(755,root,root) %{_bindir}/nepomuk-simpleresource-rcgen
173 %attr(755,root,root) %{_bindir}/nepomukbackup
174 %attr(755,root,root) %{_bindir}/nepomukcontroller
175 %attr(755,root,root) %{_bindir}/nepomukindexer
176 %attr(755,root,root) %{_bindir}/nepomukserver
177 %attr(755,root,root) %{_bindir}/nepomukservicestub
178 %attr(755,root,root) %{_bindir}/plasma-remote-helper
179 %attr(755,root,root) %{_bindir}/plasmapkg
180 %attr(755,root,root) %{_libdir}/attica_kde.so
181 %attr(755,root,root) %{_libdir}/libkdeinit4_kcmshell4.so
182 %attr(755,root,root) %{_libdir}/libkdeinit4_khelpcenter.so
183 %attr(755,root,root) %{_libdir}/libkdeinit4_kuiserver.so
184 %attr(755,root,root) %{_libdir}/libkdeinit4_kwalletd.so
185 %attr(755,root,root) %{_libdir}/libkdeinit4_kglobalaccel.so
186 %attr(755,root,root) %{_libdir}/libkdeinit4_nepomukserver.so
187 %attr(755,root,root) %{_libdir}/libknotifyplugin.so
188 %attr(755,root,root) %{_libdir}/libnepomukcommon.so
189 %attr(755,root,root) %{_libdir}/libnepomukdatamanagement.so.?
190 %attr(755,root,root) %{_libdir}/libnepomukdatamanagement.so.*.*.*
191 %attr(755,root,root) %{_libdir}/libnepomuksync.so.?
192 %attr(755,root,root) %{_libdir}/libnepomuksync.so.*.*.*
193 # Is it ok to add those files to main package?
194 %attr(755,root,root) %ghost %{_libdir}/libkwalletbackend.so.?
195 %attr(755,root,root) %{_libdir}/libkwalletbackend.so.*.*.*
196 %attr(755,root,root) %ghost %{_libdir}/libmolletnetwork.so.?
197 %attr(755,root,root) %{_libdir}/libmolletnetwork.so.4.*.*
198 %attr(755,root,root) %{_libdir}/kde4/comicbookthumbnail.so
199 %attr(755,root,root) %{_libdir}/kde4/cursorthumbnail.so
200 %attr(755,root,root) %{_libdir}/kde4/djvuthumbnail.so
201 %attr(755,root,root) %{_libdir}/kde4/exrthumbnail.so
202 %attr(755,root,root) %{_libdir}/kde4/htmlthumbnail.so
203 %attr(755,root,root) %{_libdir}/kde4/imagethumbnail.so
204 #%attr(755,root,root) %{_libdir}/kde4/jpegrotatedthumbnail.so
205 %attr(755,root,root) %{_libdir}/kde4/jpegthumbnail.so
206 %attr(755,root,root) %{_libdir}/kde4/kcm_cgi.so
207 %attr(755,root,root) %{_libdir}/kde4/kcm_componentchooser.so
208 %attr(755,root,root) %{_libdir}/kde4/kcm_device_automounter.so
209 %attr(755,root,root) %{_libdir}/kde4/kcm_emoticons.so
210 %attr(755,root,root) %{_libdir}/kde4/kcm_filetypes.so
211 %attr(755,root,root) %{_libdir}/kde4/kcm_icons.so
212 %attr(755,root,root) %{_libdir}/kde4/kcm_kded.so
213 %attr(755,root,root) %{_libdir}/kde4/kcm_kdnssd.so
214 %attr(755,root,root) %{_libdir}/kde4/kcm_knotify.so
215 %attr(755,root,root) %{_libdir}/kde4/kcm_locale.so
216 %attr(755,root,root) %{_libdir}/kde4/kcm_nepomuk.so
217 %attr(755,root,root) %{_libdir}/kde4/kcm_trash.so
218 #%attr(755,root,root) %{_libdir}/kde4/kded_activitymanager.so
219 %attr(755,root,root) %{_libdir}/kde4/kded_device_automounter.so
220 %attr(755,root,root) %{_libdir}/kde4/kded_kpasswdserver.so
221 %attr(755,root,root) %{_libdir}/kde4/kded_ktimezoned.so
222 %attr(755,root,root) %{_libdir}/kde4/kded_remotedirnotify.so
223 %attr(755,root,root) %{_libdir}/kde4/kded_soliduiserver.so
224 %attr(755,root,root) %{_libdir}/kde4/kded_desktopnotifier.so
225 %attr(755,root,root) %{_libdir}/kde4/kded_nepomuksearchmodule.so
226 %attr(755,root,root) %{_libdir}/kde4/kded_networkstatus.so
227 %attr(755,root,root) %{_libdir}/kde4/kded_networkwatcher.so
228 %attr(755,root,root) %{_libdir}/kde4/kded_solidautoeject.so
229 %attr(755,root,root) %{_libdir}/kde4/kio_applications.so
230 %attr(755,root,root) %{_libdir}/kde4/kio_bookmarks.so
231 %attr(755,root,root) %{_libdir}/kde4/kio_desktop.so
232 %attr(755,root,root) %{_libdir}/kde4/kio_about.so
233 %attr(755,root,root) %{_libdir}/kde4/kio_archive.so
234 %attr(755,root,root) %{_libdir}/kde4/kio_cgi.so
235 %attr(755,root,root) %{_libdir}/kde4/kio_filter.so
236 %attr(755,root,root) %{_libdir}/kde4/kio_finger.so
237 %attr(755,root,root) %{_libdir}/kde4/kio_fish.so
238 %attr(755,root,root) %{_libdir}/kde4/kio_floppy.so
239 %attr(755,root,root) %{_libdir}/kde4/kio_info.so
240 %attr(755,root,root) %{_libdir}/kde4/kio_man.so
241 %attr(755,root,root) %{_libdir}/kde4/kio_nepomuksearch.so
242 %attr(755,root,root) %{_libdir}/kde4/kio_network.so
243 %attr(755,root,root) %{_libdir}/kde4/kio_nfs.so
244 %attr(755,root,root) %{_libdir}/kde4/kio_remote.so
245 %attr(755,root,root) %{_libdir}/kde4/kio_settings.so
246 %attr(755,root,root) %{_libdir}/kde4/kio_sftp.so
247 %attr(755,root,root) %{_libdir}/kde4/kio_smb.so
248 %attr(755,root,root) %{_libdir}/kde4/kio_thumbnail.so
249 %attr(755,root,root) %{_libdir}/kde4/kio_timeline.so
250 %attr(755,root,root) %{_libdir}/kde4/kio_trash.so
251 %attr(755,root,root) %{_libdir}/kde4/kio_nepomuk.so
252 %attr(755,root,root) %{_libdir}/kde4/libkmanpart.so
253 %attr(755,root,root) %{_libdir}/kde4/fixhosturifilter.so
254 %attr(755,root,root) %{_libdir}/kde4/kcm_attica.so
255 %attr(755,root,root) %{_libdir}/kde4/kcm_phonon.so
256 %attr(755,root,root) %{_libdir}/kde4/kcmspellchecking.so
257 %attr(755,root,root) %{_libdir}/kde4/kshorturifilter.so
258 %attr(755,root,root) %{_libdir}/kde4/kuriikwsfilter.so
259 %attr(755,root,root) %{_libdir}/kde4/kurisearchfilter.so
260 %attr(755,root,root) %{_libdir}/kde4/localdomainurifilter.so
261 %attr(755,root,root) %{_libdir}/kde4/librenaudioplugin.so
262 %attr(755,root,root) %{_libdir}/kde4/librenimageplugin.so
263 #%attr(755,root,root) %{_libdir}/kde4/nepomukactivitiesservice.so
264 %attr(755,root,root) %{_libdir}/kde4/nepomukbackupsync.so
265 %attr(755,root,root) %{_libdir}/kde4/nepomukfilewatch.so
266 %attr(755,root,root) %{_libdir}/kde4/nepomukfileindexer.so
267 #%attr(755,root,root) %{_libdir}/kde4/nepomukontologyloader.so
268 %attr(755,root,root) %{_libdir}/kde4/nepomukqueryservice.so
269 #%attr(755,root,root) %{_libdir}/kde4/nepomukremovablestorageservice.so
270 %attr(755,root,root) %{_libdir}/kde4/nepomukstorage.so
271 %attr(755,root,root) %{_libdir}/kde4/plasma-kpart.so
272 %attr(755,root,root) %{_libdir}/kde4/plasma_appletscript_declarative.so
273 %attr(755,root,root) %{_libdir}/kde4/plasma_appletscript_simple_javascript.so
274 %attr(755,root,root) %{_libdir}/kde4/plasma_containment_newspaper.so
275 %attr(755,root,root) %{_libdir}/kde4/plasma_dataenginescript_javascript.so
276 %attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_javascriptaddon.so
277 %attr(755,root,root) %{_libdir}/kde4/plasma_runnerscript_javascript.so
278 %attr(755,root,root) %{_libdir}/kde4/svgthumbnail.so
279 %attr(755,root,root) %{_libdir}/kde4/textthumbnail.so
280 %attr(755,root,root) %{_libdir}/kde4/windowsexethumbnail.so
281 %attr(755,root,root) %{_libdir}/kde4/windowsimagethumbnail.so
282
283 %attr(755,root,root) %{_libdir}/kde4/imports
284
285 %attr(755,root,root) %{_libdir}/kde4/libexec/drkonqi
286 #%attr(755,root,root) %{_libdir}/kde4/libexec/installdbgsymbols.sh
287 %attr(755,root,root) %{_libdir}/kde4/libexec/kdeeject
288 %attr(755,root,root) %{_libdir}/kde4/libexec/kdesu
289 %attr(755,root,root) %{_libdir}/kde4/libexec/kdesud
290 %attr(755,root,root) %{_libdir}/kde4/libexec/kdontchangethehostname
291 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_docbookdig.pl
292 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_htdig.pl
293 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_htsearch.pl
294 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_indexbuilder
295 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_mansearch.pl
296 %attr(755,root,root) %{_libdir}/kde4/libexec/kioexec
297 #%attr(755,root,root) %{_libdir}/kde4/libexec/klocaldomainurifilterhelper
298 %attr(755,root,root) %{_libdir}/kde4/libexec/knetattach
299 #%attr(755,root,root) %{_libdir}/strigi/strigiindex_nepomukbackend.so
300 %attr(755,root,root) %{_libdir}/kde4/libexec/kcmremotewidgetshelper
301 %{_sysconfdir}/dbus-1/system.d/org.kde.kcontrol.kcmremotewidgets.conf
302 %{_desktopdir}/kde4/nepomukbackup.desktop
303 %{_desktopdir}/kde4/nepomukcontroller.desktop
304 %{_datadir}/dbus-1/system-services/org.kde.kcontrol.kcmremotewidgets.service
305 %{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
306 %{_datadir}/apps/drkonqi
307 %dir %{_datadir}/apps/kcm_componentchooser
308 %{_datadir}/apps/hardwarenotifications
309 %{_datadir}/apps/kcm_componentchooser/kcm_browser.desktop
310 %{_datadir}/apps/kcm_componentchooser/kcm_filemanager.desktop
311 %{_datadir}/apps/kcm_componentchooser/kcm_kemail.desktop
312 %{_datadir}/apps/kcm_componentchooser/kcm_terminal.desktop
313 %{_datadir}/apps/kcm_componentchooser/kcm_wm.desktop
314 %{_datadir}/apps/kcmlocale
315 %{_datadir}/apps/kconf_update/kuriikwsfilter.upd
316 %{_datadir}/apps/kconf_update/nepomukstrigiservice-migrate.upd
317 %{_datadir}/apps/kde/kde.notifyrc
318 %dir %{_datadir}/apps/kglobalaccel
319 %{_datadir}/apps/kglobalaccel/kglobalaccel.notifyrc
320 %{_datadir}/apps/khelpcenter
321 %{_datadir}/apps/kio_bookmarks
322 %{_datadir}/apps/kio_finger
323 %{_datadir}/apps/kio_info
324 #%{_datadir}/apps/kio_thumbnail
325 %dir %{_datadir}/apps/konqueror/dirtree
326 %dir %{_datadir}/apps/konqueror/dirtree/remote
327 %{_datadir}/apps/konqueror/dirtree/remote/smb-network.desktop
328 %dir %{_datadir}/apps/remoteview
329 %{_datadir}/apps/remoteview/smb-network.desktop
330 #%dir %{_datadir}/apps/nepomuk
331 #%dir %{_datadir}/apps/nepomuk/ontologies
332 #%{_datadir}/apps/nepomuk/ontologies/*
333 %{_datadir}/apps/fileindexerservice
334 %{_datadir}/apps/nepomukfilewatch
335 %dir %{_datadir}/apps/nepomukstorage
336 %{_datadir}/apps/nepomukstorage/nepomukstorage.notifyrc
337 %{_datadir}/config.kcfg/khelpcenter.kcfg
338 %{_datadir}/config.kcfg/jpegcreatorsettings.kcfg
339 %{_datadir}/config/khotnewstuff.knsrc
340 %{_datadir}/config/icons.knsrc
341 %{_datadir}/config/emoticons.knsrc
342 %{_datadir}/config/kshorturifilterrc
343 %{_datadir}/config/khotnewstuff_upload.knsrc
344 %{_datadir}/dbus-1/services/org.kde.knotify.service
345 %{_datadir}/dbus-1/services/org.kde.kuiserver.service
346 %{_datadir}/dbus-1/interfaces/*.xml
347 %{_datadir}/emoticons/kde4
348 %{_datadir}/kde4/services/about.protocol
349 %{_datadir}/kde4/services/applications.protocol
350 %{_datadir}/kde4/services/ar.protocol
351 %{_datadir}/kde4/services/kcm_attica.desktop
352 %{_datadir}/kde4/services/bookmarks.protocol
353 %{_datadir}/kde4/services/bzip.protocol
354 %{_datadir}/kde4/services/bzip2.protocol
355 %{_datadir}/kde4/services/cgi.protocol
356 %{_datadir}/kde4/services/comicbookthumbnail.desktop
357 %{_datadir}/kde4/services/componentchooser.desktop
358 %{_datadir}/kde4/services/cursorthumbnail.desktop
359 %{_datadir}/kde4/services/device_automounter_kcm.desktop
360 %{_datadir}/kde4/services/djvuthumbnail.desktop
361 %{_datadir}/kde4/services/emoticons.desktop
362 %{_datadir}/kde4/services/exrthumbnail.desktop
363 %{_datadir}/kde4/services/finger.protocol
364 %{_datadir}/kde4/services/fish.protocol
365 %{_datadir}/kde4/services/fixhosturifilter.desktop
366 %{_datadir}/kde4/services/floppy.protocol
367 %{_datadir}/kde4/services/gzip.protocol
368 %{_datadir}/kde4/services/htmlthumbnail.desktop
369 %{_datadir}/kde4/services/icons.desktop
370 #%{_datadir}/kde4/services/jpegrotatedthumbnail.desktop
371 %{_datadir}/kde4/services/imagethumbnail.desktop
372 %{_datadir}/kde4/services/info.protocol
373 %{_datadir}/kde4/services/jpegthumbnail.desktop
374 %{_datadir}/kde4/services/kcm_kdnssd.desktop
375 %{_datadir}/kde4/services/kcmcgi.desktop
376 %{_datadir}/kde4/services/kcmkded.desktop
377 %{_datadir}/kde4/services/kcmnotify.desktop
378 %{_datadir}/kde4/services/kcmtrash.desktop
379 %{_datadir}/kde4/services/kded/device_automounter.desktop
380 %{_datadir}/kde4/services/kded/kpasswdserver.desktop
381 %{_datadir}/kde4/services/kded/ktimezoned.desktop
382 %{_datadir}/kde4/services/kded/nepomuksearchmodule.desktop
383 %{_datadir}/kde4/services/kded/networkstatus.desktop
384 %{_datadir}/kde4/services/kded/remotedirnotify.desktop
385 %{_datadir}/kde4/services/kded/soliduiserver.desktop
386 %{_datadir}/kde4/services/khelpcenter.desktop
387 %{_datadir}/kde4/services/kmanpart.desktop
388 %{_datadir}/kde4/services/knotify4.desktop
389 %{_datadir}/kde4/services/kshorturifilter.desktop
390 %{_datadir}/kde4/services/kuiserver.desktop
391 %{_datadir}/kde4/services/kuriikwsfilter.desktop
392 %{_datadir}/kde4/services/kurisearchfilter.desktop
393 %{_datadir}/kde4/services/kwalletd.desktop
394 %{_datadir}/kde4/services/language.desktop
395 %{_datadir}/kde4/services/localdomainurifilter.desktop
396 %{_datadir}/kde4/services/lzma.protocol
397 %{_datadir}/kde4/services/man.protocol
398 %{_datadir}/kde4/services/nepomuk.protocol
399 %{_datadir}/kde4/services/nepomukfileindexer.desktop
400 %{_datadir}/kde4/services/nepomukactivitiesservice.desktop
401 %{_datadir}/kde4/services/nepomukbackupsync.desktop
402 %{_datadir}/kde4/services/nepomukremovablestorageservice.desktop
403 %{_datadir}/kde4/services/nfs.protocol
404 %{_datadir}/kde4/services/programs.protocol
405 %{_datadir}/kde4/services/remote.protocol
406 %{_datadir}/kde4/services/renaudiodlg.desktop
407 %{_datadir}/kde4/services/renimagedlg.desktop
408 %{_datadir}/kde4/services/searchproviders
409 %{_datadir}/kde4/services/settings.protocol
410 %{_datadir}/kde4/services/sftp.protocol
411 %{_datadir}/kde4/services/smb.protocol
412 %{_datadir}/kde4/services/svgthumbnail.desktop
413 %{_datadir}/kde4/services/tar.protocol
414 %{_datadir}/kde4/services/textthumbnail.desktop
415 %{_datadir}/kde4/services/thumbnail.protocol
416 %{_datadir}/kde4/services/timeline.protocol
417 %{_datadir}/kde4/services/trash.protocol
418 %{_datadir}/kde4/services/zip.protocol
419 %{_datadir}/kde4/services/xz.protocol
420 %{_datadir}/kde4/services/desktop.protocol
421 %{_datadir}/kde4/services/kded/desktopnotifier.desktop
422 %{_datadir}/kde4/services/desktopthumbnail.desktop
423 %{_datadir}/kde4/services/directorythumbnail.desktop
424 %{_datadir}/kde4/services/filetypes.desktop
425 %{_datadir}/kde4/services/kded/networkwatcher.desktop
426 %{_datadir}/kde4/services/kded/solidautoeject.desktop
427 %{_datadir}/kde4/services/kglobalaccel.desktop
428 %{_datadir}/kde4/services/network.protocol
429 %{_datadir}/kde4/services/kcm_nepomuk.desktop
430 %{_datadir}/kde4/services/nepomukfilewatch.desktop
431 #%{_daetadir}/kde4/services/nepomukmigration1.desktop
432 %{_datadir}/kde4/services/nepomukontologyloader.desktop
433 %{_datadir}/kde4/services/nepomukqueryservice.desktop
434 %{_datadir}/kde4/services/nepomuksearch.protocol
435 %{_datadir}/kde4/services/nepomukstorage.desktop
436 %{_datadir}/kde4/services/nepomukstrigiservice.desktop
437 %{_datadir}/kde4/services/plasma-containment-newspaper.desktop
438 %{_datadir}/kde4/services/plasma-kpart.desktop
439 %{_datadir}/kde4/services/plasma-packagestructure-javascript-addon.desktop
440 %{_datadir}/kde4/services/plasma-scriptengine-applet-declarative.desktop
441 %{_datadir}/kde4/services/plasma-scriptengine-applet-simple-javascript.desktop
442 %{_datadir}/kde4/services/plasma-scriptengine-dataengine-javascript.desktop
443 %{_datadir}/kde4/services/plasma-scriptengine-runner-javascript.desktop
444 %{_datadir}/kde4/services/windowsexethumbnail.desktop
445 %{_datadir}/kde4/services/windowsimagethumbnail.desktop
446 %{_datadir}/kde4/servicetypes/knotifynotifymethod.desktop
447 %{_datadir}/kde4/servicetypes/nepomukservice.desktop
448 %{_datadir}/kde4/servicetypes/plasma-javascriptaddon.desktop
449 %{_datadir}/kde4/servicetypes/searchprovider.desktop
450 %{_datadir}/kde4/servicetypes/thumbcreator.desktop
451 %{_datadir}/desktop-directories
452 %{_datadir}/mime/packages/network.xml
453 %{_datadir}/autostart/nepomukcontroller.desktop
454 %{_datadir}/autostart/nepomukserver.desktop
455
456 %dir %{_datadir}/ontology/kde
457 %{_datadir}/ontology/kde/*.ontology
458 %{_datadir}/ontology/kde/*.trig
459
460 #%{_datadir}/locale/en_US/*
461 %dir %{_datadir}/locale/l10n
462 %{_datadir}/locale/l10n/C
463 %{_datadir}/locale/l10n/caribbean.desktop
464 %{_datadir}/locale/l10n/centralafrica.desktop
465 %{_datadir}/locale/l10n/centralamerica.desktop
466 %{_datadir}/locale/l10n/centralasia.desktop
467 %{_datadir}/locale/l10n/centraleurope.desktop
468 %{_datadir}/locale/l10n/eastafrica.desktop
469 %{_datadir}/locale/l10n/eastasia.desktop
470 %{_datadir}/locale/l10n/easteurope.desktop
471 %{_datadir}/locale/l10n/middleeast.desktop
472 %{_datadir}/locale/l10n/northafrica.desktop
473 %{_datadir}/locale/l10n/northamerica.desktop
474 %{_datadir}/locale/l10n/northeurope.desktop
475 %{_datadir}/locale/l10n/oceania.desktop
476 %{_datadir}/locale/l10n/southafrica.desktop
477 %{_datadir}/locale/l10n/southamerica.desktop
478 %{_datadir}/locale/l10n/southasia.desktop
479 %{_datadir}/locale/l10n/southeastasia.desktop
480 %{_datadir}/locale/l10n/southeurope.desktop
481 %{_datadir}/locale/l10n/westafrica.desktop
482 %{_datadir}/locale/l10n/westeurope.desktop
483 # really?
484 %{_datadir}/locale/currency
485
486 %{_desktopdir}/kde4/Help.desktop
487 %{_desktopdir}/kde4/knetattach.desktop
488 %lang(en) %{_kdedocdir}/en/kcontrol/*
489 %lang(en) %{_kdedocdir}/en/kdebugdialog
490 %lang(en) %{_kdedocdir}/en/kdesu
491 %lang(en) %{_kdedocdir}/en/khelpcenter
492 %lang(en) %{_kdedocdir}/en/kioslave/bzip2
493 %lang(en) %{_kdedocdir}/en/kioslave/bookmarks
494 %lang(en) %{_kdedocdir}/en/kioslave/cgi
495 %lang(en) %{_kdedocdir}/en/kioslave/finger
496 %lang(en) %{_kdedocdir}/en/kioslave/fish
497 %lang(en) %{_kdedocdir}/en/kioslave/floppy
498 %lang(en) %{_kdedocdir}/en/kioslave/gzip
499 %lang(en) %{_kdedocdir}/en/kioslave/info
500 %lang(en) %{_kdedocdir}/en/kioslave/man
501 %lang(en) %{_kdedocdir}/en/kioslave/nfs
502 %lang(en) %{_kdedocdir}/en/kioslave/sftp
503 %lang(en) %{_kdedocdir}/en/kioslave/smb
504 %lang(en) %{_kdedocdir}/en/kioslave/tar
505 %lang(en) %{_kdedocdir}/en/kioslave/thumbnail
506 %lang(en) %{_kdedocdir}/en/knetattach
507 %lang(en) %{_kdedocdir}/en/network
508 %lang(en) %{_mandir}/man1/kdesu.1*
509 %lang(en) %{_mandir}/man8/nepomuk*.8*
510
511 %{_datadir}/sounds/*
512 %{_iconsdir}/hicolor/*/*/*.png
513 %dir %{_datadir}/apps/ksmserver
514 %dir %{_datadir}/apps/ksmserver/windowmanagers
515 %{_datadir}/apps/ksmserver/windowmanagers/compiz-custom.desktop
516 %{_datadir}/apps/ksmserver/windowmanagers/compiz.desktop
517 %{_datadir}/apps/ksmserver/windowmanagers/metacity.desktop
518 %{_datadir}/apps/ksmserver/windowmanagers/openbox.desktop
519 %{_datadir}/apps/kio_docfilter
520 %dir %{_datadir}/apps/konqsidebartng
521 %dir %{_datadir}/apps/konqsidebartng/virtual_folders
522 %dir %{_datadir}/apps/konqsidebartng/virtual_folders/remote
523 %{_datadir}/apps/konqsidebartng/virtual_folders/remote/virtualfolder_network.desktop
524 %{_datadir}/apps/kwalletd
525 %{_datadir}/apps/remoteview/network.desktop
526
527 # dir owned by kdelibs
528 %{_datadir}/apps/desktoptheme/default/*
529 %{_datadir}/apps/desktoptheme/oxygen
530 %{_datadir}/apps/desktoptheme/appdashboard
531
532 %files devel
533 %defattr(644,root,root,755)
534 %{_includedir}/knotify*.h
535 %{_includedir}/nepomuk
536 %attr(755,root,root) %{_libdir}/libkwalletbackend.so
537 %attr(755,root,root) %{_libdir}/libmolletnetwork.so
538 %attr(755,root,root) %{_libdir}/libnepomuksync.so
539 %attr(755,root,root) %{_libdir}/libnepomukdatamanagement.so
540 %{_datadir}/apps/cmake/modules/FindCLucene.cmake
541 %{_datadir}/apps/cmake/modules/FindSLP.cmake
542
543 %files -n kde4-phonon
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_libdir}/kconf_update_bin/phonon_devicepreference_update
546 %attr(755,root,root) %{_libdir}/kconf_update_bin/phonon_deviceuids_update
547 %attr(755,root,root) %{_libdir}/kde4/kded_phononserver.so
548 %attr(755,root,root) %{_libdir}/kde4/kcm_phononxine.so
549 %{_datadir}/kde4/services/kcm_phonon.desktop
550 %{_datadir}/kde4/services/spellchecking.desktop
551 %{_datadir}/kde4/servicetypes/phononbackend.desktop
552 %{_datadir}/kde4/services/kcm_phononxine.desktop
553
554 %dir %{_libdir}/kde4/plugins/phonon_platform
555 %{_libdir}/kde4/plugins/phonon_platform/kde.so
556 %dir %{_datadir}/apps/kcm_phonon
557 %{_datadir}/apps/kcm_phonon/listview-background.png
558 %{_datadir}/apps/kconf_update/devicepreference.upd
559 %dir %{_datadir}/apps/libphonon
560 %{_datadir}/apps/libphonon/hardwaredatabase
561 %dir %{_datadir}/apps/phonon
562 %{_datadir}/apps/phonon/phonon.notifyrc
563 %dir %{_datadir}/apps/kio_desktop
564 %dir %{_datadir}/apps/kio_desktop/DesktopLinks
565 %{_datadir}/apps/kio_desktop/DesktopLinks/Home.desktop
566 %{_datadir}/apps/kio_desktop/directory.desktop
567 %{_datadir}/apps/kio_desktop/directory.trash
568 %{_datadir}/kde4/services/kded/phononserver.desktop
This page took 0.130585 seconds and 3 git commands to generate.