- updated to 21.08.1
[packages/ka5-libkgapi.git] / ka5-libkgapi.spec
index f4e7271f6c44e871dad349912c1de4f4caa944dd..251f4c2b90dca1d626386727a6d784fd3b29bc89 100644 (file)
@@ -1,14 +1,15 @@
-%define                kdeappsver      18.12.1
+%define                kdeappsver      21.08.1
+%define                kframever       5.56.0
 %define                qtver           5.9.0
 %define                kaname          libkgapi
 Summary:       libkgapi
 Name:          ka5-%{kaname}
-Version:       18.12.1
+Version:       21.08.1
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
-# Source0-md5: 4c1586446861dce28820711ae8ecaa7e
+Source0:       http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
+# Source0-md5: 5a2367f6d6a4c9d466930c8410176fc1
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: Qt5Gui-devel >= 5.11.1
@@ -25,23 +26,29 @@ BuildRequires:      Qt5Xml-devel
 BuildRequires: cmake >= 2.8.12
 BuildRequires: cyrus-sasl-devel
 BuildRequires: gettext-devel
-BuildRequires: ka5-kcalcore-devel >= %{kdeappsver}
-BuildRequires: ka5-kcontacts-devel >= %{kdeappsver}
-BuildRequires: kf5-extra-cmake-modules >= 5.53.0
-BuildRequires: kf5-kio-devel >= 5.51.0
-BuildRequires: kf5-kwallet-devel >= 5.51.0
-BuildRequires: kf5-kwindowsystem-devel >= 5.51.0
+BuildRequires: kf5-extra-cmake-modules >= %{kframever}
+BuildRequires: kf5-kcalendarcore-devel >= %{kframever}
+BuildRequires: kf5-kcontacts-devel >= %{kframever}
+BuildRequires: kf5-kio-devel >= %{kframever}
+BuildRequires: kf5-kwallet-devel >= %{kframever}
+BuildRequires: kf5-kwindowsystem-devel >= %{kframever}
+BuildRequires: ninja
 BuildRequires: qt5-build >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.164
 BuildRequires: shared-mime-info
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
+ExclusiveArch: i686  %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 LibKGAPI is a KDE-based library for accessing various Google services
 via their public API.
 
+%description -l pl.UTF-8
+LibKGAPI is biblioteką KDE do dostępu do różnych usług Google'a
+korzystając z ich publicznego API.
+
 %package devel
 Summary:       Header files for %{kaname} development
 Summary(pl.UTF-8):     Pliki nagłówkowe dla programistów używających %{kaname}
@@ -60,15 +67,15 @@ Pliki nagłówkowe dla programistów używających %{kaname}.
 %build
 install -d build
 cd build
-%cmake \
+%cmake -G Ninja \
+       -DHTML_INSTALL_DIR=%{_kdedocdir} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ..
-%{__make}
+%ninja_build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} -C build install \
-       DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
 
 %find_lang %{kaname}_qt --with-qm --all-name --with-kde
 
@@ -80,40 +87,40 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{kaname}_qt.lang
 %defattr(644,root,root,755)
-/etc/xdg/libkgapi.categories
-%attr(755,root,root) %ghost %{_libdir}/libKPimGAPIBlogger.so.5
+%ghost %{_libdir}/libKPimGAPIBlogger.so.5
 %attr(755,root,root) %{_libdir}/libKPimGAPIBlogger.so.5.*.*
-%attr(755,root,root) %ghost %{_libdir}/libKPimGAPICalendar.so.5
+%ghost %{_libdir}/libKPimGAPICalendar.so.5
 %attr(755,root,root) %{_libdir}/libKPimGAPICalendar.so.5.*.*
-%attr(755,root,root) %ghost %{_libdir}/libKPimGAPIContacts.so.5
+%ghost %{_libdir}/libKPimGAPIContacts.so.5
 %attr(755,root,root) %{_libdir}/libKPimGAPIContacts.so.5.*.*
-%attr(755,root,root) %ghost %{_libdir}/libKPimGAPICore.so.5
+%ghost %{_libdir}/libKPimGAPICore.so.5
 %attr(755,root,root) %{_libdir}/libKPimGAPICore.so.5.*.*
-%attr(755,root,root) %ghost %{_libdir}/libKPimGAPIDrive.so.5
+%ghost %{_libdir}/libKPimGAPIDrive.so.5
 %attr(755,root,root) %{_libdir}/libKPimGAPIDrive.so.5.*.*
-%attr(755,root,root) %ghost %{_libdir}/libKPimGAPILatitude.so.5
+%ghost %{_libdir}/libKPimGAPILatitude.so.5
 %attr(755,root,root) %{_libdir}/libKPimGAPILatitude.so.5.*.*
-%attr(755,root,root) %ghost %{_libdir}/libKPimGAPIMaps.so.5
+%ghost %{_libdir}/libKPimGAPIMaps.so.5
 %attr(755,root,root) %{_libdir}/libKPimGAPIMaps.so.5.*.*
-%attr(755,root,root) %ghost %{_libdir}/libKPimGAPITasks.so.5
+%ghost %{_libdir}/libKPimGAPITasks.so.5
 %attr(755,root,root) %{_libdir}/libKPimGAPITasks.so.5.*.*
-%attr(755,root,root) %ghost %{_libdir}/sasl2/libkdexoauth2.so.3
+%{_libdir}/sasl2/libkdexoauth2.so.3
 %attr(755,root,root) %{_libdir}/sasl2/libkdexoauth2.so.3.*.*
+%{_datadir}/qlogging-categories5/libkgapi.categories
 
 %files devel
 %defattr(644,root,root,755)
 %{_includedir}/KPim/KGAPI
 %{_includedir}/KPim/kgapi_version.h
 %{_libdir}/cmake/KPimGAPI
-%attr(755,root,root) %{_libdir}/libKPimGAPIBlogger.so
-%attr(755,root,root) %{_libdir}/libKPimGAPICalendar.so
-%attr(755,root,root) %{_libdir}/libKPimGAPIContacts.so
-%attr(755,root,root) %{_libdir}/libKPimGAPICore.so
-%attr(755,root,root) %{_libdir}/libKPimGAPIDrive.so
-%attr(755,root,root) %{_libdir}/libKPimGAPIMaps.so
-%attr(755,root,root) %{_libdir}/libKPimGAPILatitude.so
-%attr(755,root,root) %{_libdir}/libKPimGAPITasks.so
-%attr(755,root,root) %{_libdir}/sasl2/libkdexoauth2.so
+%{_libdir}/libKPimGAPIBlogger.so
+%{_libdir}/libKPimGAPICalendar.so
+%{_libdir}/libKPimGAPIContacts.so
+%{_libdir}/libKPimGAPICore.so
+%{_libdir}/libKPimGAPIDrive.so
+%{_libdir}/libKPimGAPIMaps.so
+%{_libdir}/libKPimGAPILatitude.so
+%{_libdir}/libKPimGAPITasks.so
+%{_libdir}/sasl2/libkdexoauth2.so
 %{_libdir}/qt5/mkspecs/modules/qt_KGAPIBlogger.pri
 %{_libdir}/qt5/mkspecs/modules/qt_KGAPICalendar.pri
 %{_libdir}/qt5/mkspecs/modules/qt_KGAPIContacts.pri
This page took 0.074147 seconds and 4 git commands to generate.