- updated to 19.04.1
[packages/ka5-libkgapi.git] / ka5-libkgapi.spec
1 %define         kdeappsver      19.04.1
2 %define         kframever       5.56.0
3 %define         qtver           5.9.0
4 %define         kaname          libkgapi
5 Summary:        libkgapi
6 Name:           ka5-%{kaname}
7 Version:        19.04.1
8 Release:        1
9 License:        GPL v2+/LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
12 # Source0-md5:  d786bbb44bd559a97d3c8ac823b2db07
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= 5.11.1
16 BuildRequires:  Qt5Network-devel
17 BuildRequires:  Qt5Positioning-devel >= 5.11.1
18 BuildRequires:  Qt5PrintSupport-devel >= 5.11.1
19 BuildRequires:  Qt5Qml-devel >= 5.11.1
20 BuildRequires:  Qt5Quick-devel >= 5.11.1
21 BuildRequires:  Qt5Test-devel
22 BuildRequires:  Qt5WebChannel-devel >= 5.11.1
23 BuildRequires:  Qt5WebEngine-devel >= 5.11.1
24 BuildRequires:  Qt5Widgets-devel
25 BuildRequires:  Qt5Xml-devel
26 BuildRequires:  cmake >= 2.8.12
27 BuildRequires:  cyrus-sasl-devel
28 BuildRequires:  gettext-devel
29 BuildRequires:  ka5-kcalcore-devel >= %{kdeappsver}
30 BuildRequires:  ka5-kcontacts-devel >= %{kdeappsver}
31 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
32 BuildRequires:  kf5-kio-devel >= %{kframever}
33 BuildRequires:  kf5-kwallet-devel >= %{kframever}
34 BuildRequires:  kf5-kwindowsystem-devel >= %{kframever}
35 BuildRequires:  ninja
36 BuildRequires:  qt5-build >= %{qtver}
37 BuildRequires:  rpmbuild(macros) >= 1.164
38 BuildRequires:  shared-mime-info
39 BuildRequires:  tar >= 1:1.22
40 BuildRequires:  xz
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 LibKGAPI is a KDE-based library for accessing various Google services
45 via their public API.
46
47 %package devel
48 Summary:        Header files for %{kaname} development
49 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
50 Group:          X11/Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 Header files for %{kaname} development.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe dla programistów używających %{kaname}.
58
59 %prep
60 %setup -q -n %{kaname}-%{version}
61
62 %build
63 install -d build
64 cd build
65 %cmake -G Ninja \
66         -DHTML_INSTALL_DIR=%{_kdedocdir} \
67         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
68         ..
69 %ninja_build
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %ninja_install -C build
74
75 %find_lang %{kaname}_qt --with-qm --all-name --with-kde
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files -f %{kaname}_qt.lang
84 %defattr(644,root,root,755)
85 /etc/xdg/libkgapi.categories
86 %attr(755,root,root) %ghost %{_libdir}/libKPimGAPIBlogger.so.5
87 %attr(755,root,root) %{_libdir}/libKPimGAPIBlogger.so.5.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libKPimGAPICalendar.so.5
89 %attr(755,root,root) %{_libdir}/libKPimGAPICalendar.so.5.*.*
90 %attr(755,root,root) %ghost %{_libdir}/libKPimGAPIContacts.so.5
91 %attr(755,root,root) %{_libdir}/libKPimGAPIContacts.so.5.*.*
92 %attr(755,root,root) %ghost %{_libdir}/libKPimGAPICore.so.5
93 %attr(755,root,root) %{_libdir}/libKPimGAPICore.so.5.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libKPimGAPIDrive.so.5
95 %attr(755,root,root) %{_libdir}/libKPimGAPIDrive.so.5.*.*
96 %attr(755,root,root) %ghost %{_libdir}/libKPimGAPILatitude.so.5
97 %attr(755,root,root) %{_libdir}/libKPimGAPILatitude.so.5.*.*
98 %attr(755,root,root) %ghost %{_libdir}/libKPimGAPIMaps.so.5
99 %attr(755,root,root) %{_libdir}/libKPimGAPIMaps.so.5.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libKPimGAPITasks.so.5
101 %attr(755,root,root) %{_libdir}/libKPimGAPITasks.so.5.*.*
102 %attr(755,root,root) %ghost %{_libdir}/sasl2/libkdexoauth2.so.3
103 %attr(755,root,root) %{_libdir}/sasl2/libkdexoauth2.so.3.*.*
104
105 %files devel
106 %defattr(644,root,root,755)
107 %{_includedir}/KPim/KGAPI
108 %{_includedir}/KPim/kgapi_version.h
109 %{_libdir}/cmake/KPimGAPI
110 %attr(755,root,root) %{_libdir}/libKPimGAPIBlogger.so
111 %attr(755,root,root) %{_libdir}/libKPimGAPICalendar.so
112 %attr(755,root,root) %{_libdir}/libKPimGAPIContacts.so
113 %attr(755,root,root) %{_libdir}/libKPimGAPICore.so
114 %attr(755,root,root) %{_libdir}/libKPimGAPIDrive.so
115 %attr(755,root,root) %{_libdir}/libKPimGAPIMaps.so
116 %attr(755,root,root) %{_libdir}/libKPimGAPILatitude.so
117 %attr(755,root,root) %{_libdir}/libKPimGAPITasks.so
118 %attr(755,root,root) %{_libdir}/sasl2/libkdexoauth2.so
119 %{_libdir}/qt5/mkspecs/modules/qt_KGAPIBlogger.pri
120 %{_libdir}/qt5/mkspecs/modules/qt_KGAPICalendar.pri
121 %{_libdir}/qt5/mkspecs/modules/qt_KGAPIContacts.pri
122 %{_libdir}/qt5/mkspecs/modules/qt_KGAPICore.pri
123 %{_libdir}/qt5/mkspecs/modules/qt_KGAPIDrive.pri
124 %{_libdir}/qt5/mkspecs/modules/qt_KGAPILatitude.pri
125 %{_libdir}/qt5/mkspecs/modules/qt_KGAPIMaps.pri
126 %{_libdir}/qt5/mkspecs/modules/qt_KGAPITasks.pri
This page took 0.187229 seconds and 3 git commands to generate.