]> git.pld-linux.org Git - packages/ka5-ktp-call-ui.git/blob - ka5-ktp-call-ui.spec
f356e5a451f5cfae30bb0b04c269301e6e0e2896
[packages/ka5-ktp-call-ui.git] / ka5-ktp-call-ui.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.04.1
5 %define         kframever       5.56.0
6 %define         qtver           5.9.0
7 %define         kaname          ktp-call-ui
8 Summary:        ktp-call-ui
9 Name:           ka5-%{kaname}
10 Version:        22.04.1
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications
14 Source0:        http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  f1997fcf29c3c4889870afcd045ef253
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Qml-devel
19 BuildRequires:  Qt5Quick-devel
20 BuildRequires:  cmake >= 2.8.12
21 BuildRequires:  gettext-devel
22 BuildRequires:  ka5-ktp-common-internals-devel >= %{kdeappsver}
23 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
24 BuildRequires:  kf5-kcmutils-devel >= %{kframever}
25 BuildRequires:  kf5-kconfig-devel >= %{kframever}
26 BuildRequires:  kf5-kdeclarative-devel >= %{kframever}
27 BuildRequires:  kf5-ki18n-devel >= %{kframever}
28 BuildRequires:  kf5-kiconthemes-devel >= %{kframever}
29 BuildRequires:  kf5-knotifications-devel >= %{kframever}
30 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
31 BuildRequires:  ninja
32 BuildRequires:  phonon-qt5-devel
33 BuildRequires:  qt5-build >= %{qtver}
34 BuildRequires:  qt5-gstreamer-devel
35 BuildRequires:  rpmbuild(macros) >= 1.164
36 BuildRequires:  shared-mime-info
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  telepathy-qt5-devel >= 0.9.8
39 BuildRequires:  xz
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 ktp-call-ui is interacting with telepathy and farstream.
44
45 %description -l pl.UTF-8
46 ktp-call-ui komunikuje siÄ™ z telepathy i farstream.
47
48 %prep
49 %setup -q -n %{kaname}-%{version}
50
51 %build
52 install -d build
53 cd build
54 %cmake \
55         -G Ninja \
56         %{!?with_tests:-DBUILD_TESTING=OFF} \
57         -DHTML_INSTALL_DIR=%{_kdedocdir} \
58         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
59         ..
60 %ninja_build
61
62 %if %{with tests}
63 ctest
64 %endif
65
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 %ninja_install -C build
70
71 %find_lang %{kaname} --all-name --with-kde
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files -f %{kaname}.lang
77 %defattr(644,root,root,755)
78 %attr(755,root,root) %{_bindir}/ktp-dialout-ui
79 %attr(755,root,root) %{_libexecdir}/ktp-call-ui
80 %{_datadir}/dbus-1/services/org.freedesktop.Telepathy.Client.KTp.CallUi.service
81 %{_datadir}/ktp-call-ui
82 %{_datadir}/kxmlgui5/ktp-call-ui
83 %{_datadir}/telepathy/clients/KTp.CallUi.client
This page took 0.168714 seconds and 2 git commands to generate.