]> git.pld-linux.org Git - packages/ka5-kosmindoormap.git/blob - ka5-kosmindoormap.spec
- 22.04.0
[packages/ka5-kosmindoormap.git] / ka5-kosmindoormap.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.04.0
5 %define         kframever       5.56.0
6 %define         qtver           5.15.2
7 %define         kaname          kosmindoormap
8 Summary:        A library for rendering multi-level OSM indoor maps
9 Name:           ka5-%{kaname}
10 Version:        22.04.0
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  850d431939165319aae6885c16968eb4
16 URL:            https://community.kde.org/
17 BuildRequires:  Qt5Gui-devel
18 BuildRequires:  Qt5Network-devel >= 5.15.2
19 BuildRequires:  Qt5Qml-devel >= 5.15.2
20 BuildRequires:  Qt5Quick-devel
21 BuildRequires:  Qt5Widgets-devel
22 BuildRequires:  bison
23 BuildRequires:  flex
24 BuildRequires:  gettext-devel
25 BuildRequires:  ka5-kpublictransport-devel
26 BuildRequires:  kf5-extra-cmake-modules >= 5.89
27 BuildRequires:  kf5-ki18n-devel
28 BuildRequires:  ninja
29 BuildRequires:  protobuf-devel
30 BuildRequires:  qt5-build >= %{qtver}
31 BuildRequires:  rpmbuild(macros) >= 1.605
32 BuildRequires:  shared-mime-info
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 BuildRequires:  zlib-devel
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 A library and QML component for rendering multi-level OSM indoor maps
40 of for example a (large) train station.
41
42 ## Features
43
44 User facing:
45 - Floor-level separation of OSM data and inter-floor navigation using
46   stairs, escalators or elevators.
47 - Information model for showing details about a selected amenity.
48 - Support for identifying railway platforms or airport gates in the
49   map data.
50 - Integration with KPublicTransport line meta-data to show line icons
51   for railway platforms.
52 - Integration with KPublicTransport rental vehicle data to show
53   availability of rental bikes.
54 - Integration with KPublicTransport realtime equipment
55   (elevators/escalators/etc) status information.
56
57 Technical:
58 - QPainter and QML integration interface.
59 - Declarative styling using MapCSS.
60 - Picking support for implementing interaction with map elements.
61 - Support for externally provided overlay elements.
62 - Based on OSM raw data tiles from maps.kde.org.
63 - Pre-loading and caching API for offline support in applications.
64
65 %package devel
66 Summary:        Header files for %{kaname} development
67 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
68 Group:          X11/Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70
71 %description devel
72 Header files for %{kaname} development.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe dla programistów używających %{kaname}.
76
77 %prep
78 %setup -q -n %{kaname}-%{version}
79
80 %build
81 install -d build
82 cd build
83 %cmake \
84         -G Ninja \
85         %{!?with_tests:-DBUILD_TESTING=OFF} \
86         -DHTML_INSTALL_DIR=%{_kdedocdir} \
87         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
88         ..
89 %ninja_build
90
91 %if %{with tests}
92 ctest
93 %endif
94
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 %ninja_install -C build
99
100 %find_lang %{kaname} --all-name --with-kde
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files -f %{kaname}.lang
109 %defattr(644,root,root,755)
110 %doc README.md
111 %ghost %{_libdir}/libKOSM.so.1
112 %attr(755,root,root) %{_libdir}/libKOSM.so.*.*.*
113 %ghost %{_libdir}/libKOSMIndoorMap.so.1
114 %attr(755,root,root)%{_libdir}/libKOSMIndoorMap.so.*.*.*
115 %{_libdir}/qt5/qml/org/kde/kosmindoormap/IndoorMap.qml
116 %{_libdir}/qt5/qml/org/kde/kosmindoormap/IndoorMapAttributionLabel.qml
117 %{_libdir}/qt5/qml/org/kde/kosmindoormap/IndoorMapScale.qml
118 %dir %{_libdir}/qt5/qml/org/kde/kosmindoormap
119 %dir %{_libdir}/qt5/qml/org/kde/kosmindoormap/kpublictransport
120 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/kosmindoormap/kpublictransport/libkosmindoormap_kpublictransport_integration_plugin.so
121 %{_libdir}/qt5/qml/org/kde/kosmindoormap/kpublictransport/qmldir
122 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/kosmindoormap/libkosmindoormapquickplugin.so
123 %{_libdir}/qt5/qml/org/kde/kosmindoormap/qmldir
124 %{_datadir}/qlogging-categories5/org_kde_kosmindoormap.categories
125
126 %files devel
127 %defattr(644,root,root,755)
128 %{_includedir}/KOSM
129 %{_includedir}/KOSMIndoorMap
130 %{_includedir}/kosm
131 %{_includedir}/kosmindoormap
132 %{_includedir}/kosmindoormap_version.h
133 %{_libdir}/cmake/KOSMIndoorMap
134 %{_libdir}/libKOSM.so
135 %{_libdir}/libKOSMIndoorMap.so
This page took 0.047145 seconds and 3 git commands to generate.