]> git.pld-linux.org Git - packages/ka5-kdevelop.git/blob - ka5-kdevelop.spec
710b925d946ead1e991843822bb13a0454f089ba
[packages/ka5-kdevelop.git] / ka5-kdevelop.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  webengine       # build without webengine
5
6 %define         kdeappsver      22.12.3
7 %define         kframever       5.103.0
8 %define         qtver           5.15.2
9 %define         kaname          kdevelop
10
11 %ifarch x32
12 %undefine with_webengine
13 %endif
14
15 Summary:        KDE Integrated Development Environment
16 Summary(de.UTF-8):      KDevelop ist eine grafische Entwicklungsumgebung für KDE
17 Summary(pl.UTF-8):      Zintegrowane środowisko programisty dla KDE
18 Summary(pt_BR.UTF-8):   Ambiente Integrado de Desenvolvimento para o KDE
19 Summary(zh_CN.UTF-8):   KDE C/C++集成开发环境
20 Name:           ka5-kdevelop
21 Version:        22.12.3
22 Release:        2
23 License:        GPL
24 Group:          X11/Development/Tools
25 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
26 # Source0-md5:  f19a9d9936703d1fca5adb9c953478b0
27 URL:            http://www.kdevelop.org/
28 BuildRequires:  Qt5Help-devel >= %{qtver}
29 %{?with_webengine:BuildRequires:        Qt5WebEngine-devel >= %{qtver}}
30 BuildRequires:  astyle-devel >= 3.1
31 BuildRequires:  clang-devel
32 BuildRequires:  cmake >= 2.8.9
33 BuildRequires:  docbook-dtd45-xml
34 BuildRequires:  docbook-style-xsl
35 BuildRequires:  gettext-tools
36 BuildRequires:  ka5-libkomparediff2-devel
37 BuildRequires:  ka5-okteta-devel
38 BuildRequires:  kf5-kcrash-devel >= %{kframever}
39 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
40 BuildRequires:  kf5-krunner-devel >= %{kframever}
41 BuildRequires:  kf5-plasma-framework-devel >= %{kframever}
42 BuildRequires:  kf5-syntax-highlighting-devel >= %{kframever}
43 BuildRequires:  kf5-threadweaver-devel >= %{kframever}
44 BuildRequires:  kp5-libksysguard-devel
45 BuildRequires:  qt5-assistant >= %{qtver}
46
47 BuildRequires:  libstdc++-devel >= 3.3
48 BuildRequires:  ninja
49 BuildRequires:  pkgconfig
50 BuildRequires:  rpmbuild(macros) >= 1.600
51 BuildRequires:  zlib-devel >= 1.2.0
52 BuildConflicts: star
53 Requires:       libstdc++-gdb
54 Requires(post,postun):  desktop-file-utils
55 Requires(post,postun):  shared-mime-info
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %define         _noautoreqfiles .*\\.zshrc
59
60 %description
61 The KDevelop Integrated Development Environment provides many features
62 that developers need as well as providing a unified interface to
63 programs like gdb, the C/C++ compiler, and make.
64
65 KDevelop manages or provides: all development tools needed for C++
66 programming like Compiler, Linker, automake and autoconf; KAppWizard,
67 which generates complete, ready-to-go sample applications;
68 Classgenerator, for creating new classes and integrating them into the
69 current project; File management for sources, headers, documentation
70 etc. to be included in the project; The creation of User-Handbooks
71 written with SGML and the automatic generation of HTML-output with the
72 KDE look and feel; Automatic HTML-based API-documentation for your
73 project's classes with cross-references to the used libraries;
74 Internationalization support for your application, allowing
75 translators to easily add their target language to a project;
76
77 KDevelop also includes WYSIWYG (What you see is what you get)-creation
78 of user interfaces with a built-in dialog editor; Debugging your
79 application by integrating KDbg; Editing of project-specific pixmaps
80 with KIconEdit; The inclusion of any other program you need for
81 development by adding it to the "Tools"-menu according to your
82 individual needs.
83
84 %description -l de.UTF-8
85 KDevelop ist eine grafische Entwicklungsumgebung für KDE.
86
87 Das KDevelop-Projekt wurde 1998 begonnen, um eine einfach zu
88 bedienende grafische (integrierte) Entwicklungsumgebung für C++ und C
89 auf Unix-basierten Betriebssystemen bereitzustellen. Seit damals ist
90 die KDevelop-IDE öffentlich unter der GPL erhältlich und unterstützt
91 u. a. Qt-, KDE-, GNOME-, C++- und C-Projekte.
92
93 %description -l pl.UTF-8
94 KDevelop to zintegrowane środowisko programistyczne dla KDE, dające
95 wiele możliwości przydatnych programistom oraz zunifikowany interfejs
96 do programów typu gdb, kompilator C/C++ oraz make.
97
98 KDevelop obsługuje lub zawiera: wszystkie narzędzia programistyczne
99 potrzebne do programowania w C++ jak kompilator, linker, automake,
100 autoconf; KAppWizard, generujący kompletne, gotowe do uruchomienia,
101 proste aplikacje; Classgenerator do tworzenia nowych klas i włączania
102 ich do projektu; zarządzanie plikami źródłowymi, nagłówkowymi,
103 dokumentacją itp.; tworzenie podręczników użytkownika pisanych w SGML
104 i automatyczne generowanie wyjścia HTML pasującego do KDE;
105 automatyczne tworzenie dokumentacji API w HTML do klas projektu z
106 odniesieniami do używanych bibliotek; wsparcie dla
107 internacjonalizacji, pozwalające tłumaczom łatwo dodawać pliki z
108 tłumaczeniami do projektu.
109
110 KDevelop ma także tworzenie interfejsów użytkownika przy użyciu
111 edytora dialogów WYSIWYG; odpluskwianie aplikacji poprzez integrację z
112 KDbg; edycję ikon przy pomocy KIconEdit; dołączanie innych programów
113 potrzebnych do programowania przez dodanie ich do menu Tools według
114 własnych potrzeb.
115
116 %package devel
117 Summary:        kdevelop - header files and development documentation
118 Summary(pl.UTF-8):      kdevelop - pliki nagłówkowe i dokumentacja
119 Group:          X11/Development/Libraries
120 Requires:       %{name} = %{version}-%{release}
121
122 %description devel
123 This package contains header files and development documentation for
124 kdevelop.
125
126 %description devel -l pl.UTF-8
127 Pakiet ten zawiera pliki nagłówkowe i dokumentację potrzebną przy
128 pisaniu własnych programów wykorzystujących kdevelop.
129
130 %package -n bash-completion-kdevelop
131 Summary:        Bash completion for KDevelop commands
132 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń KDevelop
133 Group:          Applications/Shells
134 Requires:       %{name} = %{version}-%{release}
135 Requires:       bash-completion >= 2.0
136 %{?noarchpackage}
137
138 %description -n bash-completion-kdevelop
139 Bash completion for KDevelop commands.
140
141 %description -n bash-completion-kdevelop -l pl.UTF-8
142 Bashowe uzupełnianie parametrów dla poleceń KDevelop.
143
144 %prep
145 %setup -q -n %{kaname}-%{version}
146
147 %build
148 install -d build
149 cd build
150 %cmake \
151         -G Ninja \
152         %{!?with_tests:-DBUILD_TESTING=OFF} \
153         -DHTML_INSTALL_DIR=%{_kdedocdir} \
154         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
155         -DFORCE_BASH_COMPLETION_INSTALLATION=ON \
156         ..
157 %ninja_build
158
159 %if %{with tests}
160 ctest
161 %endif
162
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166 %ninja_install -C build
167
168 %find_lang %{kaname} --all-name --with-kde
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %post
174 /sbin/ldconfig
175 %update_mime_database
176 %update_desktop_database
177
178 %postun
179 /sbin/ldconfig
180 %update_mime_database
181 %update_desktop_database_postun
182
183 %files -f %{kaname}.lang
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_bindir}/kdevelop
186 %attr(755,root,root) %{_bindir}/kdevelop!
187 %attr(755,root,root) %{_bindir}/kdev_includepathsconverter
188 %attr(755,root,root) %{_libdir}/libKDevClangPrivate.so.*
189 %attr(755,root,root) %{_libdir}/libKDevCMakeCommon.so.*
190 %attr(755,root,root) %{_libdir}/libKDevCompileAnalyzerCommon.so.*
191 %attr(755,root,root) %{_libdir}/libKDevelopSessionsWatch.so
192 %dir %{_libdir}/qt5/plugins/kf5/krunner
193 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/krunner/krunner_kdevelopsessions.so
194 %dir %{_libdir}/qt5/qml/org/kde/plasma/private/kdevelopsessions
195 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/plasma/private/kdevelopsessions/libkdevelopsessionsplugin.so
196 %{_libdir}/qt5/qml/org/kde/plasma/private/kdevelopsessions/qmldir
197 %dir %{_datadir}/kdevplatform
198 %dir %{_datadir}/kdevplatform/shellutils
199 %{_datadir}/kdevplatform/shellutils/.zshrc
200 %{_datadir}/kdevappwizard
201 %{_datadir}/kdevclangsupport
202 %{_datadir}/kdevelop
203 %{_datadir}/kdevfiletemplates
204 %{_datadir}/kdevgdb
205 %{_datadir}/kdevlldb
206 %{_datadir}/kdevmanpage
207 %{_datadir}/kdevqmljssupport
208 %{_datadir}/knotifications5/*
209 %{_datadir}/knsrcfiles/kdev*.knsrc
210 %{_datadir}/metainfo/*
211 %{_datadir}/mime/packages/*
212 %{_datadir}/kservices5/*
213 %{_datadir}/plasma/plasmoids/kdevelopsessions
214 %{_desktopdir}/org.kde.kdevelop.desktop
215 %{_desktopdir}/org.kde.kdevelop_*.desktop
216 %{_iconsdir}/*/*x*/*/*.png
217 %{_datadir}/qlogging-categories5/kdev*.categories
218
219 #kdevplatform
220 %attr(755,root,root) %{_bindir}/kdev_dbus_socket_transformer
221 %attr(755,root,root) %{_bindir}/kdev_format_source
222 %attr(755,root,root) %{_bindir}/kdevplatform_shell_environment.sh
223 %attr(755,root,root) %{_libdir}/libKDevPlatformDebugger.so.*.*.*
224 %ghost %{_libdir}/libKDevPlatformDebugger.so.???
225 %attr(755,root,root) %{_libdir}/libKDevPlatformDocumentation.so.*.*.*
226 %ghost %{_libdir}/libKDevPlatformDocumentation.so.???
227 %attr(755,root,root) %{_libdir}/libKDevPlatformInterfaces.so.*.*.*
228 %ghost %{_libdir}/libKDevPlatformInterfaces.so.???
229 %attr(755,root,root) %{_libdir}/libKDevPlatformLanguage.so.*.*.*
230 %ghost %{_libdir}/libKDevPlatformLanguage.so.???
231 %attr(755,root,root) %{_libdir}/libKDevPlatformOutputView.so.*.*.*
232 %ghost %{_libdir}/libKDevPlatformOutputView.so.???
233 %attr(755,root,root) %{_libdir}/libKDevPlatformProject.so.*.*.*
234 %ghost %{_libdir}/libKDevPlatformProject.so.???
235 %attr(755,root,root) %{_libdir}/libKDevPlatformSerialization.so.*.*.*
236 %ghost %{_libdir}/libKDevPlatformSerialization.so.???
237 %attr(755,root,root) %{_libdir}/libKDevPlatformShell.so.*.*.*
238 %ghost %{_libdir}/libKDevPlatformShell.so.???
239 %attr(755,root,root) %{_libdir}/libKDevPlatformSublime.so.*.*.*
240 %ghost %{_libdir}/libKDevPlatformSublime.so.???
241 %attr(755,root,root) %{_libdir}/libKDevPlatformUtil.so.*.*.*
242 %ghost %{_libdir}/libKDevPlatformUtil.so.???
243 %attr(755,root,root) %{_libdir}/libKDevPlatformVcs.so.*.*.*
244 %ghost %{_libdir}/libKDevPlatformVcs.so.???
245 %dir %{_libdir}/qt5/plugins/grantlee
246 %dir %{_libdir}/qt5/plugins/grantlee/5.2
247 %attr(755,root,root) %{_libdir}/qt5/plugins/grantlee/*/kdev_filters.so
248 %dir %{_libdir}/qt5/plugins/kdevplatform
249 %dir %{_libdir}/qt5/plugins/kdevplatform/510
250 %attr(755,root,root) %{_libdir}/qt5/plugins/kdevplatform/*/kdev*.so
251
252 %{_libdir}/qt5/qml/org/kde/kdevplatform/qmldir
253 %dir %{_libdir}/qt5/qml/org/kde/kdevplatform
254 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/kdevplatform/libkdevelopdashboarddeclarativeplugin.so
255 %{_datadir}/kdevcodegen
256 %{_datadir}/kdevcodeutils
257 %{_datadir}/kservicetypes5/kdevelopplugin.desktop
258 %{_iconsdir}/hicolor/*/actions/*.svg
259 %{_iconsdir}/hicolor/*/apps/*.svg
260
261
262 %files devel
263 %defattr(644,root,root,755)
264 %{_libdir}/cmake/KDevelop
265 %{_includedir}/kdevelop
266
267 #kdevplatform
268 %{_includedir}/kdevplatform
269 %{_libdir}/libKDevPlatformDebugger.so
270 %{_libdir}/libKDevPlatformDocumentation.so
271 %{_libdir}/libKDevPlatformInterfaces.so
272 %{_libdir}/libKDevPlatformLanguage.so
273 %{_libdir}/libKDevPlatformOutputView.so
274 %{_libdir}/libKDevPlatformProject.so
275 %{_libdir}/libKDevPlatformSerialization.so
276 %{_libdir}/libKDevPlatformShell.so
277 %{_libdir}/libKDevPlatformSublime.so
278 %{_libdir}/libKDevPlatformUtil.so
279 %{_libdir}/libKDevPlatformVcs.so
280 %dir %{_libdir}/cmake/KDevPlatform
281 %{_libdir}/cmake/KDevPlatform/KDevPlatformConfig.cmake
282 %{_libdir}/cmake/KDevPlatform/KDevPlatformConfigVersion.cmake
283 %{_libdir}/cmake/KDevPlatform/KDevPlatformMacros.cmake
284 %{_libdir}/cmake/KDevPlatform/KDevPlatformTargets.cmake
285 %{_libdir}/cmake/KDevPlatform/KDevPlatformTargets-pld.cmake
286
287 %files -n bash-completion-kdevelop
288 %defattr(644,root,root,755)
289 %{bash_compdir}/kdevelop
This page took 0.095639 seconds and 2 git commands to generate.