]> git.pld-linux.org Git - packages/ka5-kdevelop.git/blob - ka5-kdevelop.spec
- updated to 22.04.3
[packages/ka5-kdevelop.git] / ka5-kdevelop.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  webengine       # build without webengine
5
6 %define         kdeappsver      22.04.3
7 %define         kframever       5.94.0
8 %define         qtver           5.15.2
9 %define         kaname          kdevelop
10
11 %ifarch x32
12 %undefine with_webengine
13 %endif
14
15 Summary:        KDE Integrated Development Environment
16 Summary(de.UTF-8):      KDevelop ist eine grafische Entwicklungsumgebung für KDE
17 Summary(pl.UTF-8):      Zintegrowane środowisko programisty dla KDE
18 Summary(pt_BR.UTF-8):   Ambiente Integrado de Desenvolvimento para o KDE
19 Summary(zh_CN.UTF-8):   KDE C/C++集成开发环境
20 Name:           ka5-kdevelop
21 Version:        22.04.3
22 Release:        1
23 License:        GPL
24 Group:          X11/Development/Tools
25 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
26 # Source0-md5:  86142c3f49537d557bdab48dae4fe45b
27 URL:            http://www.kdevelop.org/
28 BuildRequires:  Qt5Help-devel >= %{qtver}
29 %{?with_webengine:BuildRequires:        Qt5WebEngine-devel >= %{qtver}}
30 BuildRequires:  astyle-devel >= 3.1
31 BuildRequires:  clang-devel
32 BuildRequires:  cmake >= 2.8.9
33 BuildRequires:  docbook-dtd45-xml
34 BuildRequires:  docbook-style-xsl
35 BuildRequires:  gettext-tools
36 BuildRequires:  ka5-libkomparediff2-devel
37 BuildRequires:  ka5-okteta-devel
38 BuildRequires:  kf5-kcrash-devel >= %{kframever}
39 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
40 BuildRequires:  kf5-krunner-devel >= %{kframever}
41 BuildRequires:  kf5-plasma-framework-devel >= %{kframever}
42 BuildRequires:  kf5-syntax-highlighting-devel >= %{kframever}
43 BuildRequires:  kp5-libksysguard-devel
44 BuildRequires:  qt5-assistant >= %{qtver}
45
46 BuildRequires:  libstdc++-devel >= 3.3
47 BuildRequires:  ninja
48 BuildRequires:  pkgconfig
49 BuildRequires:  rpmbuild(macros) >= 1.600
50 BuildRequires:  zlib-devel >= 1.2.0
51 BuildConflicts: star
52 Requires:       libstdc++-gdb
53 Requires(post,postun):  desktop-file-utils
54 Requires(post,postun):  shared-mime-info
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         _noautoreqfiles .*\\.zshrc
58
59 %description
60 The KDevelop Integrated Development Environment provides many features
61 that developers need as well as providing a unified interface to
62 programs like gdb, the C/C++ compiler, and make.
63
64 KDevelop manages or provides: all development tools needed for C++
65 programming like Compiler, Linker, automake and autoconf; KAppWizard,
66 which generates complete, ready-to-go sample applications;
67 Classgenerator, for creating new classes and integrating them into the
68 current project; File management for sources, headers, documentation
69 etc. to be included in the project; The creation of User-Handbooks
70 written with SGML and the automatic generation of HTML-output with the
71 KDE look and feel; Automatic HTML-based API-documentation for your
72 project's classes with cross-references to the used libraries;
73 Internationalization support for your application, allowing
74 translators to easily add their target language to a project;
75
76 KDevelop also includes WYSIWYG (What you see is what you get)-creation
77 of user interfaces with a built-in dialog editor; Debugging your
78 application by integrating KDbg; Editing of project-specific pixmaps
79 with KIconEdit; The inclusion of any other program you need for
80 development by adding it to the "Tools"-menu according to your
81 individual needs.
82
83 %description -l de.UTF-8
84 KDevelop ist eine grafische Entwicklungsumgebung für KDE.
85
86 Das KDevelop-Projekt wurde 1998 begonnen, um eine einfach zu
87 bedienende grafische (integrierte) Entwicklungsumgebung für C++ und C
88 auf Unix-basierten Betriebssystemen bereitzustellen. Seit damals ist
89 die KDevelop-IDE öffentlich unter der GPL erhältlich und unterstützt
90 u. a. Qt-, KDE-, GNOME-, C++- und C-Projekte.
91
92 %description -l pl.UTF-8
93 KDevelop to zintegrowane środowisko programistyczne dla KDE, dające
94 wiele możliwości przydatnych programistom oraz zunifikowany interfejs
95 do programów typu gdb, kompilator C/C++ oraz make.
96
97 KDevelop obsługuje lub zawiera: wszystkie narzędzia programistyczne
98 potrzebne do programowania w C++ jak kompilator, linker, automake,
99 autoconf; KAppWizard, generujący kompletne, gotowe do uruchomienia,
100 proste aplikacje; Classgenerator do tworzenia nowych klas i włączania
101 ich do projektu; zarządzanie plikami źródłowymi, nagłówkowymi,
102 dokumentacją itp.; tworzenie podręczników użytkownika pisanych w SGML
103 i automatyczne generowanie wyjścia HTML pasującego do KDE;
104 automatyczne tworzenie dokumentacji API w HTML do klas projektu z
105 odniesieniami do używanych bibliotek; wsparcie dla
106 internacjonalizacji, pozwalające tłumaczom łatwo dodawać pliki z
107 tłumaczeniami do projektu.
108
109 KDevelop ma także tworzenie interfejsów użytkownika przy użyciu
110 edytora dialogów WYSIWYG; odpluskwianie aplikacji poprzez integrację z
111 KDbg; edycję ikon przy pomocy KIconEdit; dołączanie innych programów
112 potrzebnych do programowania przez dodanie ich do menu Tools według
113 własnych potrzeb.
114
115 %package devel
116 Summary:        kdevelop - header files and development documentation
117 Summary(pl.UTF-8):      kdevelop - pliki nagłówkowe i dokumentacja
118 Group:          X11/Development/Libraries
119 Requires:       %{name} = %{version}-%{release}
120
121 %description devel
122 This package contains header files and development documentation for
123 kdevelop.
124
125 %description devel -l pl.UTF-8
126 Pakiet ten zawiera pliki nagłówkowe i dokumentację potrzebną przy
127 pisaniu własnych programów wykorzystujących kdevelop.
128
129 %package -n bash-completion-kdevelop
130 Summary:        Bash completion for KDevelop commands
131 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń KDevelop
132 Group:          Applications/Shells
133 Requires:       %{name} = %{version}-%{release}
134 Requires:       bash-completion >= 2.0
135 %{?noarchpackage}
136
137 %description -n bash-completion-kdevelop
138 Bash completion for KDevelop commands.
139
140 %description -n bash-completion-kdevelop -l pl.UTF-8
141 Bashowe uzupełnianie parametrów dla poleceń KDevelop.
142
143 %prep
144 %setup -q -n %{kaname}-%{version}
145
146 %build
147 install -d build
148 cd build
149 %cmake \
150         -G Ninja \
151         %{!?with_tests:-DBUILD_TESTING=OFF} \
152         -DHTML_INSTALL_DIR=%{_kdedocdir} \
153         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
154         -DFORCE_BASH_COMPLETION_INSTALLATION=ON \
155         ..
156 %ninja_build
157
158 %if %{with tests}
159 ctest
160 %endif
161
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165 %ninja_install -C build
166
167 %find_lang %{kaname} --all-name --with-kde
168
169 %clean
170 rm -rf $RPM_BUILD_ROOT
171
172 %post
173 /sbin/ldconfig
174 %update_mime_database
175 %update_desktop_database
176
177 %postun
178 /sbin/ldconfig
179 %update_mime_database
180 %update_desktop_database_postun
181
182 %files -f %{kaname}.lang
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_bindir}/kdevelop
185 %attr(755,root,root) %{_bindir}/kdevelop!
186 %attr(755,root,root) %{_bindir}/kdev_includepathsconverter
187 %attr(755,root,root) %{_libdir}/libKDevClangPrivate.so.*
188 %attr(755,root,root) %{_libdir}/libKDevCMakeCommon.so.*
189 %attr(755,root,root) %{_libdir}/libKDevCompileAnalyzerCommon.so.*
190 %attr(755,root,root) %{_libdir}/libKDevelopSessionsWatch.so
191 %dir %{_libdir}/qt5/plugins/kf5/krunner
192 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/krunner/krunner_kdevelopsessions.so
193 %dir %{_libdir}/qt5/qml/org/kde/plasma/private/kdevelopsessions
194 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/plasma/private/kdevelopsessions/libkdevelopsessionsplugin.so
195 %{_libdir}/qt5/qml/org/kde/plasma/private/kdevelopsessions/qmldir
196 %dir %{_datadir}/kdevplatform
197 %dir %{_datadir}/kdevplatform/shellutils
198 %{_datadir}/kdevplatform/shellutils/.zshrc
199 %{_datadir}/kdevappwizard
200 %{_datadir}/kdevclangsupport
201 %{_datadir}/kdevelop
202 %{_datadir}/kdevfiletemplates
203 %{_datadir}/kdevgdb
204 %{_datadir}/kdevlldb
205 %{_datadir}/kdevmanpage
206 %{_datadir}/kdevqmljssupport
207 %{_datadir}/knotifications5/*
208 %{_datadir}/knsrcfiles/kdev*.knsrc
209 %{_datadir}/metainfo/*
210 %{_datadir}/mime/packages/*
211 %{_datadir}/kservices5/*
212 %{_datadir}/plasma/plasmoids/kdevelopsessions
213 %{_desktopdir}/org.kde.kdevelop.desktop
214 %{_desktopdir}/org.kde.kdevelop_*.desktop
215 %{_iconsdir}/*/*x*/*/*.png
216 %{_datadir}/qlogging-categories5/kdev*.categories
217
218 #kdevplatform
219 %attr(755,root,root) %{_bindir}/kdev_dbus_socket_transformer
220 %attr(755,root,root) %{_bindir}/kdev_format_source
221 %attr(755,root,root) %{_bindir}/kdevplatform_shell_environment.sh
222 %attr(755,root,root) %{_libdir}/libKDevPlatformDebugger.so.*.*.*
223 %ghost %{_libdir}/libKDevPlatformDebugger.so.??
224 %attr(755,root,root) %{_libdir}/libKDevPlatformDocumentation.so.*.*.*
225 %ghost %{_libdir}/libKDevPlatformDocumentation.so.??
226 %attr(755,root,root) %{_libdir}/libKDevPlatformInterfaces.so.*.*.*
227 %ghost %{_libdir}/libKDevPlatformInterfaces.so.??
228 %attr(755,root,root) %{_libdir}/libKDevPlatformLanguage.so.*.*.*
229 %ghost %{_libdir}/libKDevPlatformLanguage.so.??
230 %attr(755,root,root) %{_libdir}/libKDevPlatformOutputView.so.*.*.*
231 %ghost %{_libdir}/libKDevPlatformOutputView.so.??
232 %attr(755,root,root) %{_libdir}/libKDevPlatformProject.so.*.*.*
233 %ghost %{_libdir}/libKDevPlatformProject.so.??
234 %attr(755,root,root) %{_libdir}/libKDevPlatformSerialization.so.*.*.*
235 %ghost %{_libdir}/libKDevPlatformSerialization.so.??
236 %attr(755,root,root) %{_libdir}/libKDevPlatformShell.so.*.*.*
237 %ghost %{_libdir}/libKDevPlatformShell.so.??
238 %attr(755,root,root) %{_libdir}/libKDevPlatformSublime.so.*.*.*
239 %ghost %{_libdir}/libKDevPlatformSublime.so.??
240 %attr(755,root,root) %{_libdir}/libKDevPlatformUtil.so.*.*.*
241 %ghost %{_libdir}/libKDevPlatformUtil.so.??
242 %attr(755,root,root) %{_libdir}/libKDevPlatformVcs.so.*.*.*
243 %ghost %{_libdir}/libKDevPlatformVcs.so.??
244 %dir %{_libdir}/qt5/plugins/grantlee
245 %dir %{_libdir}/qt5/plugins/grantlee/5.2
246 %attr(755,root,root) %{_libdir}/qt5/plugins/grantlee/*/kdev_filters.so
247 %dir %{_libdir}/qt5/plugins/kdevplatform
248 %dir %{_libdir}/qt5/plugins/kdevplatform/36
249 %attr(755,root,root) %{_libdir}/qt5/plugins/kdevplatform/*/kdev*.so
250
251 %{_libdir}/qt5/qml/org/kde/kdevplatform/qmldir
252 %dir %{_libdir}/qt5/qml/org/kde/kdevplatform
253 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/kdevplatform/libkdevelopdashboarddeclarativeplugin.so
254 %{_datadir}/kdevcodegen
255 %{_datadir}/kdevcodeutils
256 %{_datadir}/kservicetypes5/kdevelopplugin.desktop
257 %{_iconsdir}/hicolor/*/actions/*.svg
258 %{_iconsdir}/hicolor/*/apps/*.svg
259
260
261 %files devel
262 %defattr(644,root,root,755)
263 %{_libdir}/cmake/KDevelop
264 %{_includedir}/kdevelop
265
266 #kdevplatform
267 %{_includedir}/kdevplatform
268 %{_libdir}/libKDevPlatformDebugger.so
269 %{_libdir}/libKDevPlatformDocumentation.so
270 %{_libdir}/libKDevPlatformInterfaces.so
271 %{_libdir}/libKDevPlatformLanguage.so
272 %{_libdir}/libKDevPlatformOutputView.so
273 %{_libdir}/libKDevPlatformProject.so
274 %{_libdir}/libKDevPlatformSerialization.so
275 %{_libdir}/libKDevPlatformShell.so
276 %{_libdir}/libKDevPlatformSublime.so
277 %{_libdir}/libKDevPlatformUtil.so
278 %{_libdir}/libKDevPlatformVcs.so
279 %dir %{_libdir}/cmake/KDevPlatform
280 %{_libdir}/cmake/KDevPlatform/KDevPlatformConfig.cmake
281 %{_libdir}/cmake/KDevPlatform/KDevPlatformConfigVersion.cmake
282 %{_libdir}/cmake/KDevPlatform/KDevPlatformMacros.cmake
283 %{_libdir}/cmake/KDevPlatform/KDevPlatformTargets.cmake
284 %{_libdir}/cmake/KDevPlatform/KDevPlatformTargets-pld.cmake
285
286 %files -n bash-completion-kdevelop
287 %defattr(644,root,root,755)
288 %{bash_compdir}/kdevelop
This page took 0.162017 seconds and 3 git commands to generate.