]> git.pld-linux.org Git - packages/ka5-kdepim-addons.git/blobdiff - ka5-kdepim-addons.spec
- bcond_with tests
[packages/ka5-kdepim-addons.git] / ka5-kdepim-addons.spec
index 8d66888f95df861b7c09ff65490e2a5255dbf98d..4c9a0d8695a0f241de19ae02f58f9e0a2cd82ad4 100644 (file)
@@ -1,3 +1,6 @@
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
 %define                kdeappsver      21.12.3
 %define                kframever       5.56.0
 %define                qtver           5.9.0
@@ -25,6 +28,7 @@ BuildRequires:        Qt5Widgets-devel
 BuildRequires: cmake >= 2.8.12
 BuildRequires: gettext-devel
 BuildRequires: gpgme-qt5-devel >= 1.8.0
+BuildRequires: ka5-kaddressbook-devel >= %{kdeappsver}
 BuildRequires: ka5-akonadi-calendar-devel >= %{kdeappsver}
 BuildRequires: ka5-akonadi-contacts-devel >= %{kdeappsver}
 BuildRequires: ka5-akonadi-devel >= %{kdeappsver}
@@ -84,11 +88,17 @@ install -d build
 cd build
 %cmake \
        -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DHTML_INSTALL_DIR=%{_kdedocdir} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ..
 %ninja_build
 
+%if %{with tests}
+ctest
+%endif
+
+
 %install
 rm -rf $RPM_BUILD_ROOT
 %ninja_install -C build
This page took 0.068577 seconds and 4 git commands to generate.