]> git.pld-linux.org Git - packages/ka5-incidenceeditor.git/blob - ka5-incidenceeditor.spec
648c7b2da0368bc96288e595620ff4a15c0e8c52
[packages/ka5-incidenceeditor.git] / ka5-incidenceeditor.spec
1 %define         kdeappsver      18.12.0
2 %define         qtver           5.9.0
3 %define         kaname          incidenceeditor
4 Summary:        Incidence editor
5 Name:           ka5-%{kaname}
6 Version:        18.12.0
7 Release:        1
8 License:        GPL v2+/LGPL v2.1+
9 Group:          X11/Libraries
10 Source0:        http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
11 # Source0-md5:  e9fdda4650d2a6c4de728100dd1b7967
12 URL:            http://www.kde.org/
13 BuildRequires:  Qt5Core-devel >= %{qtver}
14 BuildRequires:  Qt5Gui-devel >= 5.11.1
15 BuildRequires:  Qt5Widgets-devel
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  gettext-devel
18 BuildRequires:  ka5-akonadi-devel >= 18.12.0
19 BuildRequires:  ka5-akonadi-mime-devel >= 18.12.0
20 BuildRequires:  ka5-calendarsupport-devel >= 18.12.0
21 BuildRequires:  ka5-eventviews-devel >= 18.12.0
22 BuildRequires:  ka5-kcalcore-devel >= 18.12.0
23 BuildRequires:  ka5-kcalutils-devel >= 18.12.0
24 BuildRequires:  ka5-kdepim-apps-libs-devel >= 18.12.0
25 BuildRequires:  ka5-kldap-devel >= 18.12.0
26 BuildRequires:  ka5-kmailtransport-devel >= 18.12.0
27 BuildRequires:  ka5-kmime-devel >= 18.12.0
28 BuildRequires:  ka5-libkdepim-devel >= 18.12.0
29 BuildRequires:  kdiagram-devel >= 1.4.0
30 BuildRequires:  kf5-extra-cmake-modules >= 5.53.0
31 BuildRequires:  kf5-kcodecs-devel >= 5.51.0
32 BuildRequires:  kf5-ki18n-devel >= 5.51.0
33 BuildRequires:  kf5-kiconthemes-devel >= 5.51.0
34 BuildRequires:  kf5-kio-devel >= 5.51.0
35 BuildRequires:  qt5-build >= %{qtver}
36 BuildRequires:  rpmbuild(macros) >= 1.164
37 BuildRequires:  shared-mime-info
38 BuildRequires:  tar >= 1:1.22
39 BuildRequires:  xz
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 This lib provides incidence editor.
44
45 %package devel
46 Summary:        Header files for %{kaname} development
47 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
48 Group:          X11/Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 Header files for %{kaname} development.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe dla programistów używających %{kaname}.
56
57 %prep
58 %setup -q -n %{kaname}-%{version}
59
60 %build
61 install -d build
62 cd build
63 %cmake \
64         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
65         ..
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 %{__make} -C build install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %find_lang %{kaname} --all-name --with-kde
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files -f %{kaname}.lang
82 %defattr(644,root,root,755)
83 /etc/xdg/incidenceeditor.categories
84 /etc/xdg/incidenceeditor.renamecategories
85 %attr(755,root,root) %{_bindir}/kincidenceeditor
86 %attr(755,root,root) %ghost %{_libdir}/libKF5IncidenceEditor.so.5
87 %attr(755,root,root) %{_libdir}/libKF5IncidenceEditor.so.5.*.*
88
89 %files devel
90 %defattr(644,root,root,755)
91 %{_includedir}/KF5/IncidenceEditor
92 %{_includedir}/KF5/incidenceeditor
93 %{_includedir}/KF5/incidenceeditor_version.h
94 %{_libdir}/cmake/KF5IncidenceEditor
95 %attr(755,root,root) %{_libdir}/libKF5IncidenceEditor.so
96 %{_libdir}/qt5/mkspecs/modules/qt_IncidenceEditor.pri
This page took 0.082832 seconds and 2 git commands to generate.