]> git.pld-linux.org Git - packages/json-c.git/blob - json-c.spec
- initial
[packages/json-c.git] / json-c.spec
1 Summary:        A JSON implementation in C
2 Name:           json-c
3 Version:        0.9
4 Release:        1
5 License:        LGPL v2
6 Group:          Development/Libraries
7 Source0:        http://oss.metaparadigm.com/json-c/%{name}-%{version}.tar.gz
8 # Source0-md5:  3a13d264528dcbaf3931b0cede24abae
9 URL:            http://oss.metaparadigm.com/json-c/
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %description
13 JSON-C implements a reference counting object model that allows you to
14 easily construct JSON objects in C, output them as JSON formatted
15 strings and parse JSON formatted strings back into the C
16 representation of JSON objects.
17
18 %package devel
19 Summary:        Header files for the json-c library
20 Group:          Development/Libraries
21 Requires:       %{name} = %{version}-%{release}
22
23 %description devel
24 Header files for the json-c library.
25
26 %package static
27 Summary:        Static json-c library
28 Group:          Development/Libraries
29 Requires:       %{name}-devel = %{version}-%{release}
30
31 %description static
32 Static json-c library.
33
34 %prep
35 %setup -q
36
37 %build
38 %configure
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post   -p /sbin/ldconfig
51 %postun -p /sbin/ldconfig
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README INSTALL AUTHORS NEWS README
56 %attr(755,root,root) %{_libdir}/libjson.so.*.*.*
57 %attr(755,root,root) %ghost %{_libdir}/libjson.so.0
58
59 %files devel
60 %defattr(644,root,root,755)
61 %{_includedir}/json
62 %attr(755,root,root) %{_libdir}/libjson.so
63 %{_libdir}/libjson.la
64 %{_pkgconfigdir}/json.pc
65
66 %files static
67 %defattr(644,root,root,755)
68 %{_libdir}/libjson.a
This page took 0.065567 seconds and 3 git commands to generate.