]> git.pld-linux.org Git - packages/json-c.git/blob - json-c.spec
- updated to 0.13.1 (note: new soname)
[packages/json-c.git] / json-c.spec
1 Summary:        A JSON implementation in C
2 Summary(pl.UTF-8):      Implementacja JSON w C
3 Name:           json-c
4 Version:        0.13.1
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 #Source0Download: https://s3.amazonaws.com/json-c_releases/releases/index.html # with AJAX (requires JavaScript)
9 Source0:        https://s3.amazonaws.com/json-c_releases/releases/%{name}-%{version}.tar.gz
10 # Source0-md5:  04969ad59cc37bddd83741a08b98f350
11 URL:            https://github.com/json-c/json-c/wiki
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 JSON-C implements a reference counting object model that allows you to
16 easily construct JSON objects in C, output them as JSON formatted
17 strings and parse JSON formatted strings back into the C
18 representation of JSON objects.
19
20 %description -l pl.UTF-8
21 JSON-C implementuje model obiektów ze zliczaniem odwołań, pozwalający
22 łatwo konstruować obiekty JSON w C, wypisywać je w postaci łańcuchów w
23 formacie JSON i analizować łańcuchy w formacie JSON tworząc z powrotem
24 reprezentacje obiektów JSON w C.
25
26 %package devel
27 Summary:        Header files for the json-c library
28 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki json-c
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31
32 %description devel
33 Header files for the json-c library.
34
35 %description devel -l pl.UTF-8
36 Pliki nagłówkowe biblioteki json-c.
37
38 %package static
39 Summary:        Static json-c library
40 Summary(pl.UTF-8):      Statyczna biblioteka json-c
41 Group:          Development/Libraries
42 Requires:       %{name}-devel = %{version}-%{release}
43
44 %description static
45 Static json-c library.
46
47 %description static -l pl.UTF-8
48 Statyczna biblioteka json-c.
49
50 %prep
51 %setup -q
52
53 %build
54 # avoid "json_tokener.c:355:6: error: variable 'size' set but not used [-Werror=unused-but-set-variable]"
55 CFLAGS="%{rpmcflags} -Wno-unused-but-set-variable"
56 %configure \
57         --disable-silent-rules
58 %{__make} -j1
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post   -p /sbin/ldconfig
72 %postun -p /sbin/ldconfig
73
74 %pretrans devel
75 # transition from 0.11-2
76 [ ! -L %{_includedir}/json-c ] || rm -f %{_includedir}/json-c
77 # transition from <= 0.10 and 0.11-2
78 if [ -d %{_includedir}/json -a ! -d %{_includedir}/json-c ]; then
79         mv -f %{_includedir}/json %{_includedir}/json-c
80         ln -sf json-c %{_includedir}/json
81 fi
82
83 %files
84 %defattr(644,root,root,755)
85 %doc AUTHORS COPYING ChangeLog README README.html
86 %attr(755,root,root) %{_libdir}/libjson-c.so.*.*.*
87 %attr(755,root,root) %ghost %{_libdir}/libjson-c.so.4
88
89 %files devel
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/libjson-c.so
92 %{_includedir}/json-c
93 %{_pkgconfigdir}/json-c.pc
94
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/libjson-c.a
This page took 0.798652 seconds and 3 git commands to generate.