]> git.pld-linux.org Git - packages/json-c.git/blame - json-c.spec
- updated to 0.13.1 (note: new soname)
[packages/json-c.git] / json-c.spec
CommitLineData
990e8f22 1Summary: A JSON implementation in C
d42ebe80 2Summary(pl.UTF-8): Implementacja JSON w C
990e8f22 3Name: json-c
bfee6771 4Version: 0.13.1
1466ae76 5Release: 1
d42ebe80 6License: MIT
6cafbf58 7Group: Libraries
bfee6771 8#Source0Download: https://s3.amazonaws.com/json-c_releases/releases/index.html # with AJAX (requires JavaScript)
040cc79c 9Source0: https://s3.amazonaws.com/json-c_releases/releases/%{name}-%{version}.tar.gz
bfee6771 10# Source0-md5: 04969ad59cc37bddd83741a08b98f350
040cc79c 11URL: https://github.com/json-c/json-c/wiki
990e8f22
AM
12BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14%description
15JSON-C implements a reference counting object model that allows you to
16easily construct JSON objects in C, output them as JSON formatted
17strings and parse JSON formatted strings back into the C
18representation of JSON objects.
19
d42ebe80
JB
20%description -l pl.UTF-8
21JSON-C implementuje model obiektów ze zliczaniem odwołań, pozwalający
22łatwo konstruować obiekty JSON w C, wypisywać je w postaci łańcuchów w
23formacie JSON i analizować łańcuchy w formacie JSON tworząc z powrotem
24reprezentacje obiektów JSON w C.
25
990e8f22
AM
26%package devel
27Summary: Header files for the json-c library
d42ebe80 28Summary(pl.UTF-8): Pliki nagłówkowe biblioteki json-c
990e8f22
AM
29Group: Development/Libraries
30Requires: %{name} = %{version}-%{release}
31
32%description devel
33Header files for the json-c library.
34
d42ebe80
JB
35%description devel -l pl.UTF-8
36Pliki nagłówkowe biblioteki json-c.
37
990e8f22
AM
38%package static
39Summary: Static json-c library
d42ebe80 40Summary(pl.UTF-8): Statyczna biblioteka json-c
990e8f22
AM
41Group: Development/Libraries
42Requires: %{name}-devel = %{version}-%{release}
43
44%description static
45Static json-c library.
46
d42ebe80
JB
47%description static -l pl.UTF-8
48Statyczna biblioteka json-c.
49
990e8f22
AM
50%prep
51%setup -q
52
53%build
814dcbaa
JB
54# avoid "json_tokener.c:355:6: error: variable 'size' set but not used [-Werror=unused-but-set-variable]"
55CFLAGS="%{rpmcflags} -Wno-unused-but-set-variable"
bfee6771
JB
56%configure \
57 --disable-silent-rules
040cc79c 58%{__make} -j1
990e8f22
AM
59
60%install
61rm -rf $RPM_BUILD_ROOT
62
63%{__make} install \
64 DESTDIR=$RPM_BUILD_ROOT
65
2233c506
JR
66%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
67
990e8f22
AM
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%post -p /sbin/ldconfig
72%postun -p /sbin/ldconfig
73
6cafbf58
JB
74%pretrans devel
75# transition from 0.11-2
76[ ! -L %{_includedir}/json-c ] || rm -f %{_includedir}/json-c
77# transition from <= 0.10 and 0.11-2
78if [ -d %{_includedir}/json -a ! -d %{_includedir}/json-c ]; then
79 mv -f %{_includedir}/json %{_includedir}/json-c
80 ln -sf json-c %{_includedir}/json
81fi
82
990e8f22
AM
83%files
84%defattr(644,root,root,755)
d42ebe80 85%doc AUTHORS COPYING ChangeLog README README.html
2233c506 86%attr(755,root,root) %{_libdir}/libjson-c.so.*.*.*
bfee6771 87%attr(755,root,root) %ghost %{_libdir}/libjson-c.so.4
990e8f22
AM
88
89%files devel
90%defattr(644,root,root,755)
2233c506 91%attr(755,root,root) %{_libdir}/libjson-c.so
2233c506 92%{_includedir}/json-c
2233c506 93%{_pkgconfigdir}/json-c.pc
990e8f22
AM
94
95%files static
96%defattr(644,root,root,755)
2233c506 97%{_libdir}/libjson-c.a
This page took 0.164687 seconds and 4 git commands to generate.