]> git.pld-linux.org Git - packages/json-c.git/blame - json-c.spec
- initial
[packages/json-c.git] / json-c.spec
CommitLineData
990e8f22
AM
1Summary: A JSON implementation in C
2Name: json-c
3Version: 0.9
4Release: 1
5License: LGPL v2
6Group: Development/Libraries
7Source0: http://oss.metaparadigm.com/json-c/%{name}-%{version}.tar.gz
8# Source0-md5: 3a13d264528dcbaf3931b0cede24abae
9URL: http://oss.metaparadigm.com/json-c/
10BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12%description
13JSON-C implements a reference counting object model that allows you to
14easily construct JSON objects in C, output them as JSON formatted
15strings and parse JSON formatted strings back into the C
16representation of JSON objects.
17
18%package devel
19Summary: Header files for the json-c library
20Group: Development/Libraries
21Requires: %{name} = %{version}-%{release}
22
23%description devel
24Header files for the json-c library.
25
26%package static
27Summary: Static json-c library
28Group: Development/Libraries
29Requires: %{name}-devel = %{version}-%{release}
30
31%description static
32Static json-c library.
33
34%prep
35%setup -q
36
37%build
38%configure
39%{__make}
40
41%install
42rm -rf $RPM_BUILD_ROOT
43
44%{__make} install \
45 DESTDIR=$RPM_BUILD_ROOT
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%post -p /sbin/ldconfig
51%postun -p /sbin/ldconfig
52
53%files
54%defattr(644,root,root,755)
55%doc README INSTALL AUTHORS NEWS README
56%attr(755,root,root) %{_libdir}/libjson.so.*.*.*
57%attr(755,root,root) %ghost %{_libdir}/libjson.so.0
58
59%files devel
60%defattr(644,root,root,755)
61%{_includedir}/json
62%attr(755,root,root) %{_libdir}/libjson.so
63%{_libdir}/libjson.la
64%{_pkgconfigdir}/json.pc
65
66%files static
67%defattr(644,root,root,755)
68%{_libdir}/libjson.a
This page took 0.092024 seconds and 4 git commands to generate.