]> git.pld-linux.org Git - packages/json-c.git/blame - json-c.spec
- updated to 0.12.1
[packages/json-c.git] / json-c.spec
CommitLineData
990e8f22 1Summary: A JSON implementation in C
d42ebe80 2Summary(pl.UTF-8): Implementacja JSON w C
990e8f22 3Name: json-c
1466ae76
JB
4Version: 0.12.1
5Release: 1
d42ebe80 6License: MIT
6cafbf58 7Group: Libraries
040cc79c 8Source0: https://s3.amazonaws.com/json-c_releases/releases/%{name}-%{version}.tar.gz
1466ae76 9# Source0-md5: 55f7853f7d8cf664554ce3fa71bf1c7d
040cc79c 10URL: https://github.com/json-c/json-c/wiki
990e8f22
AM
11BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13%description
14JSON-C implements a reference counting object model that allows you to
15easily construct JSON objects in C, output them as JSON formatted
16strings and parse JSON formatted strings back into the C
17representation of JSON objects.
18
d42ebe80
JB
19%description -l pl.UTF-8
20JSON-C implementuje model obiektów ze zliczaniem odwołań, pozwalający
21łatwo konstruować obiekty JSON w C, wypisywać je w postaci łańcuchów w
22formacie JSON i analizować łańcuchy w formacie JSON tworząc z powrotem
23reprezentacje obiektów JSON w C.
24
990e8f22
AM
25%package devel
26Summary: Header files for the json-c library
d42ebe80 27Summary(pl.UTF-8): Pliki nagłówkowe biblioteki json-c
990e8f22
AM
28Group: Development/Libraries
29Requires: %{name} = %{version}-%{release}
30
31%description devel
32Header files for the json-c library.
33
d42ebe80
JB
34%description devel -l pl.UTF-8
35Pliki nagłówkowe biblioteki json-c.
36
990e8f22
AM
37%package static
38Summary: Static json-c library
d42ebe80 39Summary(pl.UTF-8): Statyczna biblioteka json-c
990e8f22
AM
40Group: Development/Libraries
41Requires: %{name}-devel = %{version}-%{release}
42
43%description static
44Static json-c library.
45
d42ebe80
JB
46%description static -l pl.UTF-8
47Statyczna biblioteka json-c.
48
990e8f22
AM
49%prep
50%setup -q
51
52%build
814dcbaa
JB
53# avoid "json_tokener.c:355:6: error: variable 'size' set but not used [-Werror=unused-but-set-variable]"
54CFLAGS="%{rpmcflags} -Wno-unused-but-set-variable"
990e8f22 55%configure
040cc79c 56%{__make} -j1
990e8f22
AM
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
61%{__make} install \
62 DESTDIR=$RPM_BUILD_ROOT
63
2233c506
JR
64%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
65
990e8f22
AM
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%post -p /sbin/ldconfig
70%postun -p /sbin/ldconfig
71
6cafbf58
JB
72%pretrans devel
73# transition from 0.11-2
74[ ! -L %{_includedir}/json-c ] || rm -f %{_includedir}/json-c
75# transition from <= 0.10 and 0.11-2
76if [ -d %{_includedir}/json -a ! -d %{_includedir}/json-c ]; then
77 mv -f %{_includedir}/json %{_includedir}/json-c
78 ln -sf json-c %{_includedir}/json
79fi
80
990e8f22
AM
81%files
82%defattr(644,root,root,755)
d42ebe80 83%doc AUTHORS COPYING ChangeLog README README.html
2233c506
JR
84%attr(755,root,root) %{_libdir}/libjson-c.so.*.*.*
85%attr(755,root,root) %ghost %{_libdir}/libjson-c.so.2
990e8f22
AM
86
87%files devel
88%defattr(644,root,root,755)
2233c506 89%attr(755,root,root) %{_libdir}/libjson-c.so
2233c506 90%{_includedir}/json-c
2233c506 91%{_pkgconfigdir}/json-c.pc
990e8f22
AM
92
93%files static
94%defattr(644,root,root,755)
2233c506 95%{_libdir}/libjson-c.a
This page took 0.104349 seconds and 4 git commands to generate.